Subject: Re: [Capwap] need clarification on UDP ports

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 24 Oct 2006 09:39:58 -0700

While it is impossible to disagree, it is worth noting that version fields are typically fixed in location (for future compatibility), and generally increase monotonically. 

This does point out that CAPWAP should specify a DTLS version.

PatC

 -----Original Message-----
From: 	Hasan Raza [mailto:[email-masked]]
Sent:	Tuesday, October 24, 2006 09:35 AM Pacific Standard Time
To:	Pat Calhoun (pacalhou); Scott G. Kelly; [email-masked]
Cc:	capwap
Subject:	Re: [Capwap] need clarification on UDP ports

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]]
Sent: Mon 10/23/2006 7:28 AM
To: Scott G. Kelly; [email-masked]
Cc: capwap
Subject: Re: [Capwap] need clarification on UDP ports

> True, and if we decide that hacks are not acceptable, then a third port
> is really the only way to solve this one. However, I'd like people to
> consider the zero filled DTLS header. Yes, it is "hack-ish", but 
> I believe it to be completely workable.
For that matter any unique pattern of fixed amount of bytes in front
of udp header can work for discovery packets. Why should it be zero filled
DTLS header only? The only restriction on the pattern should be
that it is uniquely different from first fixed bytes of the DTLS header.
All zeros is a good pattern, though. I think zero filled DTLS header
would impose variable header size problems (in future), because version
field would also become zero.

Hasan
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Hasan Raza" <[email-masked]>
Date: Tue, 24 Oct 2006 10:18:57 -0700

Pat Calhoun (pacalhou) wrote:
 
> While it is impossible to disagree, it is worth noting that version
> fields are typically fixed in location (for future compatibility),
> and generally increase monotonically.
My mistake that I was not clear. I agree that version field is at
fixed location, and increase monotonically. But header size might
be version dependent as well. Now since DTLS header is made zero,
the version information, and in turn header size info., is lost.

Hasan

 -----Original Message-----
From: 	Hasan Raza [mailto:[email-masked]]
Sent:	Tuesday, October 24, 2006 09:35 AM Pacific Standard Time
To:	Pat Calhoun (pacalhou); Scott G. Kelly; [email-masked]
Cc:	capwap
Subject:	Re: [Capwap] need clarification on UDP ports

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]]
Sent: Mon 10/23/2006 7:28 AM
To: Scott G. Kelly; [email-masked]
Cc: capwap
Subject: Re: [Capwap] need clarification on UDP ports

Hasan