Subject: Re: [Capwap] transition to join state

From: "Smitha Smitha (ssmitha)" <[email-masked]>
Date: Thu, 26 Oct 2006 17:04:19 +0530

One correction to the transitions. 

Discovery to "DTLS Establishment":

WTP: Occurs when WTP sends DTLSStart command after figuring out which AC
to join.
AC: Nop

"DTLS Establishment" to Join:
WTP: Occurs when DTLSSessionEstablished command is received from DTLS. 
WTP sends a Join Request and starts the WaitJoin timer.
AC: Nop

Idle to "DTLS Establishment"
WTP: Nop
AC:Occurs when DTLSSessionEstablished command is received from DTLS. 
AC allocates state for this WTP and starts the WaitJoin timer.

Thanks
Smitha

-----Original Message-----
From: Smitha Smitha (ssmitha) 
Sent: Thursday, October 26, 2006 4:53 PM
To: Pat Calhoun (pacalhou); 'capwap'
Subject: RE: [Capwap] transition to join state

Pat,

I think we should have this additional state and have the following
transitions on the AC and WTP.

Discovery to "DTLS Establishment":

WTP: Occurs when WTP sends DTLSStart command after figuring out which AC
to join.
AC: Nop

"DTLS Establishment" to Join:
WTP: Occurs when DTLSSessionEstablished command is received from DTLS. 
WTP sends a Join Request and starts the WaitJoin timer.
AC:Occurs when DTLSSessionEstablished command is received from DTLS. 
AC allocates state for this WTP and starts the WaitJoin timer.

Thanks
Smitha
-----Original Message-----
From: Pat Calhoun (pacalhou)
Sent: Thursday, October 26, 2006 4:14 PM
To: Smitha Smitha (ssmitha); 'capwap'
Subject: RE: [Capwap] transition to join state

I see your point. Clearly, some interim CAPWAP state is needed between
idle and join, which we could call "DTLS Establishment".

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: Smitha Smitha (ssmitha)
> Sent: Tuesday, October 24, 2006 6:37 PM
> To: Pat Calhoun (pacalhou); 'capwap'
> Subject: RE: [Capwap] transition to join state
> 
> Pat,
> 
> The spec talks about transitioning to join state from idle - (Idle to 
> Join (aa)). This would make it necessary for CAPWAP to know of the 
> various DTLS packets are being received during handshake. Why is it 
> necessary to have a "join ready" state?
> 
> Thanks
> Smitha
> 
> -----Original Message-----
> From: Pat Calhoun (pacalhou)
> Sent: Tuesday, October 24, 2006 9:26 PM
> To: Smitha Smitha (ssmitha); 'capwap'
> Subject: RE: [Capwap] transition to join state
> 
> I'm not so sure. If that were the case we would need a "join ready" 
> state. We clearly need to transition to a new
> (non-DTLS) state when the DTLS channel is open.
> 
> PatC
> 
>  -----Original Message-----
> From: 	Smitha Smitha (ssmitha)
> Sent:	Tuesday, October 24, 2006 08:52 AM Pacific Standard Time
> To:	capwap
> Subject:	[Capwap] transition to join state
> 
> All,
>  
> The spec talks about AC transitioning to Join state on receiving DTLS 
> Client Hello with a valid cookie. Should this really be the case?
> The AC should transition to Join state on receiving a Join Request.
>  
> Thanks
> Smitha
>  
> 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: Scott G Kelly <[email-masked]>
Date: Thu, 26 Oct 2006 05:03:31 -0700

If you add this state, you must also add a WaitDTLS timer.