Subject: [Capwap] CAPWAP Timer element issue

From: "Bob O'Hara (boohara)" <[email-masked]>
Date: Fri, 20 Oct 2006 13:38:55 -0700

In 4.4.12 of the -03 draft, the Discovery Timer and Echo Timer fields
are defined.  The value of the field determines the number of seconds
between the two types of Request packets.  What does a value of zero
mean in this field?

For the Echo Timer, I would propose that a value of zero be defined to
mean that no Echo Request packets are sent.  For the Discovery Timer, I
would propose that a value of zero be reserved and, if received by a
WTP, is interpreted to be the same as if the value of 1 was received.

 -Bob

Bob O'Hara
Cisco Systems - WNBU

Phone:  +1 408 853 5513
Mobile: +1 408 218 4025
 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 23 Oct 2006 07:28:39 -0700

Bob,

The names "Discovery Timer" and "Echo Timer" are not used in the CAPWAP
specification. I will assume you mean the DiscoveryInterval and
EchoInterval. I believe the issue you are raising is that the text is
not descriptive on what to expect if the timer value is set to zero (0).
This is a valid issue that does need to be addressed.

I am OK with your proposal to simply disable the Echo mechanism when the
timer value is set to zero.

For DiscoveryInterval, I would propose we make the value illegal in the
spec, and state that any illegal values MUST use the default value.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: Bob O'Hara (boohara) 
> Sent: Friday, October 20, 2006 1:39 PM
> To: [email-masked]
> Subject: [Capwap] CAPWAP Timer element issue
> 
> In 4.4.12 of the -03 draft, the Discovery Timer and Echo 
> Timer fields are defined.  The value of the field determines 
> the number of seconds between the two types of Request 
> packets.  What does a value of zero mean in this field?
> 
> For the Echo Timer, I would propose that a value of zero be 
> defined to mean that no Echo Request packets are sent.  For 
> the Discovery Timer, I would propose that a value of zero be 
> reserved and, if received by a WTP, is interpreted to be the 
> same as if the value of 1 was received.
> 
>  -Bob
> 
> Bob O'Hara
> Cisco Systems - WNBU
> 
> Phone:  +1 408 853 5513
> Mobile: +1 408 218 4025
>

---

From: "Bob O'Hara (boohara)" <[email-masked]>
Date: Mon, 23 Oct 2006 21:37:58 -0700

Pat,

Actually, in 4.4.12 of the -03 draft, those names do appear as fielded
names, not timer names.  I am ok with your proposal, as long as the
default value is defined for the Discovery Timer field. 

 -Bob
 
-----Original Message-----
From: Pat Calhoun (pacalhou) 
Sent: Monday, October 23, 2006 7:29 AM
To: Bob O'Hara (boohara); [email-masked]
Subject: RE: [Capwap] CAPWAP Timer element issue

Bob,

Pat Calhoun