Subject: Re: [Capwap] This is not need.: Proposed resolution to Issue214-Prioritization of IEEE 802.1X frames

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 9 Oct 2006 10:42:09 -0700

Even in the case of EDCA, there is no guarantees that the STA can send
an 802.1X frame with a high priority UP field. This is especially true
if the WTP requires authorization prior to making use of the QoS class.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: Cheng Hong [mailto:[email-masked]] 
	Sent: Wednesday, September 27, 2006 6:20 PM
	To: Michael Montemurro
	Cc: capwap
	Subject: Re: [Capwap] This is not need.: Proposed resolution to
Issue214-Prioritization of IEEE 802.1X frames

	Hi Mike,
	 
	In the HCCA case, the TID value is in the range of 8 to 15, and
according to clause 6.1.1.1.1 point b:
	 
	"b) QoS subtypes, in which case the QAP shall infer the UP value
from the TID in the QoS Control field
	directly for TID values between 0 and 7. For TID values between
8 and 15, the QAP shall extract the
	UP value in the UP subfield of the TS Info field in the
associated TSPEC or from the UP field in the
	associated TCLAS (traffic classification) element, as
applicable."
	 
	It seems that the WTP needs to do much more to obtain the actual
UP value. In case the TSPEC or TCLAS elemets are located at the AC, how
would the WTP get the UP value in the HCCA case?
	 
	Or is there any place that prevents sending EAPOL frames using
HCCA? If that is the case, it is not a problem. But, then again, all the
data traffic sent using HCCA will have difficulty to obtain the correct
priority in CAPWAP delivery.
	 
	cheers
	 
	Cheng Hong

________________________________

		From: Michael Montemurro
[mailto:[email-masked]] 
		Sent: Thursday, September 28, 2006 2:23 AM
		To: Cheng Hong
		Cc: capwap
		Subject: Re: [Capwap] This is not need.: Proposed
resolution to Issue 214-Prioritization of IEEE 802.1X frames

		Cheng,
		 
		In the HCCA case, the TID case should work as well. I
don't see why it wouldn't.
		 
		Cheers,
		 
		Mike

		On 9/26/06, Cheng Hong <[email-masked]>
wrote: 

			Hi Mike, 
			 
			It seems OK to use TID in the EDCA case. If the
HCCA is used, would the TID still be meaningful in mapping the priority?
(Haven't check the 802.11 standards in detail). 
			 
			cheers
			 
			Cheng Hong 

________________________________

				From: Michael Montemurro
[mailto:[email-masked] ] 
				Sent: Wednesday, September 27, 2006
12:24 AM 
				
				To: Cheng Hong
				Cc: zhaoyujin 31390; capwap
				Subject: Re: [Capwap] This is not need.:
Proposed resolution to Issue 214 -Prioritization of IEEE 802.1X frames

				
				Cheng,
				 
				Thanks for you input.
				 
				Also, that's a good question. In my
opinion, the CAPWAP priority should be based on the TID(UP). Which means
yes, the WTP would need to read into the QoS control field.
				 
				Cheers,
				 
				Mike
				 
				On 9/25/06, Cheng Hong
<[email-masked] > wrote: 

				Hi Mike,
				 
				In this case, I tend to agree with the
other Michael on the first point. 
				 
				However, on the mapping 802.11e priority
back to CAPWAP priority, I am not really sure how that is done. Is it
based on 802.11e AC or TID (UP)? For later case, does it mean the WTP
need to read into the QoS Control Field? 
				 
				cheers
				 
				Cheng Hong

________________________________

				From: Michael Montemurro
[mailto:[email-masked] ] 
				Sent: Tuesday, September 26, 2006 1:17
AM
				To: Cheng Hong
				Cc: zhaoyujin 31390; capwap 
				
				Subject: Re: [Capwap] This is not need.:
Proposed resolution to Issue 214 -Prioritization of IEEE 802.1X frames

				
				Cheng Hong,
				 
				In the CAPWAP draft, both wireless data
and management frames are treated as CAPWAP data frames. Given that, all
CAPWAP data traffic would need to go to the same logical instance of the
AC.
				 
				Cheers,
				 
				Mike

				On 9/24/06, Cheng Hong
<[email-masked] > wrote: 

				Hi Michael & Michael,
				 
				Sorry if the issue has already been
discussed before. Just thinking if the WTP does not differentiate 802.1X
frames from normal data frames, would it be possible that the 802.1X
frames being forwarded to a different AC instance than the one
processing the control/management frames? (in case different ACs are
used to process the control and data channel) Is this acceptable?
				 
				cheers
				 
				Cheng Hong

________________________________

				From: Michael Montemurro
[mailto:[email-masked]] 
				Sent: Sunday, September 24, 2006 3:18 AM
				To: zhaoyujin 31390
				Cc: capwap
				Subject: Re: [Capwap] This is not need.:
Proposed resolution to Issue 214 -Prioritization of IEEE 802.1X frames 

				Michael,
				 
				Thanks. Is anybody else opinionated on
this feature. 
				 
				Cheers,
				 
				Mike

				On 9/23/06, zhaoyujin 31390
<[email-masked] > wrote: 

				Firstly, I have some doubt one this
suggestion.
				
				1. If CAPWAP difines like this, AP
device must decode the payload frames of 802.11 frames.
				2. Another problem, the 802.1x priority
should be implement by 802.11e. When station sends 802.11 data frames,
it can set 802.11e priority. AP should transfer 802.11e to actual CAPWAP
packet priority.
				
				So that I think CAPWAP does not need
consider the priority of 802.11 data frames payload. 
				
				Thanks
				Michael

				>Practically speaking, IEEE 802.1X
frames should be transmitted at the same priority as >IEEE 802.11
Management frames.
				>
				>I will update Section 11.5, rename
Quality of Service for IEEE 802.11 Control Messages >to "Quality
				>of Service for IEEE 802.11 control
messages and IEEE 802.1X EAPoL frames" and add text to >indicate that
IEEE 802.1X frames are sent at a higher priority.
				>Cheers,
				>Mike

				This e-mail and attachments contain
confidential information from HUAWEI, which is intended only for the
person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to,
total or partial disclosure, reproduction, or dissemination) by persons
other than the intended recipient's) is prohibited. If you receive this
e-mail in error, please notify the sender by phone or email 
				immediately and delete it!

				Practically speaking, IEEE 802.1X frames
should be transmitted at the same priority as IEEE 802.11 Management
frames. 
				 
				I will update Section 11.5, rename
Quality of Service for IEEE 802.11 Control Messages to "Quality
				of Service for IEEE 802.11 control
messages and IEEE 802.1X EAPoL frames" and add text to indicate that
IEEE 802.1X frames are sent at a higher priority.
				 
				Cheers,
				 
				Mike

_________________________________________________________________
				To unsubscribe or modify your
subscription options, please visit:
	
http://lists.frascone.com/mailman/listinfo/capwap
				
				Archives:
http://lists.frascone.com/pipermail/capwap 

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Cheng Hong" <[email-masked]>
Date: Tue, 10 Oct 2006 10:20:10 +0800

Hi Pat,
 
You are right. So, it seems that 802.1X frame may not  even always have
higher priority over wireless link.
 
Another concern I have is about the CAPWAP QoS preservation. It seems
that for the HCCA case, CAPWAP may not be able to guarantee the same QoS
over the wired section for the STA. 
 
cheers
 
Cheng Hong

  _____  

From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2006 1:42 AM
To: Cheng Hong; Michael Montemurro
Cc: capwap
Subject: RE: [Capwap] This is not need.: Proposed resolution to
Issue214-Prioritization of IEEE 802.1X frames

Pat Calhoun

  _____  

Hi Mike,

"b) QoS subtypes, in which case the QAP shall infer the UP value from
the TID in the QoS Control field
directly for TID values between 0 and 7. For TID values between 8 and
15, the QAP shall extract the
UP value in the UP subfield of the TS Info field in the associated TSPEC
or from the UP field in the
associated TCLAS (traffic classification) element, as applicable."
 
It seems that the WTP needs to do much more to obtain the actual UP
value. In case the TSPEC or TCLAS elemets are located at the AC, how
would the WTP get the UP value in the HCCA case?
 
Or is there any place that prevents sending EAPOL frames using HCCA? If
that is the case, it is not a problem. But, then again, all the data
traffic sent using HCCA will have difficulty to obtain the correct
priority in CAPWAP delivery.
 
cheers
 
Cheng Hong

  _____  

From: Michael Montemurro [mailto:[email-masked]] 
Sent: Thursday, September 28, 2006 2:23 AM
To: Cheng Hong
Cc: capwap
Subject: Re: [Capwap] This is not need.: Proposed resolution to Issue
214-Prioritization of IEEE 802.1X frames

Cheng,
 
In the HCCA case, the TID case should work as well. I don't see why it
wouldn't.
 
Cheers,
 
Mike

On 9/26/06, Cheng Hong <[email-masked]> wrote: 

Hi Mike, 
 
It seems OK to use TID in the EDCA case. If the HCCA is used, would the
TID still be meaningful in mapping the priority? (Haven't check the
802.11 standards in detail). 
 
cheers
 
Cheng Hong 

  _____  

From: Michael Montemurro [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Wednesday, September 27, 2006 12:24 AM 

To: Cheng Hong
Cc: zhaoyujin 31390; capwap
Subject: Re: [Capwap] This is not need.: Proposed resolution to Issue
214 -Prioritization of IEEE 802.1X frames

Cheng,
 
Thanks for you input.
 
Also, that's a good question. In my opinion, the CAPWAP priority should
be based on the TID(UP). Which means yes, the WTP would need to read
into the QoS control field.
 
Cheers,
 
Mike
 
On 9/25/06, Cheng Hong <[email-masked]
<mailto:[email-masked]> > wrote: 

Hi Mike,
 
In this case, I tend to agree with the other Michael on the first point.

However, on the mapping 802.11e priority back to CAPWAP priority, I am
not really sure how that is done. Is it based on 802.11e AC or TID (UP)?
For later case, does it mean the WTP need to read into the QoS Control
Field? 
 
cheers
 
Cheng Hong

  _____  

From: Michael Montemurro [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, September 26, 2006 1:17 AM
To: Cheng Hong
Cc: zhaoyujin 31390; capwap 

Subject: Re: [Capwap] This is not need.: Proposed resolution to Issue
214 -Prioritization of IEEE 802.1X frames

Cheng Hong,
 
In the CAPWAP draft, both wireless data and management frames are
treated as CAPWAP data frames. Given that, all CAPWAP data traffic would
need to go to the same logical instance of the AC.
 
Cheers,
 
Mike

On 9/24/06, Cheng Hong <[email-masked]
<mailto:[email-masked]> > wrote: 

Hi Michael & Michael,
 
Sorry if the issue has already been discussed before. Just thinking if
the WTP does not differentiate 802.1X frames from normal data frames,
would it be possible that the 802.1X frames being forwarded to a
different AC instance than the one processing the control/management
frames? (in case different ACs are used to process the control and data
channel) Is this acceptable?
 
cheers
 
Cheng Hong

  _____  

From: Michael Montemurro [mailto:[email-masked]] 
Sent: Sunday, September 24, 2006 3:18 AM
To: zhaoyujin 31390
Cc: capwap
Subject: Re: [Capwap] This is not need.: Proposed resolution to Issue
214 -Prioritization of IEEE 802.1X frames 

Michael,
 
Thanks. Is anybody else opinionated on this feature. 
 
Cheers,
 
Mike

On 9/23/06, zhaoyujin 31390 <[email-masked]
<mailto:[email-masked]> > wrote: 

Firstly, I have some doubt one this suggestion.

1. If CAPWAP difines like this, AP device must decode the payload frames
of 802.11 frames.
2. Another problem, the 802.1x priority should be implement by 802.11e.
When station sends 802.11 data frames, it can set 802.11e priority. AP
should transfer 802.11e to actual CAPWAP packet priority.

So that I think CAPWAP does not need consider the priority of 802.11
data frames payload. 

Thanks
Michael

>Practically speaking, IEEE 802.1X frames should be transmitted at the
same priority as >IEEE 802.11 Management frames.
>
>I will update Section 11.5, rename Quality of Service for IEEE 802.11
Control Messages >to "Quality
>of Service for IEEE 802.11 control messages and IEEE 802.1X EAPoL
frames" and add text to >indicate that IEEE 802.1X frames are sent at a
higher priority.
>Mike

This e-mail and attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure,
reproduction, or dissemination) by persons other than the intended
recipient's) is prohibited. If you receive this e-mail in error, please
notify the sender by phone or email 
immediately and delete it!

Practically speaking, IEEE 802.1X frames should be transmitted at the
same priority as IEEE 802.11 Management frames. 
 
I will update Section 11.5, rename Quality of Service for IEEE 802.11
Control Messages to "Quality
of Service for IEEE 802.11 control messages and IEEE 802.1X EAPoL
frames" and add text to indicate that IEEE 802.1X frames are sent at a
higher priority.
 
Cheers,
 
Mike

Archives: http://lists.frascone.com/pipermail/capwap
<http://lists.frascone.com/pipermail/capwap>