Subject: Re: [Capwap] CAPWAP for 802.11r

From: "Mani, Mahalingam (Mani)" <[email-masked]>
Date: Wed, 1 Nov 2006 14:27:25 -0700

Charles,

I agree. It is early. Moreover. We had discussed in IETF66 meeting and I
think we heard consensus that all IEEE802.11ma-rev2006, will be the
basis of CAPWAP protocol media-bindings for this round of charter -
assuming rev2006 will be done well
ahead of us - which is what we hear from our IEEE liaison/advisor.

<!chair>
With a potential for CAPWAP being a candidate protocol for HoKey to
consider extending (a little early to say so - but had been mooted
earlier) - should there be a requirement to address 802.11r keying
problem in HoKey - then it is worth discussing there.

However, 802.11r itself is appearing to address its key-transfer problem
at L2 going by recent proposals and adoption in September meetings.
</!chair>

Behcet's draft objective appears to be broader than 802.11r
key-transfer.

Regards,
-mani
-----Original Message-----
From: Charles Clancy [mailto:[email-masked]] 
Sent: Wednesday, November 01, 2006 12:42 PM
To: Margaret Wasserman
Cc: [email-masked]; capwap
Subject: Re: [Capwap] CAPWAP for 802.11r

<hat = "HOKEY chair">
Protocols for 11r handoff in CAPWAP are outside the HOKEY scope.
HOKEY's
handoff focus is based on EAP credentials before the enter the .11
keying
hierarchy, rather than after.
</hat>

<hat = "CAPWAP sec adv">
I think 11r integration to CAPWAP is out of scope for the current 802.11
binding.  I think after that's well on its way, and the WG has interest,
work on an 802.11r binding for CAPWAP could be completed.  Nothing in
the
.11 binding would prevent implementation of a .11r binding.
</hat>

Behcet, I know you're anxious to get started on 11r in CAPWAP, but I
think
you're a little early.  It's still D3 in the IEEE, and I think CAPWAP is
focused on getting everything else to work first.

-- 
t. charles clancy, ph.d.  <>  [email-masked]  <>  www.cs.umd.edu/~clancy

On Wed, November 1, 2006 8:06 am, Margaret Wasserman wrote:
>
> Hi Behcet,
>
> Thank you for sending us a pointer to this work.
>
> Unfortunately, this work is not currently in-scope for the CAPWAP
> WG.  Our only two deliverables at this point are the CAPWAP protocol
> specification (now in two documents) and the CAPWAP MIB.  After we
> complete that work, it may make sense to consider further extension
> to CAPWAP such as your CAPWAP for 802.11r extension, but we would
> need to be re-chartered to consider that work.
>
> In the meantime, you might want to join the HOKEY WG and discuss your
> ideas for how CAPWAP could be used with 802.11r in that forum.
>
> Best Regards,
> Margaret
> (for the CAPWAP Chairs)
>
> On Oct 18, 2006, at 3:43 AM, Behcet Sarikaya wrote:
>
>> Pat and all,
>>
>> The link:
>> http://www.ietf.org/internet-drafts/draft-sarikaya-capwap-
>> fastbss-00.txt
>> is now on.
>>
>> Regards,
>>
>> --behcet
>>
>> ----- Original Message ----
>> From: Pat Calhoun (pacalhou) <[email-masked]>
>> To: Behcet Sarikaya <[email-masked]>
>> Sent: Monday, October 16, 2006 7:01:11 PM
>> Subject: RE: [Capwap] CAPWAP for 802.11r
>>
>> ok, I will once it becomes available.
>>
>>
>> Pat Calhoun
>> CTO, Wireless Networking Business Unit
>> Cisco Systems
>>
>>
>>
>>
>>
----------------------------------------------------------------------
>> --
>>     *From:* Behcet Sarikaya [mailto:[email-masked]]
>>     *Sent:* Monday, October 16, 2006 4:41 PM
>>     *To:* Pat Calhoun (pacalhou); [email-masked]
>>     *Subject:* Re: [Capwap] CAPWAP for 802.11r
>>
>>     Pat,
>>
>>
>>     ----- Original Message ----
>>     From: Pat Calhoun (pacalhou) <[email-masked]>
>>     To: Behcet Sarikaya <[email-masked]>;
>> [email-masked]
>>     Sent: Monday, October 16, 2006 1:02:43 PM
>>     Subject: RE: [Capwap] CAPWAP for 802.11r
>>
>>     Behcet,
>>
>>     I believe we've discussed this idea a few times, and I am still
>>     unsure why we believe CAPWAP needs to define anything to support
>>     TGr. The current CAPWAP protocol is sufficient to support the
>>     upcoming standard.
>>
>>     ==>
>>     The basis is there but we need several extensions.
>>     Please read the draft and comment, then we can make a more
>> informed
>>     decision, I think.
>>
>>
>>     Pat Calhoun
>>     CTO, Wireless Networking Business Unit
>>     Cisco Systems
>>
>>
>>     Regards,
>>
>>     --behcet
>>
>>
>>
----------------------------------------------------------------------
>> --
>>         *From:* Behcet Sarikaya [mailto:[email-masked]]
>>         *Sent:* Saturday, October 14, 2006 8:33 AM
>>         *To:* [email-masked]
>>         *Subject:* [Capwap] CAPWAP for 802.11r
>>
>>         Dear all,
>>           I submitted a draft on CAPWAP Roaming Protocol in 802.11R
>> Domains.
>>         It should be available soon at the following link:
>>
>>         http://www.ietf.org/internet-drafts/draft-sarikaya-capwap-
>> fastbss-00.txt
>>
>>         Regards,
>>
>>         Behcet
>>
>> _________________________________________________________________
>> To unsubscribe or modify your subscription options, please visit:
>> http://lists.frascone.com/mailman/listinfo/capwap
>>
>> Archives: http://lists.frascone.com/pipermail/capwap
>
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
>
> Archives: http://lists.frascone.com/pipermail/capwap
>

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: Charles Clancy <[email-masked]>
Date: Fri, 03 Nov 2006 01:44:35 -0500

HOKEY handles handoff between authenticators, and will operate over EAP 
keys.  802.11r handles handoff between NASes, and will operate over 
802.11 keys.  In most wireless networks, your NAS is the same thing as 
your authenticator, so 11r and HOKEY both offer different solutions to 
the same problem.  However in CAPWAP the authenticator is the AC, and 
the NAS is either the WTP or AC depending on how your MAC is split.

11r support in CAPWAP means faster handoffs between WTPs by eliminating 
the 4-way-handshake.  In my opinion, these shouldn't require any CAPWAP 
protocol changes, but as discussed earlier, there are varying opinions 
on this.

HOKEY support for CAPWAP means the abilitiy to roam between different 
ACs without having to reauthenticate to the AAA server.  CAPWAP would 
not have to directly support this either.  802.11 would have to support 
it, and CAPWAP would then have to support the enhancements to 802.11, 
but again I don't think any CAPWAP protocol changes would be necessary. 
  Each AC would simply have to implement the HOKEY (possibly AAA-based) 
handoff protocols, and support the new EAP keying hierarchy extensions.

There are a lot of nuances between the various handoff protocols, each 
solving similar problems at different points in the network.  It might 
be worth while to write up a tutorial on all three and how they could 
potential interoperate.

It should also be noted that I only described the handoff features of 
HOKEY, and not some of the other ideas, including roaming to other AAA 
servers, reauth, and preauth.