Subject: Re: [Capwap] WTP MAC address

From: "Peter Nilsson J (LI/EAB)" <[email-masked]>
Date: Mon, 5 Feb 2007 14:50:25 +0100

Do we specify a format for the MAC address such as "00:11:22:33:44:55"
encoded in a UTF-8 ?

Peter

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
Sent: den 28 januari 2007 22:09
To: Peter Nilsson J (LI/EAB); Smitha Smitha (ssmitha);
[email-masked]
Subject: RE: [Capwap] WTP MAC address

Proposed text below. Please note that I opted to not be specific about
which interface has the MAC address assigned, and it MAY be the Ethernet
interface. The reason for this is that some APs do not have any Ethernet
interfaces.
 
4.5.37.  WTP Board Data
[...]
   Type:   The following values are supported:
[...]

      4 - Base MAC Addres   The WTP's Base MAC Address, which MAY be
         assigned to the primary Ethernet interface.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: Peter Nilsson J (LI/EAB)
[mailto:[email-masked]] 
	Sent: Friday, January 26, 2007 1:00 AM
	To: Pat Calhoun (pacalhou); Smitha Smitha (ssmitha);
[email-masked]
	Subject: RE: [Capwap] WTP MAC address

	Pat,
	 
	Will this change make it into the specification?  there is no
issue number opened for this as far as I can recall.
	Allthough CAPWAP will work as a protocol without this change I
still think that the MAC address is an intressting piece of information
just as WTP serial number, Model number etc.
	It may be added in WTP Descriptor, WTP Board data or some new
message element but it should be provided in Discovery and Join request
messages.
	An it should be mandatory.
	 
	Peter

________________________________

	From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
	Sent: den 12 januari 2007 16:31
	To: Peter Nilsson J (LI/EAB); Smitha Smitha (ssmitha);
[email-masked]
	Subject: RE: [Capwap] WTP MAC address

	Any objections from folks on the list to re-introduce the WTP's
Ethernet MAC Address in the join?

	Pat Calhoun
	CTO, Wireless Networking Business Unit
	Cisco Systems

________________________________

		From: Peter Nilsson J (LI/EAB)
[mailto:[email-masked]] 
		Sent: Friday, January 12, 2007 12:02 AM
		To: Pat Calhoun (pacalhou); Smitha Smitha (ssmitha);
[email-masked]
		Subject: RE: [Capwap] WTP MAC address

		Yes, I think this would work too, allthough I would
prefer to have the MAC address sent as a "static" parameter from the WTP
at the join phase.
		 
		Peter

________________________________

		From: Pat Calhoun (pacalhou) [mailto:[email-masked]]

		Sent: den 10 januari 2007 16:30
		To: Peter Nilsson J (LI/EAB); Smitha Smitha (ssmitha);
[email-masked]
		Subject: RE: [Capwap] WTP MAC address

		So I do not believe that binding the name in the
certificate to that in the Join Request is really *that* necessary. In
fact, the new state machine includes a call to the CAPWAP module to
perform authorization based on the identity provided through the DTLS
exchange. I do, however, wonder why the WTP Name cannot be used here.
For instance, it seems to me like we could recommend that the WTP has a
default WTP Name that is equal to the MAC Address (in UTF-8 format, of
course). This value can always be changed, as the WTP Name can be, but
at least it has a default value.
		 
		Thoughts?

		Pat Calhoun
		CTO, Wireless Networking Business Unit
		Cisco Systems

________________________________

			From: Peter Nilsson J (LI/EAB)
[mailto:[email-masked]] 
			Sent: Wednesday, January 10, 2007 3:18 AM
			To: Pat Calhoun (pacalhou); Smitha Smitha
(ssmitha); [email-masked]
			Subject: RE: [Capwap] WTP MAC address

			Yes, some value that is static and unique for
the WTP.
			Also as I have mentioned erlier in this thread
CAPWAP has defined that the MAC address to be part of the Common Name in
the certificates used by DTLS. By adding the MAC address to the WTP
Descriptor one could use the same value when associating to (config)
data (in the AC) for a WTP both during DTLS handshake and CAPWAP join.
			 
			Peter

________________________________

			From: Pat Calhoun (pacalhou)
[mailto:[email-masked]] 
			Sent: den 9 januari 2007 18:36
			To: Peter Nilsson J (LI/EAB); Smitha Smitha
(ssmitha); [email-masked]
			Subject: RE: [Capwap] WTP MAC address

			The text is already pretty clear that the
IP/Port MUST NOT while a session is active. Are you stating that you are
looking for a value that is static across WTP resets?

			Pat Calhoun
			CTO, Wireless Networking Business Unit
			Cisco Systems

________________________________

				From: Peter Nilsson J (LI/EAB)
[mailto:[email-masked]] 
				Sent: Monday, January 08, 2007 11:49 PM
				To: Pat Calhoun (pacalhou); Smitha
Smitha (ssmitha); [email-masked]
				Subject: RE: [Capwap] WTP MAC address

				Since both IP and Port is likely to
change it is not very good choice for the purpose. 
				Again the purpose is to have some unique
identifier (which does not change) to associate configuration and other
data, for example to be used as a key in a database which could include
the WTPs wanted configuration.
				 
				Peter 

________________________________

				From: Pat Calhoun (pacalhou)
[mailto:[email-masked]] 
				Sent: den 8 januari 2007 17:41
				To: Peter Nilsson J (LI/EAB); Smitha
Smitha (ssmitha); [email-masked]
				Subject: RE: [Capwap] WTP MAC address

				And the combination of IP/UDP port is
not sufficient to provide uniqueness.

				Pat Calhoun
				CTO, Wireless Networking Business Unit
				Cisco Systems

________________________________

					From: Peter Nilsson J (LI/EAB)
[mailto:[email-masked]] 
					Sent: Friday, January 05, 2007
12:50 AM
					To: Pat Calhoun (pacalhou);
Smitha Smitha (ssmitha); [email-masked]
					Subject: RE: [Capwap] WTP MAC
address

					The purpose is to have a unique
identifier for the WTP which can be used when associating configuration
or other data with a specific WTP in the AC.  
					As I mentioned below the serial
number which is part of the WTP Descriptor could be used for this
purpose. 
					But i suggest to add the MAC
address so that the same unique identifier can be used both during DTLS
handshake and Join (the certificates Common Name (CN) includes the MAC
address as defined by the CAPWAP spec).
					As far as I know there is no
standard mechanism to resolve the MAC address from the IP address in a
routed network.
					 
					Peter

________________________________

					From: Pat Calhoun (pacalhou)
[mailto:[email-masked]] 
					Sent: den 5 januari 2007 01:59
					To: Peter Nilsson J (LI/EAB);
Smitha Smitha (ssmitha); [email-masked]
					Subject: RE: [Capwap] WTP MAC
address

					Could you help me understand why
one would need the Ethernet MAC address if the protocol is running over
IP?

					Pat Calhoun
					CTO, Wireless Networking
Business Unit
					Cisco Systems

________________________________

					From: Peter Nilsson J (LI/EAB)
[mailto:[email-masked]] 
					Sent: Wednesday, January 03,
2007 11:42 PM
					To: Smitha Smitha (ssmitha);
[email-masked]
					Subject: Re: [Capwap] WTP MAC
address

					But the Radio Mac Address filed
is defined to be the MAC address of the radio interface.
					I was intrested to get hold of
the MAC address of the (Ethernet) interface on which the CAPWAP packets
are transmitted.
					 
					Peter

________________________________

					From: Smitha Smitha (ssmitha)
[mailto:[email-masked]] 
					Sent: den 3 januari 2007 03:57
					To: Peter Nilsson J (LI/EAB);
[email-masked]
					Subject: RE: [Capwap] WTP MAC
address

					Peter,
					 
					You can use the "M" bit in the
CAPWAP transport header and populate the mac address in the "Radio Mac
Address" field.
					 
					Thanks
					Smitha

________________________________

					From: Peter Nilsson J (LI/EAB)
[mailto:[email-masked]] 
					Sent: Thursday, December 21,
2006 3:50 PM
					To: [email-masked]
					Subject: [Capwap] WTP MAC
address

					In the early days of CAPWAP
(draft-ohara-capwap-lwapp-03.txt) the WTP MAC address was part of the
WTP Board Data message element.

					It has since been removed and I
can not see that there is a way for the AC to retrieve the WTP MAC
address. 
					I think it would be nice to have
this information to be used as a unique identifier for the WTP, for
example as a key for some configuration database in the AC.

					The serial number which should
be unique per WTP is already a part of the WTP Descriptor and could be
used for the purpose. 

					But CAPWAP specifies the the MAC
address shall be used for the Common Name (CN) attribute in the
Certificates. 
					Maybe one wants to access the
database during the DTLS handshake. Then it would be nice to be able to
use the same key for both these purposes.

					I suggest to add the WTP MAC
address to the WTP Descriptor element. 

					Peter 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 5 Feb 2007 08:20:44 -0800

As with all of the other fields in the WTP Board Data (e.g., Serial
Number), it is up to the vendor to dictate the format. So it MAY be in
the format you suggest below, but is not required.

Pat Calhoun

> From: Peter Nilsson J (LI/EAB) [mailto:[email-masked]] 
> Sent: Monday, February 05, 2007 5:50 AM
> Proposed text below. Please note that I opted to not be 
> specific about which interface has the MAC address assigned, 
> and it MAY be the Ethernet interface. The reason for this is 
> that some APs do not have any Ethernet interfaces.
>  
> 4.5.37.  WTP Board Data
> [...]
> 	Will this change make it into the specification?  there 
> is no issue number opened for this as far as I can recall.
> 	Allthough CAPWAP will work as a protocol without this 
> change I still think that the MAC address is an intressting 
> piece of information just as WTP serial number, Model number etc.
> 	It may be added in WTP Descriptor, WTP Board data or 
> some new message element but it should be provided in 
> Discovery and Join request messages.
> 	Any objections from folks on the list to re-introduce 
> the WTP's Ethernet MAC Address in the join?
> 	 
> 
> 	Pat Calhoun
> 		Yes, I think this would work too, allthough I 
> would prefer to have the MAC address sent as a "static" 
> parameter from the WTP at the join phase.
> 		 
> 		Peter
> 
> 		So I do not believe that binding the name in 
> the certificate to that in the Join Request is really *that* 
> necessary. In fact, the new state machine includes a call to 
> the CAPWAP module to perform authorization based on the 
> identity provided through the DTLS exchange. I do, however, 
> wonder why the WTP Name cannot be used here.
> For instance, it seems to me like we could recommend that the 
> WTP has a default WTP Name that is equal to the MAC Address 
> (in UTF-8 format, of course). This value can always be 
> changed, as the WTP Name can be, but at least it has a default value.
> 		 
> 		Thoughts?
> 		 
> 
> 		Pat Calhoun
> 			Yes, some value that is static and 
> unique for the WTP.
> 			Also as I have mentioned erlier in this 
> thread CAPWAP has defined that the MAC address to be part of 
> the Common Name in the certificates used by DTLS. By adding 
> the MAC address to the WTP Descriptor one could use the same 
> value when associating to (config) data (in the AC) for a WTP 
> both during DTLS handshake and CAPWAP join.
> 			 
> 			Peter
> 
> 			The text is already pretty clear that 
> the IP/Port MUST NOT while a session is active. Are you 
> stating that you are looking for a value that is static 
> across WTP resets?
> 			 
> 
> 			Pat Calhoun
> 				Again the purpose is to have 
> some unique identifier (which does not change) to associate 
> configuration and other data, for example to be used as a key 
> in a database which could include the WTPs wanted configuration.
> 				 
> 				Peter 
> 
> 				And the combination of IP/UDP 
> port is not sufficient to provide uniqueness.
> 				 
> 
> 				Pat Calhoun
> identifier for the WTP which can be used when associating 
> configuration or other data with a specific WTP in the AC.  
> number which is part of the WTP Descriptor could be used for 
> this purpose. 
> address so that the same unique identifier can be used both 
> during DTLS handshake and Join (the certificates Common Name 
> (CN) includes the MAC address as defined by the CAPWAP spec).
> standard mechanism to resolve the MAC address from the IP 
> address in a routed network.
> 					 
> 					Peter
> 					 
> 
> one would need the Ethernet MAC address if the protocol is 
> running over IP?
> 					 
> 
> 					Pat Calhoun
> 					CTO, Wireless Networking
> Business Unit
> 					Cisco Systems
> 
> 	
> 
> 					
> 					
> 
> the MAC address of the (Ethernet) interface on which the 
> CAPWAP packets are transmitted.
> 					 
> 					Peter
> 
> CAPWAP transport header and populate the mac address in the 
> "Radio Mac Address" field.
> 					 
> 					Thanks
> 					Smitha
> 
> (draft-ohara-capwap-lwapp-03.txt) the WTP MAC address was 
> part of the WTP Board Data message element.
> 
> can not see that there is a way for the AC to retrieve the 
> WTP MAC address. 
> this information to be used as a unique identifier for the 
> WTP, for example as a key for some configuration database in the AC.
> 
> be unique per WTP is already a part of the WTP Descriptor and 
> could be used for the purpose. 
> 
> address shall be used for the Common Name (CN) attribute in 
> the Certificates. 
> database during the DTLS handshake. Then it would be nice to 
> be able to use the same key for both these purposes.
>