Subject: [Capwap] vendor specific payloads

From: "Abhijit Choudhury (achoudhu)" <[email-masked]>
Date: Sat, 1 Dec 2007 18:43:16 -0800

In the CAPWAP spec, Vendor Specific Payloads are defined but
nothing is said about which messages can carry these payloads.
 
We should add text to specify that ANY message, including
ECHO Response, EVENT Response etc. can carry Vendor Specific 
Payloads. As mentioned in 4.5.1.5, if a WTP or AC receives 
a CAPWAP message with a message element that the WTP or AC 
does not recognize, the CAPWAP message will be discarded.
 
Thanks,
Abhijit

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Sun, 2 Dec 2007 14:34:29 -0800

Created issue 29 to track this
 
PatC

________________________________

From: Abhijit Choudhury (achoudhu) 
Sent: Saturday, December 01, 2007 6:43 PM
To: [email-masked]
Subject: [Capwap] vendor specific payloads

 
Thanks,
Abhijit

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 3 Dec 2007 17:09:35 -0800

All,

During today's face to face meeting, the group decided that this issue
was valid and we need to resolve it in the current protocol. I am
providing the proposed text changes to support the issue. 

Comments appreciated.

<base draft>

4.6.39.  Vendor Specific Payload

   The Vendor Specific Payload message element is used to communicate
   vendor specific information between the WTP and the AC.  The Vendor
   Specific Payload message element MAY be present in any CAPWAP
   message.  The message element uses the following format:

      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |                       Vendor Identifier                       |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |          Element ID           |   Value...    |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

5.1.  Discovery Request Message
[...]
   The following message elements MAY be included in the Discovery
   Request message:

   o  Vendor Specific Payload, see Section 4.6.39

5.2.  Discovery Response Message
[...]
   The following message elements MAY be included in the Discovery
   Response message:

   o  Vendor Specific Payload, see Section 4.6.39

5.3.  Primary Discovery Request Message
[...]

   The following message elements MAY be included in the Primary
   Discovery Request message:

   o  Vendor Specific Payload, see Section 4.6.39

5.4.  Primary Discovery Response
[...]
   The following message elements MAY be included in the Primary
   Discovery Response message:

   o  Vendor Specific Payload, see Section 4.6.39

6.1.  Join Request
[...]
   The following message element MAY be included in the Join Request
   message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

6.2.  Join Response
[...]
   The following message elements MAY be included in the Join Response
   message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

7.1.  Echo Request
[...]
   The following message elements MAY be included in the Echo Request
   message:

   o  Vendor Specific Payload, see Section 4.6.39

7.2.  Echo Response
[...]
   The following message elements MAY be included in the Echo Response
   message:

   o  Vendor Specific Payload, see Section 4.6.39

8.2.  Configuration Status
[...]
   The following message elements MAY be included in the Configuration
   Status message.

   o  Vendor Specific Payload, see Section 4.6.39

8.3.  Configuration Status Response
[...]
   The following message element MAY be included in the Configuration
   Status Response message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

8.4.  Configuration Update Request
[...]
   One or more of the following message elements MAY be included in the
   Configuration Update message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

8.5.  Configuration Update Response
[...]
   The following message elements MAY be present in the Configuration
   Update Response message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

8.6.  Change State Event Request
[...]
   One or more of the following message elements MAY be present in the
   Change State Event Request message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

8.7.  Change State Event Response
[...]
   The following message elements MAY be included in the Change State
   Event Response message:

   o  Vendor Specific Payload, see Section 4.6.39

8.8.  Clear Configuration Request
[...]
   The following message elements MAY be included in the Clear
   Configuration Request message:

   o  Vendor Specific Payload, see Section 4.6.39

8.9.  Clear Configuration Response
[...]
   The following message elements MAY be included in the Clear
   Configuration Request message:

   o  Vendor Specific Payload, see Section 4.6.39

9.1.1.  Image Data Request
[...]

   The following message elements MAY be included in the Image Data
   Request message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

9.1.2.  Image Data Response
[...]
   The following message elements MAY be included in the Image Data
   Response message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

9.2.  Reset Request
   The following message elements MAY be included in the Reset Request
   message:

   o  Vendor Specific Payload, see Section 4.6.39

9.3.  Reset Response
[...]
   The following message element MAY be included in the Reset Response
   message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

9.4.  WTP Event Request
[...]
   More than one of each messsage element
   listed MAY be included in the WTP Event Request message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

9.5.  WTP Event Response
[...]
   The following message elements MAY be included in the WTP Event
   Response message:

   o  Vendor Specific Payload, see Section 4.6.39

9.6.  Data Transfer Request
[...]
   The following message elements MAY be included in the Data Transfer
   Request message:

   o  Vendor Specific Payload, see Section 4.6.39

9.7.  Data Transfer Response
[...]
   The following message elements MAY be included in the Data Transfer
   Response message:

   o  Vendor Specific Payload, see Section 4.6.39

10.1.  Station Configuration Request
[...]
   More than one of each message
   element listed MAY be included in the Station Configuration Request
   message.
[...]
   o  Vendor Specific Payload, see Section 4.6.39

10.2.  Station Configuration Response
[...]
   The following message elements MAY be included in the Station
   Configuration Response message:

   o  Vendor Specific Payload, see Section 4.6.39

</base draft>

<binding draft>

3.1.  IEEE 802.11 WLAN Configuration Request
[...]
   The following message element MAY be present.
[...]
   o  Vendor Specific Payload, see [3]

3.2.  IEEE 802.11 WLAN Configuration Response
[...]
   The following message element MAY be present.
[...]
   o  Vendor Specific Payload, see [3]

</binding draft>

PatC

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 4 Dec 2007 14:16:51 -0500

These changes look good to me.

Margaret

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 21 Dec 2007 08:20:11 -0800

I am closing this issue as no additional comments have been received
since the text was proposed.

PatC 

-----Original Message-----
From: Margaret Wasserman [mailto:[email-masked]] 
Sent: Tuesday, December 04, 2007 11:17 AM
To: Pat Calhoun (pacalhou)
Cc: Abhijit Choudhury (achoudhu); [email-masked]
Subject: Re: [Capwap] Issue 29: vendor specific payloads

Margaret

> 5.3.  Primary Discovery Request Message [...]
>
> 3.1.  IEEE 802.11 WLAN Configuration Request [...]
> 3.2.  IEEE 802.11 WLAN Configuration Response [...]