Subject: RE: low-infrastructure GSS mechanisms?

From: Paul Leach <[email-masked]>
Date: Fri, 8 Jan 1999 10:41:48 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, January 08, 1999 5:29 AM
> 
> Furthermore, GSSAPI offers confidentiality and data 
> encryption services,
> and I think that it's really important for a low-infrastructure
> mechanism to provide these services.  Given that it's not hard to do
> this, I think we should add these features.

Please note that the last Digest SASL draft also included integrity and
confidentiality services.

Also, it seems to me that creation of a DH tunnel ought to be able to be
done in a way that is orthogonal to the protocol (authentication or
otherwise) being tunneled. I wouldn't want to have to define DH tunnel
capabilities for every new auth protocol that comes down the pike.

Paul
==========================================================================
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]

---

From: David Jablon <[email-masked]>
Date: Fri, 08 Jan 1999 16:21:17 -0500

At 10:41 AM 1/8/99 -0800, Paul Leach wrote:
> otherwise) being tunneled. [...]

Unfortunately this advice is contrary to a basic sound
design principle for secure authentication protocols:
namely, that authentication should be integrated with
key exchange.

In general, artificially separating the authentication
from the key exchange weakens a protocol.
Here, it opens it to middleman attack.

Sure, added protection from DH *can* be obtained with a
separate tunnel, and still be better than not using it at all.
But I see no reason for a standard to mandate or take pains
to limit people to such practice.

> [...] I wouldn't want to have to define DH tunnel

I'm curious.  How many new auth protocols do you see coming
that could use the extra protection of a separate DH exchange?
I presumed you were advocating just Digest-MD5.

-------------------------
David P. Jablon
Integrity Sciences, Inc.
[email-masked]
<http://world.std.com/~dpj/>
+1 508 898 9024