Subject: [Cbor] Ambiguities in CDDL specifiction

From: Jeffrey Yasskin <[email-masked]>
Date: Wed, 21 Mar 2018 14:39:31 +0000

I've filed a collection of issues against CDDL where parts seem ambiguous.

   - groups: https://github.com/cbor-wg/cddl/issues/14
   - .size: https://github.com/cbor-wg/cddl/issues/15
   - types of numbers: https://github.com/cbor-wg/cddl/issues/16
   - .eq and .ne: https://github.com/cbor-wg/cddl/issues/18

One thing that happens when you write a specification formally, is that you
discover ambiguities that hid in a more colloquial draft, so I'm not sure
this is everything, but it's all I've found.

I am worried that some readers will miss that Appendix C exists, and will
read uses of CDDL in other specs incorrectly as a result, but fixing that
is probably as much work as making the whole spec rigorous.

As discussed in the face-to-face meeting, while I'd rather wait to publish
the CDDL RFC until it's rigorous so that I can use it in web
specifications, the working group has heard my argument and disagrees, and
that's all right.

Jeffrey

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 21 Mar 2018 14:51:01 +0000

On Mar 21, 2018, at 14:39, Jeffrey Yasskin <[email-masked]> wrote:
> 	• groups: https://github.com/cbor-wg/cddl/issues/14
> 	• .size: https://github.com/cbor-wg/cddl/issues/15
> 	• types of numbers: https://github.com/cbor-wg/cddl/issues/16
> 	• .eq and .ne: https://github.com/cbor-wg/cddl/issues/18

Thank you, this is very useful input.

> One thing that happens when you write a specification formally, is that you discover ambiguities that hid in a more colloquial draft, so I’m not sure this is everything, but it's all I've found.

Barring formal semantics (hint for bright young grad students :-), we will always have uncertainties on an English language specification.

> I am worried that some readers will miss that Appendix C exists, and will read uses of CDDL in other specs incorrectly as a result, but fixing that is probably as much work as making the whole spec rigorous.

Lots of people write ABNF specifications without fully understanding the implications of grammars…
There is no way we can avoid the situation that CDDL is used by people who haven’t invested the time to learn all its intricacies (as few of those as there are); I actually think that this is a good thing.

> As discussed in the face-to-face meeting, while I’d rather wait to publish the CDDL RFC until it's rigorous so that I can use it in web specifications, the working group has heard my argument and disagrees, and that's all right.

I’d rather not wait, instead make it rigorous fast, and publish it…

Let’s work on this the next couple of weeks.

Grüße, Carsten