Subject: Re: [Cbor] Progressing work on draft-ietf-cbor-7049bis

From: Jeffrey Yasskin <[email-masked]>
Date: Fri, 25 May 2018 11:18:58 -0700

My impression of the state of these PRs is:

On Thu, Apr 26, 2018 at 7:14 AM Francesca Palombini <
[email-masked]> wrote:

> Hi all,
>
>
>
> In order to progress the draft, I’d like you to take a look at Jeffrey’s
> proposals (quoted selected text from his mail below).
>
>
>
> Only PR17 has gotten one comment so far (let’s discuss it further). Note
> that the PR were submitted more than a month ago, if I hear no objections
> to them before the 11th of May, we’ll ask the editors to go ahead and
> merge them, so please take a look and speak up. Even a “+1” is useful.
>
>
>
> Big PR:
>
> https://github.com/cbor-wg/CBORbis/pull/17 has a lot of changes to define
> which kinds of CBOR parsers need to detect which errors in the encoded
> data, and which errors are recoverable.
>

Still under discussion.

> https://github.com/cbor-wg/CBORbis/pull/18 defines when the known kinds
> of tagged items are valid.
>

The only objection misunderstood which text I removed, so this is probably
ok to merge. Its description of tag 35 is still somewhat ambiguous because
PCRE and ECMAScript have different sets of valid regular expressions, but I
think it's still an improvement over what was there before.

Minor PR:
>
> https://github.com/cbor-wg/CBORbis/pull/14 removes the duplicate Data
> Models section.
>

No comments at all, and this is probably uncontroversial.

> https://github.com/cbor-wg/CBORbis/pull/19 fixes an example of Javascript
> being unable to distinguish strings from numbers when they're used as map
> keys
>

One comment from Jim led to me updating the ECMAScript reference.

> https://github.com/cbor-wg/CBORbis/pull/20/files changes a statement that
> depending on map order "would be very bad practice" in protocols using CBOR
> to a statement that these protocols "MUST NOT" do that.
>

Jim wondered whether declaring a map ordering to be an error constitutes a
change to the semantics based on ordering, and I've changed the text to be
clear that it's allowed.

Thanks,
Jeffrey

---

From: Jim Schaad <[email-masked]>
Date: Fri, 25 May 2018 15:19:45 -0700

From: CBOR <[email-masked]> On Behalf Of Jeffrey Yasskin
Sent: Friday, May 25, 2018 11:19 AM
To: Francesca Palombini <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Cbor] Progressing work on draft-ietf-cbor-7049bis

On Thu, Apr 26, 2018 at 7:14 AM Francesca Palombini <[email-masked] <mailto:[email-masked]> > wrote:

Hi all,

In order to progress the draft, I’d like you to take a look at Jeffrey’s proposals (quoted selected text from his mail below).

Only PR17 has gotten one comment so far (let’s discuss it further). Note that the PR were submitted more than a month ago, if I hear no objections to them before the 11th of May, we’ll ask the editors to go ahead and merge them, so please take a look and speak up. Even a “+1” is useful.

Big PR:

 <https://github.com/cbor-wg/CBORbis/pull/17> https://github.com/cbor-wg/CBORbis/pull/17 has a lot of changes to define which kinds of CBOR parsers need to detect which errors in the encoded data, and which errors are recoverable.

Still under discussion.

 <https://github.com/cbor-wg/CBORbis/pull/18> https://github.com/cbor-wg/CBORbis/pull/18 defines when the known kinds of tagged items are valid. 

The only objection misunderstood which text I removed, so this is probably ok to merge. Its description of tag 35 is still somewhat ambiguous because PCRE and ECMAScript have different sets of valid regular expressions, but I think it's still an improvement over what was there before.

[JLS] I have no real opinion on this set of changes

Minor PR:

 <https://github.com/cbor-wg/CBORbis/pull/14> https://github.com/cbor-wg/CBORbis/pull/14 removes the duplicate Data Models section.

 <https://github.com/cbor-wg/CBORbis/pull/19> https://github.com/cbor-wg/CBORbis/pull/19 fixes an example of Javascript being unable to distinguish strings from numbers when they're used as map keys

[JLS] My only problem with this has more to do with the original language  than with any changes (the problem I have is still there).  I would not block anything on the problem I have as it is probably just me.

 <https://github.com/cbor-wg/CBORbis/pull/20/files> https://github.com/cbor-wg/CBORbis/pull/20/files changes a statement that depending on map order "would be very bad practice" in protocols using CBOR to a statement that these protocols "MUST NOT" do that.

Jim wondered whether declaring a map ordering to be an error constitutes a change to the semantics based on ordering, and I've changed the text to be clear that it's allowed.

[JLS] No problems with this update

Thanks,

Jeffrey

---

From: Francesca Palombini <[email-masked]>
Date: Mon, 28 May 2018 11:23:49 +0000

Hi all,

We have left enough time to let these PR being discussed. According to the response on github and the threads in here, I think it is time to merge: 14, 15, 19, 20. Authors, could you go on and merge these?

Jim, would you be able to open an issue (or a mail thread)/ propose a change to fix the problem with the original language you mention below?

17 and 18 are still under discussion.

Note that some new PR have been opened (24, 25): discussion is going on (github issues and mailing list), so make sure to voice your opinion if you have any.

Thanks to everybody who is participating!
Francesca

From: Jim Schaad <[email-masked]>
Sent: den 26 maj 2018 00:20
To: 'Jeffrey Yasskin' <[email-masked]>; Francesca Palombini <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Cbor] Progressing work on draft-ietf-cbor-7049bis

From: CBOR <[email-masked]<mailto:[email-masked]>> On Behalf Of Jeffrey Yasskin
Sent: Friday, May 25, 2018 11:19 AM
To: Francesca Palombini <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Cbor] Progressing work on draft-ietf-cbor-7049bis

On Thu, Apr 26, 2018 at 7:14 AM Francesca Palombini <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Big PR:
https://github.com/cbor-wg/CBORbis/pull/17 has a lot of changes to define which kinds of CBOR parsers need to detect which errors in the encoded data, and which errors are recoverable.

Still under discussion.

https://github.com/cbor-wg/CBORbis/pull/18 defines when the known kinds of tagged items are valid.

Minor PR:
https://github.com/cbor-wg/CBORbis/pull/14 removes the duplicate Data Models section.

https://github.com/cbor-wg/CBORbis/pull/19 fixes an example of Javascript being unable to distinguish strings from numbers when they're used as map keys

https://github.com/cbor-wg/CBORbis/pull/20/files changes a statement that depending on map order "would be very bad practice" in protocols using CBOR to a statement that these protocols "MUST NOT" do that.

Thanks,
Jeffrey

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 28 May 2018 14:49:21 +0200

On May 28, 2018, at 13:23, Francesca Palombini <[email-masked]> wrote:
> 
> I think it is time to merge: 14, 15, 19, 20. Authors, could you go on and merge these?

This week is a good week for getting merges done.

Contributors: Please do not make formatting changes that are unrelated to the part that you are proposing to change.  This creates merge conflicts and obscures the changes that actually are being made.  (Yes, the source is somewhat inconsistently formatted in some places — the damage to version control from fixing this is much larger than the slight discomfort we experience when we are editing it.)

Grüße, Carsten

---

From: Jeffrey Yasskin <[email-masked]>
Date: Tue, 29 May 2018 11:28:50 -0700

On Mon, May 28, 2018 at 4:23 AM Francesca Palombini <
[email-masked]> wrote:

> Hi all,
>
>
>
> We have left enough time to let these PR being discussed. According to the
> response on github and the threads in here, I think it is time to merge:
> 14, 15, 19, 20. Authors, could you go on and merge these?
>

Thanks! I assume you mean that the editors should merge these, since I
don't have write access.

Jeffrey

>
>
> Jim, would you be able to open an issue (or a mail thread)/ propose a
> change to fix the problem with the original language you mention below?
>
>
>
> Note that some new PR have been opened (24, 25): discussion is going on
> (github issues and mailing list), so make sure to voice your opinion if you
> have any.
>
>
>
> *From:* Jim Schaad <[email-masked]>
> *Sent:* den 26 maj 2018 00:20
> *To:* 'Jeffrey Yasskin' <[email-masked]>; Francesca Palombini <
> [email-masked]>
> *Cc:* [email-masked]; [email-masked];
> [email-masked]
> *Subject:* RE: [Cbor] Progressing work on draft-ietf-cbor-7049bis
>
>
>
>
>
>
>
> *From:* CBOR <[email-masked]> *On Behalf Of *Jeffrey Yasskin
> *Sent:* Friday, May 25, 2018 11:19 AM
> *To:* Francesca Palombini <[email-masked]>
> *Cc:* [email-masked]; [email-masked];
> [email-masked]
> *Subject:* Re: [Cbor] Progressing work on draft-ietf-cbor-7049bis
>
>
>
> [email-masked] <[email-masked]>>
> wrote:
>
> Hi all,
>
>
>
> [JLS] My only problem with this has more to do with the original language
>  than with any changes (the problem I have is still there).  I would not
> block anything on the problem I have as it is probably just me.
>
>
>