Subject: [Cbor] Background Information (PR #26)

From: Carsten Bormann <[email-masked]>
Date: Mon, 28 May 2018 15:07:34 +0200

Burt has started collecting some information about the backdrop in front of which CBOR was created in PR #26.  I think this is interesting material, but like most “history of computing” style collection, it will take some effort to get it right and reasonably complete.  E.g., I’d sure like to talk to the people who where there when RFC 713 was created and get a more complete picture of their thinking.  All in all, this makes a nice project for a couple of years of on-and-off work, but doesn’t quite fit into the schedule we have set ourselves for the CBORbis work.

Should we maybe start a separate document for background information like this?  Maybe we can add some background information on canonicalization…

Grüße, Carsten

---

From: Jim Schaad <[email-masked]>
Date: Mon, 28 May 2018 10:31:07 -0700

I am not sure that I find the history lesson to be especially useful for this document.  Much of the information presented seems to be completely unrelated to anything (why have section on ASCII?), some of it may cause people to become more defensive about things (one throw away line on ASN.1 is not going to get me mad, but a large dis of it is going to cause me to make lots of arguments) and none if it seems to be helpful to the goal of the document which is to describe what CBOR is and how to use it.  I agree with Carsten that getting this right is going to take far longer than we can currently afford.

Jim

> -----Original Message-----
> From: CBOR <[email-masked]> On Behalf Of Carsten Bormann
> Sent: Monday, May 28, 2018 6:08 AM
> To: [email-masked]
> Subject: [Cbor] Background Information (PR #26)
> 
> Burt has started collecting some information about the backdrop in front of
> which CBOR was created in PR #26.  I think this is interesting material, but like
> most “history of computing” style collection, it will take some effort to get it
> right and reasonably complete.  E.g., I’d sure like to talk to the people who
> where there when RFC 713 was created and get a more complete picture of
> their thinking.  All in all, this makes a nice project for a couple of years of on-
> and-off work, but doesn’t quite fit into the schedule we have set ourselves
> for the CBORbis work.
> 
> Should we maybe start a separate document for background information like
> this?  Maybe we can add some background information on canonicalization…
> 
> Grüße, Carsten
> 
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor