Subject: [Cbor] I-D Action: draft-ietf-cbor-array-tags-01.txt

From: [email-masked]
Date: Wed, 27 Feb 2019 05:19:45 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Concise Binary Object Representation Maintenance and Extensions WG of the IETF.

        Title           : Concise Binary Object Representation (CBOR) Tags for Typed Arrays
        Authors         : Johnathan Roatch
                          Carsten Bormann
	Filename        : draft-ietf-cbor-array-tags-01.txt
	Pages           : 14
	Date            : 2019-02-27

Abstract:
   The Concise Binary Object Representation (CBOR, RFC 7049) is a data
   format whose design goals include the possibility of extremely small
   code size, fairly small message size, and extensibility without the
   need for version negotiation.

   The present document makes use of this extensibility to define a
   number of CBOR tags for typed arrays of numeric data, as well as two
   additional tags for multi-dimensional and homogeneous arrays.  It is
   intended as the reference document for the IANA registration of the
   CBOR tags defined.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cbor-array-tags/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-cbor-array-tags-01
https://datatracker.ietf.org/doc/html/draft-ietf-cbor-array-tags-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-cbor-array-tags-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 Feb 2019 14:30:45 +0100

I have now submitted the array-tags draft as updated in Bangkok (go for 1+1, plus nits).

One thing I added was a column-major multi-dimensional array tag, out of the 1+2 space — thank you, Jim, for reminding us, and some off-line research about outstanding use of column-major corroborated this as somewhat useful.  This could definitely be criticized as “Vorratsstandardisierung” (stock-building standardization), but hey, this is an FCFS tag, and sooner or later this will come up.

We didn’t have the mailing list validation of 1+1 we said we were having in Bangkok.
Maybe silence is a form of validation (probably not good enough for the chairs, but maybe good enough for the designated expert?).
To make a point about a need to fine-tune our IANA considerations, I’ll now go ahead with registering these code points, anyway, which will allow us to finally clear out a long-standing IANA request.

I missed an issue on array-tags that I don’t think really is an issue on those, but really on the way we do decimal fractions: https://github.com/cbor-wg/array-tags/issues/1
This is one of many tags that has the interesting property of transforming the data in its data item.  The weird thing about those is that the tag should be usable in all places where the result of that transformation should be usable.  Makes me think about all those attempts at data validation of data items in other tags.  Maybe a fine point, but quite relevant for the further evolution of CBOR usage.

Grüße, Carsten

> On Feb 27, 2019, at 14:19, [email-masked] wrote:
> 
> 
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor
>