Subject: [Cbor] Private Use Tags

From: Richter, Jörg <[email-masked]>
Date: Tue, 19 Feb 2019 10:11:11 +0000

I had the idea to tag some internal types. These types are
never transferred to other communication partners.
Would it be possible to provide a tag range that is explicitly
marked as "Private Use Area"? This would exclude the
possibility that these tags will be assigned in the future and
that there will be a collision.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 19 Feb 2019 13:27:20 +0100

Hi Jörg,

The IETF has a long and checkered history with private-use allocations.

Generally, the observation is that private-use allocations start to get used for something that does get wide deployment, and suddenly, those allocations take on specific semantics and no longer truly are available for private use.
This is somewhat related to the “X-Dash problem”, which is discussed in RFC 6648.

Instead, you can just go ahead and register the tags “Jörg Richter Private 1” to “Jörg Richter Private 10”.  (Preferably in the 1+2 or, if the allocation is huge, 1+4 byte space.)  The Tag number space is huge, so it is unlikely we will run out because of such private use allocations.  And if one of these suddenly takes off, you can keep the number and change the name (and supply a specification, I hope).  (You might want to use a middle person for the allocation if you don’t even want to disclose that you are using CBOR Tags.)

Grüße, Carsten

> On Feb 19, 2019, at 11:11, Richter, Jörg <[email-masked]> wrote:
> 
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor

---

From: Richter, Jörg <[email-masked]>
Date: Tue, 19 Feb 2019 12:44:42 +0000

Good point. At the moment I use tag 27 for it. (Serialised 
language-independent object with type name and constructor arguments)

The disadvantage is that the CBOR encoding is quite long.
But I think I'll keep that for now and allocate tags when the need grows.

> -----Original Message-----
> From: Carsten Bormann [mailto:[email-masked]]
> Sent: Tuesday, February 19, 2019 1:27 PM
> To: Richter, Jörg
> Cc: [email-masked]
> Subject: Re: [Cbor] Private Use Tags
> 
> Hi Jörg,
> 
> Generally, the observation is that private-use allocations start to get
> used for something that does get wide deployment, and suddenly, those
> allocations take on specific semantics and no longer truly are available
> for private use.
> Instead, you can just go ahead and register the tags “Jörg Richter Private
> 1” to “Jörg Richter Private 10”.  (Preferably in the 1+2 or, if the
> allocation is huge, 1+4 byte space.)  The Tag number space is huge, so it
> is unlikely we will run out because of such private use allocations.  And
> if one of these suddenly takes off, you can keep the number and change the
> name (and supply a specification, I hope).  (You might want to use a
> middle person for the allocation if you don’t even want to disclose that
> you are using CBOR Tags.)
> 
> Grüße, Carsten
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 20 Feb 2019 11:52:28 +1300

> This is somewhat related to the “X-Dash problem”, which is discussed in RFC 6648.

In my not unbiased opinion, it's also related to the limited domains problem [https://tools.ietf.org/html/draft-carpenter-limited-domains] and the whole topic of protocol extensions [https://tools.ietf.org/html/rfc6709]. Perhaps not a topic for this list, but I agree with Carsten that registering a tag intended for private use is much safer than using a potentially ambiguous value.

    Brian