Subject: [Cbor] Reminder: CBOR Virtual Meeting: 2019-02-13

From: Barry Leiba <[email-masked]>
Date: Tue, 12 Feb 2019 15:15:30 -0500

Reminder: The next CBOR teleconference is Wednesday, 13 February; see below.

Webex:
https://ietf.webex.com/ietf/j.php?MTID=mf31b8e63cfd354ca8461b998aa30c4ba

Barry

On Mon, Dec 3, 2018 at 12:29 PM IESG Secretary <[email-masked]> wrote:
> The Concise Binary Object Representation Maintenance and Extensions
> (cbor) Working Group will hold a virtual interim meeting on 2019-02-13
> from 18:00 to 19:00 UTC.
>
> The CBOR working group will have conference calls running every two
> weeks through the end of March (until IETF 104 in Prague).
> Day: every other Wednesday beginning on 19 December
> Dates: 19 Dec; 2, 16, 30 Jan; 13, 27 Feb; 13 March
> Time: 18:00 to 19:00 UT
>
>Agenda:
> (No agenda submitted)
>
> Information about remote participation:
> We will use the working group WebEx for the calls.  The IETF WebEx
> account does not allow International dialing nor US toll free ("800"
> numbers), but you can use the WebEx app to connect your device audio,
> and there's also the option of connection directly from your browser if
> your browser supports it.  WebEx details will be sent to the mailing
> list before each call (the details will be the same for all calls, but
> the messages will serve as reminders).

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 12 Feb 2019 22:59:21 +0100

> https://ietf.webex.com/ietf/j.php?MTID=mf31b8e63cfd354ca8461b998aa30c4ba

For draft-ietf-cbor-cddl, I have pushed a proposal for Appendix A, Parsing Expression Grammars (PEG).
This is intended to address Ekr’s remaining DISCUSS point.  I know the notice is short, but if you could have a look at the github repo…

Unfortunately, xml2rfc is core dumping (!?), so there is no current CI build, but I pushed a local build:

https://cbor-wg.github.io/cddl/draft-ietf-cbor-cddl.html#rfc.appendix.A

And a diff of all changes since -06:
https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-cbor-cddl.txt&url2=https://cbor-wg.github.io/cddl/draft-ietf-cbor-cddl.txt

Maybe we can put a lid on this tomorrow (or at least decide what else is needed).

Grüße, Carsten

---

From: Francesca Palombini <[email-masked]>
Date: Wed, 13 Feb 2019 18:46:21 +0000

Hi all,

Here are the minutes from today's interim, also uploaded to the datatracker. For the presents, please let me know if anything was incorrectly captured.

As an action point for everybody, please take a look at the update that Carsten posted about CDDL (see below), and let us know as soon as possible.

Thanks,
Francesca

--

CBOR WG Conference Call
Wednesday,Feb 13 2019, 18:00 - 18:30 UTC
Chairs: Barry Leiba, Francesca Palombini

Minute takers: Francesca

Participants:
* Carsten Bormann
* Francesca Palombini
* Laurence Lundblade
* Michael Richardson
    
Paul sends regrets and hope to do updates and discuss progress on CBOR bis during next interim.

Laurence: waiting on PR 17 to be merged to discuss that (CBOR bis) --> next interim

CDDL doc summary: in IESG processing with 1 remaining DISCUSS from Ekr: "PEG reference should be a normative reference". During discussion with the WG it was decided to add some text that would summarize the PEG text.
New appendix: appendix A - normative. Contains everything you need to know to parse CDDL. 2 text pages.

Michael Richardson: where?
Carsten: github

Michael: after looking at the github, think the appendix is very good.

Carsten: Plan to submit this in the next few hours, let the WG take a look and wait for Ekr's comments (Carsten to ping him)

Francesca to ping the wg for feedback

Michael: what is left in CBOR?
Carsten: CBOR Bis to internet standard + few tag documents

Carsten still to submit v-02 of error tag. + other proposal of dates (as opposed to point in time), time of day, currency.

Michael: concise identities? (Henk proposal)
Carsten: do not think it fits in CBOR.
Laurence: think it belongs to RATS.

On 12/02/2019, 22:59, "CBOR on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    

    
    
    Grüße, Carsten
    
    _______________________________________________
    CBOR mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/cbor