Subject: [Cbor] Reminder: CBOR Virtual Meeting: 2019-02-27

From: Francesca Palombini <[email-masked]>
Date: Wed, 27 Feb 2019 17:30:17 +0000

Reminder: The next CBOR teleconference is in 30 minutes.

Webex:
https://ietf.webex.com/ietf/j.php?MTID=mf31b8e63cfd354ca8461b998aa30c4ba 

Talk to you soon,
Francesca

On 03/12/2018, 18:31, "CBOR on behalf of IESG Secretary" <[email-masked] on behalf of [email-masked]> wrote:

    The Concise Binary Object Representation Maintenance and Extensions (cbor) Working Group will hold
    a virtual interim meeting on 2019-02-27 from 18:00 to 19:00 UTC.
    
    The CBOR working group will have conference calls running every two weeks through the end of March (until IETF 104 in Prague).   
    Day: every other Wednesday beginning on 19 December 
    Dates: 19 Dec; 2, 16, 30 Jan; 13, 27 Feb; 13 March 
    Time: 18:00 to 19:00 UT
    
    Agenda:
    (No agenda submitted)
    
    Information about remote participation:
    We will use the working group WebEx for the calls.  The IETF WebEx account does not allow International dialing nor US toll free ("800" numbers), but you can use the WebEx app to connect your device audio, and there's also the option of connection directly from your browser if your browser supports it.  WebEx details will be sent to the mailing list before each call (the details will be the same for all calls, but the messages will serve as reminders).
    
    _______________________________________________
    CBOR mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/cbor

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 28 Feb 2019 07:56:01 +0000

Hi all,

Here are the minutes and slides from yesterday's meeting: https://datatracker.ietf.org/meeting/interim-2019-cbor-05/session/cbor 
Next meeting is in two weeks, 13th of March, last meeting before the IETF104.

Participants, please let me know if anything was incorrectly captured.

Thanks,
Francesca

--

CBOR WG Conference Call
Wednesday, Feb 27 2019, 18:00 - 19:00 UTC
Chairs: Barry Leiba, Francesca Palombini

Minute takers: Francesca

Participants:
* Francesca Palombini
* Carsten Bormann
* Jim Schaad
* Laurence Lundblade
* Paul Hoffman
* Michael Richardson
* Jeff Sipek
* Jeffrey Yasskin
    
Agenda:
    * CDDL Status
    * CBOR Bis status
    * Tags documents
    
- CDDL Status:
    Still in IESG review, Ekr DISCUSS
    FP: AP on Barry to remind Ekr this week

- CBOR Bis:
        
    https://github.com/cbor-wg/CBORbis/issues 
    PR17: will close 37, 45, 3 (do a check first, PR18 will contribute to close 3)
    Paul: Issues in reasonably good shape, PRs still big work to be done
    Jeffrey has not had time to check the PR but will do.
    message from Jim from Jan 16 which is still to do
    Laurence: should I look at PR17 in detail in relation to 37 or 45 before it's merged? 
    Paul: do it after? It is easier to check with the rest of the changes
    
    Issue #25:
        feels that can be closed, there is not much we can do about it.
        Jeffrey: agree
        Paul: send a message to the list
        
    AP Jeffrey to check both PR17 and PR18, send to authors to be merged and everybody to check afterward.
    
    https://github.com/cbor-wg/CBORbis/commits/master
    canonicalization in one section

    Tag validity (PR18)
    Carsten: always a problem with that, figured it out why: see new issue in the array-tags document: https://github.com/cbor-wg/array-tags/issues/1
    How do we handle that in tag validity?
    worth looking at this issue in more detail (Carsten, Jeffrey)
    Paul: not assuming we're going to make progress on this as it is complicated
    Jeffrey: agree we should figure it out, but would not want to block progress
    Carsten: rather keep the flexibility in a way that it does not become a problem later

    IANA Considerations for CBOR Bis
    2 new registry by CBOR: simple values and tags
    Tags has been used
    Tried to have low thresholds
    IANA Considerations: only the low points are DE, but IANA still contacted DE
    Propose to mend the 1+1 and 1+2 registration policy
    1+1: specification required (minor change, more detail about Expert review)
    1+2: FCFS to ER
    MCR: what is the problem with now?
    Carsten: Problem is that someone could come and take 50 numbers and the expert could not stop it
    Paul: yes, expert review. Expert says no, they appeal, and goes to IETF. (for 1+1)
    MCR: agree, don't need to have more info.
    Francesca (hat off): likes having more text about what experts will decide on.
    Paul: don't agree with changing 2+1 to Expert Required. We can reconsider if get >50% of tags occupied.
    AP Carsten: propose to have PRs for next meeting about text on Expert guidelines/guidelines for tags requesters.
    Carsten: text about circuit breaker?
    Paul: no, that is the IESG job

new document: port json-seq to CBOR
    MCR: seems interesting
    Laurence: suggest a very week link to it from CBOR Bis.
    AP Carsten to propose text in CBOR Bis

Carsten: Discussion on rechartering?
Next meeting + Prague. Also discussion in the ML.

On 27/02/2019, 18:30, "CBOR on behalf of Francesca Palombini" <[email-masked] on behalf of [email-masked]> wrote:

    Webex:
    
    Talk to you soon,
    Francesca

        
        
        Agenda:
        (No agenda submitted)