Subject: Re: [Cbor] correctness of implied top level array?

From: John Mattsson <[email-masked]>
Date: Wed, 13 Mar 2019 16:49:32 +0000

Hi,

Great with a document that define a CBOR sequence. I have already made draft-bormann-cbor-sequence a normative reference in EDHOC.

I would like to see CDDL and CBOR diagnostic notation for a CBOR sequence. In lack of something better, EDHOC is currently using the CDDL group notation:

message_1 = (
  TYPE : int,
  SUITES_U : suite / [ index: uint, 2* suite ],
  X_U : bstr,
  C_U : bstr,
  ID_PSK : bstr / header_map,
  ? UAD_1 : bstr,
)

Cheers,
John

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 13 Mar 2019 17:56:20 +0100

>  ID_PSK : bstr / header_map,

That is probably where we want to go, but not with CDDL version 1.
For now, both diagnostic notation and CDDL can use an array and just say in English that we are not using a single data item but a CBOR sequence instead.

Grüße, Carsten