Subject: [Cbor] draft-ietf-core-sid-05 and draft-ietf-core-yang-cbor-07

From: Michael Richardson <[email-masked]>
Date: Sun, 03 Mar 2019 20:16:53 -0500

I wonder if these two drafts wouldn't be better off in CBOR WG?
  draft-ietf-core-sid-05
  YANG Schema Item iDentifier (SID)
  draft-ietf-core-yang-cbor-07
  CBOR Encoding of Data Modeled with YANG

Well, anything that would allow the SID to progress enough for the
registries to be created so that they can be used.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 15 Mar 2019 13:24:35 +0000

I think that it would be good if these drafts could somehow progress to completion.

I've previously posted comments on the SID draft, but never received any response.

In short, I think that it would be more pragmatic if SIDs are restricted to the non-negative range of the signed 64 bit integer type.  I.e. disallow values from (2^63 through 2^64 - 1).

Thanks,
Rob 

-----Original Message-----
From: core <[email-masked]> On Behalf Of Michael Richardson
Sent: 04 March 2019 01:17
To: [email-masked]; [email-masked]
Subject: [core] draft-ietf-core-sid-05 and draft-ietf-core-yang-cbor-07

Well, anything that would allow the SID to progress enough for the registries to be created so that they can be used.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 15 Mar 2019 16:42:22 +0100

> In short, I think that it would be more pragmatic if SIDs are restricted to the non-negative range of the signed 64 bit integer type.  I.e. disallow values from (2^63 through 2^64 - 1).

SIDs are unsigned integers.  However, there are still languages that have a hard time with those.  And it helps if all SID deltas fit into a signed 64-bit integer.
So maybe limiting SIDs to the (non-negative) range of signed 64-bit integers is a restriction that makes sense.

https://github.com/core-wg/yang-cbor has three pull requests, but no issues.
(This apparently also happens to be the repo for the SID specification.)

Should we put up the issues there?

Grüße, Carsten

---

From: Robert Wilton <[email-masked]>
Date: Fri, 15 Mar 2019 17:47:35 +0000

On 15/03/2019 15:42, Carsten Bormann wrote:
> SIDs are unsigned integers.  However, there are still languages that have a hard time with those.

I imagine that you may be referring to languages like Java and Python, 
but in my experience, C and C++ also struggle to safely use unsigned 
numbers.

E.g. https://blog.regehr.org/archives/268 and their similar cases.

>    And it helps if all SID deltas fit into a signed 64-bit integer.

This is really the key one for me.

Otherwise, I would guess that many implementations will probably just 
assume that the delta always fits into a signed 64-bit integer and 
potentially fail silently in the future when they hit an 
overflow/underflow condition.

> Should we put up the issues there?

I've added the author alias.  Hopefully we'll get an answer.

Thanks,
Rob

> .