Subject: [Cbor] Review of draft-ietf-cbor-date-tag-03

From: Francesca Palombini <[email-masked]>
Date: Thu, 9 Jul 2020 14:06:41 +0000

Hi Mike,

While reviewing for the shepherd writeup I found the following minor issues:

Section 1:
I would suggest removing the comma from the number: 40,587. Using the comma as separator is not the best, as in some countries it is used as decimal sign (also not preferred but allowed in ISO 8601).

From I-D nits:
  == The document doesn't use any RFC 2119 keywords, yet seems to have RFC
     2119 boilerplate text.
Is it necessary to have the 2119 - 8174 boilerplate text even if no normative keywords are used? 

[POSIX.1] seems more like a normative reference to me, don't you think?

Thanks,
Francesca

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 9 Jul 2020 19:43:37 +0200

> [POSIX.1] seems more like a normative reference to me, don't you think?

Actually, no.
You do not have to have read that to implement this spec.
(This is markedly different from Tag 1).

The epoch used for tag 100 is inspired by UNIX time (Posix), but does not rely in its definition on understanding UNIX time.  (As we have found, understanding UNIX time is slightly counterproductive :-)

Grüße, Carsten

---

From: Mike Jones <[email-masked]>
Date: Fri, 10 Jul 2020 22:43:21 +0000

Thanks, Francesca.  Is this the full shepherd write-up or is there more to come?

				-- Mike

-----Original Message-----
From: Francesca Palombini <francesca.palombini=[email-masked]> 
Sent: Thursday, July 9, 2020 7:07 AM
To: Mike Jones <[email-masked]>; [email-masked]
Subject: Review of draft-ietf-cbor-date-tag-03

Hi Mike,

Section 1:

From I-D nits:

Thanks,
Francesca

---

From: Francesca Palombini <[email-masked]>
Date: Fri, 10 Jul 2020 22:51:28 +0000

Hi Mike,

No, I will post the full write up following the usual template (https://www.ietf.org/chairs/document-writeups/document-writeup-working-group-documents/ ) for the next submission of the draft, but these are all the comments I have, no more to come.

Francesca

On 11/07/2020, 00:43, "Mike Jones" <Michael.Jones=[email-masked]> wrote:

    				-- Mike

    -----Original Message-----
    From: Francesca Palombini <francesca.palombini=[email-masked]> 
    Sent: Thursday, July 9, 2020 7:07 AM
    To: Mike Jones <[email-masked]>; [email-masked]
    Subject: Review of draft-ietf-cbor-date-tag-03

    Hi Mike,

    Section 1:

    From I-D nits:

    Thanks,
    Francesca

---

From: Mike Jones <[email-masked]>
Date: Wed, 15 Jul 2020 02:27:01 +0000

Shoot - I finished preparing -04 to address your comments and those of others, only to discover that submission is presently closed (as happens before IETF meetings).  I'm attaching the source and .txt version of -04.  If the chairs or AD choose to, maybe you can pull whatever strings you need to with the secretariat to get it posted anyway.  (I know Kathleen did that for me at least once while she was an area director.)

				Thanks,
				-- Mike

-----Original Message-----
From: Francesca Palombini <francesca.palombini=[email-masked]> 
Sent: Thursday, July 9, 2020 7:07 AM
To: Mike Jones <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Review of draft-ietf-cbor-date-tag-03

Hi Mike,

Section 1:

From I-D nits:

Thanks,
Francesca

---

From: Barry Leiba <[email-masked]>
Date: Tue, 14 Jul 2020 23:25:31 -0400

I can do that, but submissions will re-open on Monday of IETF week anyway.
Do we really need it posted before then, or should we just wait for the
blackout period to end normally? It’s not long to wait.

Personally, I thing we should get rid of the blackout, and let WGCs impose
their own deadlines for meetings as appropriate. But every time we suggest
that, the chairs, almost en bloc, insist that they want the IESG to impose
the deadline.

Barry

On Tue, Jul 14, 2020 at 10:27 PM Mike Jones <[email-masked]>
wrote:

> Shoot - I finished preparing -04 to address your comments and those of
> others, only to discover that submission is presently closed (as happens
> before IETF meetings).  I'm attaching the source and .txt version of -04.
> If the chairs or AD choose to, maybe you can pull whatever strings you need
> to with the secretariat to get it posted anyway.  (I know Kathleen did that
> for me at least once while she was an area director.)
>
>                                 Thanks,
>                                 -- Mike
>
> I would suggest removing the comma from the number: 40,587. Using the
> comma as separator is not the best, as in some countries it is used as
> decimal sign (also not preferred but allowed in ISO 8601).
>
> From I-D nits:

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Jul 2020 13:54:53 +0200

Hi Mike,

(1)
I like the John Lennon example.
You could complete it by giving the Tag-1004 syntax, as well as the Tag-100 numbers, both of which are visible in the following lines:

>> Date.parse("1940-10-09").mjd-Date.parse("1970-01-01").mjd
=> -10676
>> Date.parse("1980-12-08").mjd-Date.parse("1970-01-01").mjd
=> 3994

(2)
…comparing that augmented date…
Hmm, once you add a time-of-day, it is no longer just a “date”, so I would speak about a date-time.

Grüße, Carsten

> On 2020-07-15, at 04:27, Mike Jones <Michael.Jones=[email-masked]> wrote:
> 
> <draft-ietf-cbor-date-tag-04.xml><draft-ietf-cbor-date-tag-04.txt>_______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor