Subject: [Cbor] draft-goessner-dispatch-jsonpath-00.txt

From: Carsten Bormann <[email-masked]>
Date: Tue, 14 Jul 2020 07:14:13 +0200

(Reply-To set to [email-masked])

I would like to initiate discussion for draft-goessner-dispatch-jsonpath:

https://www.ietf.org/id/draft-goessner-dispatch-jsonpath-00.html

It says:

> This document picks up the popular JSONPath specification dated
> 2007-02-21 and provides a more normative definition for it.
> It is intended as a submission to the IETF DISPATCH WG, in order to
> find the right way to complete standardization of this specification.
> In its current state, it is a strawman document showing what needs to
> be covered.

(For some reason the abstract landed in the Contributing note; typical Internet-Draft deadline day botch.)

This is a widely implemented specification that has been around for more than a decade; now may be a good opportunity to finally go ahead and turn it into a proper Internet standards document.  The immediate cause for writing this up now is that some IoT discovery work (some of which happens in W3C) can make good use of JSONPath.  Clearly, we already have JSON Pointer (RFC 6901) for a more limited set of applications; the specification would do good in defining how these two fit together.

There is no active WG that immediately fits this work.

Eventually CDDL may pick JSONPath up in the form of a predicate operator; this might make the CBOR WG the right group (which probably would then go ahead and write up another specification that makes JSONPath useful for querying CBOR instances that go beyond the JSON generic data model).

Reopening the JSON WG may be another approach, as may be creating a short-lived targeted WG.

Please discuss!

Grüße, Carsten

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-goessner-dispatch-jsonpath-00.txt
> Date: 2020-07-13 at 22:08:50 CEST
> To: "Stefan Gössner" <[email-masked]>, "Stefan Gossner" <[email-masked]>, "Carsten Bormann" <[email-masked]>
> 
> 
> A new version of I-D, draft-goessner-dispatch-jsonpath-00.txt
> has been successfully submitted by Carsten Bormann and posted to the
> IETF repository.
> 
> Name:		draft-goessner-dispatch-jsonpath
> Revision:	00
> Title:		JSONPath -- XPath for JSON
> Document date:	2020-07-12
> Group:		Individual Submission
> Pages:		14
> URL:            https://www.ietf.org/internet-drafts/draft-goessner-dispatch-jsonpath-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-goessner-dispatch-jsonpath/
> Htmlized:       https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-goessner-dispatch-jsonpath
> 
> 
> Abstract:
>   insert abstract here
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
>

---

From: Tim Bray <[email-masked]>
Date: Mon, 13 Jul 2020 22:31:49 -0700

During my time at AWS I worked very heavily with JSONPath and lamented a
useful referenceable spec. I would be happy to invest cycles into this
work. There currently isn't a JSON working group but I suppose it wouldn't
be too hard to reconstitute it for this purpose.

On Mon, Jul 13, 2020 at 10:14 PM Carsten Bormann <[email-masked]> wrote:

> This is a widely implemented specification that has been around for more
> than a decade; now may be a good opportunity to finally go ahead and turn
> it into a proper Internet standards document.  The immediate cause for
> writing this up now is that some IoT discovery work (some of which happens
> in W3C) can make good use of JSONPath.  Clearly, we already have JSON
> Pointer (RFC 6901) for a more limited set of applications; the
> specification would do good in defining how these two fit together.
>
> Eventually CDDL may pick JSONPath up in the form of a predicate operator;
> this might make the CBOR WG the right group (which probably would then go
> ahead and write up another specification that makes JSONPath useful for
> querying CBOR instances that go beyond the JSON generic data model).
>
> > To: "Stefan Gössner" <[email-masked]>, "Stefan Gossner"
> <[email-masked]>, "Carsten Bormann" <[email-masked]>
> >
> >
> > URL:
> https://www.ietf.org/internet-drafts/draft-goessner-dispatch-jsonpath-00.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-goessner-dispatch-jsonpath/
> > Htmlized:
> https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00
> > Htmlized:
> https://datatracker.ietf.org/doc/html/draft-goessner-dispatch-jsonpath
> >
> >
> > Abstract:
> >   insert abstract here
> >
> >
> >
> >
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>

---

From: Mario Loffredo <[email-masked]>
Date: Tue, 14 Jul 2020 09:33:53 +0200

Il 14/07/2020 07:31, Tim Bray ha scritto:
> During my time at AWS I worked very heavily with JSONPath and lamented 
> a useful referenceable spec. I would be happy to invest cycles into 
> this work. There currently isn't a JSON working group but I suppose it 
> wouldn't be too hard to reconstitute it for this purpose.

+1

Mario

>
> On Mon, Jul 13, 2020 at 10:14 PM Carsten Bormann <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     (Reply-To set to [email-masked] <mailto:[email-masked]>)
>
>     (For some reason the abstract landed in the Contributing note;
>     typical Internet-Draft deadline day botch.)
>
>     This is a widely implemented specification that has been around
>     for more than a decade; now may be a good opportunity to finally
>     go ahead and turn it into a proper Internet standards document. 
>     The immediate cause for writing this up now is that some IoT
>     discovery work (some of which happens in W3C) can make good use of
>     JSONPath.  Clearly, we already have JSON Pointer (RFC 6901) for a
>     more limited set of applications; the specification would do good
>     in defining how these two fit together.
>
>     Eventually CDDL may pick JSONPath up in the form of a predicate
>     operator; this might make the CBOR WG the right group (which
>     probably would then go ahead and write up another specification
>     that makes JSONPath useful for querying CBOR instances that go
>     beyond the JSON generic data model).
>
>     > From: [email-masked] <mailto:[email-masked]>
>     > To: "Stefan Gössner" <[email-masked]
>     <mailto:[email-masked]>>, "Stefan Gossner"
>     <[email-masked]
>     <mailto:[email-masked]>>, "Carsten Bormann"
>     <[email-masked] <mailto:[email-masked]>>
>     >
>     >
>     > until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>     >
>     > The IETF Secretariat
>     >
>     >
>
>     [email-masked] <mailto:[email-masked]>

-- 
Dr. Mario Loffredo
Systems and Technological Development Unit
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

---

From: Michael Toomim <[email-masked]>
Date: Tue, 14 Jul 2020 00:37:42 -0700

I'm replying off-list — just to say I'd also help with such an effort. Thanks for spearheading.

We could use this in braid <https://braid.news/>— specifically for the JSON Range Patch <https://raw.githubusercontent.com/braid-work/braid-spec/master/draft-toomim-httpbis-range-patch-00.txt> spec.

> On Jul 13, 2020, at 10:31 PM, Tim Bray <[email-masked]> wrote:
> 
> During my time at AWS I worked very heavily with JSONPath and lamented a useful referenceable spec. I would be happy to invest cycles into this work. There currently isn't a JSON working group but I suppose it wouldn't be too hard to reconstitute it for this purpose.  
> 
> On Mon, Jul 13, 2020 at 10:14 PM Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
> https://www.ietf.org/id/draft-goessner-dispatch-jsonpath-00.html <https://www.ietf.org/id/draft-goessner-dispatch-jsonpath-00.html>
> 
> It says:
> 
> > To: "Stefan Gössner" <[email-masked] <mailto:[email-masked]>>, "Stefan Gossner" <[email-masked] <mailto:[email-masked]>>, "Carsten Bormann" <[email-masked] <mailto:[email-masked]>>
> > 
> > 
> > URL:            https://www.ietf.org/internet-drafts/draft-goessner-dispatch-jsonpath-00.txt <https://www.ietf.org/internet-drafts/draft-goessner-dispatch-jsonpath-00.txt>
> > Status:         https://datatracker.ietf.org/doc/draft-goessner-dispatch-jsonpath/ <https://datatracker.ietf.org/doc/draft-goessner-dispatch-jsonpath/>
> > Htmlized:       https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00 <https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00>
> > Htmlized:       https://datatracker.ietf.org/doc/html/draft-goessner-dispatch-jsonpath <https://datatracker.ietf.org/doc/html/draft-goessner-dispatch-jsonpath>
> > 
> > 
> > Abstract:
> >   insert abstract here
> > 
> > 
> > 
> > 
> > until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> > 
> > The IETF Secretariat
> > 
> > 
> 
> https://www.ietf.org/mailman/listinfo/json <https://www.ietf.org/mailman/listinfo/json>
> dispatch mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dispatch <https://www.ietf.org/mailman/listinfo/dispatch>

---

From: Brian Rosen <[email-masked]>
Date: Tue, 14 Jul 2020 08:25:24 -0400

+1

And I note the discussion of an HTTP API working group, to which this work would fit in.

I’m currently working on a spec for emergency services that uses jsonpath, and the lack of a referenceable spec was a big concern.  

Brian

> On Jul 14, 2020, at 3:33 AM, Mario Loffredo <[email-masked]> wrote:
> 
> 
> 
> Web: http://www.iit.cnr.it/mario.loffredo <http://www.iit.cnr.it/mario.loffredo>_______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch