Subject: Re: [Cbor] Review draft-ietf-cbor-date-tag-01

From: Jim Schaad <[email-masked]>
Date: Wed, 1 Jul 2020 07:27:59 -0700

That text does not represent what I was looking for.  I was thinking of
something more along the lines of 

When using this data type for decision making, for examples access control,
it needs to be noted that since this does not represent a specific point in
time the results of the evaluation can differ depending upon where the
decision is made.  This can represent more than  24-hour period in total as
a different 24-hours are used in the timezone -12:00 and +12:00.

That text probably needs to get cleaned up and expanded but it gives the
gist of what I am looking for.  You can also look at the latest email on the
CBOR mailing list.

Jim

From: Mike Jones <[email-masked]> 
Sent: Tuesday, June 30, 2020 6:43 PM
To: Jim Schaad <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: Review draft-ietf-cbor-date-tag-01

I created text.

-- Mike

  _____  

From: Jim Schaad <[email-masked] <mailto:[email-masked]> >
Sent: Tuesday, June 30, 2020 6:13:22 PM
To: Mike Jones <[email-masked]
<mailto:[email-masked]> >; [email-masked]
<mailto:[email-masked]>
<[email-masked]
<mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]>  <[email-masked]
<mailto:[email-masked]> >
Subject: [EXTERNAL] RE: Review draft-ietf-cbor-date-tag-01 

> -----Original Message-----
> From: Mike Jones <[email-masked]
<mailto:[email-masked]> >
> Sent: Tuesday, June 30, 2020 5:41 PM
> To: Jim Schaad <[email-masked] <mailto:[email-masked]> >;
[email-masked] <mailto:[email-masked]>

> Cc: [email-masked] <mailto:[email-masked]> 
> Subject: RE: Review draft-ietf-cbor-date-tag-01
> 
> Hi Jim,
> 
> I've applied these changes in
https://tools.ietf.org/html/draft-ietf-cbor-date-
> tag-02.
> 
>                                Thanks again,
>                                -- Mike
> 
> -----Original Message-----
> From: Mike Jones
> Sent: Friday, June 12, 2020 11:52 AM
> To: Jim Schaad <[email-masked] <mailto:[email-masked]> >;
[email-masked] <mailto:[email-masked]>

> Cc: [email-masked] <mailto:[email-masked]> 
> Subject: RE: Review draft-ietf-cbor-date-tag-01
> 
> Thanks for your review, Jim.  My replies are inline below...
> 
> Is it time to start WGLC so others also get their reviews in?  I'll note
that the
> IANA registrations have already occurred at
> https://www.iana.org/assignments/cbor-tags/cbor-tags.xhtml.
> 
> -----Original Message-----
> From: Jim Schaad <[email-masked] <mailto:[email-masked]> >
> Sent: Thursday, June 11, 2020 11:48 AM
> To: [email-masked]
<mailto:[email-masked]> 
> Cc: [email-masked] <mailto:[email-masked]> 
> Subject: Review draft-ietf-cbor-date-tag-01
> 
> * Is there any chance that you can upgrade to using the v3 of xml2rfc
schema?
> If not then there is not an issue as the RFC Editor will do it.
> 
> I haven't really learned all the ins and outs of the new syntax yet, so
I'd have
> more confidence with the RFC Editor doing it correctly than me.
> 
> * Introduction:  I prefer the abstract form of /date but not a time/date
without
> a time/
> 
> I agree and will make this change in the next published draft.
> 
> * While this is something that is clear to me, I got a recent comment when
I
> suggested that this be used elsewhere of, "But how does this work with
time
> zones?".  Based on that I think that there needs to be some text about why
time
> zones are not of interest here.
> 
> Agreed and will do.
> 
> * Section 3- I think that the second paragraph would be wise to
distinguish
> between a point in time and a date when looking at access control
decisions.
> 
> I understand your point in general.  Is there particular text that you'd
suggest
> that I incorporate?

No I don't have any text in mind. 

Jim

> Jim
>                                Thanks again,
>                                -- Mike

---

From: Mike Jones <[email-masked]>
Date: Thu, 2 Jul 2020 02:06:55 +0000

Thanks for the suggested wording, Jim.  I used your first sentence and substituted a real-world example that should resonate with people for the latter part of the second one.

                                                       -- Mike

From: Jim Schaad <[email-masked]>
Sent: Wednesday, July 1, 2020 7:28 AM
To: Mike Jones <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: Review draft-ietf-cbor-date-tag-01

That text does not represent what I was looking for.  I was thinking of something more along the lines of

When using this data type for decision making, for examples access control, it needs to be noted that since this does not represent a specific point in time the results of the evaluation can differ depending upon where the decision is made.  This can represent more than  24-hour period in total as a different 24-hours are used in the timezone -12:00 and +12:00.

That text probably needs to get cleaned up and expanded but it gives the gist of what I am looking for.  You can also look at the latest email on the CBOR mailing list.

Jim

From: Mike Jones <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 30, 2020 6:43 PM
To: Jim Schaad <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: Review draft-ietf-cbor-date-tag-01

I created text.

-- Mike

________________________________
From: Jim Schaad <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 30, 2020 6:13:22 PM
To: Mike Jones <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [EXTERNAL] RE: Review draft-ietf-cbor-date-tag-01

> From: Mike Jones <[email-masked]<mailto:[email-masked]>>
> To: Jim Schaad <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
> To: Jim Schaad <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
that the
> From: Jim Schaad <[email-masked]<mailto:[email-masked]>>
> To: [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
schema?
I'd have
without
I
time
time
distinguish
decisions.
suggest

Jim