Subject: [Cbor] Going forward on draft-ietf-cbor-tags-oid-01.txt

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 Oct 2020 13:34:58 +0100

Jim Schaad was a major commenter on draft-ietf-cbor-tags-oid, and we all went into shock when he passed.  So nothing has happened since the below update on 2020-09-30.

I believe that the draft is pretty much done, not the least due to Jim’s ever so helpful comments.

What is left to do is:

— tick off and delete the yellow editors’ comment at the end of Section 5:
https://raw.githack.com/cbor-wg/cbor-oid/master/draft-ietf-cbor-tags-oid.html#name-tag-factoring-with-oid-arra — i.e., agree that we now have reached the right level of complexity here.
— discuss whether we need the detail in https://raw.githack.com/cbor-wg/cbor-oid/master/draft-ietf-cbor-tags-oid.html#section-9.1 — conversion between BER and dotted decimal is not exactly the focus of this draft any longer, and the third paragraph of Section 9 (https://raw.githack.com/cbor-wg/cbor-oid/master/draft-ietf-cbor-tags-oid.html#section-9-3) already contains a good warning about this.

We could discuss this later today in the interim, generate a -02 with the above (and a few editorial) changes, and go for WGLC (which should get us any further reviews we need).

Grüße, Carsten

> On 2020-09-30, at 20:34, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Concise Binary Object Representation Maintenance and Extensions WG of the IETF.
> 
>        Title           : Concise Binary Object Representation (CBOR) Tags for Object Identifiers
>        Authors         : Carsten Bormann
>                          Sean Leonard
> 	Filename        : draft-ietf-cbor-tags-oid-01.txt
> 	Pages           : 14
> 	Date            : 2020-09-30
> 
> Abstract:
>   The Concise Binary Object Representation (CBOR, draft-ietf-cbor-
>   7049bis) is a data format whose design goals include the possibility
>   of extremely small code size, fairly small message size, and
>   extensibility without the need for version negotiation.
> 
>   The present document defines CBOR tags for object identifiers (OIDs).
>   It is intended as the reference document for the IANA registration of
>   the CBOR tags so defined.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-cbor-tags-oid/
> 
> There is also a HTML versions available at:
> https://www.ietf.org/id/draft-ietf-cbor-tags-oid-01.html
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-cbor-tags-oid-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 Oct 2020 18:49:58 +0100

> We could discuss this later today in the interim, generate a -02 with the above (and a few editorial) changes, and go for WGLC (which should get us any further reviews we need).

We did this, and based on the discussion I have now submitted -02:

Name:		draft-ietf-cbor-tags-oid
Revision:	02
Title:		Concise Binary Object Representation (CBOR) Tags for Object Identifiers
Document date:	2020-10-28
Group:		cbor
Pages:		14
URL:            https://www.ietf.org/archive/id/draft-ietf-cbor-tags-oid-02.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-cbor-tags-oid/
Html:           https://www.ietf.org/archive/id/draft-ietf-cbor-tags-oid-02.html
Htmlized:       https://tools.ietf.org/html/draft-ietf-cbor-tags-oid-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-cbor-tags-oid-02

This should be ready for WGLC now, potentially discussion results of that at the IETF 109 meeting.

In the interim today, Ira mentioned that SACM and RATS might be good WGs to make aware of a WGLC, as a good collection of people who know about ASN.1 Object Identifiers is assembled there.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Thu, 29 Oct 2020 08:51:17 -0400

> https://raw.githack.com/cbor-wg/cbor-oid/master/draft-ietf-cbor-tags-oid.html#name-tag-factoring-with-oid-arra
    > — i.e., agree that we now have reached the right level of complexity
    > here.

    > We could discuss this later today in the interim, generate a -02 with the above (and a few editorial) changes, and go for WGLC (which should get us any further reviews we need).

I think that your -02 update broke the link that included the "yellow
editors' comment" above.

Reading the diff, I think you acted on these already, and I'm good with that.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide