Subject: Re: [Cbor] [Technical Errata Reported] RFC8610 (6575)

From: Carsten Bormann <[email-masked]>
Date: Fri, 7 May 2021 06:46:30 +0200

Well, representation types for tags are explained in 3.6, so 2.2.3 should have a forward reference to 3.6 instead of trying to restate 3.6 (which it only manages by half).
(Note that the text doesn’t say what #6.24 without parentheses means — the ABNF suggests that the number after the dot should be ai not argument.
In hindsight, maybe using a different character than “.” for tag/argument would have been more suggestive.)

I’d say, this is "hold for document update” so we get a chance to cover the corner case, but it is worth saying now that 3.6 is the detailed description of the exception for #6.nn(tt).

Grüße, Carsten

> On 7. May 2021, at 01:52, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC8610,
> "Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data Structures".
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid6575
> 
> --------------------------------------
> Type: Technical
> Reported by: Laurence Lundblade <[email-masked]>
> 
> Section: 2.2.3
> 
> Original Text
> -------------
> Where a major type of 6 (Tag) is used, the type
>   of the tagged item can be specified by appending it in parentheses.
> 
> Corrected Text
> --------------
> Where a major type of 6 (Tag) is used, the type of the tagged item can be specified by appending it in parentheses. Additionally,
> for major type 6 the value of the argument, not the additional info is what follows the dot.
> 
> Notes
> -----
> The text at the top of page 50 is correct. The examples in 2.2.3 are also correct.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC8610 (draft-ietf-cbor-cddl-08)
> --------------------------------------
> Title               : Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data Structures
> Publication Date    : June 2019
> Author(s)           : H. Birkholz, C. Vigano, C. Bormann
> Category            : PROPOSED STANDARD
> Source              : Concise Binary Object Representation Maintenance and Extensions
> Area                : Applications and Real-Time
> Stream              : IETF
> Verifying Party     : IESG

---

From: RFC Errata System <[email-masked]>
Date: Thu, 6 May 2021 16:52:20 -0700 (PDT)

Section: 2.2.3

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------