Subject: [Cbor] Reminder: bi-weekly CBOR conference call on 5 May

From: Barry Leiba <[email-masked]>
Date: Tue, 4 May 2021 10:54:44 -0400

We'll have our regular bi-weekly CBOR conference call on
Wednesday, 5 May, at 1600 UTC.  Various pointers are here:
https://datatracker.ietf.org/meeting/interim-2021-cbor-08/session/cbor

In particular, see the agenda here:
https://codimd.ietf.org/notes-ietf-interim-2021-cbor-08-cbor

Please edit the agenda to flesh it out and propose specific discussions.

Meeting link: https://ietf.webex.com/ietf/j.php?MTID=m3ed3d0309a5f216c8a4d8463130b07cb
Meeting number: 178 745 7694
Password: VDkAMXjG443

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 4 May 2021 21:18:30 +0200

> https://codimd.ietf.org/notes-ietf-interim-2021-cbor-08-cbor

I finally managed to get a version of the cbor-packed gem out.

Best to use with cbor-diag, e.g.

$ echo '[1, 2, 2, 4711, 4711]' | diag2diag.rb -p
51([[4711], [], [], [1, 2, 2, simple(0), simple(0)]])
$ echo '[1, 2, 2, 4711, 4711]' | diag2diag.rb -pq
[1, 2, 2, 4711, 4711]

(OK, that is not great compression when adding in the compression tag overhead, but it does show that 2 is not shared while 4711 is.)

-p = pack
-q = unpack (u was taken…)

echo '["https://tzi.de", "http://ietf.org", "https://www.facebook.com", "https://www.twitter.com", "https://tzi.de"]' | diag2diag.rb -p
51([[225("tzi.de")], 
    ["http", 6("s://"), 225("www.")], 
    [], 
    [simple(0), 6("://ietf.org"), 226("facebook.com"), 226("twitter.com"), simple(0)]])

As you can see, the compressor is a bit simple-minded, and it doesn’t do suffixes at all yet (should do “.com"!), or prefixes for anything but strings.

Let the bug reports flow in…
(And let’s discuss this tomorrow.)

Grüße, Carsten

---

From: Barry Leiba <[email-masked]>
Date: Mon, 17 May 2021 10:01:32 -0400

We'll have our regular bi-weekly CBOR conference call on
Wednesday, 19 May, at 1600 UTC.  Various pointers are here:
https://datatracker.ietf.org/meeting/interim-2021-cbor-09/session/cbor

In particular, see the agenda here:
https://codimd.ietf.org/notes-ietf-interim-2021-cbor-09-cbor