Subject: [Cbor] CDDL check in draft-ietf-dtn-bpsec-default-sc-11

From: Francesca Palombini <[email-masked]>
Date: Thu, 29 Jul 2021 17:12:19 +0000

Hi all,

Following my review while the document was in IESG evaluation, the authors of draft-ietf-dtn-bpsec-default-sc have added the CDDL definition for two structures defined in the document, namely IPPT and AAD: https://datatracker.ietf.org/doc/html/draft-ietf-dtn-bpsec-default-sc-11#appendix-B 

I have taken a quick look and it seems fine to me. If anybody else has time to check the CDDL, that would be much appreciated! (Carsten and Thomas cc'ed as our esteemed CDDL experts) Note that, if I remember correctly, the Appendix A does not do print outs of those two structures, so it would only need a check again the text definition.

Thanks,
Francesca

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 29 Jul 2021 19:19:56 +0200

I'd maybe put 'target-btsd: bstr' at the top of IPPT-list, to help 
distinguishing the types IPPT-list and AAD-list in the start rule a bit 
easier.

For more, I'd have to read the I-D first and I won't get to that quickly.

Viele Grüße,

Henk

On 29.07.21 19:12, Francesca Palombini wrote:
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor
>

---

From: Thomas Fossati <[email-masked]>
Date: Thu, 29 Jul 2021 17:26:35 +0000

Hi Francesca, all,

On 29/07/2021, 19:12, "Francesca Palombini" <[email-masked]> wrote:
>
> Hi all,
>
> Following my review while the document was in IESG evaluation, the
> authors of draft-ietf-dtn-bpsec-default-sc have added the CDDL
> definition for two structures defined in the document, namely IPPT and
> AAD:
> https://datatracker.ietf.org/doc/html/draft-ietf-dtn-bpsec-default-sc-11#appendix-B
>
> I have taken a quick look and it seems fine to me. If anybody else has
> time to check the CDDL, that would be much appreciated! (Carsten and
> Thomas cc'ed as our esteemed CDDL experts) Note that, if I remember
> correctly, the Appendix A does not do print outs of those two
> structures, so it would only need a check again the text definition.
>
> Thanks, Francesca

From a very quick scan it seems like it's missing the definitions
for primary-block and block-control-flags.

Cheers, t

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 29 Jul 2021 17:29:44 +0000

Thanks Thomas! Those are defined in https://datatracker.ietf.org/doc/html/draft-ietf-dtn-bpbis-31#appendix-B as the text introducing the text mentions.

Francesca

On 29/07/2021, 19:27, "Thomas Fossati" <[email-masked]> wrote:

    Hi Francesca, all,

    Cheers, t

---

From: Thomas Fossati <[email-masked]>
Date: Thu, 29 Jul 2021 22:06:38 +0000

On 29/07/2021, 19:29, "Francesca Palombini" <[email-masked]> wrote:
> Thanks Thomas! Those are defined in
> https://datatracker.ietf.org/doc/html/draft-ietf-dtn-bpbis-31#appendix-B
> as the text introducing the text mentions.

Oh sorry for the red herring, I missed the preamble to the CDDL.

LGTM now!

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 14:57:42 +0200

> Thanks Thomas! Those are defined in https://datatracker.ietf.org/doc/html/draft-ietf-dtn-bpbis-31#appendix-B as the text introducing the text mentions.

Which makes me remember the cop-out weasel-word text in front of the appendix.
It’s great that we do have CDDL for BPv7, but I also think that standards-track documents should not only have formal definitions, but be committing to their formal definitions more.

(Not an actionable comment on this document, but something to keep in mind on the way forward.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 15:06:17 +0200

Oh, and here is a readable version (without line wraps that break the syntax, without the inexplicable double-spacing, and without additional indentation):

https://tzi.de/~cabo/bpv7.cddl

Grüße, Carsten

> On 2021-07-30, at 14:57, Carsten Bormann <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 15:16:38 +0200

… and a combined version:

https://tzi.de/~cabo/bpsec-default-sc.cddl

I’m not such a great fan of the flag-bits construction (non-local structural dependencies), but in this case it probably works well enough.

CBOR WG: These cross-structural dependencies are a typical use case for co-occurrence constraints, so that the comments “present if…” can be put in in a machine-readable way.

Grüße, Carsten