Subject: [Cbor] Genart last call review of draft-ietf-cbor-network-addresses-08

From: Robert Sparks via Datatracker <[email-masked]>
Date: Sun, 19 Sep 2021 16:04:57 -0700

Reviewer: Robert Sparks
Review result: Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-cbor-network-addresses-08
Reviewer: Robert Sparks
Review Date: 2021-09-19
IETF LC End Date: 2021-09-22
IESG Telechat date: Not scheduled for a telechat

Summary: Ready for publication as a Proposed Standard RFC

Should the IANA registry (and/or the document) say something more about what
one can do if one wanted to represent an Ethernet address? 260 allowed that but
you are deprecating it - are you only deprecating it for v4 and v6 use, or do
you hope its use goes away completely?

---

From: Michael Richardson <[email-masked]>
Date: Wed, 22 Sep 2021 16:07:08 -0400

> you hope its use goes away completely?

I have no opinion, and it's why I didn't set out to deprecate them at 
all.  The WG consensus wanted this note added, so I think that the WG 
ought to weigh in.

I noted that 260 doesn't accommodate 8-byte ethernet addresses (used in 
802.15.4 today, and apparently a future ethernet spec).

How about:

-IANA is requested to add the note "DEPRECATED in favor of 52 and 54" to 
registrations 260 and 261
+IANA is requested to add the note "DEPRECATED in favor of 52 and 54 for 
IP addresses" to registrations 260 and 261

---

From: Lars Eggert <[email-masked]>
Date: Thu, 30 Sep 2021 14:27:57 +0300

Robert, thank you for your review. I have entered a No Objection ballot for this document.

Lars

> On 2021-9-20, at 2:04, Robert Sparks via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Robert Sparks
> Review result: Ready
> 
> --
> last-call mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/last-call

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 30 Sep 2021 13:39:38 +0200

On 2021-09-22, at 22:07, Michael Richardson <[email-masked]> wrote:
> 
> -IANA is requested to add the note "DEPRECATED in favor of 52 and 54" to registrations 260 and 261
> +IANA is requested to add the note "DEPRECATED in favor of 52 and 54 for IP addresses" to registrations 260 and 261

I’m still not sure that the WG can deprecate other peoples’ registrations, but ignoring that, I think that is a good resolution of the MAC address issue for now.

(Should we have thought about MAC addresses for this draft?  
Maybe…
But that is such a can of worms.)

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Thu, 30 Sep 2021 14:29:22 -0400

> I’m still not sure that the WG can deprecate other peoples’
    > registrations, but ignoring that, I think that is a good resolution of
    > the MAC address issue for now.

Maybe the shepherd write up could ask the IESG for their view.
Maybe the shepherd could note it was a WG decision :-)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide