Subject: [Cbor] AD review of draft-ietf-cbor-network-addresses-07

From: Francesca Palombini <[email-masked]>
Date: Wed, 8 Sep 2021 13:41:59 +0000

Thank you for this document. Here is my review: I have one comment I'd like to discuss, because if we don't I have a feeling it will come up again. Please handle all other minor comments together with the Last Call ones. 

Francesca

1. -----

I agree with the sentiment from other people (I have seen Brian's email but I think there was more discussion in the mailing list) that this document should do something about marking tags 260 and 261 as obsoleted in the IANA registry, especially if, as stated, they are not well defined or usable.

If the working group does not wish to undertake the restructuring of the IANA registry at this moment (which I understand) it could at least add a note to the existing tags 260 and 261. So in practice, the current text in the registry:

260                      byte string Network Address (IPv4 or IPv6 or MAC Address)   [http://www.employees.org/~ravir/cbor-network.txt][Ravi_Raju]

would become

260 - OBSOLETED in favor of 52 and 54                       byte string Network Address (IPv4 or IPv6 or MAC Address)   [http://www.employees.org/~ravir/cbor-network.txt][Ravi_Raju]

This could be easily done by adding a sentence on the lines of:

"
IANA is requested to add the note "OBSOLETED in favor of 52 and 54” to registrations 260 and 261”
"

In the IANA section of this draft.

## Minor

2. ------

FP: Please expand CIDR.

3. -----

   For example:

FP: please add "in CBOR diagnostic notation"

4. -----

   with the (full-length) IPv6 address first and the length of the
   associated network the prefix next.

FP: missing something before "the prefix next"?

5. -----

FP: For the examples, it would have been useful to have the usual address representation next to the CBOR tagged byte strings. For example, section 3.2 only adds the equivalent address for 54([48, h'20010db81234']) (in the paragraph above: "such as 2001:db8:1234::/48") but not for the other examples.

6. -----

   with the length of the prefix (implied 192.0.2.0/24) last.

FP: I am not sure I understand the "implied" parenthesis.

7. -----

FP: I see this document has undergone some reviews, so I was surprised to see the acknowledgement section empty.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 08 Sep 2021 11:48:07 -0400

I have added the requested sentence to the IANA considerations and posted -08.
I thought I had some queued edits from Carsten, but they are on file-magic
actually.

	8.3.  Tags 260 and 261

 	   IANA is requested to add the note "DEPRECATED in favor of 52 and 54"
 	   to registrations 260 and 261

https://www.ietf.org/rfcdiff?url1=draft-ietf-cbor-network-addresses-07&url2=draft-ietf-cbor-network-addresses-08

(Oh I have an extra closing " in the document)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Francesca Palombini <[email-masked]>
Date: Wed, 8 Sep 2021 15:50:06 +0000

Thanks Michael! You can fix that with the rest of the last call comments. Last Call is requested, should start soon.

Francesca

On 08/09/2021, 17:48, "Michael Richardson" <[email-masked]> wrote:

    	8.3.  Tags 260 and 261