Subject: Re: [Cbor] 🔔 WGLC with request for reviews on cbor-file-magic-02

From: Christian Amsüss <[email-masked]>
Date: Wed, 20 Oct 2021 14:16:42 +0200

Hello John,

thanks for proving this review; just picking a few points to comment:

On Sat, Jul 31, 2021 at 10:02:37AM +0000, John Mattsson wrote:
> Are protocols supposed to use some generic ".cbor" or ...

Independent of the either-or question (which AIU has not been addressed
up to -05), ".cbor" is the extension registered for the application/cbor
type.

> - "00000000  d9 d9 f8 da 4f 50 53 4e  43 42 4f 52         |....OPSNCBOR|"
> I don’t understand where the zeroes come from? Seems like postfix instead of prefix.

It's just the offset in the `hd` output -- read "at location 00000000
are bytes 0xd9, 0xd9, ....".

BR
c

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Christian Amsüss <[email-masked]>
Date: Wed, 20 Oct 2021 16:37:44 +0200

Hello file-magic authors,

while the minor comments have been addressed in the updates, I think
that these two were neither answered nor resulted in changes (not that
they'd necessarily would, but a change might be just as good as an
answer), could you comment on them?

On Sat, Jul 31, 2021 at 10:02:37AM +0000, John Mattsson wrote:
> - "as is a file extension"
> The draft does not say anything about how to chose a file extension. I think the needs to say something and give guidance. Are protocols supposed to use some generic ".cbor" or use there own like ".c509". Is it recommended to use several tags with the same extension, i.e., should .c509 be used for several different tags (chain, bag, CSR, CRL,...) or should each tag use its own file extension. In the later case it would be good if the file extension was registered together with tag number in IANA.
> 
> - I think it would help the reader to have an examples (CBOR diagnostic + CBOR encoding) already in Sections 3.1 and 3.2.
>   Something like the example in appendix B: "55800(1330664270(h'424F52'))"
>   Example CBOR protocol values and the resulting bytes in the file would be even better and would really help to make the draft easy to understand.

Thanks
Christian

---

From: Christian Amsüss <[email-masked]>
Date: Wed, 20 Oct 2021 17:09:16 +0200

(now with the right address, especially for group replies)

Thanks
Christian

---

From: Michael Richardson <[email-masked]>
Date: Wed, 20 Oct 2021 11:17:40 -0400

> answer), could you comment on them?

I don't think that the document should recommend any file extension.
That's not the place of this document.

    >> - I think it would help the reader to have an examples (CBOR
    >> diagnostic + CBOR encoding) already in Sections 3.1 and 3.2.
    >> Something like the example in appendix B:
    >> "55800(1330664270(h'424F52'))" Example CBOR protocol values and the
    >> resulting bytes in the file would be even better and would really help
    >> to make the draft easy to understand.

I'm not sure I understand.
Is an example that is CBOR TAG Wrapped being asked for?