Subject: [Cbor] Fwd: New Version Notification for draft-bormann-cbor-cddl-csv-00.txt

From: Carsten Bormann <[email-masked]>
Date: Thu, 24 Feb 2022 18:32:13 +0100

Rob Wilton (unknowingly) made me do it.
With big apologies from my side…

(But this brief spec is actually filling a real gap, so I would like to seriously pursue this.)

Grüße, Carsten

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-bormann-cbor-cddl-csv-00.txt
> Date: 2022-02-24 at 18:29:38 CET
> To: "Carsten Bormann" <[email-masked]>
> Message-Id: <[email-masked]>
> 
> 
> A new version of I-D, draft-bormann-cbor-cddl-csv-00.txt
> has been successfully submitted by Carsten Bormann and posted to the
> IETF repository.
> 
> Name:		draft-bormann-cbor-cddl-csv
> Revision:	00
> Title:		Using CDDL for CSVs
> Document date:	2022-02-24
> Group:		Individual Submission
> Pages:		6
> URL:            https://www.ietf.org/archive/id/draft-bormann-cbor-cddl-csv-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-bormann-cbor-cddl-csv/
> Html:           https://www.ietf.org/archive/id/draft-bormann-cbor-cddl-csv-00.html
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-bormann-cbor-cddl-csv
> 
> 
> Abstract:
>   The Concise Data Definition Language (CDDL), standardized in RFC
>   8610, is defined to provide data models for data shaped like JSON or
>   CBOR.
> 
>   Another representation format that is quote popular is the CSV file
>   as defined by RFC 4180.
> 
>   The present document shows how to use CDDL to provide a data model
>   for CSV files.
> 
> 
> 
> 
> The IETF Secretariat
> 
>

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 24 Feb 2022 18:48:33 +0100

Hi Carsten,

this is *exactly* what fills a surprisingly big gap that might look 
trivial at first... but there is so. much. weirdness. out there. Please 
have a look at specimen A.):

> https://www.w3.org/TR/tabular-data-primer/

And then there have been even deeper and more dangerous semantic 
tranches being dug. Please have look at specimen B.) while having your 
OWL spectacles at hand:

> https://github.com/CommonCoreOntology/CommonCoreOntologies

(if OWL is not your native language) With the latter, I am referring to 
  InformationContentEntity and the InformationBearingEntity - semantic 
classes that, if you look into the details, potentially enable you to 
associate URI based semantics for header field values in a CSV.

*shudders*

The idea is good, but the execution is... an interesting read.

There are a lot of things that I.D-draft-bormann-cbor-cddl-csv could 
kickstart to fix.

Viele Grüße,

Henk

On 24.02.22 18:32, Carsten Bormann wrote:
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor