Subject: Re: I-D ACTION:draft-ietf-ccamp-gmpls-alarm-spec-02.txt

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 7 Dec 2004 15:12:32 -0000

Hi,

This version of the draft was submitted to address the WG last call comments. Note that
the DISMAN WG was also polled during WG last call and, although they had a couple of
questions, they did not produce anything that needed a change to the draft.

There are a few nits outstanding and it offers me the oportunity to preach to draft
authors and editors.
(Note: I'm an author of this draft so, as usual, I am talking to myself.)

When you are responsible for a WG draft you need to assume full responsibility for the
state of the draft and for informing the WG about the changes in the draft. Thus, when a
new version is published to address WG last call comments it is important that the editor
sends a note to the mailing list to describe how they have addressed each issue. It should
not be left up to the WG chair to go through the comments one by one and check to see if
they have been handled.

Similarly, if (as often seems to be the case these days)-: the draft is mangled in the
publication process, it is the editor's job to handle this with the secretariat and ensure
that a new, clean copy is published.

So, for this draft, can we please have:
- an email that shows what has been done to address each last call comment
- a clean version with
   - page throws
   - formatting fixed
   - line lengths kept to the required minimum

Thanks,
Adrian

---

From: Lou Berger <[email-masked]>
Date: Wed, 22 Dec 2004 17:26:11 -0500

>- an email that shows what has been done to address each last call comment

Here are a summary of the changes made in 
draft-ietf-ccamp-gmpls-alarm-spec-02.txt:
1) Noted that RFC3473 is updated by the document
2) Reiterated the extension does not replace any (existing) data plane 
fault propagation techniques.
3) Made c-type 1 and 2 reserved, and removed related references
4) Clarified ordering requirements within the IF_ID ALARM_SPEC (and 
ERROR_SPEC) TLVs
5) Clarified Reference Count field definition
6) Clarified handling of Reserved field
7) Added clarification and reference to definition of Impact and Severity 
fields
8) Clarified length of Error String field
9) Clarified procedures related
10) Removed some redundant text
11) Corrected typos and add other minor clarification text

>    - line lengths kept to the required minimum

Any issues introduced by the secretariat that aren't cleaned up by them 
will be corrected in the 48 hour Authors review or, if needed, in the next 
rev of the draft.  (as will the extra characters.)

Lou (and co-authors)