Subject: Question on LMP Adjacency

From: 김영화 <[email-masked]>
Date: Fri, 10 Dec 2004 16:07:25 +0900

Hi, ccampers

I've a question on the LMP adjacency.

In the LMP draft, the definition is as follows:

An "LMP adjacency" is formed between two nodes when at least one bi-
directional control channel is established between them. Multiple
control channels may be active simultaneously for each adjacency;
control channel parameters, however, MUST be individually negotiated
for each control channel.

Then, my question is this.

For an example,

we assume a sample network consisting of Node#1, Node#2, and Node#3. Node#1 is directly connected to Node#2, and Node#2 is directly connected to Node#3.

This means there is no direct connection between Node#1 and Node#3 in the sample network.

In this situation, we assume that an EoS channel(EoS#1) between Node#1 and Node#2 is terminated, but another EoS channel(EoS#2) between Node#1 and Node#3 is terminated through Node#2.

Here, I think that in case of the EoS#1, LMP adjacent nodes are Node#1 and Node#2, but in case of the EoS#2, LMP adjacent nodes are Node#1 and Node#3. In addition, I think that the type of data link for EoS#1 and EoS#2 is a component link and the link connection verification of EoS#2 between Node#1 and Node#3 could be performed. The only condition is, of course,  is to observe the definition of the LMP adjacency above.

Node#1               Node#2            Node#3

|-----EoS#1----|                        |

|------------EoS#2------------|

Could you help me if my understanding is short ?

Thanks,

Young.

---

From: Harish M <[email-masked]>
Date: Fri, 10 Dec 2004 12:59:21 +0530

Question is not clear.

 -----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
김영화
Sent: Friday, December 10, 2004 12:37 PM
To: [email-masked]
Subject: Question on LMP Adjacency

  Hi, ccampers

  For an example,
  we assume a sample network consisting of Node#1, Node#2, and Node#3.
Node#1 is directly connected to Node#2, and Node#2 is directly connected to
Node#3.
  This means there is no direct connection between Node#1 and Node#3 in the
sample network.
  In this situation, we assume that an EoS channel(EoS#1) between Node#1 and
Node#2 is terminated, but another EoS channel(EoS#2) between Node#1 and
Node#3 is terminated through Node#2.
  Here, I think that in case of the EoS#1, LMP adjacent nodes are Node#1 and
Node#2, but in case of the EoS#2, LMP adjacent nodes are Node#1 and Node#3.
In addition, I think that the type of data link for EoS#1 and EoS#2 is a
component link and the link connection verification of EoS#2 between Node#1
and Node#3 could be performed. The only condition is, of course,  is to
observe the definition of the LMP adjacency above.

  Node#1               Node#2            Node#3
        |-----EoS#1----|                        |

  Thanks,

  Young.

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 10 Dec 2004 08:00:47 -0000

Hi,

I *think* what you are saying is that in the control plane the physical connectivity is 

node#1----node#2----node#3

but in the data plane the TE connectivity is

node#1----node#2      node#3
  |                     |
   ---------------------

Note that these are TE links and there may be other underlying physical connectivity.

Note that an LMP control channel is formed simply when the two LMP speakers are in communication. Since they communicate using LMP over UDP, this is not a big problem in your figure so long as:

1. node#1 knows about the existence of node#3
   and can send UDP packets to it.
2. node#2 is capable of forwarding IP packets

Cheers,
Adrian