Subject: RE: I-D ACTION:draft-ietf-ccamp-gmpls-addressing-01.txt

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Thu, 28 Jul 2005 17:48:10 +0200

Hi Kohei, Rajiv, Richard,

I have on comment related to your GMPLS addressing ID:
In section 5.2 you recommend, that in the session object, the IP tunnel end-point be set to the destination TE router id and that the extended tunnel id be set to the source TE router id, which makes sense. But as per 3209, a session object can either encode IPv4 or IPv6 addresses but not both types, and there may be an issue if source TE router id is IPv6 and destination TE router id is IPv4 (or vice versa). This may happen for instance with inter-AS/SP LSPs. IMHO we should address this point.

Best Regards,

JL

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de 
> [email-masked]
> Envoyé : mardi 21 juin 2005 21:50
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D ACTION:draft-ietf-ccamp-gmpls-addressing-01.txt 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Common Control and 
> Measurement Plane Working Group of the IETF.
> 
> 	Title		: Use of Addresses in Generalized Multi-Protocol
>                           Label Switching (GMPLS) Networks
> 	Author(s)	: K. Shiomoto, et al.
> 	Filename	: draft-ietf-ccamp-gmpls-addressing-01.txt
> 	Pages		: 23
> 	Date		: 2005-6-21
> 	
> This document explains and clarifies the use of addresses in 
>    Generalized Multi-Protocol Label Switching (GMPLS) 
> networks.  The aim 
>    of this document is to facilitate and ensure better 
> interworking of 
>    GMPLS-capable Label Switching Routers (LSRs) based on experience 
>    gained in deployments and interoperability testing and proper 
>    interpretation of published RFCs. 
>     
>    The document recommends a proper approach for the 
> interpretation and 
>    choice of address and identifier fields within GMPLS protocols and 
>    references specific control plane usage models.  It also examines 
>    some common GMPLS Resource Reservation Protocol-Traffic 
> Engineering 
>    (RSVP-TE) signaling message processing issues and recommends 
>    solutions.  It finally discusses how to handle IPv6 sources and 
>    destinations in the MPLS and GMPLS TE (Traffic Engineering) MIB 
>    (Management Information Base) modules.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-add
ressing-01.txt
> 
> To remove yourself from the I-D Announcement list, send a 
> message to [email-masked] with the word 
> unsubscribe in the body of the message.  
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username "anonymous" and a password of your e-mail 
> address. After logging in, type "cd internet-drafts" and then
> 	"get draft-ietf-ccamp-gmpls-addressing-01.txt".
> 
> A list of Internet-Drafts directories can be found in 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE 
> /internet-drafts/draft-ietf-ccamp-gmpls-addressing-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: Kohei Shiomoto <[email-masked]>
Date: Sat, 30 Jul 2005 00:24:14 +0900

Hi Jean-Louis

Thank you for your comments. Your point sounds important when we 
consider the case IPv4 and IPv6 coexist.

But I feel that the IPv4 and IPv6 interwork seems a little bit future 
topic in a (G)MPLS context, in particular, from the control plane 
perspective.

I would be happy if you could provide your experience with the actual 
network operation and contribution.

Best regards,
--
Kohei

LE ROUX Jean-Louis RD-CORE-LAN wrote:
>>Envoy� : mardi 21 juin 2005 21:50
>>� : [email-masked]
>>Cc : [email-masked]

-- 
Kohei Shiomoto, Ph.D
Senior Research Engineer, Supervisor
NTT Network Service Systems Laboratories
3-9-11 Midori, Musashino, Tokyo 180-8585, Japan
Phone +81 422 59 4402    Fax +81 422 59 3787