Subject: Re: Frameformat in a l2cs gmpls rnvironment.

From: [email-masked]
Date: Fri, 22 Jul 2005 15:24:10 +0200

loa,

during the discussion loop one of the possibilities that came out consisted in using a dedicated TPID value (different from the value 0x8100 used in .1q), that would precede the encoded value as part of the TCI

would you please clarify your specific concern ? i would like also to point out that there are several cases here

1. both type of traffic on the same switch but not necessarily on the same interface

2. both type of traffic on the same interface

with the following variant

2a. interface must accommodate any type of traffic (un-/tagged and labeled)

2b. interface must accommodate tagged and labeled type of traffic only

thanks,

- dimitri.

Loa Andersson <[email-masked]>
Sent by: [email-masked]
07/22/2005 12:04 ZE2

To: Pär Mattsson <[email-masked]>
cc: [email-masked]
bcc:
Subject: Re: Frameformat in a l2cs gmpls rnvironment.

Per and Dimitri,

I would like to come down stronger than that, for me it is
a very strong requirement that the same switch can handle
both VLANs and GMPLs trafic correctly. I can't dsee how that
could be done if using the VLAN tpid to indicate GMPLS
traffic.

/Loa

Pär Mattsson wrote:
>>hi par, one of the possibilities that has been considered to cope with
>>this requirement is to use a dedicated TPID for the Ethernet labeled
>>frames; this would allow differentiated processing with non-labeled
>>framesthanks.
>
>
> That seems to make more sence. If that frame is to be sized like a 802.1q
> frame. There is not that much space left to a label. Or is the demand to
> use jumboframes ?
> Has there been any discussion on labelstacking, and mainly where to place
> the information?
>
> Regards.
> Per
>
>
>

--
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]

[email-masked]

---

From: Loa Andersson <[email-masked]>
Date: Mon, 25 Jul 2005 15:06:54 +0200

Dimitri,

the simple answer is that I need my VLANs, they give me a
good, understood and reliable service, even when I can set up
LSP through an Ethernet network.

As I see it VLANsd and LSPs is not the same, if we use the
VLAN to encapsulate LSPs we get into a problem of distinguishing
between a VLAN and an LSP.

VLAN is a scarce resource, 2048 per network (yeah - know I can
increase it by managing the VLAN budget carefully, but it is
kind of awkward). I think we should aim for something like 2000
labels per link (I wouldn't object if we can do better).

I'd also say that the the Ethernet network needs to be able
to handle all types of traffic, gmpls, tagged and untagged
over the same swtich. Don't see that a interface separation would
help since VLAN are per platform.

Did I answer your questions?

/Loa

[email-masked] wrote:
> loa,
> 
> during the discussion loop one of the possibilities that came out 
> consisted in using a dedicated TPID value (different from the value 
> 0x8100 used in .1q), that would precede the encoded value as part of the 
> TCI
> 
> would you please clarify your specific concern ? i would like also to 
> point out that there are several cases here
> 
> *Loa Andersson <[email-masked]>*

-- 
Loa Andersson