Subject: RE: Two Drafts for Resilience of Control Plane

From: "Zafar Ali \(zali\)" <[email-masked]>
Date: Fri, 28 Oct 2005 10:13:49 -0400

Hi All, 
 
I am unable to understand the problem we are trying to solve or
fabricate. My control network is IP based and IP has proven resiliency
(Internet *does* work), why would I like to take control plan resiliency
problem at a layer *above-IP* and complicate my life. Did I miss
something? 
 
Thanks
 
Regards... Zafar 

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Kim Young Hwa
	Sent: Friday, October 28, 2005 6:04 AM
	To: [email-masked]
	Subject: Two Drafts for Resilience of Control Plane

	Dear all,
	 
	I posted two drafts for the resilience of control plane.
	One is for requirements of the resilience of control plane, the
other is for a protocol specification as a solution of that .
	These are now available at:
	
http://www.ietf.org/internet-drafts/draft-kim-ccamp-cpr-reqts-01.txt
	
http://www.ietf.org/internet-drafts/draft-kim-ccamp-accp-protocol-00.txt
	 
	I want your comments.
	 
	Regards
	 
	Young.
	 
	====================================
	Young-Hwa Kim
	Principal Member / Ph.D
	BcN Research Division, ETRI
	Tel:     +82-42-860-5819
	Fax:    +82-42-860-5440
	e-mail: [email-masked]
	====================================
	
<http://umail.etri.re.kr/External_ReadCheck.aspx?email=[email-masked]
g&name=ccamp%40ops.ietf.org&fromemail=[email-masked]&messageid=%3C863
[email-masked]%3E>

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 28 Oct 2005 08:50:12 -0700 (PDT)

Zafar,

The problem arises when the control plane is decoupled
from the data plane. The question is do we need such
decoupling in IP networks? Consider, for example, the
situation when several parallel PSC data links bundled
together and controlled by a single control channel.
Does it mean in this case that when the control
channel fails all associated data links also fail? Do
we need to reroute in this case LSPs that use the data
links? Can we rely in this case on control plane
indications to decide whether an associated data link
is healthy or not (in other words, can we rely on RSVP
Hellos or should we use, for example, BTD)? Should we
be capable to recover control channels without
disturbing data plane? I think control plane
resilience is important for all layers. You are right,
Internet does work, however, we do need for some
reason TE and (fast) recovery in IP as much as in
other layers,don't we?

Cheers,
Igor

> [email-masked]%3E> 

		
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com

---

From: dimitri papadimitriou <[email-masked]>
Date: Fri, 28 Oct 2005 18:27:48 +0200

zafar -

> problem at a layer *above-IP* and complicate my life. Did I miss

... i don't think the issue is to invent new problems but at some point 
in time it may be become advisable to document the mechanisms available 
at hand and applicable to support control plane resilience - note they 
are disseminated in several I-Ds and RFCs today - at least this would 
prevent from re-discussing periodically this issue while at the end the 
initial problem has been covered progressively since CCAMP work started

---

From: dimitri papadimitriou <[email-masked]>
Date: Fri, 28 Oct 2005 18:55:55 +0200

igor -

over time CCAMP came with a set of mechanims to improve control plane 
resilience (RSVP and LMP GR upon channel/node failure) other WG protocol 
work are also usable used here OSPF GR, etc. ... on the other side, 
mechanism such as link bundling have built-in resilience capabilities 
and most GMPLS control plane capabilities have been designed such as to 
be independent of the control plane realisation (in-band, out-of-band, etc.)

so indeed i share the concern of Zafar what could we do more here than 
document these tools and provide our experience in using them;

now, before stating there are (potential) problems(s) arising - would 
you please be more specific on what are these potential issue(s) and/or 
problems ? (not related to policy/config. - note: all the issues you 
have pointed here below are simply policy/config specific but none of 
them highlights a missing IP control plane resiliency feature)

thanks,
- dimitri.

Igor Bryskin wrote:

> .