Subject: RE: A quick question on http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-e2e-signaling-03.txt

From: "Zafar Ali \(zali\)" <[email-masked]>
Date: Tue, 20 Dec 2005 09:49:26 -0500

________________________________

	From: [email-masked]
[mailto:[email-masked]] 
	Sent: Tuesday, December 20, 2005 8:05 AM
	To: Zafar Ali (zali)
	Cc: Adrian Farrel; [email-masked]; [email-masked]
	Subject: Re: A quick question on
http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-e2e-
signaling-03.txt

	zafar, i am not sure to fully understand your question 
	
	the O-bit is used for 1+1 and 1:1 protection scheme such as to
have an indication when a protecting LSP is carrying the "normal"
traffic after protection switching (so it applies only in case of 1+1
LSP uni-/bidirectional protection or 1:1 LSP protection)  .

Dimitri, 
 
More specifically, my question was mainly on what "LSP (Protection Type)
Flags" to use for, dedicated 1:1 protection, where 

*	Traffic is NOT duplicated at working and protecting LSP-es
(i.e., this is not 1+1 protection), 
*	There is NO extra traffic on the protecting LSP (i.e., it's
dedicated protection), 

In this case there is NO duplication of the traffic on the backup
resource (it's NOT 1+1). There is also NO extra traffic that protection
resources carry. 
 
Thanks
 
Regards... Zafar 

	
	thanks, 
	- dimitri. 
	
	ps: purpose is not to "contrast" between protection schemes 

	
	"Zafar Ali \(zali\)" <[email-masked]> 
Sent by: [email-masked] 

19/12/2005 23:10 

        To:        <[email-masked]> 
        cc:        "Adrian Farrel" <[email-masked]>, Dimitri
PAPADIMITRIOU/BE/ALCATEL@ALCATEL 
        Subject:        A quick question on
http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-e2e-
signaling-03.txt

	Hi All, 
	  
	It's a bit confusing how one would encode protection object for
dedicated 1:1 protection (without traffic duplication) and I thought it
deserves a confirmation. 
	  
	I just wanted to confirm that to signal an LSP that is dedicated
1:1 protection, where 

	*	Traffic is NOT duplicated at working and protecting
LSP-es (i.e., this is not 1+1 protection), 
	*	There is NO extra traffic on the protecting LSP (i.e.,
it's dedicated protection), 

	we are expected to: 

	*	Set O-bit in protection object to 1 in signaling
protecting LSP, to indicate that the protecting LSP is (only) carrying
the normal traffic after protection switching (i.e., It's NOT 1+1
setup). If contrasting 1:1 with 1+1 is NOT the intended use of O-bit,
what is the intended use. 
	*	LSP (Protection Type) Flags to 0x10 = 1+1 Bi-directional
Protection (for GMPLS optical LSPs). I.e., this is a dedicated
protection.

	If above is not the intended use of O-bit, I am not sure why
O-bit is defined (as protection LSP is expected to carry normal traffic
after switchover). In which is it expected to use 0x04 = 1:N Protection
with Extra-Traffic as LSP (Protection Type) Flags? 
	  
	Thanks 
	  
	Regards... Zafar

---

From: [email-masked]
Date: Tue, 20 Dec 2005 16:07:50 +0100

zafar
 
> More specifically, my question was mainly on what 
> "LSP (Protection Type) Flags" to use for, dedicated 
> 1:1 protection, where 
> - Traffic is NOT duplicated at working and protecting 
> - There is NO extra traffic on the protecting LSP 
>   (i.e., it's dedicated protection), 
> In this case there is NO duplication of the traffic 
> on the backup resource (it's NOT 1+1). There is also 
> NO extra traffic that protection resources carry. 
  
as pointed into the document for the 1:1 LSP protection:

   "Although the resources for the protecting LSP are pre-allocated, 
   preemptable traffic may be carried end-to-end using this LSP. Thus, 
   the protecting LSP is capable of carrying extra-traffic with the 
   caveat that this traffic will be preempted if the working LSP fails." 

hope this clarifies (i.e. there is no specific flag when there is no 
extra-traffic)

thanks, 
- dimitri. 

        
        To:        <[email-masked]> 
        cc:        "Adrian Farrel" <[email-masked]>, Dimitri 
PAPADIMITRIOU/BE/ALCATEL@ALCATEL 
        Subject:        A quick question on 
http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-e2e-signaling-03.txt

Hi All, 
  
It's a bit confusing how one would encode protection object for dedicated 
1:1 protection (without traffic duplication) and I thought it deserves a 
confirmation. 
  
I just wanted to confirm that to signal an LSP that is dedicated 1:1 
protection, where 
Traffic is NOT duplicated at working and protecting LSP-es (i.e., this is 
not 1+1 protection), 
There is NO extra traffic on the protecting LSP (i.e., it's dedicated 
protection), 
we are expected to: 
Set O-bit in protection object to 1 in signaling protecting LSP, to 
indicate that the protecting LSP is (only) carrying the normal traffic 
after protection switching (i.e., It's NOT 1+1 setup). If contrasting 1:1 
with 1+1 is NOT the intended use of O-bit, what is the intended use. 
LSP (Protection Type) Flags to 0x10 = 1+1 Bi-directional Protection (for 
GMPLS optical LSPs). I.e., this is a dedicated protection.
If above is not the intended use of O-bit, I am not sure why O-bit is 
defined (as protection LSP is expected to carry normal traffic after 
switchover). In which is it expected to use 0x04 = 1:N Protection with 
Extra-Traffic as LSP (Protection Type) Flags? 
  
Thanks 
  
Regards... Zafar

---

From: "Igor Bryskin" <[email-masked]>
Date: Tue, 20 Dec 2005 11:16:14 -0500

Hi Zafar,

I have a question to you. Why would you need a dedicated 1:1 protection without allowing the protection LSP to be used for carrying extra traffic? If the resources of the protection LSP are allocated anyway and the LSP is totally dedicated to protect the working LSP you might as well bridge the traffic on the protection LSP with an immediate benefit of much better recovery time. The whole point of 1:1 protection is to allow using resources of the protection LSP for something else - carrying extra traffic in case of dedicated 1:1 or extra traffic and other protection LSPs in cases of shared 1:1 protection.

The other thing to note is that extra traffic does not have to be carried all the time or any time for that matter - 1:1 protected service is provisioned in such a way that extra traffic could be carried over idle protection LSP should such need arise in the future. Thus, Dimitri is right: O-bit is set to zero for the protection LSP to signal the fact that originally the protection LSP is going to be idle in a sense that it will not be carrying the"normal" (read protected traffic) and is ready to carry extra traffic.

Cheers and Happy Holidays,
Igor
  ----- Original Message ----- 
  From: Zafar Ali (zali) 
  To: [email-masked] 
  Cc: Adrian Farrel ; [email-masked] ; [email-masked] 
  Sent: Tuesday, December 20, 2005 9:49 AM
  Subject: RE: A quick question on http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-e2e-signaling-03.txt

----------------------------------------------------------------------------
    From: [email-masked] [mailto:[email-masked]] 
    Sent: Tuesday, December 20, 2005 8:05 AM
    To: Zafar Ali (zali)
    Cc: Adrian Farrel; [email-masked]; [email-masked]
    Subject: Re: A quick question on http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-e2e-signaling-03.txt

    the O-bit is used for 1+1 and 1:1 protection scheme such as to have an indication when a protecting LSP is carrying the "normal" traffic after protection switching (so it applies only in case of 1+1 LSP uni-/bidirectional protection or 1:1 LSP protection)  .

  Dimitri, 

  More specifically, my question was mainly on what "LSP (Protection Type) Flags" to use for, dedicated 1:1 protection, where 
    a.. Traffic is NOT duplicated at working and protecting LSP-es (i.e., this is not 1+1 protection), 
    b.. There is NO extra traffic on the protecting LSP (i.e., it's dedicated protection), 
  In this case there is NO duplication of the traffic on the backup resource (it's NOT 1+1). There is also NO extra traffic that protection resources carry. 

  Thanks

  Regards... Zafar 

    thanks, 
    - dimitri. 

                 
                  To:        <[email-masked]> 
                  cc:        "Adrian Farrel" <[email-masked]>, Dimitri PAPADIMITRIOU/BE/ALCATEL@ALCATEL 
                  Subject:        A quick question on http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-e2e-signaling-03.txt 

    Hi All, 
      
    It's a bit confusing how one would encode protection object for dedicated 1:1 protection (without traffic duplication) and I thought it deserves a confirmation. 
      
    I just wanted to confirm that to signal an LSP that is dedicated 1:1 protection, where 
      a.. Traffic is NOT duplicated at working and protecting LSP-es (i.e., this is not 1+1 protection), 
      b.. There is NO extra traffic on the protecting LSP (i.e., it's dedicated protection), 
    we are expected to: 
      a.. Set O-bit in protection object to 1 in signaling protecting LSP, to indicate that the protecting LSP is (only) carrying the normal traffic after protection switching (i.e., It's NOT 1+1 setup). If contrasting 1:1 with 1+1 is NOT the intended use of O-bit, what is the intended use. 
      b.. LSP (Protection Type) Flags to 0x10 = 1+1 Bi-directional Protection (for GMPLS optical LSPs). I.e., this is a dedicated protection.
    If above is not the intended use of O-bit, I am not sure why O-bit is defined (as protection LSP is expected to carry normal traffic after switchover). In which is it expected to use 0x04 = 1:N Protection with Extra-Traffic as LSP (Protection Type) Flags? 
      
    Thanks 
      
    Regards... Zafar