Subject: RE: Opinion on WG drafts for Multi-region/layer networks

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Fri, 23 Dec 2005 09:04:26 +0100

Hi Richard

See inline, 

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de Richard Rabbat
> Envoyé : jeudi 22 décembre 2005 23:28
> À : [email-masked]
> Cc : [email-masked]
> Objet : Re: Opinion on WG drafts for Multi-region/layer networks
> 
> yes to both
> 
> two questions:
> 1. since MLN is a special case of MRN, can we collapse this 
> whole topic to MRN? is there a compelling reason for keeping 
> these 2 notation?

Actually a MLN is not a special case of MRN. Rather a MRN is a special case of MLN. A network comprised of VC4 and VC4-64c capable node is a MLN but not a MRN.
"Layer" refers to a data plane switching layer (e.g. VC4, VC4-64c...). While "region" refers to a switching capablity (PSC, TDM...).
The term MLN is used to discuss mechanisms that apply equally to layers and regions (VNT...) while the term MRN is used to discuss multi-regions specific mechanisms (e.g. Adaptation capability). 

> 2. Section 3 of draft-leroux-ccamp-gmpls-mrn-eval-02.txt is a 
> requirments section and therefore not relevant to this draft 
> but belongs to draft-shiomoto-ccamp-gmpls-mrn-reqs-03.txt. 
> there is no advantage to repeting requirements.

The objective was to ease the reading, but we can easily remove it if considered as irrelevant.

Thanks for your support and for these comments.

Regards,

JL

> 
> thanks,
> richard.
> 
> Adrian Farrel wrote:
> 
> >Hi,
> >
> >We have a charter milestone to start WG work on a 
> Requirements I-D for 
> >MRN/MLN, and also an Evaluation I-D to examine how the current 
> >protocols shape up to the challenge.
> >
> >There are two appropriate I-Ds that have been around for a while.
> >
> >draft-shiomoto-ccamp-gmpls-mrn-reqs-03.txt
> >draft-leroux-ccamp-gmpls-mrn-eval-02.txt
> >
> >I propose that we make these WG documents and then give them 
> a thorough 
> >review and edit.
> >
> >Opinions please.
> >
> >Yes or no will suffice, but reasons are always nice.
> >
> >Thanks,
> >Adrian
> >
> >
> >  
> >
> 
>

---

From: "Igor Bryskin" <[email-masked]>
Date: Fri, 23 Dec 2005 09:13:33 -0500

JL.

I have a correction. Please,see in-line.

Igor

----- Original Message ----- 
From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
To: "Richard Rabbat" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, December 23, 2005 3:04 AM
Subject: RE: Opinion on WG drafts for Multi-region/layer networks

Hi Richard

See inline,

> whole topic to MRN? is there a compelling reason for keeping

Actually a MLN is not a special case of MRN. Rather a MRN is a special case
of MLN. A network comprised of VC4 and VC4-64c capable node is a MLN but not
a MRN.

IB>> Agree

"Layer" refers to a data plane switching layer (e.g. VC4, VC4-64c...). While
"region" refers to a switching capablity (PSC, TDM...).

IB>> "Layer" is all about data plane. Layers exist independently of control
plane.. "Region" refers to control plane peculiarities pertinent to networks
with different switching types. Signaling objects specific to TDM , optical
impairment constraints specific to optical transparent networks are examples
of region related issues. Therefore, "region" is purely control plane
concept. See more in the lexicography draft.

The term MLN is used to discuss mechanisms that apply equally to layers and
regions (VNT...) while the term MRN is used to discuss multi-regions
specific mechanisms (e.g. Adaptation capability).
;
IB>> Disagree. Adaptation capability is entirely MLN issue. According to
your own example you need to adopt VC4 onto VC4-64c.

Cheers,
Igor

> there is no advantage to repeting requirements.

The objective was to ease the reading, but we can easily remove it if
considered as irrelevant.

Regards,

JL

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 23 Dec 2005 15:30:04 +0100

Hello JL,

You explained:

>> two questions: 1. since MLN is a special case of MRN, can we
>> collapse this whole topic to MRN? is there a compelling reason for
>> keeping these 2 notation?
> 
> Actually a MLN is not a special case of MRN. Rather a MRN is a
> special case of MLN. A network comprised of VC4 and VC4-64c capable
> node is a MLN but not a MRN. "Layer" refers to a data plane switching
> layer (e.g. VC4, VC4-64c...). While "region" refers to a switching
> capablity (PSC, TDM...). The term MLN is used to discuss mechanisms
> that apply equally to layers and regions (VNT...) while the term MRN
> is used to discuss multi-regions specific mechanisms (e.g. Adaptation
> capability).

I am still confused by the definition of MRN.
Suppose I have a TDM MRN, I can distinguish in this TDM MRN e.g.
VC-12 layer switching, VC-4 layer switching, MS-n layer switching,
so according to the above all MLN.
Why is an MRN then a special case of MLN.

With the next generation nodes: Multi Service Platforms within
the same node there can also be ethernet switching on top of
the above mentioned TDM MRN and optical switching (DWDM) below
this TDM MRN....

IMO the definition of MRN will be very difficult (impossible).

I would propose to use only the MLN definition, with this layering
and partitioning a network can be described completely.

Cheers, Huub.

-- 
================================================================
              http://members.chello.nl/hhelvoort/
================================================================
Always remember that you are unique...just like everyone else...

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 23 Dec 2005 16:09:25 +0100

Hello Igor,

> your own example you need to adopt VC4 onto VC4-64c.

There exists no adaptation function with VC-4 client and
VC-4-64c as server.
A VC-4-64c can be used as a server to transport a 10GbE LAN
client signal, or other 10 Gbit/s signals using e.g. GFP.
A VC-4 can be used as a server for VC-3, VC-12, VC-11 signals,
be a member of a VC-4-64v, or thransport a 150 Mbit/s client
signal using e.g. GFP.

Cheers, Huub.

---

From: Richard Rabbat <[email-masked]>
Date: Fri, 23 Dec 2005 12:02:33 -0800

hi Jean-Louis,
thanks for the reply,
inline...

>"Layer" refers to a data plane switching layer (e.g. VC4, VC4-64c...). While "region" refers to a switching capablity (PSC, TDM...).
My comment was incorrect. Let me use better math wording. 
Do all elements of the set MRN belong to the set MLN?

I suggest that both terms MRN and MLN be clearly defined somewhere.

>The term MLN is used to discuss mechanisms that apply equally to layers and regions (VNT...) while the term MRN is used to discuss multi-regions specific mechanisms (e.g. Adaptation capability). 
If Igor is right about adaptation (though the example is wrong from 
Huub's email), then what are other MR specific mechanisms?

>The objective was to ease the reading, but we can easily remove it if considered as irrelevant.
My suggestion is to drop it in this draft and if there is need to have a 
summary for clarity, then clarify in the req's doc.

thanks,
richard.

---

From: Kohei Shiomoto <[email-masked]>
Date: Sat, 24 Dec 2005 09:22:54 +0900

Hi Huub

Thank you for your support and comments.
Please see in line.

> Why is an MRN then a special case of MLN.

As JL explained, a MRN is a special case of MLN.  As far as the same
interface switching capability is used, the MLN is not called the MRN
[RFC4206]. The same switching type is used in control plane as long as
it is in the same region. The switching type TDM is used in control
plane of the TDM multi-layer network consisting of VC-12 and VC-4 for
instance.

A region uniquely identifies a particular data plane technology (PSC,
L2SC, TDM, LSC, and FSC) while a layer describes a data plane switching
granularity level. A region (e.g. TDM) can be sub-divided into smaller
granularity based on the bandwidth that defines the "data plane
switching layers" (e.g. from VC-11 to VC4-256c in TDM). In other words,
more than one data plane layer can be associated to the same region
(e.g. both VC4 and VC12 are associated to TDM).

> and partitioning a network can be described completely.

Thank you for your comments. Again a MRN is a special case of MLN. The
term MLN could replace the term MRN in our documents where appropriate.
We should see whether appropriate wording is used in the next revision
to resolve confusion.

> Cheers, Huub.

Thanks,
Kohei

---

From: Igor Bryskin <[email-masked]>
Date: Sat, 24 Dec 2005 05:32:30 -0800 (PST)

Huub,
  
  I am sure you are right. My only point - and I see you agree with me -  that adaptation capabilities - to adopt/to be adopted - is a property  of layer.
  
  Igor

Huub van Helvoort <[email-masked]> wrote:  Hello Igor,

Cheers, Huub.

		
---------------------------------
Yahoo! Photos
 Ring in the New Year with Photo Calendars. Add photos, events, holidays, whatever.

---

From: Igor Bryskin <[email-masked]>
Date: Sat, 24 Dec 2005 05:49:19 -0800 (PST)

Richard,
  
  See in line.
  Igor

Richard Rabbat <[email-masked]> wrote:  hi Jean-Louis,
thanks for the reply,
inline...

    
  IB>> Deborah is right. Region is purely control plane concept.  Region ( e.g. TDM. WDM. etc.) specific signaling object, translation of  signaling messages when they pass through the region boundaries is an  example of  a multi-region operation. Your own draft about  advertising available lambdas and computing paths in terms of lambdas  is an example of region specific operation. 
  Anything to do with data plane is all about layers and not regions.
    
  Igor

thanks,
richard.

		
---------------------------------
Yahoo! for Good - Make a difference this year.