Subject: Further short CCAMP WG Last Call on draft-ietf-ccamp-te-node-cap-03.txt

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 15 Dec 2006 11:32:48 -0000

Hi,

Sorry, I fumbled this.

Jean-Louis made some significant changes after we completed the working 
group last call. He took on board the comments from CCAMP, ISIS and OSPF and 
made the changes that he describes below.

Since one of these changes is relatively substantial (the conflation of two 
bit-fields into one) I want to give everyone a chance to comment before we 
go forward to the ADs.

So, there is a one week last call running on the CCAMP mailing list until 
noon GMT 22nd December 2006.

Thanks,
Adrian

----- Original Message ----- 
From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, November 22, 2006 7:25 AM
Subject: RE: I-D ACTION:draft-ietf-ccamp-te-node-cap-03.txt

Hi all,

This new version accounts for comments received during the CCAMP ISIS and 
OSPF WG last call.

Here are the main changes:

-The data plane and control plane cap sub-TLVs have been removed. The 
capabilities are now carried directly with the TE Node Capability Descriptor 
TLV, and there is a single registry for both control and data plane 
capabilities.

-In section 5:
"other occurences MUST be discarded" replaced by "other occurrences MUST be 
ignored"

-In section 6:
"a router not supporting the TE Node Capability Descriptor TLV MUST just 
silently ignore the TLV"
Replaced by: "a router not supporting the TE Node Capability Descriptor TLV 
will just silently ignore the TLV"

Regards,

JL

> -----Message d'origine-----
> De : [email-masked]
> [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : mardi 21 novembre 2006 21:50
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D ACTION:draft-ietf-ccamp-te-node-cap-03.txt
>
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories.
> This draft is a work item of the Common Control and
> Measurement Plane Working Group of the IETF.
>
> Title : IGP Routing Protocol Extensions for
> Discovery of Traffic Engineering  Node Capabilities
> Author(s) : J. Vasseur, et al.
> Filename : draft-ietf-ccamp-te-node-cap-03.txt
> Pages : 13
> Date : 2006-11-21
>
> It is highly desired in several cases, to take into account Traffic
>    Engineering (TE) node capabilities during Multi Protocol Label
>    Switching (MPLS) and Generalized MPLS (GMPLS) Traffic Engineered
>    Label Switched Path (TE-LSP)  selection, such as for instance the
>    capability to act as a branch Label Switching Router (LSR) of a
>    Point-To-MultiPoint (P2MP) LSP. This requires advertising these
>    capabilities within the Interior Gateway Protocol (IGP). For that
>    purpose, this document specifies Open Shortest Path First
> (OSPF) and
>    Intermediate System-Intermediate System (IS-IS) traffic
> engineering
>    extensions for the advertisement of control plane and data plane
>    traffic engineering node capabilities.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-ccamp-te-node-cap-03.txt

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 23 Dec 2006 13:42:39 -0000

This concludes the additional last call on this I-D.

Jean-Louis has already submitted an update to cover the comments made. I 
will check this and forward the I-D to the ADs.

Adrian
----- Original Message ----- 
From: "Adrian Farrel" <[email-masked]>
To: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>; 
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, December 15, 2006 11:32 AM
Subject: Further short CCAMP WG Last Call on 
draft-ietf-ccamp-te-node-cap-03.txt

> group last call. He took on board the comments from CCAMP, ISIS and OSPF 
> and made the changes that he describes below.
>
> Since one of these changes is relatively substantial (the conflation of 
> two bit-fields into one) I want to give everyone a chance to comment 
> before we go forward to the ADs.
>
> capabilities are now carried directly with the TE Node Capability 
> Descriptor TLV, and there is a single registry for both control and data 
> plane capabilities.
>
> -In section 5:
> "other occurences MUST be discarded" replaced by "other occurrences MUST 
> be ignored"
>
> -In section 6:
> Replaced by: "a router not supporting the TE Node Capability Descriptor 
> TLV will just silently ignore the TLV"
>
> Regards,
>
> JL
>