Subject: Signaling client layer LSP over VCAT server layer LSP

From: "Bardalai, Snigdho" <[email-masked]>
Date: Sat, 15 Mar 2008 14:25:43 -0500

Hello Kohei and Greg,

I have a question about client layer LSP signaling (e.g. ethernet) over VCAT server layer resources.

From reading 'draft-ietf-ccamp-lsp-hierarchy-bis-03.txt' it is not clear how will this exactly work.

For example, we set up a VCAT group (i.e. by signaling multiple STS1 LSPs) as allowed by the VCAT ID. I believe each of these LSPs would appear as LSP_TUNNEL_INTERFACEs in the client layer with bandwidth capacity equivalent to STS1 (i.e. 52mbps). My question is which LSP_TUNNEL_INTERFACE will be used for signaling the ethernet LSP, I think an additional component link with bandwidth capacity equivalent to the aggregate bandwidth will have to be created.

Is there a defined way of handling this situation?

Thanks,
Snigdho

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 18 Mar 2008 11:25:51 -0000

Hi,

IMHO the two drafts are not so closely related.

Hierarchy bis describes how, when an LSP is set up, the ingress may indicate 
to the egress that the LSP is to be advertised or used as a link in some 
specific network layer.

LSPs set up for VCAT are not used in that way. They are grouped together and 
the whole group is used as a link in another network layer.

So, for VCAT, one might use the call as the mechanism to exchange 
information about how to use the entire VCG as a link in the client layer. 
Alternatively (if one is implementing strictly according to the 
architecture) one might have three layers to consider...

- The server layer where a call coordinates multiple TDM LSPs
- The VCAT layer where a single hop LSP is requested between
   VCG end points resulting in the server layer call. The VCAT
   layer LSP would use hierarchy bis to determine that it should
   be advertised as a TE link in the client layer.
- The client layer where a magic TE link appears as the result of
   the VCAT layer LSP.

Depending on the deployment, the use of a VCAT layer LSP might be considered 
to be over-engineering. Just because an architecture defines multiple 
layers, it does not mean you have to implement them explicitly. It might be 
enough for the server layer call to provide the coordination with the client 
layer direct.

Cheers,
Adrian
----- Original Message ----- 
From: "Bardalai, Snigdho" <[email-masked]>
To: "Kohei Shiomoto (E-mail)" <[email-masked]>; "Greg 
Bernstein (E-mail)" <[email-masked]>
Cc: "Ccamp (E-mail)" <[email-masked]>; "Adrian Farrel (E-mail)" 
<[email-masked]>
Sent: Saturday, March 15, 2008 7:25 PM
Subject: Signaling client layer LSP over VCAT server layer LSP

Hello Kohei and Greg,

I have a question about client layer LSP signaling (e.g. ethernet) over VCAT 
server layer resources.

From reading 'draft-ietf-ccamp-lsp-hierarchy-bis-03.txt' it is not clear how 
will this exactly work.

For example, we set up a VCAT group (i.e. by signaling multiple STS1 LSPs) 
as allowed by the VCAT ID. I believe each of these LSPs would appear as 
LSP_TUNNEL_INTERFACEs in the client layer with bandwidth capacity equivalent 
to STS1 (i.e. 52mbps). My question is which LSP_TUNNEL_INTERFACE will be 
used for signaling the ethernet LSP, I think an additional component link 
with bandwidth capacity equivalent to the aggregate bandwidth will have to 
be created.

Thanks,
Snigdho

---

From: Kohei Shiomoto <[email-masked]>
Date: Tue, 18 Mar 2008 23:58:49 +0900

Hi, Snigdho

Thank you for your question.

I agree with Adrian.

Hierarchy bis describes, when a LSP is dynamically created, the ingress 
LSP may indicates the LSP is advertised or used to carry traffic. We 
consider the bundling link composed of component links in this draft.But 
VCAT connection is not a bundled link.

Call concept are used to a VCAT connection, which is composed of 
multiple co-signaled member sets.How to advertise a link composed of the 
VCG can be developed in the context of call concept to avoid 
intermediate layer. But we do not have to exclude use of the same 
mechanism defined in hierarchy-bis for this purpose.

Best regards,
Kohei
> Hierarchy bis describes how, when an LSP is set up, the ingress may 
> indicate to the egress that the LSP is to be advertised or used as a 
> link in some specific network layer.
>
> LSPs set up for VCAT are not used in that way. They are grouped 
> together and the whole group is used as a link in another network layer.
>
> information about how to use the entire VCG as a link in the client 
> layer. Alternatively (if one is implementing strictly according to the 
> Depending on the deployment, the use of a VCAT layer LSP might be 
> considered to be over-engineering. Just because an architecture 
> defines multiple layers, it does not mean you have to implement them 
> explicitly. It might be enough for the server layer call to provide 
> the coordination with the client layer direct.
>
> Cheers,
> Adrian
> ----- Original Message ----- From: "Bardalai, Snigdho" 
> <[email-masked]>
> For example, we set up a VCAT group (i.e. by signaling multiple STS1 
> LSPs) as allowed by the VCAT ID. I believe each of these LSPs would 
> appear as LSP_TUNNEL_INTERFACEs in the client layer with bandwidth 
> capacity equivalent to STS1 (i.e. 52mbps). My question is which 
> LSP_TUNNEL_INTERFACE will be used for signaling the ethernet LSP, I 
> think an additional component link with bandwidth capacity equivalent 
> to the aggregate bandwidth will have to be created.
>
-- 
Kohei Shiomoto, Ph.D
Senior Research Engineer, Supervisor, Group Leader
NTT Network Service Systems Laboratories
http://www.ntt.co.jp/islab/org/ns.html
3-9-11 Midori, Musashino, Tokyo 180-8585, Japan
Phone +81 422 59 4402 Fax +81 422 59 3787
Free online contents of "NTT Technical Review" available at
https://www.ntt-review.jp/

---

From: "Bardalai, Snigdho" <[email-masked]>
Date: Tue, 18 Mar 2008 23:02:44 -0500

Hi Adrian and Kohei,

Thanks for your response. 

So I believe we have a couple of alternatives to establish the client layer interface:
1. Extend the VCAT layer call mechanism
2. Signal a VCAT layer LSP to trigger the creation of an LSP_TUNNEL_INTERFACE

So either way we have a single client layer interface which represents a set of inversely multiplexed server layer LSPs.

I am not sure if this aspect is described in the VCAT ID, does it make sense to add this type of information?

Regards,
Snigdho

-----Original Message-----
From: Kohei Shiomoto [mailto:[email-masked]]
Sent: Tuesday, March 18, 2008 9:59 AM
To: Adrian Farrel
Cc: Bardalai, Snigdho; Greg Bernstein (E-mail); Ccamp (E-mail)
Subject: Re: Signaling client layer LSP over VCAT server layer LSP

Hi, Snigdho

I agree with Adrian.

Best regards,
Kohei