Subject: [CCAMP] IETF 76 - Draft CCAMP Minutes

From: "Daniel King" <[email-masked]>
Date: Fri, 20 Nov 2009 18:21:24 -0000

Hello all, 

The CCAMP draft minutes for the IETF 76 sessions are now available:

http://www.ietf.org/proceedings/09nov/minutes/ccamp.htm

If you have any questions or amendment requests please email me and CC the
WG Chairs.  Please let me have these comments by Friday, 4th December, 2009.

Br, Dan.

---

From: "Ong, Lyndon" <[email-masked]>
Date: Fri, 20 Nov 2009 14:16:44 -0500

HI Dan,

I would like to point out one correction, although the discussion is
correctly recorded in the notes:  in the discussion of ASON routing
implementation and testing it was stated that "the document"
(referencing draft-ietf-ccamp-gmpls-ason-routing) has been a Working
Group draft since 2003.  Actually,
draft-ietf-ccamp-gmpls-ason-routing-00.txt is dated July 2006.

Can a note be added to that effect?

Thanks,

Lyndon

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Daniel King
Sent: Friday, November 20, 2009 10:21 AM
To: [email-masked]
Subject: [CCAMP] IETF 76 - Draft CCAMP Minutes

Hello all, 

If you have any questions or amendment requests please email me and CC
the WG Chairs.  Please let me have these comments by Friday, 4th
December, 2009.   

Br, Dan.

---

From: "Sadler, Jonathan B." <[email-masked]>
Date: Fri, 20 Nov 2009 14:44:31 -0600

Hi Dan,

A similar comment about the ason-routing draft only being available after June 2006 was also made in the CCAMP Jabber session.  I assume that Jabber session comments are also to be captured in the notes - correct?

Jonathan Sadler

________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ong, Lyndon [[email-masked]]
Sent: Friday, November 20, 2009 1:16 PM
To: Daniel King; [email-masked]
Subject: Re: [CCAMP] IETF 76 - Draft CCAMP Minutes

HI Dan,

I would like to point out one correction, although the discussion is correctly recorded in the notes:  in the discussion of ASON routing implementation and testing it was stated that “the document” (referencing draft-ietf-ccamp-gmpls-ason-routing) has been a Working Group draft since 2003.  Actually, draft-ietf-ccamp-gmpls-ason-routing-00.txt is dated July 2006.

Thanks,

Lyndon

From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniel King
Sent: Friday, November 20, 2009 10:21 AM
To: [email-masked]
Subject: [CCAMP] IETF 76 - Draft CCAMP Minutes

Hello all,

If you have any questions or amendment requests please email me and CC the WG Chairs.  Please let me have these comments by Friday, 4th December, 2009.

Br, Dan.

---

From: Lou Berger <[email-masked]>
Date: Fri, 20 Nov 2009 16:02:50 -0500

In general the minutes and jabber should be in sync, but only what was 
said at a mic will be in the minutes.  This is why we have people
"channel" (speak at the mic) for those who are not in the room.  Jabber 
logs are available in the usual locations, i.e., via 
http://tools.ietf.org/wg/ccamp/.

Lou

On 11/20/2009 3:44 PM, Sadler, Jonathan B. wrote:
> Hi Dan,
> A similar comment about the ason-routing draft only being available
> after June 2006 was also made in the CCAMP Jabber session. I assume that
> Jabber session comments are also to be captured in the notes - correct?
> Jonathan Sadler
> ------------------------------------------------------------------------
> *From:* [email-masked] [[email-masked]] On Behalf Of
> Ong, Lyndon [[email-masked]]
> *Sent:* Friday, November 20, 2009 1:16 PM
> *To:* Daniel King; [email-masked]
> *Subject:* Re: [CCAMP] IETF 76 - Draft CCAMP Minutes
>
> HI Dan,
>
> implementation and testing it was stated that “the document”
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Daniel King
> *Sent:* Friday, November 20, 2009 10:21 AM
> *To:* [email-masked]
> *Subject:* [CCAMP] IETF 76 - Draft CCAMP Minutes
>
> Hello all,
>
> the WG Chairs. Please let me have these comments by Friday, 4^th
> December, 2009.
>
> Br, Dan.
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: "BRUNGARD, DEBORAH A (ATTLABS)" <[email-masked]>
Date: Mon, 23 Nov 2009 14:33:22 -0500

Hi Lyndon,

The “Working Group document” was answering the previous comment questioning the status of the Experimental document. The 2003 was referring to the history of ASON-routing as a work item in CCAMP which was in response to your sentence: “however implementation and testing began before [OSPF-ASON] was defined.”

To restate my question: “Why did OIF (independently) develop ASON routing extensions while CCAMP’s ASON work was active (since 2003)?” As you note, the WG status for the extensions document was in July 2006. This is prior to the OIF demos of 2007 and 2009.

So 2003 or 2006, both are prior the demos, and the actual question remains unanswered (other than Lyndon’s response saying it was “not intentional”).  And also the more germane question (which Lou asked), does OIF intend to adapt/test IETF protocol extensions?

Jabber really needs at least two people – one to be a scribe and the other to stay by the mike to provide Jabber input. Volunteers for next time?

Deborah

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ong, Lyndon
Sent: Friday, November 20, 2009 2:17 PM
To: Daniel King; [email-masked]
Subject: Re: [CCAMP] IETF 76 - Draft CCAMP Minutes

HI Dan,

Thanks,

Lyndon

Hello all, 

Br, Dan.

---

From: "Ong, Lyndon" <[email-masked]>
Date: Mon, 23 Nov 2009 16:00:35 -0500

Hi Deborah,

The specific statement in the minutes is: “this document has been a working group document since 2003”, which is not accurate.  I would like to request that this statement either be corrected or removed, since it is otherwise misleading.  That’s all.

As far as the history of this activity, that’s probably a long drawn out discussion, but some key points are:

-          If you take a look at documentation on the OIF website (http://www.oiforum.com/ OIF_demos.html), you will see that experimentation with ASON routing started in 2003-2004, well before any IETF work on formats to support ASON routing.  My presentation referenced 2007 and 2009 OIF Demos as the most recent ones, not meaning to imply that they were the earliest.

-          OIF activities have been generally consistent with CCAMP work on ASON requirements and evaluation documented in RFC 4258 and 4652.  These RFCs were the product of joint design teams including some OIF participants

-          Where things diverge is with draft-ietf-ccamp-ason-routing-ospf, which did not have any input from outside of IETF and so was not a joint effort.  I believe that a number of the extensions defined in that draft are equivalent in functionality to what has been implemented for the OIF Demos, but different in format, hence the interest in seeing if there is any possibility of converging on extensions that have already been tested as a way to move from Experimental to Standards Track.  Unfortunately, it sounds like the possibility is nil…

-          Whether OIF will test the extensions in draft-ietf-ccamp-ason-routing-ospf-09.txt in the future depends on the input from its member companies.  

Hope this helps to clarify.

Cheers,

Lyndon

From: [email-masked] [mailto:[email-masked]] On Behalf Of BRUNGARD, DEBORAH A (ATTLABS)
Sent: Monday, November 23, 2009 11:33 AM
To: Ong, Lyndon; [email-masked]
Subject: Re: [CCAMP] IETF 76 - Draft CCAMP Minutes

Hi Lyndon,

Deborah

HI Dan,

Thanks,

Lyndon

Hello all, 

Br, Dan.

---

From: "BRUNGARD, DEBORAH A (ATTLABS)" <[email-masked]>
Date: Mon, 23 Nov 2009 17:34:09 -0500

Sure, we can correct to say 2006.

On your statement below “so was not a joint effort”. It was a “joint” effort of CCAMP and the OSPF WG which have ownership of the protocol extensions and IETF is an open community for development. This is why I said that it had WG document status when concern was raised on its experimental status. Unfortunately, when a parallel development is done on extensions outside of the owning group, even with cross-participants, it will most likely result in a diverging solution for the same functionality.  You may want to remind OIF on the (G)MPLS change process (RFC4929) in your next status update to them to determine their interest to align with the change process.

From: Ong, Lyndon [mailto:[email-masked]] 
Sent: Monday, November 23, 2009 4:01 PM
To: BRUNGARD, DEBORAH A (ATTLABS); [email-masked]
Subject: RE: [CCAMP] IETF 76 - Draft CCAMP Minutes

Hi Deborah,

Cheers,

Lyndon

Hi Lyndon,

Deborah

HI Dan,

Thanks,

Lyndon

Hello all, 

Br, Dan.

---

From: "Ong, Lyndon" <[email-masked]>
Date: Mon, 23 Nov 2009 19:14:34 -0500

Hi Deborah,

Thanks for the correction.  Also fair point that the solutions draft was a joint effort within IETF, just not going outside of IETF.  I suspect it was a complicated effort to negotiate the waters just within IETF between multiple WGs.

One last note, I would not call the OIF work parallel development exactly in that it took place earlier than the IETF work rather than at the same time.  It’s unfortunate that the current IETF work cannot take advantage of previous testing that was done along the same lines.  

Also sorry that we were not able to have a discussion on the actual drafts, especially the second draft on new routing functionality for layer-scoped attributes and local connection type.  Hopefully we can discuss more on the list.

Cheers,

Lyndon

From: [email-masked] [mailto:[email-masked]] On Behalf Of BRUNGARD, DEBORAH A (ATTLABS)
Sent: Monday, November 23, 2009 2:34 PM
To: Ong, Lyndon; [email-masked]
Subject: Re: [CCAMP] IETF 76 - Draft CCAMP Minutes

 

Hi Deborah,

Cheers,

Lyndon

Hi Lyndon,

Deborah

HI Dan,

Thanks,

Lyndon

Hello all, 

Br, Dan.