Subject: [CCAMP] Clarification reqd: RFC 4802/03 XCIndex for Bidirectional LSP

From: Srivatsan Raghavan <[email-masked]>
Date: Wed, 2 Jun 2010 10:25:10 +0530

Hi  all

I require a clarification on the examples in RFC 4802 and 4803
with respective to Bidirectional LSPs.

RFC 4803 shows an example where the two cross connect entries
are created, containing references to insegment and outsegment
in each direction respectively.
Since this is actually one Bidirectional LSP , each of the Cross
Connect Entries contain pointers to the same mplsXCLspId as illustrated in the
example

However, if we assume the LspID as equivalent to the Tunnel Instance
in the tunnel Table Mib, each row in the tunnel table contains a
single mplsTunnelXCPointer  which could reference one of the two
cross connect entries mentioned above.
So how is the other XC index referenced from the Tunnel Table entry ?

In order to achieve this, if we were to create a separate Tunnel Table
row with a new Tunnel Instance field containing a separate XC pointer,
then this degenerates to the  case of two unidirectional LSPs in opposite direction
defeating the purpose of the gmplsTunnelDirection field in the Tunnel Table.

Could the authors or anyone in the mailing list throw light on this tunnel table
-> XCIndex Linkage for bidirectional LSPs ?

Thanks
Srivatsan

"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 2 Jun 2010 16:04:20 +0100

Hi,

I owe you a response on this but am currently very tied up in meetings.

Please ping me if you have not heard back in two weeks.

Adrian
----- Original Message ----- 
From: "Srivatsan Raghavan" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, June 02, 2010 5:55 AM
Subject: [CCAMP] Clarification reqd: RFC 4802/03 XCIndex for 
BidirectionalLSP

> "DISCLAIMER: This message is proprietary to Aricent and is intended solely 
> for the use of the individual to whom it is addressed. It may contain 
> privileged or confidential information and should not be circulated or 
> used for any purpose other than for what it is intended. If you have 
> received this message in error, please notify the originator immediately. 
> If you are not the intended recipient, you are notified that you are 
> strictly prohibited from using, copying, altering, or disclosing the 
> contents of this message. Aricent accepts no responsibility for loss or 
> damage arising from the use of the information transmitted by this email 
> including damage from virus."
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>