Subject: [CCAMP] Input for Terminology discussion: UNI definitions across different SDOs

From: Oscar González de Dios <[email-masked]>
Date: Thu, 07 Nov 2013 19:25:33 +0000

Hi all,

As inputs for the terminology discussions, please find bellow a set of definitions for UNI coming from different SDOs (with a short reference, they are easy to find with the number):

[G.807] (ITU-T): "User-Network Interface for the control plane (UNI): A bidirectional signaling interface between service requester and service provider control plane entities."

In the same document: "UNI: This interface supports, as a minimum, the following information elements:
? End-point name and address;
? Authentication and connection admission control;
? Connection service messages.”

[G.8081] (ITU-T): "user-network interface for the control plane (UNI): An UNI is a bidirectional signaling interface between service requester and service provider control plane entities.”

[G.8080] (ITU-T): “UNI
Information flows expected across the UNI reference point support the following functions:
- call control
- resource discovery
- connection control
- connection selection.
Note, there is no routing function associated with the UNI reference point. Additional functions such as security and authentication of calls, or enhanced directory services,
may be added to this basic set of functions."

[RFC3717]: “The client-optical internetwork interface (UNI) represents a service boundary between the client (e.g., IP router) and the optical network.  The client and server (optical network) are essentially two different roles: the client role requests a service connection from a server; the server role establishes the connection to fulfill the service request — provided all relevant admission control conditions are satisfied.”

   [OIF UNI1.0]: UNI: “The service control interface between a client device and the transport network.”
 UNI-C: ”The logical entity that terminates UNI signalling on the client device side.”
UNI-N: “The logical entity that terminates UNI signalling on the transport network side.”

       [MEF 11]: “The MEF UNI is a reference point for all interactions between Subscribers of MEF defined services and the MEN Service Provider.”

Hope it helps in the discussions,

Best Regards,

Oscar

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Thu, 7 Nov 2013 21:33:35 +0000

Thank you, Oscar. It indeed helps me to understand the UNI better.

Previously I thought the UNI defintion would include allowing for reachability information across this interface. Clearly, it DOES NOT from the text you provide below.

So, i double-checked RFC4208, it turns out that this "reachability information" is mentioned when talking about overlay model:

" In the overlay model, the core-nodes act more as a closed system. The edge-nodes do not participate
  in the routing protocol instance that runs among the core nodes; in particular, the edge-nodes are unaware

of the topology of the core-nodes.  There may, however, be a routing protocol interaction between
   a core-node and an edge-node for the exchange of reachability information to other edge-nodes."

Hope this helps a bit on clarification and ongoing discussion.

Regards,

Xian

发件人: [email-masked] [[email-masked]] 代表 Oscar González de Dios [[email-masked]]
发送时间: 2013年11月8日 3:25
收件人: CCAMP
主题: [CCAMP] Input for Terminology discussion: UNI definitions across different SDOs

Hi all,

[G.8080] (ITU-T): “UNI

[RFC3717]: “The client-optical internetwork interface (UNI) represents a service boundary between the client (e.g., IP router) and the optical network.  The client and server (optical network) are essentially two different roles: the client role requests a service connection from a server; the server role establishes the connection to fulfill the service request ― provided all relevant admission control conditions are satisfied.”

Best Regards,

Oscar

---

From: Dieter Beller <[email-masked]>
Date: Fri, 08 Nov 2013 00:14:05 +0100

Hi all,

ITU-T
Recommendation G.8080 is probably the most appropriate
reference as far as the existing UNI definitions are concerned
from a CCAMP perspective. The OIF UNI/E-NNI work was based on the
architecture and definition of the

UNI/E-NNI reference points in G.8080.

Please note that there is no UNI protocol defined to convey reachability
information - the assumption was that this

information needs to be configured on the CE device (UNI-C side).
A protocol for conveying this information is

certainly something that can be considered as a future add-on.
Policy rules are required on the network side of the

UNI as to what reachbility information should be provided to a
specific CE device (-->VPNs).

Thanks,

Dieter

On 07.11.2013 22:33, Zhangxian (Xian)
wrote:

Thank you, Oscar. It indeed helps me to understand the UNI
better.

Previously I thought the UNI defintion would include allowing
for reachability information across this interface. Clearly,
it DOES NOT from the text you provide below.

So, i double-checked RFC4208, it turns out that this
"reachability information" is mentioned when talking about
overlay model:

" In the overlay model, the core-nodes act more as a closed
system. The edge-nodes do not participate

in the routing protocol instance that runs among the core
nodes; in particular, the edge-nodes are unaware

of the topology of the core-nodes.  There may, however, be a
routing protocol interaction between

a core-node and an edge-node for the exchange of
reachability information to other edge-nodes."

Hope this helps a bit on clarification and ongoing
discussion.

Regards,

Xian

发件人:
[email-masked] [[email-masked]] 代表 Oscar
González de Dios [[email-masked]]

发送时间: 2013年11月8日 3:25

收件人: CCAMP

主题: [CCAMP] Input for Terminology discussion: UNI
definitions across different SDOs

Hi all,

As
inputs for the terminology discussions, please find bellow
a set of definitions for UNI coming from different SDOs
(with a short reference, they are easy to find with the
number):

[G.807] (ITU-T): "User-Network
Interface for the control plane (UNI): A bidirectional
signaling interface between service requester and service
provider control plane entities."

In the same document:
"UNI: This interface supports, as a minimum, the following
information elements:

?
End-point name and address;

?
Authentication and connection admission control;

?
Connection service messages.”

[G.8081] (ITU-T):
"user-network interface for the control plane (UNI): An
UNI is a bidirectional signaling interface between service
requester and service provider control plane entities.”

[G.8080] (ITU-T): “UNI

Information flows expected
across the UNI reference point support the following
functions:

- call control

- resource discovery

- connection control

- connection selection.

Note, there is no routing
function associated with the UNI reference point.
Additional functions such as security and authentication
of calls, or enhanced directory services,

[RFC3717]: “The
client-optical internetwork interface (UNI) represents a
service boundary between the client (e.g., IP router) and
the optical network.  The client and server (optical
network) are essentially two different roles: the client
role requests a service connection from a server; the
server role establishes the connection to fulfill the
service request — provided all relevant admission control
conditions are satisfied.”

[OIF UNI1.0]: UNI:
“The service control interface between a client device
and the transport network.”

UNI-C: ”The logical
entity that terminates UNI signalling on the client
device side.”

UNI-N:
“The logical entity that terminates UNI signalling on
the transport network side.”

[MEF 11]: “The
MEF UNI is a reference point for all interactions
between Subscribers of MEF defined services and the
MEN Service Provider.”

Hope
it helps in the discussions,

Best
Regards,

Oscar

Este mensaje se dirige exclusivamente a su destinatario.
Puede consultar nuestra política de envío y recepción de
correo electrónico en el enlace situado más abajo.

This message is intended exclusively for its addressee. We
only send and receive email on the basis of the terms set
out at:

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Dieter Beller <[email-masked]>
Date: Fri, 08 Nov 2013 00:19:33 +0100

Hi all,

ITU-T

Recommendation G.8080 is probably the most appropriate
reference as far as the existing UNI definitions are

concerned from a CCAMP perspective. The OIF UNI/E-NNI work was
based on the architecture and definition of the

Thanks,

Dieter

Regards,

Xian

发件人: [email-masked]
[[email-masked]]
代表 Oscar González de Dios [[email-masked]]

发送时间: 2013年11月8日 3:25

收件人: CCAMP

Hi all,

As inputs for the
terminology discussions, please find bellow a set of
definitions for UNI coming from different SDOs (with a
short reference, they are easy to find with the number):

In the same document:

? End-point name and
address;

? Authentication and
connection admission control;

? Connection service
messages.”

[G.8081] (ITU-T):

[G.8080] (ITU-T): “UNI

- call control

- resource discovery

- connection control

- connection selection.

[RFC3717]: “The

[OIF UNI1.0]: UNI:

UNI-C: ”The logical

UNI-N:

[MEF 11]: “The

Hope

Best

Regards,

Oscar

---

From: Lou Berger <[email-masked]>
Date: Thu, 07 Nov 2013 16:13:45 -0800

While referencing ITU-T documents and terminology is certainly something we 
often do in CCAMP, I think the foundation of the WG's activity is first 
within the IETF and RFCs.

Lou

On November 7, 2013 3:19:33 PM Dieter Beller 
<[email-masked]> wrote:
> P {
> MARGIN-TOP: 0px; MARGIN-BOTTOM: 0px
> }
>
> Hi all,
>
> ITU-T
>

---

From: Gert Grammel <[email-masked]>
Date: Fri, 8 Nov 2013 02:28:49 +0000

Adding the detail I mentioned on the mic:

[G.8080](ITU-T) "NOTE - The route query interface does not apply for the CC interface at the UNI reference point."

From: [email-masked] [mailto:[email-masked]] On Behalf Of Oscar González de Dios
Sent: 07 November 2013 20:26
To: CCAMP
Subject: [CCAMP] Input for Terminology discussion: UNI definitions across different SDOs

Hi all,

In the same document: "UNI: This interface supports, as a minimum, the following information elements:
?
End-point name and address;
?
Authentication and connection admission control;
?
Connection service messages."

[G.8081] (ITU-T): "user-network interface for the control plane (UNI): An UNI is a bidirectional signaling interface between service requester and service provider control plane entities."

[G.8080] (ITU-T): "UNI

[RFC3717]: "The client-optical internetwork interface (UNI) represents a service boundary between the client (e.g., IP router) and the optical network.  The client and server (optical network) are essentially two different roles: the client role requests a service connection from a server; the server role establishes the connection to fulfill the service request - provided all relevant admission control conditions are satisfied."

   [OIF UNI1.0]: UNI: "The service control interface between a client device and the transport network."
 UNI-C: "The logical entity that terminates UNI signalling on the client device side."
UNI-N: "The logical entity that terminates UNI signalling on the transport network side."

       [MEF 11]: "The MEF UNI is a reference point for all interactions between Subscribers of MEF defined services and the MEN Service Provider."

Best Regards,

Oscar