Subject: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

From: Lou Berger <[email-masked]>
Date: Thu, 07 Nov 2013 18:17:49 -0800

Zafar,
	My comment in today's session was that you are redefining the format of
an existing object (by adding TLVs) this breaks compatibility.  You
stated that this wasn't the case.

FWIW:

Your document says:

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |            Length             | Class-Num(37) |   C-Type(2)   |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |S|P|N|O| Reserved  | LSP Flags |      Reserved     | Link Flags|
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |I|R|   Reserved    | Seg.Flags |           Reserved            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                                                               |
   ~                           sub-TLVs                            ~
   |                                                               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

RFC4872 says
      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |            Length             | Class-Num(37) | C-Type (2)    |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |S|P|N|O| Reserved  | LSP Flags |     Reserved      | Link Flags|
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |                           Reserved                            |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Perhaps you meant C-Type(TBD).  You should address compatibility
explicitly in any case.

Lou

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Fri, 8 Nov 2013 21:11:04 +0000

Hi Lou- 

You are right, the ctype is TBD, like I mentioned during the meeting that
we are using different ctype.

We would like to take this opportunity to solicit comments from the WG on
this draft. 

Thanks

Regards Š Zafar

---

From: Lou Berger <[email-masked]>
Date: Fri, 08 Nov 2013 16:19:30 -0500

Zafar,
	Your document says 2, i.e., is incompatible with existing implementations.

Lou

---

From: Dieter Beller <[email-masked]>
Date: Sun, 10 Nov 2013 15:07:33 +0100

Hi Zafar,

this draft is defining signaling extensions for the hold-off time
as well as the wait-to-restore time for protected LSPs

where applicable.

There are default values set for these timers in the data plane
and signaling them in the control plane makes only

sense if the timer values shall differ from the default values. Do
you see a need for that? IMO, operators typically

use the defaults and do not set these values on a per connection
basis.

Thanks,

Dieter

On 08.11.2013 22:11, Zafar Ali (zali)
wrote:

Hi Lou-

Thanks

Regards Š Zafar

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Thursday, November 7, 2013 6:17 PM
To: zali <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Comment on compatibility in draft-takacs-ccamp-revertive-ps

Zafar,

FWIW:

Your document says:

0 1 2 3

RFC4872 says
0 1 2 3

Lou

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

--

DIETER
BELLER

ALCATEL-LUCENT
DEUTSCHLAND AG

PROJECT MANAGER ASON/GMPLS CONTROL PLANE

IP ROUTING AND TRANSPORT BL

IP TRANSPORT BU

Lorenzstrasse 10

70435 Stuttgart, Germany

Phone: +49 711 821 43125

Mobil: +49 175 7266874

[email-masked]

Alcatel-Lucent
Deutschland AG

Domicile of the Company: Stuttgart · Local Court Stuttgart HRB
4026

Chairman of the Supervisory Board: Michael Oppenhoff

Board of Management: Wilhelm Dresselhaus (Chairman) · Hans-Jörg
Daub · Andreas Gehe

This e-mail and its attachments, if any, may contain
confidential information.

If you have received this e-mail in error, please notify us and
delete or destroy the e-mail and its attachments, if any,
immediately.

If you have received this e-mail in error, you must not forward
or make use of the e-mail and its attachments, if any.

---

From: Fatai Zhang <[email-masked]>
Date: Tue, 12 Nov 2013 02:04:25 +0000

Hi,

Moreover, this information is only make sense for the end points and no need to be signaled.

Best Regards

Fatai

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: Sunday, November 10, 2013 10:08 PM
To: Zafar Ali (zali)
Cc: CCAMP
Subject: Re: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi Zafar,

this draft is defining signaling extensions for the hold-off time as well as the wait-to-restore time for protected LSPs
where applicable.

There are default values set for these timers in the data plane and signaling them in the control plane makes only
sense if the timer values shall differ from the default values. Do you see a need for that? IMO, operators typically
use the defaults and do not set these values on a per connection basis.

Thanks,
Dieter

On 08.11.2013 22:11, Zafar Ali (zali) wrote:

Hi Lou-

this draft.

Thanks

Regards Š Zafar

-----Original Message-----

From: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>

To: zali <[email-masked]><mailto:[email-masked]>, "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>

Zafar,

FWIW:

Your document says:

   0                   1                   2                   3

  |                                                               |

  ~                           sub-TLVs                            ~

  |                                                               |

RFC4872 says

     0                   1                   2                   3

    |                           Reserved                            |

explicitly in any case.

Lou

CCAMP mailing list

[email-masked]<mailto:[email-masked]>

--
DIETER BELLER
ALCATEL-LUCENT DEUTSCHLAND AG
PROJECT MANAGER ASON/GMPLS CONTROL PLANE
IP ROUTING AND TRANSPORT BL
IP TRANSPORT BU

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874
[email-masked]<mailto:[email-masked]>

Alcatel-Lucent Deutschland AG
Domicile of the Company: Stuttgart * Local Court Stuttgart HRB 4026
Chairman of the Supervisory Board: Michael Oppenhoff
Board of Management: Wilhelm Dresselhaus (Chairman) * Hans-Jörg Daub * Andreas Gehe

This e-mail and its attachments, if any, may contain confidential information.
If you have received this e-mail in error, please notify us and delete or destroy the e-mail and its attachments, if any, immediately.
If you have received this e-mail in error, you must not forward or make use of the e-mail and its attachments, if any.

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Tue, 12 Nov 2013 19:01:55 +0000

Hi Dieter:

The default parameter value in data plan is deficient for the following reasons:

  1.  We cannot differentiate between revertive and non-revertive behavior using default value of wait-to-restore timer. E.g., as far as I remember default value for WRT is 0, which means protection is non-revertive. So this default does not work for revertive protection. I.e., the data plan default cannot cover both revertive and non-revertive cases.
  2.  Correct setting for wait-to-restore and hold-off timers need to account for differential delays between working and protection paths.

In summary, default values cannot cover all use cases. Hence, SP typically wants to set revertive vs. non-revertive behavior, wait-to-restore and hold-off timers on per connection basis.

Thanks

Regards … Zafar

From: Dieter Beller <[email-masked]<mailto:[email-masked]>>
Organization: Alcatel-Lucent
Date: Sunday, November 10, 2013 9:07 AM
To: zali <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi Zafar,

Thanks,
Dieter

Hi Lou-

Thanks

Regards Š Zafar

-----Original Message-----
From: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Date: Thursday, November 7, 2013 6:17 PM
To: zali <[email-masked]><mailto:[email-masked]>, "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: Comment on compatibility in draft-takacs-ccamp-revertive-ps

Zafar,

FWIW:

Your document says:

   0                   1                   2                   3

RFC4872 says
     0                   1                   2                   3

Lou

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/ccamp

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

Alcatel-Lucent Deutschland AG
Domicile of the Company: Stuttgart · Local Court Stuttgart HRB 4026
Chairman of the Supervisory Board: Michael Oppenhoff
Board of Management: Wilhelm Dresselhaus (Chairman) · Hans-Jörg Daub · Andreas Gehe

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Tue, 12 Nov 2013 19:06:58 +0000

From: Fatai Zhang <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 11, 2013 9:04 PM
To: Dieter Beller <[email-masked]<mailto:[email-masked]>>, zali <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi,

Fatai-

Are you saying that we NEVER signal any attribute that only matter to the end-point? This is a news to me.

Thanks

Regards … Zafar

Best Regards

Fatai

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: Sunday, November 10, 2013 10:08 PM
To: Zafar Ali (zali)
Cc: CCAMP
Subject: Re: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi Zafar,

Thanks,
Dieter

Hi Lou-

this draft.

Thanks

Regards Š Zafar

-----Original Message-----

Zafar,

FWIW:

Your document says:

   0                   1                   2                   3

  |                                                               |

  ~                           sub-TLVs                            ~

  |                                                               |

RFC4872 says

     0                   1                   2                   3

    |                           Reserved                            |

explicitly in any case.

Lou

CCAMP mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 13 Nov 2013 02:02:50 +0000

Hi Zafar,

I will NEVER say NERVER.

I think you need justify why it needs to signal the attributes, which only matter to the end-points.

Best Regards

Fatai

From: Zafar Ali (zali) [mailto:[email-masked]]
Sent: Wednesday, November 13, 2013 3:07 AM
To: Fatai Zhang; Dieter Beller
Cc: CCAMP
Subject: Re: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi,

Fatai-

Thanks

Regards … Zafar

Best Regards

Fatai

Hi Zafar,

Thanks,
Dieter

Hi Lou-

this draft.

Thanks

Regards Š Zafar

-----Original Message-----

Zafar,

FWIW:

Your document says:

   0                   1                   2                   3

  |                                                               |

  ~                           sub-TLVs                            ~

  |                                                               |

RFC4872 says

     0                   1                   2                   3

    |                           Reserved                            |

explicitly in any case.

Lou

CCAMP mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 13 Nov 2013 06:25:38 +0000

From: Fatai Zhang <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, November 12, 2013 9:02 PM
To: zali <[email-masked]<mailto:[email-masked]>>, Dieter Beller <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi Zafar,

I will NEVER say NERVER.

Fatai-

Ingress needs to let egress node know on how it is using protection (e.g., if protection is revertive or non-revertive, etc.). See also my email in response to Deiter question.

Thanks

Regards … Zafar

Best Regards

Fatai

Hi,

Fatai-

Thanks

Regards … Zafar

Best Regards

Fatai

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: Sunday, November 10, 2013 10:08 PM
To: Zafar Ali (zali)
Cc: CCAMP
Subject: Re: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi Zafar,

Thanks,
Dieter

Hi Lou-

this draft.

Thanks

Regards Š Zafar

-----Original Message-----

Zafar,

FWIW:

Your document says:

   0                   1                   2                   3

  |                                                               |

  ~                           sub-TLVs                            ~

  |                                                               |

RFC4872 says

     0                   1                   2                   3

    |                           Reserved                            |

explicitly in any case.

Lou

CCAMP mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 13 Nov 2013 06:52:41 +0000

Date: Wednesday, November 13, 2013 1:43 AM

The operator can just click a button to configure it, otherwise how the ingress knows what to tell the egress.

This will require operator to apply configurations on both ingress and egress. Applying a matching configuration for a connection that does not exists at egress is not feasible. If we go with your logic, we don't need similar extensions that are already RFCs, e.g., http://tools.ietf.org/html/rfc6107.

Thanks

Regards…Zafar

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 13 Nov 2013 06:43:54 +0000

Hi Zafar,

I don’t think it is smart to send signaling to do this.

BTW,  there were much discussion on what should be configured and what should be signalled in SG15 ITU-T.

Best Regards

Fatai

From: Zafar Ali (zali) [mailto:[email-masked]]
Sent: Wednesday, November 13, 2013 2:26 PM
To: Fatai Zhang; Dieter Beller
Cc: CCAMP
Subject: Re: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi Zafar,

I will NEVER say NERVER.

Fatai-

Thanks

Regards … Zafar

Best Regards

Fatai

Hi,

Fatai-

Thanks

Regards … Zafar

Best Regards

Fatai

Hi Zafar,

Thanks,
Dieter

Hi Lou-

this draft.

Thanks

Regards Š Zafar

-----Original Message-----

Zafar,

FWIW:

Your document says:

   0                   1                   2                   3

  |                                                               |

  ~                           sub-TLVs                            ~

  |                                                               |

RFC4872 says

     0                   1                   2                   3

    |                           Reserved                            |

explicitly in any case.

Lou

CCAMP mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: Huub van Helvoort <[email-masked]>
Date: Wed, 13 Nov 2013 21:53:04 +0100

Hello Zafar,

You wrote:

>  1. We cannot differentiate between revertive and non-revertive behavior
>     using default value of wait-to-restore timer.

The value of the WTR timer should not determine the (non-)revertive
behavior. The (non-)revertive behaviour should be explicitly
provisioned.

>     E.g., as far
>     as I remember default value for WRT is 0, which means protection
>     is non-revertive.

The typical default value for WTR is 5 minutes to provide a
hysteresis, it can be overruled by a higher priority event
like Sf or SD.
Setting the value of WTR to 0 does not mean protection is
non-revertive.

>     So this default does not work for revertive
>     protection. I.e., the data plan default cannot cover both revertive
>     and non-revertive cases.

Again: the WTR value should not be used to indicate (non-)revertive
behavior.

>  2. Correct setting for wait-to-restore and hold-off timers need to
>     account for differential delays between working and protection paths.

No, WTR accounts for repair of the failed path and to encertain
that the repair can be trusted.
Hold-off timers are used to allow protection switching in layers
closer to the physical layer to complete before protection
switching in the affected layer.

> In summary, default values cannot cover all use cases. Hence, SP
> typically wants to set revertive vs. non-revertive behavior,
> wait-to-restore and hold-off timers on per connection basis.

They will provision default values per layer in the network.

Regards, Huub.

===========
> From: Dieter Beller <[email-masked]
> <mailto:[email-masked]>>
> To: zali <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked]
> <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>"
> <[email-masked] <mailto:[email-masked]>>
>     this draft is defining signaling extensions for the hold-off time as
>     well as the wait-to-restore time for protected LSPs
>     where applicable.
>
>     There are default values set for these timers in the data plane and
>     signaling them in the control plane makes only
>>     From:"[email-masked]"  <[email-masked]>
>>     To: zali<[email-masked]>,"[email-masked]"  <[email-masked]>
>>     [email-masked]://www.ietf.org/mailman/listinfo/ccamp
>

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: John E Drake <[email-masked]>
Date: Wed, 13 Nov 2013 21:02:07 +0000

Huub,

A nice note.  Dou you think this draft is gilding the lily?

Yours Irrespectively,

John

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Huub van Helvoort
> Sent: Wednesday, November 13, 2013 12:53 PM
> To: [email-masked]
>  > The default parameter value in data plan is deficient for the  > following
> reasons:
> >
> The value of the WTR timer should not determine the (non-)revertive behavior.
> The (non-)revertive behaviour should be explicitly provisioned.
> 
> >     E.g., as far
> The typical default value for WTR is 5 minutes to provide a hysteresis, it can be
> overruled by a higher priority event like Sf or SD.
> Setting the value of WTR to 0 does not mean protection is non-revertive.
> 
> Again: the WTR value should not be used to indicate (non-)revertive behavior.
> 
> No, WTR accounts for repair of the failed path and to encertain that the repair
> can be trusted.
> Hold-off timers are used to allow protection switching in layers closer to the
> physical layer to complete before protection switching in the affected layer.
>

---

From: Huub van Helvoort <[email-masked]>
Date: Wed, 13 Nov 2013 22:10:10 +0100

Hello John,

> A nice note.  Dou you think this draft is gilding the lily?

Yes, indeed.

Regards, Huub.

---

From: John E Drake <[email-masked]>
Date: Wed, 13 Nov 2013 21:19:05 +0000

It might be fun to enumerate all of the CCAMP drafts that fall into this category.

Yours Irrespectively,

John

> Sent: Wednesday, November 13, 2013 1:10 PM
> To: [email-masked]
> >> From: [email-masked] [mailto:[email-masked]] On
> >> Behalf Of Huub van Helvoort
> >> hysteresis, it can be overruled by a higher priority event like Sf or SD.
> >> No, WTR accounts for repair of the failed path and to encertain that
> >> the repair can be trusted.
> >> closer to the physical layer to complete before protection switching in the
> affected layer.
> >>
> >>>>      We would like to take this opportunity to solicit comments
> >>>> from the WG
> >> on
> >>>>      this draft.
> >>>>
> >>>>      Thanks
> >>>>
> >>>>      Regards Š Zafar
> >>>>
> >>>>>      	My comment in today's session was that you are redefining
> >>>>> the format
> >> of

---

From: Acee Lindem <[email-masked]>
Date: Wed, 13 Nov 2013 21:24:10 +0000

When all is said and done, more is said than done…
Acee 

On 11/13/13 1:19 PM, "John E Drake" <[email-masked]> wrote:

>> >>>>      You are right, the ctype is TBD, like I mentioned during the
>>meeting
>> that
>> >>>>>          0                   1                   2
>>   3
>> >>>>>         | 
>>      |
>> >>>>>         ~                           sub-TLVs
>>      ~
>> >>>>>         | 
>>      |
>> >>>>>            0                   1                   2
>>     3
>> >>>>>           |                           Reserved
>>        |

---

From: Francesco Fondelli <[email-masked]>
Date: Thu, 14 Nov 2013 09:31:28 +0100

Hi,

> They will provision default values per layer in the network.

Many years ago we had a request (for a gmpls-controlled sdh network)
to control hoff on a per connection basis. Some connections were
supporting a form of protection switching at upper layer. Other
connections (at the same layer) were supported by a form of protection
switching in the lower layer. They wanted different hold off timers
(default was 100ms if I am not wrong). They also pointed me to
"Hold-off times are useful for interworking of protection schemes. The
objective is that these times should be provisionable on an individual
VC basis" [G.841]. No idea what OTN or WDM recommendations say about
this point.

> A nice note.  Dou you think this draft is gilding the lily?

I do not know, it might. All I know is that during the past 5 years I
sporadically receive the request described above. I typically reply
with a link to this draft.

thanks
ciao
fra

On Wed, Nov 13, 2013 at 10:10 PM, Huub van Helvoort
<[email-masked]> wrote:
>>>> as
>>>>> meeting that
>>>>>      We would like to take this opportunity to solicit comments from
>>>>> the WG
>>>
>>> on
>>>>>
>>>>>      this draft.
>>>>>
>>>>>      Thanks
>>>>>
>>>>>      Regards Š Zafar
>>>>>
>>>>>>         My comment in today's session was that you are redefining the
>>>>>> format
>>>
>>> of
>>>>>>

---

From: Rajan Rao <[email-masked]>
Date: Thu, 14 Nov 2013 19:40:22 +0000

Zafar & draft authors

Perhaps it will be useful if you clarify which of the following cases you are looking at. May be all, but it is not clear in your doc.

1.      Linear protection no APS:  SNC/I, SNC/S, SNC/N

2.      Linear protection with APS:  SNC/I, SNC/S, SNC/N

a.      Uni-dir switching & reversions

b.      Bi-dir switching & reversions

3.      Revertive and non-revertive restorations

The linear protection schemes allow independent configuration of revertive, non-revertive, WTR, etc at head & tail ends.   From the draft and this chain it appears that you are trying to cover case (1) only.   May be you should clarify which case(s) will benefit from the proposed extn’s & how.

Thx
Rajan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Tuesday, November 12, 2013 10:44 PM
To: Zafar Ali (zali); Dieter Beller
Cc: CCAMP
Subject: Re: [CCAMP] Comment on compatibility in draft-takacs-ccamp-revertive-ps

Hi Zafar,

Best Regards

Fatai

Hi Zafar,

I will NEVER say NERVER.

Fatai-

Thanks

Regards … Zafar

Best Regards

Fatai

Hi,

Fatai-

Thanks

Regards … Zafar

Best Regards

Fatai

Hi Zafar,

Thanks,
Dieter

Hi Lou-

this draft.

Thanks

Regards Š Zafar

-----Original Message-----

Zafar,

FWIW:

Your document says:

   0                   1                   2                   3

  |                                                               |

  ~                           sub-TLVs                            ~

  |                                                               |

RFC4872 says

     0                   1                   2                   3

    |                           Reserved                            |

explicitly in any case.

Lou

CCAMP mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874