Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

From: "Zhangxian (Xian)" <[email-masked]>
Date: Mon, 2 Mar 2015 06:35:11 +0000

Hi, Rajan, all,

      “Min & Max slot” you mentioned below is a bit mis-leading. I think you wanted to say “Min & Max LSP bandwidth”. Let talk them one by one since we are not aligned yet on both.

      Why do we need to advertise Min LSP bandwidth per priority in ISCD, e.g., a request cannot set up a LSP smaller than X GHz and it varies per priority? If you  meant to say the interface limitation, it is covered in Section 4.3 already.

      As for the Max LSP bandwidth information, I agree with you that RFC4204 has this requirement. This draft (draft-ietf-ccamp-flexible-grid-ospf-ext-01) needs to be updated to reflect this. I can think of two options:

Option A: use the existing fields (MAX LSP Bandwidth at priority x, x=0-7)  in the ISCD (defined in Section 1.4. of RFC4203). The point that we need to update is the unit to be usable in the context of Flexi-grid. It will be Hz not byte per second.

Option B: We add the max LSP bandwidth field (16 bit) in the Available Labels Field by using the Reserved field.

    Which option does the WG prefer?

Regards,
Xian

From: Rajan Rao [mailto:[email-masked]]
Sent: 2015年2月28日 2:51
To: Zhangxian (Xian); CCAMP ([email-masked]); 'Ramon Casellas'
Cc: Khuzema Pithewan; Iftekhar Hussain; Biao Lu
Subject: RE: [CCAMP] I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Xian, all

Section 4.3 is trying to use port label restrictions sub-TLV with a new restriction type.  This is fine.  But how does a path computing node determine if it can use the link to setup an LSP with N-slots @ priority ‘p’?   For e.g  I don’t want to allow priority 7 LSPs to use bandwidth greater than 20 slots on the link but allow for LSPs with priority 0, 1 & 2.  Where is this info in the TLV?

We had given examples when we presented our draft in Taipei IETF-82.  Ref slides 8 & 10 (link below).  We had coverage for advertisement of  Min & Max slot widths per priority. This is meant to align with RFC 4202.  I believe WG doc lacks this and needs to address.
http://www.ietf.org/proceedings/82/slides/ccamp-18.pdf

thx
Rajan
From: Zhangxian (Xian) [mailto:[email-masked]]
Sent: Thursday, February 26, 2015 5:33 PM
To: Rajan Rao; CCAMP ([email-masked]); 'Ramon Casellas'
Cc: Khuzema Pithewan; Iftekhar Hussain; Biao Lu
Subject: RE: [CCAMP] I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Hi, Rajan and all,

Thank you for your clarification and I now fully understand your question. I think you have misunderstood Section 4.3. of this draft. It was not to describe dynamic Max & Min LSP bandwidth but rather the capability/constraint associated with an port, which rarely change over time.

Isn’t information per priority already supported? Quoting text from the drafts referred:

“The technology specific part of the WSON ISCD may include a variable
   number of sub-TLVs called Bandwidth sub-TLVs.”

As for the Mix and Max LSP bandwidth, could you give me an example of what you said below, i.e.,“Availability of  ‘N’ consecutive labels doesn’t mean you can setup an LSP with a size of ‘N’”?

    What does the WG think of the issue under discussion?

Regards,
Xian

From: Rajan Rao [mailto:[email-masked]]
Sent: 2015年2月27日 4:03
To: Zhangxian (Xian); CCAMP ([email-masked]<mailto:[email-masked]>); 'Ramon Casellas'
Cc: Khuzema Pithewan; Iftekhar Hussain; Biao Lu
Subject: RE: [CCAMP] I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Xian,

I understand this doc is trying to reuse GEN-ENCODE & there is support for priority.  I am not referring to this one.  The Min Width & Max  Width fields do exist in the draft but these alone are not sufficient. We need info per priority for the following reason.

The intent of Min & Max width info is to specify what is the Minimum/Maximum LSP bandwidth an LSP could reserve at a given priority ‘p’ on the link.  You can draw parallel to ‘Minimum LSP Bandwidth’ & ‘Maximum LSP Bandwidth’ fields in RFC 4202.

I don’t understand how you can derive this from label set field.   Availability of  ‘N’ consecutive labels doesn’t mean you can setup an LSP with a size of ‘N’.

Thx
Rajan

From: Zhangxian (Xian) [mailto:[email-masked]]
Sent: Wednesday, February 25, 2015 5:37 PM
To: Rajan Rao; CCAMP ([email-masked]<mailto:[email-masked]>); 'Ramon Casellas'
Subject: RE: [CCAMP] I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Hi, Rajan,

    As I was not involved earlier, I find the following may be  a bit long for others in the WG to get involved.  Before I dive into the discussion and share my thoughts, am I accurate if I recap the question as:

   You think the existing text in draft-ietf-ccamp-flexible-grid-ospf-ext-01 do not support the following:

1)      Do not support priority;

2)      Do not convey the min & max LSP bandwidth information in the SCSI field;

Could you confirm my interpretation of your issue?

The following is my thoughts ( subject to change if the question I recapped above is not as exact as what you want to say):

The  current method is to reuse what has already been proposed for WSON. So it reuses the SCSI field defined in WSON-OSPF draft (https://tools.ietf.org/html/draft-ietf-ccamp-wson-signal-compatibility-ospf-15#section-3.1). So, it DOES support priority (see the details are in [GEN-ENCODE] draft-ietf-ccamp-general-constraint-encode-20). Exactly because of the same reason, the draft under discussion uses label set field to describe what frequency slots are available. So, although it allows for all different varieties supported by [GEN-ENCODE] (i.e., list, bitmap, inclusive, exclusive etc.), the method does not see the need of specify the max&min LSP bandwidth since it can be naturally deduced from the available frequency spectrum information conveyed.

The above discussion actually reminds me of a question Ramon raised up a while ago among the authors of this draft, what has been defined in WSON-OSPF is truly usable labels in signaling. But with Flexi-grid, it is not true anymore. For example, although we use Inclusive Label Range to describe available frequency range, say the example in Section 4.4 of  draft-ietf-ccamp-flexible-grid-ospf-ext-01 (assume m=1), none of these labels are directly usable if what is actually requested is a bandwidth with m=2.  I myself do not see any issue as long as we make it clear we use the format just to describe what resource available NOT usable labels. Since it is a WG draft, it is worthwhile to solicit what you think?

Cheers,
Xian

From: Rajan Rao [mailto:[email-masked]]
Sent: 2015年2月26日 7:17
To: Daniele Ceccarelli; Zhenghaomian; Fatai Zhang; CCAMP ([email-masked]<mailto:[email-masked]>)
Cc: Khuzema Pithewan; Iftekhar Hussain; Zhangxian (Xian); Ramon Casellas; Oscar Gonzalez de Dios
Subject: RE: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Daniele,

Sure.  Added WG in the list for comments.

Thx
Rajan

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Wednesday, February 25, 2015 12:45 PM
To: Rajan Rao; Zhenghaomian; Fatai Zhang
Cc: Khuzema Pithewan; Iftekhar Hussain; Zhangxian (Xian); Ramon Casellas; Oscar Gonzalez de Dios
Subject: RE: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Hi all,

This is a really interesting discussion and since we’re speaking about a working group draft I think we should continue con the mailing list.
Please include the WG in your reply.

BR
Daniele

From: Rajan Rao [mailto:[email-masked]]
Sent: mercoledì 25 febbraio 2015 19:56
To: Zhenghaomian; Fatai Zhang
Cc: Khuzema Pithewan; Iftekhar Hussain; Zhangxian (Xian); Daniele Ceccarelli; Ramon Casellas; Oscar Gonzalez de Dios
Subject: RE: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Haomian,

The priority in each layer is independent.  The intent of explicitly carrying priority info in the advertisement is to allow for LSP creation at different priorities.  Note that priority defined in OTN RFC don’t apply here as it is a different layer.   You can have L0-LSP setup at priority-1 but L1-Telink (OTN link) formed out of this may advertise all 8 or subset of them.  It is an implementation choice.  I don’t see any conflicts here.

Once we agree on the following items we can figure out TLV encoding options.

1.      Allow for Advertisement of Min & Max slot widths at different priorities – up to 8

2.      Min/Max slot width field – 16 bit instead of 8  (I see you are agreeing to this change below)

3.      Max LSP Bandwidth – this was debated in previous meetings but no firm conclusion.

Thx
Rajan

From: Zhenghaomian [mailto:[email-masked]]
Sent: Tuesday, February 24, 2015 11:35 PM
To: Rajan Rao; Fatai Zhang
Cc: Khuzema Pithewan; Iftekhar Hussain; Zhangxian (Xian); Daniele Ceccarelli; Ramon Casellas; Oscar Gonzalez de Dios
Subject: 答复: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Hi, Rajan,

Thanks for the information, I noticed there is a change talking about extending Flexi-grid data plan to satisfy requirements in RFC4202. I forward this email to all the authors of OSPF draft to advertise your comments:)

Firstly let’s recall the sub-TLV format in draft-dhillon-ccamp-flexgrid-ospfte-ext as follow:

  0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |             Type=1            |              Length           |
   +---------------------------------------------------------------+
   |Slice Spacing | Pri |                    Reserved              |
   +---------------------------------------------------------------+
   |               N-Start         |          Num of Slices        |
   +---------------------------------------------------------------+
   |         Min Slot Width        |       Max Slot Width          |
   +---------------------------------------------------------------+
   |                                                               |
   |                   Bit-Map showing Available Slices           |
   |                     (up to 48 bytes)                          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Then I share my understanding on your concern. Compared with sub-TLV in section 4.3 of draft-ietf-ccamp-flexible-grid-ospf-ext-01, I highlight the difference as follow:

In your proposal,

1)      Slice Spacing is preferred to be carried in the  sub-TLV;

2)      Priority bits are preferred to be included in sub-TLV;

3)      Min/Max Widths should both be 16-bit;

4)      N-start and Num of Slices to represent the spectrum rather than C.F.G and S.W.G;

Below please find my comments:
Firstly I believe both of your structure and the current structure in WG draft are satisfying the requirement of flexi-grid FWK draft (the info model in Fig. 17). We only need to deal with some differences in representation format, and some additional information may be useful.

1)      Different slice spacing is applicable but may not be necessary; the spirit to introduce flexible grid is to allow flexibility in spectrum allocation and current WG draft can satisfy the requirement. Not much further advantage for using slice spacing;

2)      Priority bits: I agree that it is widely used, I am basically fine to include priority bits in the sub-TLV. My only concern is, there are also such priority information in other place (for example OTN BW sub-TLV in Section 4.1.3 in RFC7138), do we need to repeat here? What is the relationship if we have two priorities? Is it possible the OTN priority is not consistent with flexi-grid priority? Why? And How to deal with this?

3)      Agreed, will change both the min/max widths to 16-bit in the next version;

4)      Personally I don’t think it’s necessary to change the current WG draft: I think your proposed representation can have equivalent result as the one in current WG draft;

Rajan, please correct me if there is misunderstanding, also let me know if you have other comments.

All, please feel free to comments, or we move to the list if necessary:)

Best wishes,
Haomian

发件人: Rajan Rao [mailto:[email-masked]]
发送时间: 2015年2月24日 4:03
收件人: Zhenghaomian; Fatai Zhang
抄送: Khuzema Pithewan; Iftekhar Hussain
主题: RE: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Haomian,

The Flexgrid FWK doc has been updated with reference to RFC4202.   This should address the comment you had in the earlier email.  Pl refer to updated doc (attached email from Ramon).  Pl let us know how you would like to proceed.

FWK doc Snip below:

5.1.2.  Routing

   The routing protocol will support all functions as described in
   [RFC4202] and extend them to a flexi-grid data plane.

Thx
Rajan

From: Rajan Rao
Sent: Tuesday, February 03, 2015 2:28 PM
To: Zhenghaomian; Fatai Zhang
Cc: Khuzema Pithewan; Iftekhar Hussain
Subject: RE: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Haomian,

Thx for the reply. Pl see below.

-----Original Message-----
From: Zhenghaomian [mailto:[email-masked]]
Sent: Monday, February 02, 2015 11:22 PM
To: Rajan Rao; Fatai Zhang
Cc: Khuzema Pithewan; Iftekhar Hussain
Subject: 答复: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Hi, Rajan,

Firstly sorry for the very late response.

For your first concern, I see some difference in TLVs about priority issue (Table I in your draft). I think I understand your description but I didn't find very much advantage to include such 'scalable' settings.

RR>> Priority based advertisement is pretty standard mechanism used in all existing RFCs.  For e.g. you can find these in WSON, OTN  docs and any other Te-extensions draft.

Another concern from me is, for the flexi-grid literature, there are more than one WG draft, I think it's better to consider such case in fwk draft, and after that the OSPF one can revise accordingly. P.S, I don't know whether this topic was discussed on the list before (perhaps there are some conclusions, let me know). If not, I would like to suggest move to the list.

RR>> I looked at framework.  Yes, it doesn’t talk about priority based advertisement.  Thanks for pointing this out. Good catch. We will provide this comment to FWK authors & CC you.  I do not see any issue updating the fwk doc with this detail.

For your second concern on Max LSP Bandwidth, my understanding is you are trying to use the description in section 3.2 of your draft to replace the one in section 4.3 of current WG draft. Is this true? I believe the description in your draft is clear and correct. BTW, I noticed bit difference in Min Bandwidth (16 bits allocated in your draft and 8 bit in current WG draft), hopefully this will not be a big issue (8 bit support a bandwidth up to 3200GHz, which is absolutely more than the normal requirement for a minimal BW).

RR>>  Yes, I was referring to section 3.2 in our draft.

We went with 16-bit fields for Min & Max fields as the values for these fields range from 0 – 384.  We tried to address the case of using full spectrum BW as one LSP.  This is an extreme case but can’t be ruled out.

Pl let me know if you have any other comments.

Thanks.

Best wishes,

Haomian

-----邮件原件-----

发件人: Rajan Rao [mailto:[email-masked]]

发送时间: 2014年12月18日 6:09

收件人: Zhenghaomian; Fatai Zhang

抄送: Khuzema Pithewan; Iftekhar Hussain

主题: RE: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Haomian,

As I had mentioned we are no longer pushing for SuperChannel in the draft.  So, this should make it easier to merge the docs.

In my view there are couple of areas your draft doesn't address which can be taken from our draft:

1.  You have separated Max & Min Slot width in Port Label restriction sub-TLV.  This is O.K. But this doesn't allow for priority based Min/Max usage.   Our draft allows for this flexibility which can be used.

2.  Max LSP Bandwidth field definition can be taken from our doc.

The priority handling can be further simplified by merging slice info & Min/Max fields in to a single sub-TLV if other authors agree.

Pl let me know.

Thx

Rajan

-----Original Message-----

From: Zhenghaomian [mailto:[email-masked]]

Sent: Tuesday, December 16, 2014 5:15 PM

To: Rajan Rao; Fatai Zhang

Cc: Khuzema Pithewan

Subject: 答复: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Hi, Rajan and Khuzema,

Thanks for reminding. Do you guys have any suggestion on how to merge? Even if we think the current draft is self-contained, we are still open on this.

I know there are some different ideas from Infinera, but sorry I am not fully understand every detail. Please let me know the exact section that need to be updated and let's see how to proceed. Again, this will finally be determined by the WG since already adopted.

Thanks.

Best wishes,

Haomian

-----邮件原件-----

发件人: Rajan Rao [mailto:[email-masked]]

发送时间: 2014年12月17日 6:01

收件人: Zhenghaomian; Fatai Zhang

抄送: Khuzema Pithewan

主题: RE: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Haomian,

We had sent couple of emails asking about merging the contents with our draft.  Do you see an opportunity or any issues with the merge?  Can you pl respond on how you would like to proceed? Pl see the attached email we had sent a while back.

Thanks

Rajan

-----Original Message-----

From: CCAMP [mailto:[email-masked]] On Behalf Of Zhenghaomian

Sent: Tuesday, December 16, 2014 12:24 AM

To: [email-masked]<mailto:[email-masked]>

Subject: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Dear CCAMPers,

We upload an updated version to reactivate the following draft against expiration, together updating the Max width issue proposed in previous discussions. Your comments are highly welcomed, thanks.

Best wishes,

Haomian on behalf of authors

-----邮件原件-----

发件人: CCAMP [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>

发送时间: 2014年12月16日 16:16

收件人: [email-masked]<mailto:[email-masked]>

抄送: [email-masked]<mailto:[email-masked]>

主题: [CCAMP] I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

This draft is a work item of the Common Control and Measurement Plane Working Group of the IETF.

        Title           : GMPLS OSPF-TE Extensions in support of Flexible Grid

        Authors         : Xian Zhang

                          Haomian Zheng

                          Ramon Casellas

                          Oscar Gonzalez de Dios

                          Daniele Ceccarelli

               Filename        : draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

               Pages           : 14

               Date            : 2014-12-16

Abstract:

   This memo describes the OSPF-TE extensions in support of GMPLS

   control of networks that include devices that use the new flexible

   optical grid.

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-ietf-ccamp-flexible-grid-ospf-ext/

There's also a htmlized version available at:

http://tools.ietf.org/html/draft-ietf-ccamp-flexible-grid-ospf-ext-01

A diff from the previous version is available at:

http://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-flexible-grid-ospf-ext-01

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/

_______________________________________________

CCAMP mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/ccamp

_______________________________________________

CCAMP mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/ccamp

---

From: Rajan Rao <[email-masked]>
Date: Tue, 3 Mar 2015 00:55:34 +0000

Xian,

Minimum LSP bandwidth will address technological advances. For e.g. tomorrow’s 6.25GHz  instead of today’s 12.5GHz. GMPLS extensions should cover the case of network having a mix of different hardware capabilities. Advertising per priority aligns with RFC4202.  I don’t see any issues.

As far as Maximum LSP bandwidth goes, either option would work but my preference would be to put it in technology specific part (SCSI).
Thx
Rajan

Sent: Sunday, March 01, 2015 10:35 PM

Hi, Rajan, all,

Regards,
Xian

Xian, all

thx
Rajan

Hi, Rajan and all,

Regards,
Xian

Xian,

Thx
Rajan

Hi, Rajan,

Cheers,
Xian

Daniele,

Thx
Rajan

Hi all,

BR
Daniele

Haomian,

Thx
Rajan

Hi, Rajan,

  0                   1                   2                   3

In your proposal,

Best wishes,
Haomian

Haomian,

FWK doc Snip below:

5.1.2.  Routing

Thx
Rajan

From: Rajan Rao

Haomian,

-----Original Message-----
From: Zhenghaomian [mailto:[email-masked]]
Sent: Monday, February 02, 2015 11:22 PM
To: Rajan Rao; Fatai Zhang
Cc: Khuzema Pithewan; Iftekhar Hussain
Subject: 答复: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Hi, Rajan,

Thanks.

Best wishes,

Haomian

-----邮件原件-----

发送时间: 2014年12月18日 6:09

Haomian,

Pl let me know.

Thx

Rajan

-----Original Message-----

Cc: Khuzema Pithewan

Hi, Rajan and Khuzema,

Thanks.

Best wishes,

Haomian

-----邮件原件-----

发送时间: 2014年12月17日 6:01

抄送: Khuzema Pithewan

Haomian,

Thanks

Rajan

-----Original Message-----

Dear CCAMPers,

Best wishes,

-----邮件原件-----

发送时间: 2014年12月16日 16:16

        Authors         : Xian Zhang

                          Haomian Zheng

                          Ramon Casellas

                          Oscar Gonzalez de Dios

                          Daniele Ceccarelli

               Pages           : 14

               Date            : 2014-12-16

Abstract:

   optical grid.

CCAMP mailing list

CCAMP mailing list

---

From: Ramon Casellas <[email-masked]>
Date: Tue, 03 Mar 2015 08:07:37 +0100

Dear all,

Please see inline

El 03/03/2015 a las 1:55, Rajan Rao escribió:
>
> Xian,
>
> Minimum LSP bandwidth will address technological advances. For e.g. 
> tomorrow’s 6.25GHz  instead of today’s 12.5GHz. GMPLS extensions 
> should cover the case of network having a mix of different hardware 
> capabilities. Advertising per priority aligns with RFC4202.  I don’t 
> see any issues.
>
Ramon> I have no objections to adding Min LSP bw if we need it, I just 
want to point out one remark. If I remember correctly, we had discussed 
the issue whether we should be "future-proof" and take into account 
future versions of the flexi-grid, notably, the granularity. In 
particular, the following question was raised:

• Please comment on future changes regarding the values of nominal 
central frequency (NCF) granularity [NCFG, currently 6.25 GHz] and slot 
width granularity [currently 12.5 GHz], as defined in G.694.1. Is ITU-T 
considering alternative values (e.g. 3.125 GHz) for NCFG in the 
foreseeable future? If yes, is it correct to assume, that the following 
always holds, w.r.t. slot width granularity and NCF granularity?
SWG = 2 * NCFG

The reply we got was: 
[https://datatracker.ietf.org/documents/LIAISON/liaison-2014-04-23-itu-t-sg-15-ccamp-lsr-on-flexible-grid-reply-to-ietf-ccamp-ls012-attachment-1.pdf]
Currently, there have been no proposals made to Q6/15 to standardize a 
flexible grid with different granularity of slot width or nominal 
central frequency. If such a proposal is made in the future, it is more 
likely that a second flexible grid with different granularity will be 
defined in addition to the existing grid rather than changes made to the 
current flexible grid. (...) If in future a flexible grid with finer 
granularity is introduced, the same 2:1 relationship should not be assumed.

So IMHO, the text gives arguments to mainly limit ourselves to current 
in force documents. That said, I think it is worth considering other 
reasons (if any) to disseminate min-lsp-bw. It may be short-sighted to 
discard the option.

> As far as Maximum LSP bandwidth goes, either option would work but my 
> preference would be to put it in technology specific part (SCSI).
>

> *From:*Zhangxian (Xian) [mailto:[email-masked]]
> *Sent:* Sunday, March 01, 2015 10:35 PM
> *To:* Rajan Rao; CCAMP ([email-masked]); 'Ramon Casellas'
> *Cc:* Khuzema Pithewan; Iftekhar Hussain; Biao Lu
> *Subject:* RE: [CCAMP] I-D Action: 
> draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt
>
> Hi, Rajan, all,
>

>       Why do we need to advertise Min LSP bandwidth per priority in 
> ISCD, e.g., a request cannot set up a LSP smaller than X GHz and it 
> varies per priority? If you  meant to say the interface limitation, it 
> is covered in Section 4.3 already.
>
Ramon> See above.
>
>       As for the Max LSP bandwidth information, I agree with you that 
> RFC4204 has this requirement. This draft 
> (draft-ietf-ccamp-flexible-grid-ospf-ext-01) needs to be updated to 
> reflect this. I can think of two options:
>
> Option A: use the existing fields (MAX LSP Bandwidth at priority x, 
> x=0-7)  in the ISCD (defined in Section 1.4. of RFC4203). The point 
> that we need to update is the unit to be usable in the context of 
> Flexi-grid. It will be Hz not byte per second.
>
Ramon> I am wary of this one. With the original goal of "separation of 
concerns", we focus on the media layer and usually express optical 
spectrum widths in terms of "m" values. It seems clear that we must not 
talk about bytes per second  (modulation formats spectral efficiency) 
but I would not directly introduce "Hz" (along the minor issues of 
encoding IEEE Giga Hertz  etc.). Also, I am not fully convinced of 
reusing an existing information object and change the unit. In other 
words, IMHO min and max LSP bw values should be stated in terms of "m"s, 
and all fields related to bytes / sec should be set to e.g. zero.

> Option B: We add the max LSP bandwidth field (16 bit) in the Available 
> Labels Field by using the Reserved field.
>
>
Ramon> Are these the only options we have? Although adding the max LSP 
bw field in the reserved field (currently 24 bits, enough) may end up 
being the preferred option, I am not sure why we are discarding adding 
in the ISCD/SCSI new sub TLVs for this purpose, specially if we also 
justify having the min-LSP-bw? I have no strong opinion, but I do agree 
it makes sense to have it in the SCSI.

Thanks and best regards
Ramon

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Tue, 3 Mar 2015 07:22:27 +0000

Hi, Rajan,

Sent: 2015年3月3日 8:56

Xian,

Minimum LSP bandwidth will address technological advances. For e.g. tomorrow’s 6.25GHz  instead of today’s 12.5GHz. GMPLS extensions should cover the case of network having a mix of different hardware capabilities.
[Xian]: I agree with the above statements. But they are a property of an interface, which AFAIC does not change over time. That’s why I said it have already be covered by Section 4.3 (please take a look if any information is missing as well).  ISCD, especially SCSI is used to advertise the available bandwidth information and it is changing dynamically. So, I do not think SCSI is the right place to do so.

Advertising per priority aligns with RFC4202.  I don’t see any issues.
[Xian] I have to disagree.   RFC4202 does not support advertising min LSP bandwidth per priority. Please take a look at the encoding of Section 1.4. of RFC4203. What’s said there: for PSC and TDM, you carry ONE minimum LSP bandwidth information (which is not associated per priority); for Lambda switching, it does not have any SCSI at all.

Having said all these, I personally do not think the value of advertising min LSP bandwidth per priority. If you disagree again, could you give me an usage example?

As far as Maximum LSP bandwidth goes, either option would work but my preference would be to put it in technology specific part (SCSI).
[Xian]: point taken. I agree with you that both work but I would prefer to take Option 1. Let’s get a bit more feedback from the WG before updating the draft.

Regards,
Xian

Thx
Rajan

Hi, Rajan, all,

Regards,
Xian

Xian, all

thx
Rajan

Hi, Rajan and all,

Regards,
Xian

Xian,

Thx
Rajan

Hi, Rajan,

Cheers,
Xian

Daniele,

Thx
Rajan

Hi all,

BR
Daniele

Haomian,

Thx
Rajan

Hi, Rajan,

  0                   1                   2                   3

In your proposal,

Best wishes,
Haomian

Haomian,

FWK doc Snip below:

5.1.2.  Routing

Thx
Rajan

From: Rajan Rao

Haomian,

-----Original Message-----
From: Zhenghaomian [mailto:[email-masked]]
Sent: Monday, February 02, 2015 11:22 PM
To: Rajan Rao; Fatai Zhang
Cc: Khuzema Pithewan; Iftekhar Hussain
Subject: 答复: [CCAMP] 转发: I-D Action: draft-ietf-ccamp-flexible-grid-ospf-ext-01.txt

Hi, Rajan,

Thanks.

Best wishes,

Haomian

-----邮件原件-----

发送时间: 2014年12月18日 6:09

Haomian,

Pl let me know.

Thx

Rajan

-----Original Message-----

Cc: Khuzema Pithewan

Hi, Rajan and Khuzema,

Thanks.

Best wishes,

Haomian

-----邮件原件-----

发送时间: 2014年12月17日 6:01

抄送: Khuzema Pithewan

Haomian,

Thanks

Rajan

-----Original Message-----

Dear CCAMPers,

Best wishes,

-----邮件原件-----

发送时间: 2014年12月16日 16:16

        Authors         : Xian Zhang

                          Haomian Zheng

                          Ramon Casellas

                          Oscar Gonzalez de Dios

                          Daniele Ceccarelli

               Pages           : 14

               Date            : 2014-12-16

Abstract:

   optical grid.

CCAMP mailing list

CCAMP mailing list