Subject: [CCAMP] AD review of draft-ietf-ccamp-wson-signaling

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 4 Mar 2015 14:49:02 -0000

[Using explicit addresses because the tools aliases are currently unreliable]

Authors,

I've done my usual AD review of your document (the nth in the sequence 
of n+1 WSON drafts!). I have a few comments, and normally I would ask
you for a new revision at once, but because of dates and things I am
going to start the IETF last call and enter these as last call comments.

The last call will end on 3/18 and you can post a new revision then (by
sending it to me to ask the Secretary to post it) or wait to post it
yourselves when the gates reopen on 3/23.

Thanks for the work,
Adrian

===

You need to split the Authors' Addresses section and move out all those
not on the current front page to be present in a Contributors section.

---

You seem to have the name of RFC 6205 in the references section a bit
wrong!

---
                                              
Do you really mean that you are updating 6205? That is the document
that defines lambda labels.

It has no mention of G.709 despite what you say in the Abstract. This
seems a little odd.                          

What is more, I don't see any discussion of updates to the label format
or usage in the document although Section 4 does say

   [RFC6205] defines the label format as applicable to LSC capable
   device. This document extends [RFC6205] as make its label format
   applicable also to WSON-LSC capable devices.

I don't think that applying the label to WSON without changing its
meaning or the way it is used is really an "update".

---

Section 2 has FOADM, but it is not used in the document.

You need to hyphenate "Cross Connect" unless you are really angry :-)

---

Section 3 gives a caption to a list

    List 1. WSON Signal Characteristics

I've not seen that before in an I-D, and since you don't refer to the 
list by name, I suggest you just delete this.

---

I wish you hadn't suggested explicit values for the two new Error Codes
in 4.2.2 and 6. But we'll see what IANA says during IETF last call.

---

From: Leeyoung <[email-masked]>
Date: Wed, 4 Mar 2015 16:22:46 +0000

Hi Adrian,

Thanks for your attention. We will review your comment and upload the revision after 3/18. 

Best regards,
Young

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Wednesday, March 04, 2015 8:49 AM
To: [email-masked]; [email-masked]; Leeyoung; [email-masked]; [email-masked]
Cc: 'CCAMP'; [email-masked]; [email-masked]; Alvaro Retana
Subject: AD review of draft-ietf-ccamp-wson-signaling

Authors,

Thanks for the work,
Adrian

===

---

---

---

---

---

---

From: Leeyoung <[email-masked]>
Date: Mon, 9 Mar 2015 20:55:36 +0000

Hi Adrian,

Thank you for your AD review. Here's my response to your comment. 

Thanks,
Young

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Wednesday, March 04, 2015 8:49 AM
To: [email-masked]; [email-masked]; Leeyoung; [email-masked]; [email-masked]
Cc: 'CCAMP'; [email-masked]; [email-masked]; Alvaro Retana
Subject: AD review of draft-ietf-ccamp-wson-signaling

Authors,

I've done my usual AD review of your document (the nth in the sequence of n+1 WSON drafts!). I have a few comments, and normally I would ask you for a new revision at once, but because of dates and things I am going to start the IETF last call and enter these as last call comments.

The last call will end on 3/18 and you can post a new revision then (by sending it to me to ask the Secretary to post it) or wait to post it yourselves when the gates reopen on 3/23.

Thanks for the work,
Adrian

===

You need to split the Authors' Addresses section and move out all those not on the current front page to be present in a Contributors section.

YOUNG>> Yes, agree. 

---

You seem to have the name of RFC 6205 in the references section a bit wrong!

YOUNG>> OK. Corrected to "Generalized Labels for Lambda-Switch-Capable (LSC) Label Switching Routers". 

---
                                              
Do you really mean that you are updating 6205? That is the document that defines lambda labels.

YOUNG>> I agree. No need to talk about G.709 and this document does not update 6205. So, I would delete the
Following paragraph from the Abstract: 

  "These extensions build on previous
   work for the control of lambda and G.709 based networks, i.e. update
   RFC6205, to make it applicable to WSON-LSC capable equipment."

What is more, I don't see any discussion of updates to the label format or usage in the document although Section 4 does say

I don't think that applying the label to WSON without changing its meaning or the way it is used is really an "update".

YOUNG>> Yes, this is not correct. I would delete "This document extends [RFC6205] as make its label format
   applicable also to WSON-LSC capable devices." 

---

YOUNG>> Corrected. No reason to be angry with a "-" :) 
---

I've not seen that before in an I-D, and since you don't refer to the list by name, I suggest you just delete this.

YOUNG>> Deleted. 

---

I wish you hadn't suggested explicit values for the two new Error Codes in 4.2.2 and 6. But we'll see what IANA says during IETF last call.

YOUNG>> Yes. Agree

---

From: Leeyoung <[email-masked]>
Date: Mon, 9 Mar 2015 21:02:37 +0000

I forgot one item:

I would delete FOAMD from the document.

Thanks,
Young

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: Monday, March 09, 2015 3:56 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: 'CCAMP'; [email-masked]
Subject: Re: [CCAMP] AD review of draft-ietf-ccamp-wson-signaling

Hi Adrian,

Thanks,
Young

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Wednesday, March 04, 2015 8:49 AM
To: [email-masked]; [email-masked]; Leeyoung; [email-masked]; [email-masked]
Cc: 'CCAMP'; [email-masked]; [email-masked]; Alvaro Retana
Subject: AD review of draft-ietf-ccamp-wson-signaling

Authors,

Thanks for the work,
Adrian

===

YOUNG>> Yes, agree. 

---

---

---

YOUNG>> Deleted. 

---

YOUNG>> Yes. Agree

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp