Subject: Re: [CCAMP] New Version Notification for draft-lee-ccamp-optical-impairment-topology-yang-00.txt

From: Leeyoung <[email-masked]>
Date: Mon, 22 Oct 2018 20:31:16 +0000

Hi,

There are some issues yet to be resolved as we discussed in the list. To avoid the deadline, the draft has been published. Pending issues are:

- flex-grid representation of (m,n) instead of (central freq, channel width). The current Flex-grid model uses the latter. So we need to align with flex-grid model.
- application codes (G.698.2 vs. other variation): I added some module per Dieter's suggestion. We can continue to discuss this point.
- power attributes: this is incomplete as for now, but we can discuss further in the list and in the face-to-face meeting as to in what details we need to mode this (including OA). 
- I am sure there are still other issues...

Thanks.
Young

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 22, 2018 3:23 PM
To: Nicola Sambo <[email-masked]>; Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept) <[email-masked]>; Gabriele Galimberti <[email-masked]>; G. Galimberti <[email-masked]>; Leeyoung <[email-masked]>; Victor Lopezalvarez <[email-masked]>; Victor Lopez <[email-masked]>
Subject: New Version Notification for draft-lee-ccamp-optical-impairment-topology-yang-00.txt

A new version of I-D, draft-lee-ccamp-optical-impairment-topology-yang-00.txt
has been successfully submitted by Young Lee and posted to the IETF repository.

Name:		draft-lee-ccamp-optical-impairment-topology-yang
Revision:	00
Title:		A Yang Data Model for Optical Impairment-aware Topology
Document date:	2018-10-22
Group:		Individual Submission
Pages:		22
URL:            https://www.ietf.org/internet-drafts/draft-lee-ccamp-optical-impairment-topology-yang-00.txt
Status:         https://datatracker.ietf.org/doc/draft-lee-ccamp-optical-impairment-topology-yang/
Htmlized:       https://tools.ietf.org/html/draft-lee-ccamp-optical-impairment-topology-yang-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-lee-ccamp-optical-impairment-topology-yang

Abstract:
   This document provides a YANG data model for the impairment-aware TE
   topology in optical networks.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jonas Mårtensson <[email-masked]>
Date: Tue, 23 Oct 2018 08:08:41 +0000

Hi,

A couple of comments on the introduction:

"The determination of appropriate paths is known as Impairment-Aware Routing and Wavelength Assignment (IA-RWA) [RFC6566] for WSON, while it is known as IA-Routing and Spectrum Assigment (IA-RSA) for SSON."

It would be nice if the draft also covered the (more advanced) use case IA-Routing, Modulation and Spectrum Assignment (IA-RMSA). This is related to the proposal in one of my earlier mails to add attributes for spectral efficiency and required OSNR for available modulation types so that the path computation can select the proper modulation depending on required capacity and actual OSNR.

"The communication between controllers is done via a NETCONF [RFC8341]."

Why only NETCONF. At least RESTCONF should be an option as well, right?

/Jonas

-----Original Message-----
From: Leeyoung <[email-masked]> 
Sent: den 22 oktober 2018 22:31
To: Nicola Sambo <[email-masked]>; Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept) <[email-masked]>; Gabriele Galimberti <[email-masked]>; G. Galimberti <[email-masked]>; Victor Lopezalvarez <[email-masked]>; Victor Lopez <[email-masked]>; Jonas Mårtensson <[email-masked]>; Gert Grammel <[email-masked]>
Cc: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; [email-masked]
Subject: RE: New Version Notification for draft-lee-ccamp-optical-impairment-topology-yang-00.txt

Hi,

Thanks.
Young

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 22, 2018 3:23 PM
To: Nicola Sambo <[email-masked]>; Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept) <[email-masked]>; Gabriele Galimberti <[email-masked]>; G. Galimberti <[email-masked]>; Leeyoung <[email-masked]>; Victor Lopezalvarez <[email-masked]>; Victor Lopez <[email-masked]>
Subject: New Version Notification for draft-lee-ccamp-optical-impairment-topology-yang-00.txt

Abstract:

The IETF Secretariat

---

From: Leeyoung <[email-masked]>
Date: Tue, 23 Oct 2018 14:19:21 +0000

Hi Jonas,

Thanks for your review of the draft and sharing your comments. Please see inline for my response to yours. 

Best regards,
young

-----Original Message-----
From: Jonas Mårtensson [mailto:[email-masked]] 
Sent: Tuesday, October 23, 2018 3:09 AM
To: Leeyoung <[email-masked]>; Nicola Sambo <[email-masked]>; Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept) <[email-masked]>; Gabriele Galimberti <[email-masked]>; G. Galimberti <[email-masked]>; Victor Lopezalvarez <[email-masked]>; Victor Lopez <[email-masked]>; Gert Grammel <[email-masked]>
Cc: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; [email-masked]
Subject: RE: New Version Notification for draft-lee-ccamp-optical-impairment-topology-yang-00.txt

Hi,

YL>> Why don't you provide some text -- the draft is on an early stage and open for use-cases like yours. If you have some model in mind, please also make a comment in the github. https://github.com/younglee-ietf/actn-wson-flexi-grid 

YL>> Yes, we can add RESTCONF reference. 

/Jonas

-----Original Message-----
From: Leeyoung <[email-masked]> 
Sent: den 22 oktober 2018 22:31
To: Nicola Sambo <[email-masked]>; Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept) <[email-masked]>; Gabriele Galimberti <[email-masked]>; G. Galimberti <[email-masked]>; Victor Lopezalvarez <[email-masked]>; Victor Lopez <[email-masked]>; Jonas Mårtensson <[email-masked]>; Gert Grammel <[email-masked]>
Cc: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; [email-masked]
Subject: RE: New Version Notification for draft-lee-ccamp-optical-impairment-topology-yang-00.txt

Hi,

Thanks.
Young

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 22, 2018 3:23 PM
To: Nicola Sambo <[email-masked]>; Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept) <[email-masked]>; Gabriele Galimberti <[email-masked]>; G. Galimberti <[email-masked]>; Leeyoung <[email-masked]>; Victor Lopezalvarez <[email-masked]>; Victor Lopez <[email-masked]>
Subject: New Version Notification for draft-lee-ccamp-optical-impairment-topology-yang-00.txt

Abstract:

The IETF Secretariat