Subject: [CCAMP] Mirja Kühlewind's No Objection on draft-ietf-ccamp-mw-yang-10: (with COMMENT)

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 25 Oct 2018 06:21:20 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-ccamp-mw-yang-10: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-mw-yang/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The shepherd write-up says that there have been normative references to
non-IETF docs which seem to have been removed now. I wondering is that is
correct. I'm by far not an expert and didn't have time to review this doc in
detail but I would think that you would need to know some details of these
on-IETF specs in-order to fully understand and correctly implement this YANG
model, no?

---

From: "Yemin (Amy)" <[email-masked]>
Date: Fri, 26 Oct 2018 01:28:01 +0000

Hi Mirja,

Thanks for your comment.
Yes, these on-IETF specs are to be understood when correctly implement this YANG model.
They are not completed removed from the draft. After shepherd write-up, those documents are moved to informative reference section according to the https://www.ietf.org/blog/iesg-statement-normative-and-informative-references/. I hope we understand the rules correctly.

BR,
Amy, on behalf of co-authors

-----Original Message-----
From: Mirja Kühlewind [mailto:[email-masked]]
Sent: Thursday, October 25, 2018 9:21 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; Fatai Zhang <[email-masked]>; [email-masked]; Fatai Zhang <[email-masked]>; [email-masked]
Subject: Mirja Kühlewind's No Objection on draft-ietf-ccamp-mw-yang-10: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

COMMENT:

The shepherd write-up says that there have been normative references to non-IETF docs which seem to have been removed now. I wondering is that is correct. I'm by far not an expert and didn't have time to review this doc in detail but I would think that you would need to know some details of these on-IETF specs in-order to fully understand and correctly implement this YANG model, no?

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Fri, 26 Oct 2018 10:26:00 +0200

Hi Amy,

not sure which part of the statement below you are relying you decision on but the document says:

"Normative references specify documents that must be read to understand or implement the technology in the new RFC“

So, as you say below, as these reference are needed to implement it correctly, they must be normative.

It is possible for non-IETF document to be normative as long as the reference are stable and open.

Mirja

> Am 26.10.2018 um 03:28 schrieb Yemin (Amy) <[email-masked]>:
> 
> Hi Mirja, 
>  
> Thanks for your comment. 
> They are not completed removed from the draft. After shepherd write-up, those documents are moved to informative reference section according to thehttps://www.ietf.org/blog/iesg-statement-normative-and-informative-references/. I hope we understand the rules correctly.
>  
> BR,

---

From: "Yemin (Amy)" <[email-masked]>
Date: Sat, 27 Oct 2018 00:59:35 +0000

Hi Mirja,

It seems I misunderstood the rules. I thought non-IETF documents have to stay in informative section, even if they are to be read to understand the new RFC. 
We will move them back to the normative reference section. 
Thank you. 

BR,
Amy
-----Original Message-----
From: Mirja Kuehlewind (IETF) [mailto:[email-masked]] 
Sent: Friday, October 26, 2018 4:26 PM
To: Yemin (Amy) <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]; Fatai Zhang <[email-masked]>; [email-masked]
Subject: Re: Mirja Kühlewind's No Objection on draft-ietf-ccamp-mw-yang-10: (with COMMENT)

Hi Amy,

Mirja

---

From: Fatai Zhang <[email-masked]>
Date: Sat, 27 Oct 2018 01:12:29 +0000

Hi Mirja and Amy,

Thanks for your review and discussion.

I think we could discuss the specific, i.e., which non-IETF documents should be normative and why, which non-IETF documents should be informative and why.

If a non-IETF document only provides background or historical information, then it should be an informative reference. 

It seems to me that these non-IETEF documents only provide background information, e.g., [EN301129] is referenced once, but this draft does not import modules from [EN301129].

Thanks

Fatai

-----邮件原件-----
发件人: Mirja Kuehlewind (IETF) [mailto:[email-masked]] 
发送时间: 2018年10月26日 16:26
收件人: Yemin (Amy) <[email-masked]>
抄送: The IESG <[email-masked]>; [email-masked]; [email-masked]; Fatai Zhang <[email-masked]>; [email-masked]
主题: Re: Mirja Kühlewind's No Objection on draft-ietf-ccamp-mw-yang-10: (with COMMENT)

Hi Amy,

Mirja

---

From: "Yemin (Amy)" <[email-masked]>
Date: Wed, 31 Oct 2018 10:32:38 +0000

Hi Fatai and Mirja,

Thank for your comments. 
The draft co-authors discussed on this again. This draft defines YANG models. For developers who implement this yang model, they don’t need to know the technology details. 
For example,  BBE, SES, they are just a data for the YANG model developers to process. But knowing the defintion will definitely help the developer's understanding. 
So those reference are to provide addtional information. 
According to IESG statement, it's better to put them in the informative reference section. 

BR,
Amy
________________________________________
发件人: Fatai Zhang
发送时间: 2018年10月27日 9:12
收件人: Mirja Kuehlewind (IETF); Yemin (Amy)
抄送: The IESG; [email-masked]; [email-masked]; [email-masked]
主题: 答复: Mirja Kühlewind's No Objection on draft-ietf-ccamp-mw-yang-10: (with COMMENT)

Hi Mirja and Amy,

Thanks

Fatai

-----邮件原件-----
发件人: Mirja Kuehlewind (IETF) [mailto:[email-masked]]
发送时间: 2018年10月26日 16:26
收件人: Yemin (Amy) <[email-masked]>
抄送: The IESG <[email-masked]>; [email-masked]; [email-masked]; Fatai Zhang <[email-masked]>; [email-masked]
主题: Re: Mirja Kühlewind's No Objection on draft-ietf-ccamp-mw-yang-10: (with COMMENT)

Hi Amy,

Mirja

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 31 Oct 2018 12:20:50 +0000

Thanks Amy-

Agree these are informative-

Deborah 

Sent from my iPhone

> On Oct 31, 2018, at 6:33 AM, Yemin (Amy) <[email-masked]> wrote:
> 
> Hi Fatai and Mirja,
> 
> Thank for your comments. 
>> Please refer to https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwIGbw&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=cU06UjyOnejuL7GUr3ZwET0o1k5G9Q54WwWv7AZDF-s&s=-pcDvKvISxUHAdfa61THnD17T0L_4B458k5LVdQEsx8&e=
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dccamp-2Dmw-2Dyang_&d=DwIGbw&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=cU06UjyOnejuL7GUr3ZwET0o1k5G9Q54WwWv7AZDF-s&s=acQ0pqjMfnxLO8VSdv7XyOJNx5smNYUYgii7qxoXjPs&e=
>> 
>> 
>> 
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ccamp&d=DwIGbw&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=cU06UjyOnejuL7GUr3ZwET0o1k5G9Q54WwWv7AZDF-s&s=MGYnx-DtgWSaM4IUq_JQDPqgby-Cm1Tlh8mRwR2kzLc&e=