Subject: Re: [CCAMP] Webex meeting invitation: Microwave topology

From: "Yemin (Amy)" <[email-masked]>
Date: Wed, 2 Oct 2019 20:58:30 +0000

Hi all,

Please see the update model, removing those that're not applicable to microwave: connectivity-matrix, LLC, TTP, LSP-bandwidth.

BR,
Amy
________________________________
发件人: CCAMP [[email-masked]] 代表 Daniele Ceccarelli [daniele.ceccarelli=[email-masked]]
发送时间: 2019年9月26日 21:26
收件人: Jonas Ahlberg; CCAMP Working Group; ccamp
主题: Re: [CCAMP] Webex meeting invitation: Microwave topology

Thanks, very good input.

I was myself struggling to understand why the TE topology is needed as opposite to the network topology.
If I may give you a suggestion, you could provide a “profile” of the TE topology for microwave. Let me try to explain it better as I can’t the find the right work in English.
I was thinking of something along the lines of: to describe a network topology you need this e.g. 30% of the TE topology and then we propose to augment it with X,Y,Z.
This would make the implementation of the TE topology for microwave much easier.

Thanks,

Daniele

From: Jonas Ahlberg <[email-masked]>
Sent: den 26 september 2019 15:05
To: CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Subject: RE: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,
Some short notes from the meeting September 26.
Participants: Amy Ye, Daniela Spreafico, Dragos D, Italo Busi, Stephen Cheng, , Jonas Ahlberg

Applicability of ietf-te-topology for microwave radio link
The meeting continued the discussion about which concepts from ietf-te-topology are applicable for microwave radio link and what use cases they support, based on the mails from Amy and Stephen.
The meeting agreed that all representatives should review ietf-te-topology and clarify what they see could be applicable for microwave radio link and which parts are not. The ambition is to get that input in time for next weeks meeting or the meeting after that at the latest.
Once there is a common and agreed view of which parts of te-topology is applicable for microwave radio link and what use cases they are supposed to support, we can get back to the discussion about how to model it in the best way.

Regards
Jonas A

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where: https://ietf.webex.com/ietf

CCAMP Working Group invites you to join this Webex meeting.

Meeting number (access code): 647 343 270

Meeting password: D7dhCJpZ

Occurs every Thursday effective Thursday, August 22, 2019 until Thursday, October 24, 2019 from 7:00 AM to 8:00 AM, (UTC-05:00) Eastern Time (US & Canada)

7:00 am  |  (UTC-05:00) Eastern Time (US & Canada)  |  1 hr

Join<https://ietf.webex.com/ietf/j.php?MTID=ma65a6a5186962890ec535e711ec3d3f9>

Join by phone

Tap to call in from a mobile device (attendees only)

1-650-479-3208<tel:%2B1-650-479-3208,,*01*647343270%23%23*01*> Call-in toll number (US/Canada)

1-877-668-4493<tel:1-877-668-4493,,*01*647343270%23%23*01*> Call-in toll free number (US/Canada)

Global call-in numbers<https://ietf.webex.com/ietf/globalcallin.php?MTID=m57c83575d64804b110f94f798d438720>  |  Toll-free calling restrictions<https://www.webex.com/pdf/tollfree_restrictions.pdf>

Need help? Go to http://help..webex.com<http://help.webex.com>

---

From: Stephen Cheng <[email-masked]>
Date: Wed, 2 Oct 2019 21:16:08 +0000

Hi all,

A couple of things:

  1.  I have requested to move this meeting time going forward but heard no reply. Due to summer time changes, the meeting is currently scheduled at my *midnight*. I suggest to move one hour earlier, or alternatively 9 hours later.

  1.  I have re-attached a copy of the modified YANG file I sent last week, for discussion. The changes from the original IETF -02 draft are:

  1.  Removing the te-topology aspects that are not applicable to microwave topology
  2.  Added presence container for microwave-link and microwave-tp, to allow microwave-topology to co-exist with other L1 topology YANG
     *   So that we could tell which link and which tp are microwave links and microwave tps
  3.  Add to termination-points a list of carriers
  4.  Moving the replacement of interface-root to termination-points and the channels therein.
  5.  I have marked my comments/changes with //[SC]

Warm regards,
Stephen Cheng

From: CCAMP <[email-masked]> On Behalf Of Yemin (Amy)
Sent: 2019年10月3日 9:59 AM
To: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; Jonas Ahlberg <[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Subject: EXTERNAL: Re: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,

BR,
Amy

Thanks,

Daniele

From: Jonas Ahlberg <[email-masked]<mailto:[email-masked]>>
Sent: den 26 september 2019 15:05
To: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>; ccamp <[email-masked]<mailto:[email-masked]>>
Subject: RE: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,

Regards
Jonas A

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where: https://ietf.webex.com/ietf

Join by phone

---

From: Stephen Cheng <[email-masked]>
Date: Thu, 3 Oct 2019 02:30:08 +0000

During discussion of whether microwave topology should be based on TE-topology in the last two meetings, Layer 3 topology (ietf-l3-unicast-topology) was mentioned as a precedent on how a non-TE topology can be used in conjunction with an (augmented) ietf-te-topology to model a TE-aware topology. This mechanism provides a balance of simplicity and capability for future expansion.

I have found an extended description of this approach in section 2 of SR topology YANG (https://tools.ietf.org/pdf/draft-ietf-teas-yang-sr-te-topo-05.pdf). Ietf-sr-topology defines a topology for segment routing, and augment ietf-l3-topology. Section 2.2 provides a very clear description of how to use the non-TE version of SR topology (ietf-sr-topology) together with L3 TE topology (ietf-l3-te-topology) to model a traffic engineered segmentrouting topology.

IMO section 2 of https://tools.ietf.org/pdf/draft-ietf-teas-yang-sr-te-topo-05.pdf is very well written, and provides a clear overview of how the SR topology YANG relates to other topology/service YANGs, and how itself is structured. I think we would do well to introduce a similar overview in the microwave topology I-D.

Warm regards

From: Stephen Cheng
Sent: 2019年10月3日 10:16 AM
To: Yemin (Amy) <[email-masked]>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; Jonas Ahlberg <[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>; Xi Li <[email-masked]>; [email-masked]
Subject: RE: EXTERNAL: Re: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,

A couple of things:

Warm regards,
Stephen Cheng

From: CCAMP <[email-masked]<mailto:[email-masked]>> On Behalf Of Yemin (Amy)
Sent: 2019年10月3日 9:59 AM
To: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:daniele.ceccarelli=[email-masked]>>; Jonas Ahlberg <[email-masked]<mailto:[email-masked]>>; CCAMP Working Group <[email-masked]<mailto:[email-masked]>>; ccamp <[email-masked]<mailto:[email-masked]>>
Subject: EXTERNAL: Re: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,

BR,
Amy

Thanks,

Daniele

Hi all,

Regards
Jonas A

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where: https://ietf.webex.com/ietf

Join by phone

---

From: Jonas Ahlberg <[email-masked]>
Date: Thu, 3 Oct 2019 06:44:13 +0000

Hi all,

Changing the meeting time works for me. My preference is to move it one hour earlier.

/JonasA

From: Stephen Cheng <[email-masked]>
Sent: den 2 oktober 2019 23:16
To: Yemin (Amy) <[email-masked]>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; Jonas Ahlberg <[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>; Xi Li <[email-masked]>; [email-masked]
Subject: RE: EXTERNAL: Re: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,

A couple of things:

Warm regards,
Stephen Cheng

Hi all,

BR,
Amy

Thanks,

Daniele

Hi all,

Regards
Jonas A

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where: https://ietf.webex.com/ietf

Join by phone

---

From: Dragos-Iulian Dosan <[email-masked]>
Date: Thu, 3 Oct 2019 06:48:14 +0000

Hi all,

                One hour earlier is fine for me as well.

Regards,
Dragos D.

From: Jonas Ahlberg <[email-masked]>
Sent: Thursday, October 3, 2019 9:44 AM
To: Stephen Cheng <[email-masked]>; Yemin (Amy) <[email-masked]>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>; Xi Li <[email-masked]>; Dragos-Iulian Dosan <[email-masked]>
Subject: Re: [CCAMP] EXTERNAL: Re: Webex meeting invitation: Microwave topology

Hi all,

/JonasA

From: Stephen Cheng <[email-masked]<mailto:[email-masked]>>
Sent: den 2 oktober 2019 23:16
To: Yemin (Amy) <[email-masked]<mailto:[email-masked]>>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:daniele.ceccarelli=[email-masked]>>; Jonas Ahlberg <[email-masked]<mailto:[email-masked]>>; CCAMP Working Group <[email-masked]<mailto:[email-masked]>>; ccamp <[email-masked]<mailto:[email-masked]>>; Xi Li <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: EXTERNAL: Re: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,

A couple of things:

Warm regards,
Stephen Cheng

Hi all,

BR,
Amy

Thanks,

Daniele

Hi all,

Regards
Jonas A

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where: https://ietf.webex.com/ietf

Join by phone

This email message and any attachments are intended solely for the use of the addressees hereof. 
This message and any attachments may contain information that is confidential, privileged and exempt from disclosure under applicable law.
If you are not the intended recipient of this message, you are prohibited from reading, disclosing, reproducing, distributing, disseminating or otherwise using this transmission.
If you have received this message in error, please promptly notify the sender at Ceragon by reply E-mail and immediately delete this message from your system.

---

From: "Spreafico, Daniela (Nokia - IT/Vimercate)" <[email-masked]>
Date: Thu, 3 Oct 2019 07:13:25 +0000

I agree to move 1 hour earlier.

BR, Daniela

From: CCAMP <[email-masked]> On Behalf Of Jonas Ahlberg
Sent: Thursday, October 3, 2019 8:44 AM
To: Stephen Cheng <[email-masked]>; Yemin (Amy) <[email-masked]>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>; Xi Li <[email-masked]>; [email-masked]
Subject: Re: [CCAMP] EXTERNAL: Re: Webex meeting invitation: Microwave topology

Hi all,

/JonasA

Hi all,

A couple of things:

Warm regards,
Stephen Cheng

Hi all,

BR,
Amy

Thanks,

Daniele

Hi all,

Regards
Jonas A

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where: https://ietf.webex.com/ietf

Join by phone

---

From: Stephen Cheng <[email-masked]>
Date: Thu, 3 Oct 2019 08:11:29 +0000

Thank you all. Would the call details be the same?

-------- Original message --------
From: "Spreafico, Daniela (Nokia - IT/Vimercate)" <[email-masked]>
Date: 3/10/19 20:13 (GMT+12:00)
To: Jonas Ahlberg <jonas.ahlberg=[email-masked]>, Stephen Cheng <[email-masked]>, "Yemin (Amy)" <[email-masked]>, Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>, CCAMP Working Group <[email-masked]>, ccamp <[email-masked]>, Xi Li <[email-masked]>, [email-masked]
Subject: RE: [CCAMP] EXTERNAL: Re: Webex meeting invitation: Microwave topology

BR, Daniela

Hi all,

/JonasA

Hi all,

A couple of things:

Warm regards,
Stephen Cheng

Hi all,

BR,
Amy

Thanks,

Daniele

Hi all,

Regards
Jonas A

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where: https://ietf.webex.com/ietf

Join by phone

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 3 Oct 2019 08:34:25 +0000

No, i’ve changed the scheduling on webex. 

You should have received an updated invitation by now.

BR

Daniele  

From: Stephen Cheng <[email-masked]> 
Sent: den 3 oktober 2019 10:11
To: Spreafico, Daniela (Nokia - IT/Vimercate) <[email-masked]>; Jonas Ahlberg <jonas.ahlberg=[email-masked]>; Yemin (Amy) <[email-masked]>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>; Xi Li <[email-masked]>; [email-masked]
Subject: Re: [CCAMP] EXTERNAL: Re: Webex meeting invitation: Microwave topology

 

-------- Original message --------

From: "Spreafico, Daniela (Nokia - IT/Vimercate)" <[email-masked] <mailto:[email-masked]> > 

To: Jonas Ahlberg <jonas.ahlberg=[email-masked] <mailto:jonas.ahlberg=[email-masked]> >, Stephen Cheng <[email-masked] <mailto:[email-masked]> >, "Yemin (Amy)" <[email-masked] <mailto:[email-masked]> >, Daniele Ceccarelli <daniele.ceccarelli=[email-masked] <mailto:daniele.ceccarelli=[email-masked]> >, CCAMP Working Group <[email-masked] <mailto:[email-masked]> >, ccamp <[email-masked] <mailto:[email-masked]> >, Xi Li <[email-masked] <mailto:[email-masked]> >, [email-masked] <mailto:[email-masked]>  

BR, Daniela

From: CCAMP <[email-masked] <mailto:[email-masked]> > On Behalf Of Jonas Ahlberg
Sent: Thursday, October 3, 2019 8:44 AM
To: Stephen Cheng <[email-masked] <mailto:[email-masked]> >; Yemin (Amy) <[email-masked] <mailto:[email-masked]> >; Daniele Ceccarelli <daniele.ceccarelli=[email-masked] <mailto:daniele.ceccarelli=[email-masked]> >; CCAMP Working Group <[email-masked] <mailto:[email-masked]> >; ccamp <[email-masked] <mailto:[email-masked]> >; Xi Li <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: [CCAMP] EXTERNAL: Re: Webex meeting invitation: Microwave topology

Hi all,

/JonasA

From: Stephen Cheng < <mailto:[email-masked]> [email-masked]> 
Sent: den 2 oktober 2019 23:16
To: Yemin (Amy) < <mailto:[email-masked]> [email-masked]>; Daniele Ceccarelli < <mailto:daniele.ceccarelli=[email-masked]> daniele.ceccarelli=[email-masked]>; Jonas Ahlberg < <mailto:[email-masked]> [email-masked]>; CCAMP Working Group < <mailto:[email-masked]> [email-masked]>; ccamp < <mailto:[email-masked]> [email-masked]>; Xi Li < <mailto:[email-masked]> [email-masked]>;  <mailto:[email-masked]> [email-masked]
Subject: RE: EXTERNAL: Re: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,

A couple of things:

2.	I have re-attached a copy of the modified YANG file I sent last week, for discussion. The changes from the original IETF -02 draft are:

a.       So that we could tell which link and which tp are microwave links and microwave tps

Warm regards,

Stephen Cheng

From: CCAMP < <mailto:[email-masked]> [email-masked]> On Behalf Of Yemin (Amy)
Sent: 2019年10月3日 9:59 AM
To: Daniele Ceccarelli < <mailto:daniele.ceccarelli=[email-masked]> daniele.ceccarelli=[email-masked]>; Jonas Ahlberg < <mailto:[email-masked]> [email-masked]>; CCAMP Working Group < <mailto:[email-masked]> [email-masked]>; ccamp < <mailto:[email-masked]> [email-masked]>
Subject: EXTERNAL: Re: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,  

BR,

Amy

  _____  

Thanks, very good input.

Thanks,

Daniele  

From: Jonas Ahlberg < <mailto:[email-masked]> [email-masked]> 
Sent: den 26 september 2019 15:05
To: CCAMP Working Group < <mailto:[email-masked]> [email-masked]>; ccamp < <mailto:[email-masked]> [email-masked]>
Subject: RE: [CCAMP] Webex meeting invitation: Microwave topology

Hi all,

Regards

Jonas A

-----Original Appointment-----
From: CCAMP Working Group < <mailto:[email-masked]> [email-masked]> 
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where:  <https://ietf.webex.com/ietf> https://ietf.webex.com/ietf

 

 

 

 <https://ietf.webex.com/ietf/j.php?MTID=ma65a6a5186962890ec535e711ec3d3f9> Join

Join by phone

 <tel:%2B1-650-479-3208,,*01*647343270%23%23*01*> 1-650-479-3208 Call-in toll number (US/Canada)

 <tel:1-877-668-4493,,*01*647343270%23%23*01*> 1-877-668-4493 Call-in toll free number (US/Canada)

 <https://ietf.webex.com/ietf/globalcallin.php?MTID=m57c83575d64804b110f94f798d438720> Global call-in numbers  |   <https://www.webex.com/pdf/tollfree_restrictions.pdf> Toll-free calling restrictions

 

Need help? Go to  <http://help.webex.com> http://help..webex.com

---

From: "Spreafico, Daniela (Nokia - IT/Vimercate)" <[email-masked]>
Date: Thu, 3 Oct 2019 08:37:22 +0000

The meeting is anticipated starting from today?

BR, Daniela

From: Stephen Cheng <[email-masked]>
Sent: Thursday, October 3, 2019 10:11 AM
To: Spreafico, Daniela (Nokia - IT/Vimercate) <[email-masked]>; Jonas Ahlberg <jonas.ahlberg=[email-masked]>; Yemin (Amy) <[email-masked]>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>; Xi Li <[email-masked]>; [email-masked]
Subject: Re: [CCAMP] EXTERNAL: Re: Webex meeting invitation: Microwave topology

-------- Original message --------
From: "Spreafico, Daniela (Nokia - IT/Vimercate)" <[email-masked]<mailto:[email-masked]>>
Date: 3/10/19 20:13 (GMT+12:00)
To: Jonas Ahlberg <jonas.ahlberg=[email-masked]<mailto:jonas.ahlberg=[email-masked]>>, Stephen Cheng <[email-masked]<mailto:[email-masked]>>, "Yemin (Amy)" <[email-masked]<mailto:[email-masked]>>, Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:daniele.ceccarelli=[email-masked]>>, CCAMP Working Group <[email-masked]<mailto:[email-masked]>>, ccamp <[email-masked]<mailto:[email-masked]>>, Xi Li <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Subject: RE: [CCAMP] EXTERNAL: Re: Webex meeting invitation: Microwave topology

BR, Daniela

From: CCAMP <[email-masked]<mailto:[email-masked]>> On Behalf Of Jonas Ahlberg
Sent: Thursday, October 3, 2019 8:44 AM
To: Stephen Cheng <[email-masked]<mailto:[email-masked]>>; Yemin (Amy) <[email-masked]<mailto:[email-masked]>>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:daniele.ceccarelli=[email-masked]>>; CCAMP Working Group <[email-masked]<mailto:[email-masked]>>; ccamp <[email-masked]<mailto:[email-masked]>>; Xi Li <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [CCAMP] EXTERNAL: Re: Webex meeting invitation: Microwave topology

Hi all,

/JonasA

Hi all,

A couple of things:

Warm regards,
Stephen Cheng

Hi all,

BR,
Amy

Thanks,

Daniele

Hi all,

Regards
Jonas A

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 20 augusti 2019 07:46
To: CCAMP Working Group; ccamp
Subject: [CCAMP] Webex meeting invitation: Microwave topology
When: den 26 september 2019 07:00-08:00 America/New_York.
Where: https://ietf.webex.com/ietf

Join by phone