Subject: Re: [CCAMP] Microwave topology

From: Jonas Ahlberg <[email-masked]>
Date: Thu, 3 Oct 2019 12:16:55 +0000

Hi all,

Short notes from our discussion today.

Please remember that the meeting time has been changed.

  *   The meeting continued the discussion about the applicability of te-topology concepts and the benefits of augmenting te-topology v.s. network-topology. The meeting concluded that most of the discussions require a refinement/clarification of the use cases to be supported by the model. It was decided that it should be the focus for the coming week and be discussed and agreed on the next meeting.
  *   The use cases mentioned (and which need to be further refined) are:
     *   L1 microwave radio link topology discovery
        *   Illustrate how radio link topology can co-exist with other L1 technologies
     *   End-to-end L2 service creation over a L1 topologies, including microwave radio link and L1 connectivity for interconnection between the radio links
        *   Show cases with and without bandwidth reservation
     *   Use case showing how microwave radio link could support higher order layers such IP/MPLS (other than L2).

Attached is a presentation showing earlier discussions about use-cases.

/JonasA

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]>
Sent: den 3 oktober 2019 12:00
To: CCAMP Working Group; ccamp
Subject: Microwave topology
When: den 3 oktober 2019 06:00-07:00 America/New_York.
Where: https://ietf.webex.com/ietf

When it's time, join the Webex meeting here.

Meeting number (access code): 647 343 270

Meeting password:
D7dhCJpZ

Join<https://ietf.webex.com/ietf/j.php?MTID=ma65a6a5186962890ec535e711ec3d3f9>

Join by phone
1-650-479-3208<tel:%2B1-650-479-3208,,*01*647343270%23%23*01*> Call-in toll number (US/Canada)
1-877-668-4493<tel:1-877-668-4493,,*01*647343270%23%23*01*> Call-in toll free number (US/Canada)
Global call-in numbers<https://ietf.webex.com/ietf/globalcallin.php?MTID=m57c83575d64804b110f94f798d438720>  |  Toll-free calling restrictions<https://www.webex.com/pdf/tollfree_restrictions.pdf>

Need help? Go to http://help.webex.com

---

From: Jonas Ahlberg <[email-masked]>
Date: Sun, 6 Oct 2019 15:05:40 +0000

Hi all,

I have created an example which I hope can be used as a basis for the continued discussion. See attachment.
I've also added a few questions which I believe are important to discuss in order to create a better understanding of how we best model the unique characteristics of a microwave radio link.

Regards
JonasA

From: CCAMP <[email-masked]> On Behalf Of Jonas Ahlberg
Sent: den 3 oktober 2019 14:17
To: CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Subject: Re: [CCAMP] Microwave topology

Hi all,

/JonasA

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 3 oktober 2019 12:00
To: CCAMP Working Group; ccamp
Subject: Microwave topology
When: den 3 oktober 2019 06:00-07:00 America/New_York.
Where: https://ietf.webex.com/ietf

Meeting password:
D7dhCJpZ

Join by phone

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 7 Oct 2019 08:41:05 +0000

Hi Jonas,

Could you please elaborate this question a bit more?

"When creating a TE connection (LSP), should all necessary information
(bandwidth, latency, availability, etc) be available in the 1st level
resources used (IGP Links), or should the PCE always query all underlaying
layers for additional information?"

Are you referring to a multilayer scenario in which the IP/MPLS link is the
client and there is a number of physical layers below? If my understanding
is correct I would say that the info needs to be available at the client
layer as the PCE might not have the capability to retrieve the information
from the lower layers (and in many cases doesn't have awareness at all of
them).

Cheers,

Daniele  

From: Jonas Ahlberg <[email-masked]> 
Sent: den 6 oktober 2019 17:06
To: CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Subject: RE: [CCAMP] Microwave topology

Hi all,

I have created an example which I hope can be used as a basis for the
continued discussion. See attachment.

I've also added a few questions which I believe are important to discuss in
order to create a better understanding of how we best model the unique
characteristics of a microwave radio link.

Regards

JonasA

From: CCAMP <[email-masked] <mailto:[email-masked]> > On
Behalf Of Jonas Ahlberg
Sent: den 3 oktober 2019 14:17
To: CCAMP Working Group <[email-masked]
<mailto:[email-masked]> >; ccamp <[email-masked]
<mailto:[email-masked]> >
Subject: Re: [CCAMP] Microwave topology

Hi all,

*	The meeting continued the discussion about the applicability of
te-topology concepts and the benefits of augmenting te-topology v.s.
network-topology. The meeting concluded that most of the discussions require
a refinement/clarification of the use cases to be supported by the model. It
was decided that it should be the focus for the coming week and be discussed
and agreed on the next meeting.
*	The use cases mentioned (and which need to be further refined) are:

*	Illustrate how radio link topology can co-exist with other L1
technologies

*	End-to-end L2 service creation over a L1 topologies, including
microwave radio link and L1 connectivity for interconnection between the
radio links

*	Use case showing how microwave radio link could support higher order
layers such IP/MPLS (other than L2).

/JonasA

-----Original Appointment-----
From: CCAMP Working Group < <mailto:[email-masked]>
[email-masked]> 
Sent: den 3 oktober 2019 12:00
To: CCAMP Working Group; ccamp
Subject: Microwave topology
When: den 3 oktober 2019 06:00-07:00 America/New_York.
Where:  <https://ietf.webex.com/ietf> https://ietf.webex.com/ietf

 

Meeting password:

D7dhCJpZ

 <https://ietf.webex.com/ietf/j.php?MTID=ma65a6a5186962890ec535e711ec3d3f9>
Join

  
Join by phone   
 <tel:%2B1-650-479-3208,,*01*647343270%23%23*01*> 1-650-479-3208 Call-in
toll number (US/Canada)   
 <tel:1-877-668-4493,,*01*647343270%23%23*01*> 1-877-668-4493 Call-in toll
free number (US/Canada)   
 
<https://ietf.webex.com/ietf/globalcallin.php?MTID=m57c83575d64804b110f94f79
8d438720> Global call-in numbers  |
<https://www.webex.com/pdf/tollfree_restrictions.pdf> Toll-free calling
restrictions  

 

Need help? Go to  <http://help.webex.com> http://help.webex.com

---

From: Jonas Ahlberg <[email-masked]>
Date: Mon, 7 Oct 2019 08:50:32 +0000

Hi Daniele,

Your interpretation of what I tried to say is correct.

I think you have described it in a better and more clear way. Thanks!

/JonasA

From: Daniele Ceccarelli <[email-masked]> 
Sent: den 7 oktober 2019 10:41
To: Jonas Ahlberg <[email-masked]>; CCAMP Working Group
<[email-masked]>; ccamp <[email-masked]>
Subject: RE: [CCAMP] Microwave topology

Hi Jonas,

Cheers,

Daniele  

From: Jonas Ahlberg <[email-masked]
<mailto:[email-masked]> > 
Sent: den 6 oktober 2019 17:06
To: CCAMP Working Group <[email-masked]
<mailto:[email-masked]> >; ccamp <[email-masked]
<mailto:[email-masked]> >
Subject: RE: [CCAMP] Microwave topology

Hi all,

Regards

JonasA

From: CCAMP < <mailto:[email-masked]> [email-masked]> On
Behalf Of Jonas Ahlberg
Sent: den 3 oktober 2019 14:17
To: CCAMP Working Group < <mailto:[email-masked]>
[email-masked]>; ccamp < <mailto:[email-masked]> [email-masked]>
Subject: Re: [CCAMP] Microwave topology

Hi all,

/JonasA

-----Original Appointment-----

 

Meeting password:

D7dhCJpZ

 
  
Join by phone

---

From: Stephen Cheng <[email-masked]>
Date: Thu, 17 Oct 2019 04:52:17 +0000

Jonas,

A few questions/comments regarding your powerpoint slides:

  1.  In your Basic Network Structure slide, are IF33-IF43 and IF34-IF44 copper Ethernet cables?
  2.  In your Basic Network Structure slide, IF 12 etc are shown in L1 topology as well as L2 topology. However in ietf-interface terms, it would be represented as 2 separate interfaces of Layer 1 and Layer 2 respectively, with the Layer 2 interface being a higher layer interface of the Layer 1 interface.
  3.  LAG is a L2 construct and not L1 construct. For LAG to work, the component interfaces/links must be layer 2 interfaces/links.
  4.  There is no need to show RLT-xx and IF-xx separate. RLT is simply a special type of interface.

I have made some modifications to the Basic Network Slides to demonstrate the above concepts. I have also extended the LAG interface to combine 2xEthernet cable links and 1xmicrowave link.

I have not yet modified the Service Structure Slide accordingly.

I have a question regarding your expectation of the PCE in the Service Structure Slide. Do you expect the PCE to work within a domain or cross-domain? From my understanding there are multiple PCE architectures that could be applicable (see RFC 4655). Depending on the type of PCE architecture, the answer to your question might be different.

Warm regards,
Stephen Cheng

From: CCAMP <[email-masked]> On Behalf Of Jonas Ahlberg
Sent: 2019年10月7日 4:06 AM
To: CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Subject: EXTERNAL: Re: [CCAMP] Microwave topology

Hi all,

I have created an example which I hope can be used as a basis for the continued discussion. See attachment.
I’ve also added a few questions which I believe are important to discuss in order to create a better understanding of how we best model the unique characteristics of a microwave radio link.

Regards
JonasA

From: CCAMP <[email-masked]<mailto:[email-masked]>> On Behalf Of Jonas Ahlberg
Sent: den 3 oktober 2019 14:17
To: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>; ccamp <[email-masked]<mailto:[email-masked]>>
Subject: Re: [CCAMP] Microwave topology

Hi all,

/JonasA

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 3 oktober 2019 12:00
To: CCAMP Working Group; ccamp
Subject: Microwave topology
When: den 3 oktober 2019 06:00-07:00 America/New_York.
Where: https://ietf.webex.com/ietf

Meeting password:
D7dhCJpZ

Join by phone

---

From: Jonas Ahlberg <[email-masked]>
Date: Thu, 17 Oct 2019 06:58:06 +0000

Hi Stephen,

I’m fine with your changes. Let’s use your updated slide as a basis for our discussion.
See additional comments in line below.

Regards
JonasA

From: Stephen Cheng <[email-masked]>
Sent: den 17 oktober 2019 06:52
To: Jonas Ahlberg <[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Subject: RE: EXTERNAL: Re: [CCAMP] Microwave topology

Jonas,

  1.  In your Basic Network Structure slide, are IF33-IF43 and IF34-IF44 copper Ethernet cables?
[JonasA] Yes, that was my intention.
  2.  In your Basic Network Structure slide, IF 12 etc are shown in L1 topology as well as L2 topology. However in ietf-interface terms, it would be represented as 2 separate interfaces of Layer 1 and Layer 2 respectively, with the Layer 2 interface being a higher layer interface of the Layer 1 interface.
[JonasA] OK
  3.  LAG is a L2 construct and not L1 construct. For LAG to work, the component interfaces/links must be layer 2 interfaces/links.
[JonasA] Yes, you are right.
  4.  There is no need to show RLT-xx and IF-xx separate. RLT is simply a special type of interface.
[JonasA] Yes, that’s true. I just wanted to highlight that they were RLT type of interfaces.

I have made some modifications to the Basic Network Slides to demonstrate the above concepts. I have also extended the LAG interface to combine 2xEthernet cable links and 1xmicrowave link.
[JonasA] I don’t think this is a configuration used very much in reality, but it could still be used as a validation of how well the model supports a combination of different technologies.

I have a question regarding your expectation of the PCE in the Service Structure Slide. Do you expect the PCE to work within a domain or cross-domain? From my understanding there are multiple PCE architectures that could be applicable (see RFC 4655). Depending on the type of PCE architecture, the answer to your question might be different.
[JonasA] In the Service Structure Slide example my assumption was that one single PCE is performing the computation end-to-end, i.e. from node 1 to node 4. I believe that the model needs to support all PCE architectures. Or do you think we can limit the scope to a subset of PCE architectures?

Warm regards,
Stephen Cheng

Hi all,

Regards
JonasA

Hi all,

/JonasA

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 3 oktober 2019 12:00
To: CCAMP Working Group; ccamp
Subject: Microwave topology
When: den 3 oktober 2019 06:00-07:00 America/New_York.
Where: https://ietf.webex.com/ietf

Meeting password:
D7dhCJpZ

Join by phone