Subject: [CCAMP] Microwave topology Notes from October 17

From: Jonas Ahlberg <[email-masked]>
Date: Thu, 17 Oct 2019 12:50:11 +0000

Hi all,

Short notes from our discussion today.

The meeting continued the discussion about the relevant use cases and the underlying network structures to consider in the work going forward.

  *   It was clarified that the main purpose of the slides created by Jonas and updated by Stephen is to elaborate the use cases and put them into a context of what the underlying network structures/layers could look like.
     *   There was a discussion about the need for and how one instance of a topology model could support multiple L1 technologies. To be continued ...
     *   Another topic discussed was how the information in a microwave topology model on L1, e.g. about availability and current bandwidth, should be made available to a PCE. Should the information be propagated in the hierarchy of layers and become accessible in the resources used directly by the PCE, or should the PCE have knowledge about when to drill down in the hierarchy of layers to get access to the information. To be continued ...
     *   There is currently only one service creation example in the slide pack and it illustrates the creation of a TE LSP and its relation to underlying resources and the supported service. There is a need to create other examples, e.g. for non-TE bridge type of services.
  *   It was decided the we should continue the discussion and the elaboration of the use cases at the meeting next week.
Until then, contributions / discussion via mail are encouraged.

Regards
JonasA

From: CCAMP <[email-masked]> On Behalf Of Jonas Ahlberg
Sent: den 3 oktober 2019 14:17
To: CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Subject: Re: [CCAMP] Microwave topology

Hi all,

Short notes from our discussion today.

Please remember that the meeting time has been changed.

  *   The meeting continued the discussion about the applicability of te-topology concepts and the benefits of augmenting te-topology v.s. network-topology. The meeting concluded that most of the discussions require a refinement/clarification of the use cases to be supported by the model. It was decided that it should be the focus for the coming week and be discussed and agreed on the next meeting.
  *   The use cases mentioned (and which need to be further refined) are:
     *   L1 microwave radio link topology discovery
        *   Illustrate how radio link topology can co-exist with other L1 technologies
     *   End-to-end L2 service creation over a L1 topologies, including microwave radio link and L1 connectivity for interconnection between the radio links
        *   Show cases with and without bandwidth reservation
     *   Use case showing how microwave radio link could support higher order layers such IP/MPLS (other than L2).

Attached is a presentation showing earlier discussions about use-cases.

/JonasA

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 3 oktober 2019 12:00
To: CCAMP Working Group; ccamp
Subject: Microwave topology
When: den 3 oktober 2019 06:00-07:00 America/New_York.
Where: https://ietf.webex.com/ietf

When it's time, join the Webex meeting here.

Meeting number (access code): 647 343 270

Meeting password:
D7dhCJpZ

Join<https://ietf.webex.com/ietf/j.php?MTID=ma65a6a5186962890ec535e711ec3d3f9>

Join by phone
1-650-479-3208<tel:%2B1-650-479-3208,,*01*647343270%23%23*01*> Call-in toll number (US/Canada)
1-877-668-4493<tel:1-877-668-4493,,*01*647343270%23%23*01*> Call-in toll free number (US/Canada)
Global call-in numbers<https://ietf.webex.com/ietf/globalcallin.php?MTID=m57c83575d64804b110f94f798d438720>  |  Toll-free calling restrictions<https://www.webex.com/pdf/tollfree_restrictions.pdf>

Need help? Go to http://help.webex.com

---

From: Stephen Cheng <[email-masked]>
Date: Thu, 24 Oct 2019 00:32:16 +0000

Hi all,

I have cleaned up the network structure slides as follow:

  1.  Take account of Amy’s comment of having L2 on top of L1, rather than the other way round
  2.  Added a L2 switch to connect 2 (or more) radios. This is a common network setup in a larger radio site
  3.  Added a separate L2 structure slide (slide 5), to make it easier to read
  4.  Added a L3 structure slide (slide 7), so that IP/MPLS service structure slide can be layered on top
  5.  Cleaned up IP/MPLS service structure (slide 8) and bridging service structure (slide 9) slide to align with L1/L2/L3 structure slides

IMO there is a use case for a L1 topology instance that supports multiple technologies. If not we cannot model the L1 Structure (Slide 3 in slide-deck) with a single topology instance. The very fact that we are drawing the L1 topology in the slide deck indicate that it is a valuable use case, even if it is just for communication. My argument is that we don’t draw the L1 Structure as 3 separate diagrams (as per slide 4), so why should we model it as 3 separate topology instances? I have created slides 4 and 6 to illustrate this argument.

I hope this would help in our further discussion of the use cases.

Also I agree to delay the meeting today, due to key participants not able to join.

Warm regards,
Stephen Cheng

From: CCAMP <[email-masked]> On Behalf Of Jonas Ahlberg
Sent: 2019年10月18日 1:50 AM
To: CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Subject: EXTERNAL: [CCAMP] Microwave topology Notes from October 17

Hi all,

  *   It was clarified that the main purpose of the slides created by Jonas and updated by Stephen is to elaborate the use cases and put them into a context of what the underlying network structures/layers could look like.
     *   There was a discussion about the need for and how one instance of a topology model could support multiple L1 technologies. To be continued …
     *   Another topic discussed was how the information in a microwave topology model on L1, e.g. about availability and current bandwidth, should be made available to a PCE. Should the information be propagated in the hierarchy of layers and become accessible in the resources used directly by the PCE, or should the PCE have knowledge about when to drill down in the hierarchy of layers to get access to the information. To be continued …
     *   There is currently only one service creation example in the slide pack and it illustrates the creation of a TE LSP and its relation to underlying resources and the supported service. There is a need to create other examples, e.g. for non-TE bridge type of services.
  *   It was decided the we should continue the discussion and the elaboration of the use cases at the meeting next week.
Until then, contributions / discussion via mail are encouraged.

Regards
JonasA

From: CCAMP <[email-masked]<mailto:[email-masked]>> On Behalf Of Jonas Ahlberg
Sent: den 3 oktober 2019 14:17
To: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>; ccamp <[email-masked]<mailto:[email-masked]>>
Subject: Re: [CCAMP] Microwave topology

Hi all,

/JonasA

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 3 oktober 2019 12:00
To: CCAMP Working Group; ccamp
Subject: Microwave topology
When: den 3 oktober 2019 06:00-07:00 America/New_York.
Where: https://ietf.webex.com/ietf

Meeting password:
D7dhCJpZ

Join by phone

---

From: Oscar González de Dios <[email-masked]>
Date: Thu, 24 Oct 2019 10:02:03 +0000

Hi guys,

        Thanks for the clarifying slides. I have some questions/suggestions:

·         The L2 topology shown in slide 5 can be modeled using the L2 topology model (https://tools.ietf.org/html/draft-ietf-i2rs-yang-l2-network-topology-12 ). Note that in the latest version -12 there is also the possibility to model the LAG. Hence, both point-to-point Ethernet links and lags are modeled. Thus, the “hierarchy” of models (slide 2) could also include l2-network topology (which will be supported over the L1-microwave & L1-fiber)

·         Client interfaces? In the slide 3 (the one of the full network) shows the interface that connects to the client in node 1 (typically there would be a base station connected). I am wondering if that interface should appear or not in the L1-topology. In routers typically we distinguish between the interfaces that belong to the “base router” that you use to connect to other routers, and the client interfaces that you use to set up services. Those will be later attached to VRFs. So, in my opinion, it would be a good idea to have a separate L1 view with that contains the client interfaces (supported by the base L1 topology which contains the node).

·         Modeling of L2 switch vs routers. It was very nice to clearly identify in the scenario that there are nodes which are L2 switches and nodes that are routers.   How is this modeled? Besides having L3 nodes being supported by the L2 nodes and that some L2 nodes are not supporting anything. The ietf-L2 topology is focused on the connections between nodes.

Best Regards,

                Oscar

De: Stephen Cheng <[email-masked]>
Enviado el: jueves, 24 de octubre de 2019 2:32
Para: Jonas Ahlberg <jonas.ahlberg=[email-masked]>; CCAMP Working Group <[email-masked]>; ccamp <[email-masked]>
Asunto: RE: EXTERNAL: [CCAMP] Microwave topology Notes from October 17

Hi all,

Warm regards,
Stephen Cheng

Hi all,

-          It was clarified that the main purpose of the slides created by Jonas and updated by Stephen is to elaborate the use cases and put them into a context of what the underlying network structures/layers could look like.
o   There was a discussion about the need for and how one instance of a topology model could support multiple L1 technologies. To be continued …
o   Another topic discussed was how the information in a microwave topology model on L1, e.g. about availability and current bandwidth, should be made available to a PCE. Should the information be propagated in the hierarchy of layers and become accessible in the resources used directly by the PCE, or should the PCE have knowledge about when to drill down in the hierarchy of layers to get access to the information. To be continued …
o   There is currently only one service creation example in the slide pack and it illustrates the creation of a TE LSP and its relation to underlying resources and the supported service. There is a need to create other examples, e.g. for non-TE bridge type of services.
-          It was decided the we should continue the discussion and the elaboration of the use cases at the meeting next week.
Until then, contributions / discussion via mail are encouraged.

Regards
JonasA

Hi all,

-          The meeting continued the discussion about the applicability of te-topology concepts and the benefits of augmenting te-topology v.s. network-topology. The meeting concluded that most of the discussions require a refinement/clarification of the use cases to be supported by the model. It was decided that it should be the focus for the coming week and be discussed and agreed on the next meeting.
-          The use cases mentioned (and which need to be further refined) are:
o   L1 microwave radio link topology discovery
§  Illustrate how radio link topology can co-exist with other L1 technologies
o   End-to-end L2 service creation over a L1 topologies, including microwave radio link and L1 connectivity for interconnection between the radio links
§  Show cases with and without bandwidth reservation
o   Use case showing how microwave radio link could support higher order layers such IP/MPLS (other than L2).

/JonasA

-----Original Appointment-----
From: CCAMP Working Group <[email-masked]<mailto:[email-masked]>>
Sent: den 3 oktober 2019 12:00
To: CCAMP Working Group; ccamp
Subject: Microwave topology
When: den 3 oktober 2019 06:00-07:00 America/New_York.
Where: https://ietf.webex.com/ietf

Meeting password:
D7dhCJpZ

Join by phone

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição