Subject: [CCAMP] Thoughts on Flex-E YANG models

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 22 Nov 2019 15:00:50 +0000

Hi,

I have some general thoughts on modelling Flex-E in YANG that may help the authors converge.  These comments mostly relate to what I would call the overall shape of the YANG model rather specific configuration (which I think can probably be sorted out once the shape has been agreed).

  1.  Flex-E groups should be identified by their group-number (both models seem to do this, but the group number seems to be optional in one model)
  2.  The configuration to identify the bonded phys should be under the flex-e group (both models do this).
  3.  In the flex-e group's bonded-phy interface configuration list, bonded-phy interface list entries could be keyed either by the bonded phy interface name, or the flex-e phy number.
     *   I would suggest that the bonded-phy interface name is the more meaningful identifier to clients.
     *   Either way, the entries should also indicate the binding to the bonded-phy interface (e.g. by an interface-ref - both models seem to do this).
  4.  The configuration required to define the client interfaces associated with a flex-e group should be under the flex-e group list entry, based on the assumption that that 16 bit client id must be unique within the group rather than across groups.
  5.  In the flex-e group's client interface configuration list, client interface list entries could be keyed either by the client interface name, or the client id.
     *   Again, I would suggest that using the client interface name is the more meaningful identifier for clients.
     *   Either way, the entries should also indicate the binding to the client interface (by interface-ref - both models seem to do this).
  6.  Client interfaces should be modelled as regular interfaces, and use the normal iftype for Ethernet interfaces, i.e. the dubiously named iftype:ethernetCsmacd.  Without using this type regular Ethernet YANG configuration (e.g. as defined in 802.3.2) won't work properly.
     *   I don't think that there should be flex-e specific configuration under the client interface itself, instead, the flex-e specific configuration should be defined as part of the group + client interfaces.

But I think that the main issue to resolve is whether Flex-E group configuration is global or scoped to a FlexE group interface.  I can see pros and cons both ways:

  1.  Putting the configuration under an FlexE group interface seems like a slightly artificial construct.
  2.  However, this does mirror how LAG interfaces are represented (at least in our vendor model), and in some ways FlexE interfaces could be considered to be like an L1 LAG interface.  However, in the LAG case, the LAG interface can forward traffic, where as for FlexE groups, this would not be the case.
  3.  There is probably a natural binding between a FlexE group and the client interfaces that closely relates to the parent child relationship between an interface and sub-interface.  E.g. disabling a FlexE group should have the effect of disabling each FlexE client interface.
  4.  My overall feeling is that representing the FlexE groups as a type of interface seems like a reasonable configuration model.

Anyway, hopefully these comments are useful to help the two sets of authors converge towards a common model.  I have other suggestions on the specific models but would suggest solving the big picture issues first.

Regards,
Rob

---

From: Jiangyuanlong <[email-masked]>
Date: Mon, 25 Nov 2019 03:54:12 +0000

Hi Rob,

Thank you  a lot for your comments, they are very helpful.
Please see my further comments inline.

Cheers,
Yuanlong

From: CCAMP [mailto:[email-masked]] On Behalf Of Rob Wilton (rwilton)
Sent: Friday, November 22, 2019 11:01 PM
To: [email-masked]
Subject: [CCAMP] Thoughts on Flex-E YANG models

Hi,

[Jiang] Agreed to both.

  1.  In the flex-e group's bonded-phy interface configuration list, bonded-phy interface list entries could be keyed either by the bonded phy interface name, or the flex-e phy number.
     *   I would suggest that the bonded-phy interface name is the more meaningful identifier to clients.
[Jiang] Just to be clear, are your saying that the list of flexe-phy should be keyed by the interface name? I think in our model, current key "flexe-phy-if" is exactly the PHY interface name, as shown in RFC 8343:
"     typedef interface-ref {
       type leafref {
         path "/if:interfaces/if:interface/if:name";
"

     *   Either way, the entries should also indicate the binding to the bonded-phy interface (e.g. by an interface-ref - both models seem to do this).
  1.  The configuration required to define the client interfaces associated with a flex-e group should be under the flex-e group list entry, based on the assumption that that 16 bit client id must be unique within the group rather than across groups.
[Jiang] Totally agreed.

  1.  In the flex-e group's client interface configuration list, client interface list entries could be keyed either by the client interface name, or the client id.
     *   Again, I would suggest that using the client interface name is the more meaningful identifier for clients.
[Jiang] Earlier we already planned to use "flexe-client-if" as the key to flexe-client-list. Could this resolve your comment?

     *   Either way, the entries should also indicate the binding to the client interface (by interface-ref - both models seem to do this).
  1.  Client interfaces should be modelled as regular interfaces, and use the normal iftype for Ethernet interfaces, i.e. the dubiously named iftype:ethernetCsmacd.  Without using this type regular Ethernet YANG configuration (e.g. as defined in 802.3.2) won't work properly.
     *   I don't think that there should be flex-e specific configuration under the client interface itself, instead, the flex-e specific configuration should be defined as part of the group + client interfaces.
[Jiang] Agreed to bullet a). But I have some doubts whether we can use the normal iftype for Ethernet interfaces directly. As FlexE Client includes only a thin MAC layer, while PHY layer is decoupled into the FlexE PHY, FlexE client management should be simpler than the regular Ethernet YANG configuration, furthermore, it seems to me all the YANG models defined in 802.3 or 802.2 more or less include some PHY configuration which cannot be applied to a FlexE client. Nevertheless, we look forward to seeing more discussions on this topic.

But I think that the main issue to resolve is whether Flex-E group configuration is global or scoped to a FlexE group interface..  I can see pros and cons both ways:

[Jiang] Totally agreed.

Anyway, hopefully these comments are useful to help the two sets of authors converge towards a common model.  I have other suggestions on the specific models but would suggest solving the big picture issues first.
[Jiang] Very useful indeed, we look forward to your further suggestions on the models.

Regards,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 25 Nov 2019 15:39:37 +0000

Hi Yuanlong,

Please see [RW] comments inline ...

From: Jiangyuanlong <[email-masked]>
Sent: 25 November 2019 03:54
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: RE: Thoughts on Flex-E YANG models

Hi Rob,

Cheers,
Yuanlong

From: CCAMP [mailto:[email-masked]] On Behalf Of Rob Wilton (rwilton)
Sent: Friday, November 22, 2019 11:01 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [CCAMP] Thoughts on Flex-E YANG models

Hi,

a.      I would suggest that the bonded-phy interface name is the more meaningful identifier to clients.
[RW]
Yes.

b.      Either way, the entries should also indicate the binding to the bonded-phy interface (e.g. by an interface-ref - both models seem to do this).
4.      The configuration required to define the client interfaces associated with a flex-e group should be under the flex-e group list entry, based on the assumption that that 16 bit client id must be unique within the group rather than across groups.
[Jiang] Totally agreed.

5.      In the flex-e group's client interface configuration list, client interface list entries could be keyed either by the client interface name, or the client id.
a.      Again, I would suggest that using the client interface name is the more meaningful identifier for clients.
[Jiang] Earlier we already planned to use "flexe-client-if" as the key to flexe-client-list. Could this resolve your comment?
[RW]
Yes, I think so.  It would be an interface-ref, similar to bonded-phy interface-ref.

However, I think that there is probably a slight difference in semantics:

In the case of the interface-ref for bonded phys, semantically it should probably be "require-instance true" (which is the default behaviour).  I.e. for the flex group configuration to be valid, it makes sense for the referenced bonded-phy interfaces to also exist in the configuration.

But in the case of the interface-ref for client interfaces, I think that it should be "require-instance false".  This is because the flex-e client interface configuration defines the parameters to create the client interface but should not require that the client interface to exist in the configuration at the same time (even if that may often be the case).

b.      Either way, the entries should also indicate the binding to the client interface (by interface-ref - both models seem to do this).
6.      Client interfaces should be modelled as regular interfaces, and use the normal iftype for Ethernet interfaces, i.e. the dubiously named iftype:ethernetCsmacd.  Without using this type regular Ethernet YANG configuration (e.g. as defined in 802.3.2) won't work properly.
a.      I don't think that there should be flex-e specific configuration under the client interface itself, instead, the flex-e specific configuration should be defined as part of the group + client interfaces.
[Jiang] Agreed to bullet a). But I have some doubts whether we can use the normal iftype for Ethernet interfaces directly. As FlexE Client includes only a thin MAC layer, while PHY layer is decoupled into the FlexE PHY, FlexE client management should be simpler than the regular Ethernet YANG configuration, furthermore, it seems to me all the YANG models defined in 802.3 or 802.2 more or less include some PHY configuration which cannot be applied to a FlexE client. Nevertheless, we look forward to seeing more discussions on this topic.
[RW]
>From the rest of the system perspective, a client interface really should look/feel like a regular physical Ethernet interface, and I think that the majority of the 802.3.2 configuration/statistics should apply.  Auto-neg, duplex, speed shouldn't be configurable, but then they can't be configured on most higher speed optical interfaces anyway.  I would have thought that the rest of the module should apply (otherwise this Ethernet configuration would need to be duplicated in another module, which isn't ideal).

[RW]
Note, I have made an assumption here that it is reasonable to represent the L1 layer of an interface as an entry in if:interfaces/if:interface.  It is worth noting that not all configuration/state in ietf-interfaces would apply sensibly to an L1 interface representation.  In particular, none of the statistics would seem to apply to the physical layer.

Anyway, hopefully these comments are useful to help the two sets of authors converge towards a common model.  I have other suggestions on the specific models but would suggest solving the big picture issues first.
[Jiang] Very useful indeed, we look forward to your further suggestions on the models.
[RW]
Thanks.  It would also be useful to see comments from other members of the WG, in particular, the authors of the draft-xiaobn-ccamp-flexe-yang-mod-03.

In case it helps, here is the pyang tree output of the structure that I believe is most suitable to represent Flex-E interfaces:

module: ietf-if-flex-e
  augment /if:interfaces/if:interface:
    +--rw flex-e
       +--rw group
          +--rw group-number              uint32
          +--rw more-group-config-here?   string
          +--rw bonded-phy* [name]
          |  +--rw name                           if:interface-ref
          |  +--rw phy-number?                    uint8
          |  +--rw more-bonded-phy-config-here?   string
          +--rw client-interface* [name]
             +--rw name                              if:interface-ref
             +--rw id?                               uint16
             +--rw more-flex-e-client-config-here?   String

I don't know whether phy-number and id should be mandatory.  I.e. always defined, or whether it is feasible that these could be automatically allocated by the device.

Of course, I have excluded any specific configuration options.  I would suggest trying to get agreement on the overall structure (i.e. the shape of the YANG model) first.

The YANG model that this is built from is available at: https://github.com/rgwilton/flex-e-yang/blob/master/ietf-if-flex-e.yang

Regards,
Rob

Regards,
Rob

---

From: Jiangyuanlong <[email-masked]>
Date: Tue, 26 Nov 2019 03:05:02 +0000

Rob,

I believe we are quite aligned in the abstract structure of the FlexE model.
Please see my further comments inline prefixed with [Jiang1].

Thanks again,
Yuanlong

From: Rob Wilton (rwilton) [mailto:[email-masked]]
Sent: Monday, November 25, 2019 11:40 PM
To: Jiangyuanlong <[email-masked]>; [email-masked]
Subject: RE: Thoughts on Flex-E YANG models

Hi Yuanlong,

From: Jiangyuanlong <[email-masked]<mailto:[email-masked]>>
Sent: 25 November 2019 03:54
To: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Thoughts on Flex-E YANG models

Hi Rob,

Cheers,
Yuanlong

Hi,

[Jiang1] Agreed. My colleague Italo also expressed such an opinion during ITU-T Q14/SG15 interim meeting not long ago.

>From the rest of the system perspective, a client interface really should look/feel like a regular physical Ethernet interface, and I think that the majority of the 802.3.2 configuration/statistics…
[Jiang1] If a reference model can work, that will be better for sure.

[Jiang1] That is true indeed.

[Jiang1] Yes, we also hope to see more inputs from the WG.

module: ietf-if-flex-e

[Jiang1] Not sure we need both "flex-e" and "group" the same time (a little redundant in the structure IMO), otherwise I believe we are fully aligned in the overall structure.

[Jiang1] phy-number and client id are mandatory. They can be configured in most use cases, but for static configuration as described in FlexE IA, they can be fixed (i.e., determined by the device), that means, they may be read-only.

Regards,
Rob

Regards,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 26 Nov 2019 10:54:54 +0000

From: Jiangyuanlong <[email-masked]>
Sent: 26 November 2019 03:05
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: RE: Thoughts on Flex-E YANG models

Rob,

Thanks again,
Yuanlong

From: Rob Wilton (rwilton) [mailto:[email-masked]]
Sent: Monday, November 25, 2019 11:40 PM
To: Jiangyuanlong <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Thoughts on Flex-E YANG models

Hi Yuanlong,

Hi Rob,

Cheers,
Yuanlong

Hi,

module: ietf-if-flex-e

Regards,
Rob

Regards,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 26 Nov 2019 11:24:01 +0000

Sorry, I accidentally hit send on my last email before typing anything!

Please see some further comments [RW] inline ...

Rob,

Thanks again,
Yuanlong

Hi Yuanlong,

Hi Rob,

Cheers,
Yuanlong

Hi,

module: ietf-if-flex-e

[RW]
So this is a relatively minor point, and I could go either way on this.

>From my perspective it is 'nice' from a modelling perspective if the configuration for a particular feature is under a single container:

  *   It makes it easier to either just get that configuration, or to filter it out if it is not wanted.
  *   It is easier for clients to immediately relate the configuration back to a particular feature/protocol.

E.g., if it is plausible that there is any need for any device-global flex-e configuration, then I would propose putting that under a single top-level flex-e container.

Equally, if there could ever be flex-e configuration on a flex-e-group interface that isn't specific to the group then having the extra layer in the hierarchy is cleaner.  However, that this seems unlikely in this case, given that the interface represents a flex-e group ...

Another choice could be to only have a single layer of hierarchy, but call the top level container "flex-e" rather than "flex-e-group", e.g. :

module: ietf-if-flex-e
          +--rw more-flex-e-client-config-here?   string

[RW]
Okay, so from a YANG perspective, I think that makes them "mandatory false", since they don't have to be configured.  The description statements should make it clear that these fields must be provided in the operational datastore.

Thanks,
Rob

Regards,
Rob

Regards,
Rob

---

From: Jiangyuanlong <[email-masked]>
Date: Tue, 26 Nov 2019 12:39:00 +0000

Rob,

Sometimes we do things faster than we think;)
Please see my further comments inline prefixed with [Jiang2].

Thanks,
Yuanlong

From: Rob Wilton (rwilton) [mailto:[email-masked]]
Sent: Tuesday, November 26, 2019 7:24 PM
To: Jiangyuanlong <[email-masked]>; [email-masked]
Subject: RE: Thoughts on Flex-E YANG models

Rob,

Thanks again,
Yuanlong

Hi Yuanlong,

Hi Rob,

Cheers,
Yuanlong

Hi,

module: ietf-if-flex-e

[RW]

>From my perspective it is 'nice' from a modelling perspective if the configuration for a particular feature is under a single container:
-          It makes it easier to either just get that configuration, or to filter it out if it is not wanted.
-          It is easier for clients to immediately relate the configuration back to a particular feature/protocol.

Equally, if there could ever be flex-e configuration on a flex-e-group interface that isn't specific to the group then having the extra layer in the hierarchy is cleaner.  However, that this seems unlikely in this case, given that the interface represents a flex-e group ...
[Jiang2] Yes, we had considered this option too. BTW, if such global inter-group FlexE configurations are found later, we can still follow this approach.

module: ietf-if-flex-e

[Jiang2] Currently, I think this is a somewhat more graceful approach.

[RW]
Okay, so from a YANG perspective, I think that makes them "mandatory false", since they don't have to be configured.  The description statements should make it clear that these fields must be provided in the operational datastore.
[Jiang2] Points taken. We can discuss more details on respective attributes if the WG could have an agreements on the overall structure.

Thanks,
Rob

Regards,
Rob

Regards,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 26 Nov 2019 17:34:12 +0000

Hi Yuanlong,

Okay.  I think that we seem to be in rough alignment on the overall structure.

I think that the next steps are to wait for comments from Xiaobing and Qilei to see if this top level structure would be an acceptable starting point to then try on the detailed configuration.

In case it helps, the updated YANG is here: https://github.com/rgwilton/flex-e-yang/blob/master/ietf-if-flex-e.yang

Thanks,
Rob

From: Jiangyuanlong <[email-masked]>
Sent: 26 November 2019 12:39
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: RE: Thoughts on Flex-E YANG models

Rob,

Thanks,
Yuanlong

Rob,

Thanks again,
Yuanlong

Hi Yuanlong,

Hi Rob,

Cheers,
Yuanlong

Hi,

module: ietf-if-flex-e

[RW]

module: ietf-if-flex-e

[RW]

Thanks,
Rob

Regards,
Rob

Regards,
Rob

---

From: Jiangyuanlong <[email-masked]>
Date: Thu, 28 Nov 2019 06:59:24 +0000

Thanks for providing the updated YANG, I have no problem with it. We look forward to comments from Xiaobing and Qilei, and other experts.

From: Rob Wilton (rwilton) [mailto:[email-masked]]
Sent: Wednesday, November 27, 2019 1:34 AM
To: Jiangyuanlong <[email-masked]>; [email-masked]
Subject: RE: Thoughts on Flex-E YANG models

Hi Yuanlong,

Thanks,
Rob

Rob,

Thanks,
Yuanlong

Rob,

Thanks again,
Yuanlong

Hi Yuanlong,

Hi Rob,

Cheers,
Yuanlong

Hi,

module: ietf-if-flex-e

[RW]

module: ietf-if-flex-e

[RW]

Thanks,
Rob

Regards,
Rob

Regards,
Rob