Subject: Re: [CCAMP] Drafted text for the ROADM architecture section (draft-ietf-ccamp-optical-impairment-topology-yang-02)

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Mon, 4 Nov 2019 07:56:01 +0000

Hi Dieter,

Thanks for the new text, I’m OK with it.

Best Regards,

Gabriele

[http://www.cisco.com/swa/i/logo.gif]

Gabriele Galimberti
Principal Engineer
Cisco Photonics Srl
Italy

via S.Maria Molgora, 48 C
20871 - Vimercate (MB)
Italy
www.cisco.com/global/IT/<http://www.cisco.com/global/IT/>

[email-masked]<mailto:[email-masked]>
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049

From: CCAMP <[email-masked]> on behalf of Sergio Belotti <[email-masked]>
Date: Saturday, 2 November 2019 at 12:05
To: Dieter Beller <[email-masked]>, "CCAMP ([email-masked])" <[email-masked]>
Subject: Re: [CCAMP] Drafted text for the ROADM architecture section (draft-ietf-ccamp-optical-impairment-topology-yang-02)

Hi Dieter,
Thanks for text, I’m fine with that.

Thanks
Sergio

From: CCAMP <[email-masked]> On Behalf Of Beller, Dieter (Nokia - DE/Stuttgart)
Sent: Friday, November 1, 2019 2:12 PM
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] Drafted text for the ROADM architecture section (draft-ietf-ccamp-optical-impairment-topology-yang-02)

Hi all,

please find below the text I drafted for draft-ietf-ccamp-optical-impairment-topology-yang-02 describing the ROADM architectures discussed during our weekly calls.

The ascii-art figures will be provided by Gabriele.

Please send me your comments before Mon, Nov 4 – the submission deadline is rapidly approaching!

Thanks,
Dieter

________________________________

1.8. ROADM Node Architectures
The ROADM node architectures in today’s dense wavelength division multiplexing (DWDM) networks can be categorized as follows:

  *   Integrated ROADM architecture with integrated optical transponders
  *   Integrated ROADM architecture with integrated optical transponders and single channel add/drop ports for remote optical transponders

o   Disaggregated ROADM architecture where the ROADM is subdivided into degree, add/drop, and optical transponder subsystems handled as separate network elements
The TE topology YANG model augmentations including optical impairments for DWDM networks defined below intend to cover all the 3 categories of ROADM architectures listed above. In the case of a disaggregated ROADM architecture, it is assumed that optical domain controller already performs some form of abstraction and presents the TE-node representing the disaggregated ROADM in the same way as an integrated ROADM with integrated optical transponders if the optical transponder subsystems and the add/drop subsystems are collocated (short fiber links not imposing significant optical impairments).
The different ROADM architectures are briefly described and illustrated in the following subsections.
[Editor’s Note: The modeling of remote optical transponders located for example in the client device with a single channel link between the OT and the add/drop port of the ROADM requires further investigations and will be addressed in a future revision of this document.]

1.8.1. Integrated ROADM architecture with integrated transponders
Figure 2 and Figure <RA1> below show the typical architecture of an integrated ROADM node, which contains the optical transponders as an integral part of the ROADM node. Such an integrated ROADM node provides DWDM interfaces as external interfaces for interconnecting the device with its neighboring ROADMs (see OTS link above). The number of these interfaces denote also the degree of the ROADM. A degree 3 ROADM for example has 3 DWDM links that interconnect the ROADM node with 3 neighboring ROADMs. Additionally, the ROADM provides client interfaces for interconnecting the ROADM with client devices such as IP routers or Ethernet switches. These client interfaces are the client interfaces of the integrated optical transponders.

1.8.2. Integrated ROADMs with integrated optical transponders and single channel add/drop interfaces for remote optical transponders
Figure <RA2> below shows the extreme case where all optical transponders are not integral parts of the ROADM but are separate devices that are interconnected with add/drop ports of the ROADM. If the optical transponders and the ROADM are collocated and if short single channel fiber links are used to interconnect the optical transponders with an add/drop port of the ROADM, the optical domain controller may present these optical transponders in the same way as integrated optical transponders. If, however, the optical impairments of the single channel fiber link between the optical transponder and the add/drop port of the ROADM cannot be neglected, it is necessary to represent the fiber link with its optical impairments in the topology model This also implies that the optical transponders belong to a separate TE node [Editor’s Note: this requires further study].

1.8.3. Disaggregated ROADMs that are subdivided into degree, add/drop, and optical transponder subsystems
Recently, some DWDM network operators started demanding ROADM subsystems from their vendors. An example is the OpenROADM project where multiple operators and vendors are developing related YANG models. The subsystems of a disaggregated ROADM are: single degree subsystems, add/drop subsystems and optical transponder subsystems. These subsystems separate network elements and each network element provides a separate management and control interface. The subsystems are typically interconnected using short fiber patch cables and form together a disaggregated ROADM node. This disaggregated ROADM architecture is depicted in Figure <RA3> below.
As this document defines TE topology YANG model augmentations [TE-TOPO] for the TE topology YANG model provided at the north-bound interface of the optical domain controller, it is a valid assumption that the optical domain controller abstracts the subsystems of a disaggregated ROADM and presents the disaggregated ROADM in the same way as an integrated ROADM hiding all the interconnects that are not relevant from an external TE topology view.

---

From: <[email-masked]>
Date: Mon, 4 Nov 2019 09:12:49 +0000

Dear Dieter,

Thanks for the text, I am OK with it,

regards

Esther

De : CCAMP [mailto:[email-masked]] De la part de Gabriele Maria Galimberti (ggalimbe)
Envoyé : lundi 4 novembre 2019 08:56
À : Belotti, Sergio (Nokia - IT/Vimercate); Beller, Dieter (Nokia - DE/Stuttgart); CCAMP ([email-masked])
Objet : Re: [CCAMP] Drafted text for the ROADM architecture section (draft-ietf-ccamp-optical-impairment-topology-yang-02)

Hi Dieter,

Best Regards,

Gabriele

Gabriele Galimberti
Principal Engineer
Cisco Photonics Srl
Italy

Hi Dieter,

Thanks
Sergio

Hi all,

Thanks,
Dieter

o  Integrated ROADM architecture with integrated optical transponders

o  Integrated ROADM architecture with integrated optical transponders and single channel add/drop ports for remote optical transponders

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.