Subject: Re: [CCAMP] Last Call: <draft-ietf-ccamp-layer0-types-06.txt> (A YANG Data Model for Layer 0 Types) to Proposed Standard

From: tom petch <[email-masked]>
Date: Fri, 18 Sep 2020 17:13:49 +0100

The YANG module references RFC4203, RFC7699 and G.694.2 but the I-D does
not so these need adding. I note that the other references from the YANG
are all Informative which seems to me debatable.

grouping wson-label-start-end is introduced as
'A YANG grouping that defines the label-start and label-end'
which leads me to expect two leaf but there is only one; the YANG
description is
"The WSON label-start or label-end ...
which seems more accurate but since the grouping is a choice of cwdm or
dwdm could it find uses which are neither start nor end in which case a
different name would be even more appropriate?

grouping flexi-grid-label-start-end is introduced as
'A YANG grouping that defines the label-start and label-end '
and again there is only one leaf; the YANG description is
"Label-start and Label-end information for Flexi-grid."
which seems equally inappropriate.  I cannot see any uses of this
grouping - I note that draft-ietf-ccamp-flexigrid-yang has not been
updated to match this I-D - and since it is but one leaf, not even a
choice, I wonder why it warrants a grouping with the increased
difficulty of comprehension that groupings introduce.

leaf min-slot-width-factor {type uint16 {range "1..max";}
            default 1;
leaf max-slot-width-factor {type uint16 {range "1..max";
but with no default. Worth a YANG conditional perhaps for max>min or
max>=min as appropriate.  Can they be equal?  the equal ranges imply so
but has it any particular meaning?

I wonder how often l0 will be construed as ten or ell-oh with an 
attendant error!

Tom Petch

----- Original Message -----
From: "The IESG" <[email-masked]>
To: "IETF-Announce" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Daniele Ceccarelli"
<[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Wednesday, September 16, 2020 9:44 PM
Subject: Last Call: <draft-ietf-ccamp-layer0-types-06.txt> (A YANG Data
Model for Layer 0 Types) to Proposed Standard

> The IESG has received a request from the Common Control and
Measurement Plane
> WG (ccamp) to consider the following document: - 'A YANG Data Model
for Layer
> 0 Types'
>   <draft-ietf-ccamp-layer0-types-06.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2020-09-30. Exceptionally,
comments may
> be sent to [email-masked] instead. In either case, please retain the
beginning
> of the Subject line to allow automated sorting.
>
>

---

From: tom petch <[email-masked]>
Date: Fri, 18 Sep 2020 16:35:19 +0000

Please do not 'reply all' to the e-mail I just posted on layer0-types.  I made a mess of my reply to Last Call and managed to include the IESG Secretary who pointed this out to me 10 seconds after I realised what I had done:-(

Tom Petch
________________________________________
From: CCAMP <[email-masked]> on behalf of tom petch <[email-masked]>
Sent: 18 September 2020 17:13
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [CCAMP] Last Call: <draft-ietf-ccamp-layer0-types-06.txt> (A YANG Data Model for Layer 0 Types) to Proposed Standard

Tom Petch

----- Original Message -----
From: "The IESG" <[email-masked]>
To: "IETF-Announce" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Daniele Ceccarelli"

Measurement Plane
for Layer
final
comments may
beginning
> of the Subject line to allow automated sorting.

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp