Subject: Re: [CCAMP] Last Call: <draft-ietf-ccamp-layer0-types-06.txt> (A YANG Data Model for Layer 0 Types) to Proposed Standard

From: Zhenghaomian <[email-masked]>
Date: Tue, 22 Sep 2020 04:05:12 +0000

Hi Tom, 

Thank you for the valuable comments, again. We have updated the draft to address them, please find the draft-ietf-ccamp-layer0-types-07 and draft-ietf-ccamp-wson-yang-26. 

BTW, there will be a ccamp interim session on Sept 23rd, and you are more than welcome to join:)

Best wishes,
Haomian

-----邮件原件-----
发件人: tom petch [mailto:[email-masked]] 
发送时间: 2020年9月19日 0:14
收件人: The IESG <[email-masked]>
抄送: [email-masked]; [email-masked]; Daniele Ceccarelli <[email-masked]>; [email-masked]; [email-masked]
主题: Re: Last Call: <draft-ietf-ccamp-layer0-types-06.txt> (A YANG Data Model for Layer 0 Types) to Proposed Standard

The YANG module references RFC4203, RFC7699 and G.694.2 but the I-D does not so these need adding. I note that the other references from the YANG are all Informative which seems to me debatable.

grouping wson-label-start-end is introduced as 'A YANG grouping that defines the label-start and label-end'
which leads me to expect two leaf but there is only one; the YANG description is "The WSON label-start or label-end ...
which seems more accurate but since the grouping is a choice of cwdm or dwdm could it find uses which are neither start nor end in which case a different name would be even more appropriate?

grouping flexi-grid-label-start-end is introduced as 'A YANG grouping that defines the label-start and label-end '
and again there is only one leaf; the YANG description is "Label-start and Label-end information for Flexi-grid."
which seems equally inappropriate.  I cannot see any uses of this grouping - I note that draft-ietf-ccamp-flexigrid-yang has not been updated to match this I-D - and since it is but one leaf, not even a choice, I wonder why it warrants a grouping with the increased difficulty of comprehension that groupings introduce.

leaf min-slot-width-factor {type uint16 {range "1..max";}
            default 1;
leaf max-slot-width-factor {type uint16 {range "1..max"; but with no default. Worth a YANG conditional perhaps for max>min or
max>=min as appropriate.  Can they be equal?  the equal ranges imply so
but has it any particular meaning?

I wonder how often l0 will be construed as ten or ell-oh with an attendant error!

Tom Petch

----- Original Message -----
From: "The IESG" <[email-masked]>
To: "IETF-Announce" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Daniele Ceccarelli"
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, September 16, 2020 9:44 PM
Subject: Last Call: <draft-ietf-ccamp-layer0-types-06.txt> (A YANG Data Model for Layer 0 Types) to Proposed Standard

> The IESG has received a request from the Common Control and
Measurement Plane
> WG (ccamp) to consider the following document: - 'A YANG Data Model
for Layer
> 0 Types'
>   <draft-ietf-ccamp-layer0-types-06.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
final
> comments on this action. Please send substantive comments to the 
> [email-masked] mailing lists by 2020-09-30. Exceptionally,
comments may
> be sent to [email-masked] instead. In either case, please retain the
beginning
> of the Subject line to allow automated sorting.
>
>

---

From: tom petch <[email-masked]>
Date: Wed, 23 Sep 2020 16:29:34 +0000

From: CCAMP <[email-masked]> on behalf of Zhenghaomian <[email-masked]>
Sent: 22 September 2020 05:05
To: tom petch

Hi Tom,

<tp>

layer0-types is ok, wson-yang not so, as I have posted separately.

In passing, I do not understand 
the term 'channel-spacing' can be alternated
alternate is one of those delightful words that have different meanings in English and American but I cannot make either fit here.  And
maximum-slot-width should be /bigger/greater/ than

Tom Petch

Best wishes,
Haomian

-----邮件原件-----
发件人: tom petch [mailto:[email-masked]]
发送时间: 2020年9月19日 0:14
收件人: The IESG <[email-masked]>
抄送: [email-masked]; [email-masked]; Daniele Ceccarelli <[email-masked]>; [email-masked]; [email-masked]
主题: Re: Last Call: <draft-ietf-ccamp-layer0-types-06.txt> (A YANG Data Model for Layer 0 Types) to Proposed Standard

Tom Petch

----- Original Message -----
From: "The IESG" <[email-masked]>
To: "IETF-Announce" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Daniele Ceccarelli"

Measurement Plane
for Layer
final
comments may
beginning
> of the Subject line to allow automated sorting.
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp