Subject: Re: [CDNi] Your comments on draft-jenkins-cdni-problem-statement-00

From: Francois Le Faucheur <[email-masked]>
Date: Tue, 28 Dec 2010 16:54:07 +0100

Hello Yiu,

(taking this to the CDNi list)

see below:

On 23 Dec 2010, at 20:22, Lee, Yiu wrote:

> Hi Ben,
> 
> The two use cases in my mind are as follows:
> 
> A regional CDN may want to serve a customer not in its footprint. It will
> require a national CDN to help.

I think this case is already covered by the following text:
"CSPs have a desire to be able to get (some of) their content to very large number of End Users and/or over many/all geographies and/or with a high quality of experience, all without having to maintain direct business relationships with many different CDN providers (or having to extend their own CDN to a large number of locations). Some NSPs are considering interconnecting their respective CDNs (as well as possibly over-the-top CDNs) so that this collective infrastructure can address the requirements of CSPs in a cost effective manner. In particular, this would enable the CSPs to benefit from on-net delivery (i.e. within the Network Service Provider's own network/CDN footprint) whenever possible and off-net delivery otherwise, ..."

> 
> A national CDN may want to serve a customer in a regional network. For
> some reasons (operational/business), the national CDN may want to use a
> regional CDN to deliver the content to the customer.

I agree this case is not currently covered. I propose to add the following at the end of section 2:
"
For operational reasons (e.g. disaster, flash crowd) or commercial reasons, an over-the-top CDN may also elect to make use of another CDN (e.g. an NSP CDN with on-net Surrogates for a given footprint) for serving a subset of the user requests (e.g. requests from users attached to that NSP). Again, for this requirement, CDN operators (over-the-top CDN operators or NSPs) are faced with a lack of open specifications and best practices.
"

Cheers

Francois

> 
> You may argue that these don't have change the fact that the CDNi problem
> statement. However, we will need to mention the CDNi WG will be able to
> serve this kind of use cases.
> 
> Thoughts and comments?
> Yiu
> 
> 
> 
> On 12/23/10 10:01 AM, "Ben Niven-Jenkins" <[email-masked]> wrote:
> 
>> Andre, Yiu,
>> 
>> You have both made essentially the same comment on
>> draft-jenkins-cdni-problem-statement-00, namely that it is very NSP
>> centric and should contain more discussion of use cases for OTT CDNs.
>> 
>> I'm currently re-spinning the problem statement but I'm struggling to come
>> up with good text to cover OTT CDNs, do either of you have any text you
>> could suggest that we can include?
>> 
>> Thanks
>> Ben
>> 
>

---

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 28 Dec 2010 16:46:23 +0000

Hi Francois,

>For operational reasons (e.g. disaster, flash crowd) or commercial
>reasons, an over-the-top CDN may also elect to make use of another CDN
>(e.g. an NSP CDN with on-net Surrogates for a given footprint) for
>serving a subset of the user requests (e.g. requests from users attached
>to that NSP). Again, for this requirement, CDN operators (over-the-top
>CDN operators or NSPs) are faced with a lack of open specifications and
>best practices.
>"

I think this is a good start. Thanks for covering this use cases.

Yiu