Subject: [CDNi] Few comments on Problem Statement

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 14 Dec 2010 01:13:55 +0000

Hi authors,

I read the problem statement draft and have few comments:

1. The current draft is very ISP-centric. I would like the PS to also discuss how to enable a regional OTT CDN provider to offer content to a global footprint or temporarily offload the traffic to other CDN providers.

2. The PS spent listed a some works done by other technical forums about content delivery. However, most of them are related to e2e content delivery, not so much about CDN-I. This confused me at firs, I thought the PS was about e2e content delivery problem. I would suggest to move this section further down

3. The definition "Content Distribution Metadata" is unclear. Can you give an example to describe what is it? I am particularly confused between Content Metadata and Content Distribution Metadata.

4. In the draft, the CSP and CDNP could be two different providers. In real world, the same entity may provide both services.  I would like to see a scenario to describe this.

Thanks,
Yiu

---

From: Francois Le Faucheur <[email-masked]>
Date: Tue, 14 Dec 2010 09:46:40 +0100

Hello Yiu,

On 14 Dec 2010, at 02:13, Lee, Yiu wrote:

> 1. The current draft is very ISP-centric.

It is true that the use cases are NSP-centric (while we want the CDNI work to apply to various types of CDNs).
Would you care to propose an additional use case description for the case you have in mind?

> I would like the PS to also discuss how to enable a regional OTT CDN provider to offer content to a global footprint or temporarily offload the traffic to other CDN providers.
> 

I see your point. Yes, perhaps it would flow better if we talk first about the problem we're after, and only later go through the long "Gap analysis".

> 3. The definition "Content Distribution Metadata" is unclear. Can you give an example to describe what is it? I am particularly confused between Content Metadata and Content Distribution Metadata. 

What we were trying to say was:

* there is a very generic concept of "metadata" which is data about data.
* when metadata is about "content" (where "content" defined before in the document) we refer to those as "Content Metadata". 
* Content Metadata comprises:
	(i) some metadata that is relevant to the distribution of the content (and therefore relevant to the CDNs).
	(ii) some metadata that is not relevant to the distribution of the content (and therefore irrelevant/opaque to the CDNs)
* We refer to (i) as "Content Distribution Metadata". Examples include "this content can only be delivered to a use after such date/time, this content can not be delivered after such date/time, this content can only be delivered after validation of a URI signature,..."
* We don't have a term for (ii). Examples of (ii) include "this content genre is Drama, this content involve such and such very famous actors". 

> 4. In the draft, the CSP and CDNP could be two different providers. In real world, the same entity may provide both services.  I would like to see a scenario to describe this.

Yes, it is a common scenario that a service provider behaves as both a CSP and an NSP running a CDN. In fact, this is the implied scenario in the 3rd/last use case described in section 2. 
I would propose that we make a statement about this in the definition section (where we define CSP & NSP).

> Thanks,

Thanks for your review and comments.

Francois

> Yiu
> 
> 
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 15 Dec 2010 17:35:34 +0000

Yiu,

To follow-up on what Francois has said, please see inline below.

> I see your point. Yes, perhaps it would flow better if we talk first about the problem we're after, and only later go through the long "Gap analysis".

We included this information to try and highlight that while other
technical/standards forums may be working on related areas there is no
overlap between the work they are doing and the work we are proposing.

However, I agree we are probably better off re-ordering so that the
current section 4 (CDN Interconnect Problem Area for IETF) comes before
the current section 3 (Gap Analysis of relevant Standardization
Activities).

> * We don't have a term for (ii). Examples of (ii) include "this content genre is Drama, this content involve such and such very famous actors". 

At the risk of adding to your confusion:

Content Metadata is the kind of metadata that a Content Service Provider
would be familiar with and is often generated as part of the workflow when
processing raw content files into the required format etc for digital
delivery. It is typically metadata associated with the actual content.
Examples of such metadata include those Francois listed like: Genre, Cast,
Category etc but may also include additional metadata such as resolution,
pixel aspect ratio etc.

Content Distribution Metadata is the metadata required by a CDN in order
for the CDN to distribute and deliver the content, as well as the examples
Francois provided, a common example of Content Distribution Metadata would
be the content delivery policy that governs to which sets of IP addresses
A CDN may deliver the content to (sometimes referred to as
"geo-blocking"), for example "Only deliver this content to End Users whose
IP address is within the USA".

Regards
Ben

---

From: "Woundy, Richard" <[email-masked]>
Date: Wed, 15 Dec 2010 19:36:54 +0000

I think I am starting to understand the two types of metadata better, thanks.

> IP address is within the USA".

It would be helpful to distinguish the "Content Distribution Metadata" that is used only within a single CDN, versus metadata that must be communicated between CDNs.

It would seem that this metadata should include the business rules associated with this content, e.g. availability windows and geo-blocking. Maybe it shouldn't include its caching priority, for example.

How about calling it "control metadata"? :)

-- Rich

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ben Niven-Jenkins
Sent: Wednesday, December 15, 2010 12:36 PM
To: Francois Le Faucheur
Cc: [email-masked]; Lee, Yiu
Subject: Re: [CDNi] Few comments on Problem Statement

Yiu,

Regards
Ben

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 16 Dec 2010 11:37:49 +0100

Richard and all,

On 15 Dec 2010, at 20:36, Woundy, Richard wrote:

> It would seem that this metadata should include the business rules associated with this content, e.g. availability windows and geo-blocking.

right.

> Maybe it shouldn't include its caching priority, for example.

Right. Although arguably, a given CDN may derive the "caching priority" to be used within that CDN from Content Distribution Metadata communicated between CDNs.

Anyways, to capture that thread, how about we update the definition to something like this:

"
Metadata: data about data.

Content Metadata: metadata about content. Content Metadata comprises:
	(i) metadata that is relevant to the distribution of the content (and therefore relevant to a CDN involved in the delivery of that content). We refer to those as "Content Distribution Metadata".
	(ii) metadata that is associated with the actual content (and not directly relevant to the distribution of that content) or content representation. For example, such metadata may include Genre, Cast, Rating as well as resolution and aspect ratio.

Content Distribution Metadata: the subset of Content Metadata that is relevant to the distribution of the content.
This is the metadata required by a CDN in order to enable and control content distribution and delivery by the CDN. In a CDN Interconnection environment, some of the Content Distribution Metadata may have an intra-CDN scope (and therefore need not be communicated between CDNs), while some of the Content Distribution Metadata have an inter-CDN scope (and therefore need to be communicated between CDNs). For example, Content Distribution Metadata with inter-CDN scope may include geo-blocking information (i.e. information defining geographical areas where the content is to be made available or blocked), availability windows (i.e. information defining time windows during which the content is to be made available or blocked) and access control mechanisms to be enforced (e.g. URI signature validation).
"

Cheers

Francois

> IP address is within the USA".

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 16 Dec 2010 19:05:37 +0000

Hi Francois and Ben,

On 12/15/10 12:35 PM, "Ben Niven-Jenkins" <[email-masked]> wrote:

>>> 2. The PS spent listed a some works done by other technical forums
>>>about content delivery. However, most of them are related to e2e
>>>content delivery, not so much about CDN-I. This confused me at firs, I
>>>thought the PS was about e2e content delivery problem. I would suggest
>>>to move this section further down
>> 
>> I see your point. Yes, perhaps it would flow better if we talk first
>>about the problem we're after, and only later go through the long "Gap
>>analysis".
>> 
>

[YL] Great! I think it will help the reader if this section is moved after
Section CDN Interconnect Problem Area

>
>>> 3. The definition "Content Distribution Metadata" is unclear. Can you
>>>give an example to describe what is it? I am particularly confused
>>>between Content Metadata and Content Distribution Metadata.
>> 
>> * when metadata is about "content" (where "content" defined before in
>>the document) we refer to those as "Content Metadata".
>>     (i) some metadata that is relevant to the distribution of the
>>content (and therefore relevant to the CDNs).
>>     (ii) some metadata that is not relevant to the distribution of the
>>content (and therefore irrelevant/opaque to the CDNs)
>> * We refer to (i) as "Content Distribution Metadata". Examples include
>>"this content can only be delivered to a use after such date/time, this
>>content can not be delivered after such date/time, this content can only
>>be delivered after validation of a URI signature,..."
>> * We don't have a term for (ii). Examples of (ii) include "this content
>>genre is Drama, this content involve such and such very famous actors".
>

[YL] I am somewhat more clear. Thanks for the explanation. If Content
Distribution Metadata is used by the CDNi, why not simply called it CDNi
Metadata?

---

From: Francois Le Faucheur <[email-masked]>
Date: Fri, 17 Dec 2010 09:20:37 +0100

Hi Yiu,

> Distribution Metadata is used by the CDNi, why not simply called it CDNi

As per recent discussion with Richard, we observed that Content Distribution Metadata comprises metadata of intra-CDN scope (ie only relevant within a CDN) and metadata of inter-CDN scope (ie relevant across CDNs).

So, to be more accurate, we could use the term "CDNi Metadata" to designate the Content Distribution Metadata of inter-CDN scope (which is quite of a mouthful).

So the definition would look like this:

"

CDNi Metadata: Content Distribution Metadata with inter-CDN scope
"

How does that sound?

Francois

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 20 Dec 2010 10:58:40 +0000

Francois,

> CDNi Metadata: Content Distribution Metadata with inter-CDN scope

Looks good to me :-)

Ben