Subject: Re: [CDNi] Long Tail personalized content delivery over CDN Interconnections

From: ramki Krishnan <[email-masked]>
Date: Sat, 8 Sep 2012 07:35:24 -0700

All,

Thanks for the comments so far. A latest version of the draft is posted at http://datatracker.ietf.org/doc/draft-krishnan-cdni-long-tail/. Kindly review and comment.

thanks, ramki

From: ramki Krishnan
Sent: Wednesday, September 05, 2012 3:59 PM
To: 'Francois Le Faucheur (flefauch)'
Cc: [email-masked]'; [email-masked]'; [email-masked]'
Subject: FW: [CDNi] Long Tail personalized content delivery over CDN Interconnections

Hi Francois,

A gentle reminder ... kindly review and comment at your earliest convenience.

Thanks, ramki

From: ramki Krishnan
Sent: Wednesday, August 29, 2012 9:07 PM
To: 'Francois Le Faucheur (flefauch)'
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]'; [email-masked]'
Subject: RE: [CDNi] Long Tail personalized content delivery over CDN Interconnections

Hi Francois,

Please find updated draft attached. For convenience, I have described inline the Metadata interface requirements and Request routing interface changes.

Metadata interface requirement

The CDNI Metadata Distribution interface shall provide indication by the downstream CDN (dCDN) to the upstream CDN (uCDN) whether the content should be cached or not cached in the dCDN. This information should be on a per URL basis. The default behavior would be to cache the content in the dCDN

Referring to the example in Fig. 2, Section 3 [I-D.ietf-cdni-framework]; it shows Operator A as the uCDN and Operator B as the dCDN, where the former has a relationship with a content provider and the latter being the best CDN to deliver content to the end-user. Referring to the HTTP example in Fig. 3, Section 3.2 [I-D.ietf-cdni-framework];

Request routing interface changes

Step 2: A Request Router for Operator A processes the HTTP request. The HTTP URL metadata is looked up in a metadata database. For long tail personalized content, the metadata database lookup result indicates that the content should not be cached by the dCDN. The Request Router for Operator A recognizes that the end-user is best served by the uCDN without any caching the in dCDN and returns a 302 redirect message with the URL of Operator A delivery node. The end-user proceeds to retrieve the data from Operator A delivery node.

Thanks, ramki

From: Francois Le Faucheur (flefauch) [mailto:[email-masked]]
Sent: Friday, August 03, 2012 8:15 AM
To: ramki Krishnan
Cc: Francois Le Faucheur (flefauch); [email-masked]<mailto:[email-masked]>; Kevin J Ma; Ram Krishnan; [email-masked]<mailto:[email-masked]>
Subject: Re: [CDNi] Long Tail personalized content delivery over CDN Interconnections

On 3 Aug 2012, at 17:04, ramki Krishnan wrote:

Hi Kevin,

Thanks a lot for your comments. Please see response below

Kevin:
>>Wrt CDNI, what is it that draft-krishnan-cdni-long-tail-00 is proposing?
>>The CDNI requirements (specifically META-14) already discuss distribution control policies, including preventing delegation.  Beyond the ability to >>prevent delegation, are you proposing that CDNs be required to implement analytics-based delegation policies?  That seems somewhat beyond our scope.

Ramki:
The CDNi req META-14 is about the selection of dCDN, but what long tail draft is proposing is the selection of uCDN

the selection of uCDN by whom?

based on the content attribute, i.e. whether the content is long tail personalized or not. The long tail draft also brings in the concept of no caching in the uCDN

The intra-CDN decision of the uCDN to cache or not is generally outside the scope of CDNI. We are not disagreeing that the uCDN may elect to not cache some content (and in that case to not redirect to a dCDN), but this does not seem directly related to CDNI.

and dCDN for certain types of content based on the content attribute, for e.g. long tail personalized content. The impacts of this on CDNi request routing is also explained.

Can you summarize again very briefly the interaction you see between the desire to not cache some content and the CDNI interfaces? (when discussing Request Routing, please separate the impact you see on the Request Routing/Redirection interface vs Request Routing/Footprint & Cap Interface).

Thanks

Thanks, ramki

From: Bhumip Khasnabish [mailto:[email-masked]]
Sent: Tuesday, July 31, 2012 10:55 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Ram Krishnan; ramki Krishnan; [email-masked]<mailto:[email-masked]>
Subject: Fwd: Long Tail personalized content delivery over CDN Interconnections

FYI.. looking for comments and suggestions on delivery of
the most popular to long tail personalized content over CDNI.

This document presents the issues and suggests solutions in delivering long tail
personalized content in CDN Interconnection scenarios. Thanks a lot.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
I-D Action: draft-krishnan-cdni-long-tail-00.txt
________________________________

 *   To: i-d-announce at ietf.org<mailto:[email-masked]>
 *   Subject: I-D Action: draft-krishnan-cdni-long-tail-00.txt
 *   From: internet-drafts at ietf.org<mailto:[email-masked]>
 *   Date: Mon, 30 Jul 2012 16:49:30 -0700
 *   Delivered-to: i-d-announce at ietfa.amsl.com<mailto:[email-masked]>
 *   List-archive: <http://www.ietf.org/mail-archive/web/i-d-announce>
 *   List-help: <mailto:[email-masked]?subject=help>
 *   List-id: Internet Draft Announcements only <i-d-announce.ietf.org<http://i-d-announce.ietf.org/>>
 *   List-post: <mailto:[email-masked]>
 *   List-subscribe: <https://www.ietf.org/mailman/listinfo/i-d-announce>, <mailto:[email-masked]?subject=subscribe>
 *   List-unsubscribe: <https://www.ietf.org/mailman/options/i-d-announce>, <mailto:[email-masked]?subject=unsubscribe>
 *   Reply-to: internet-drafts at ietf.org<mailto:[email-masked]>

________________________________

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Long Tail personalized content delivery over CDN Interconnections

        Author(s)       : Ram Krishnan

                          Mian Li

                          Bhumip Khasnabish

        Filename        : draft-krishnan-cdni-long-tail-00.txt

        Pages           : 7

        Date            : 2012-07-30

Abstract:

   The content desire of users is evolving from most popular to long

   tail personalized content. This document presents the issues and

   suggests solutions in delivering long tail personalized content in

   CDN Interconnection scenarios.

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-krishnan-cdni-long-tail

There's also a htmlized version available at:

http://tools.ietf.org/html/draft-krishnan-cdni-long-tail-00

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/
_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Sat, 8 Sep 2012 17:44:48 +0100

Ramki,

On 8 Sep 2012, at 15:35, ramki Krishnan wrote:

> All,
>  
> Thanks for the comments so far. A latest version of the draft is posted athttp://datatracker.ietf.org/doc/draft-krishnan-cdni-long-tail/. Kindly review and comment.

It is not clear to me what the draft is trying to articulate or the real problem it is trying to describe.

It starts by describing a problem case where long tail personalised content is not cacheable but then goes on to describe requirements to enable a dCDN to indicate to a uCDN which URLs the dCDN won't bother to cache.

I don't really see how the first leads to the second, i.e. how is the dCDN supposed to know a given URL is "long tail personalised" and therefore uncacheable? 

Furthermore it is not clear to me why "long tail personalised" content is a special case. What about "short tail personalised" content?

I think you need to better describe the underlying problem/use case you are trying to solve before starting to define additional requirements to place on the CDNI specifications.

Ben

> Cc: [email-masked]'; [email-masked]';[email-masked]'
> A gentle reminder … kindly review and comment at your earliest convenience.
>  
> Thanks, ramki
>  
> From: ramki Krishnan 
> Cc: [email-masked]; [email-masked]';[email-masked]'
> Cc: Francois Le Faucheur (flefauch); [email-masked]; Kevin J Ma; Ram Krishnan;[email-masked]
> To: [email-masked]
> Cc: Ram Krishnan; ramki Krishnan; [email-masked]
> 	• To: i-d-announce at ietf.org
> 	• Subject: I-D Action: draft-krishnan-cdni-long-tail-00.txt
> 	• From: internet-drafts at ietf.org
> 	• Date: Mon, 30 Jul 2012 16:49:30 -0700
> 	• Delivered-to: i-d-announce at ietfa.amsl.com
> 	• List-archive: <http://www.ietf.org/mail-archive/web/i-d-announce>
> 	• List-help: <mailto:[email-masked]?subject=help>
> 	• List-id: Internet Draft Announcements only <i-d-announce.ietf.org>
> 	• List-post: <mailto:[email-masked]>
> 	• List-subscribe: <https://www.ietf.org/mailman/listinfo/i-d-announce>, <mailto:[email-masked]?subject=subscribe>
> 	• List-unsubscribe: <https://www.ietf.org/mailman/options/i-d-announce>, <mailto:[email-masked]?subject=unsubscribe>
> 	• Reply-to: internet-drafts at ietf.org
> [email-masked]
> [email-masked]