Subject: Re: [CDNi] Long Tail personalized content delivery over CDN Interconnection

From: ramki Krishnan <[email-masked]>
Date: Tue, 11 Sep 2012 10:15:11 -0700

Hi Ben,

Thanks for the comments.

The feedback from the team so far was that the concept of long tail personalized vs most popular (the technical term for short tail is most popular) was quite clear; folks wanted to see more on the CDNI requirements such a type of content would generate.

The following link gives you a good background on long tail personalized content; http://www.wired.com/wired/archive/12.10/tail.html
In summary, long tail personalized content is something which potentially is of interest to only a few people. Examples are documentaries, very old movies etc. In contrast, most popular content is of interest to a lot people. Examples are latest movies, latest catch-up episodes etc.

Caches with limited storage space/processing power are very useful for most popular content since the same piece of content is viewed by many people. With this background, we can see that long tail personalized content is not very amenable to caching. Caching of long tail personalized content could lead to cache thrashing issues. This draft examines in detail the CDNI requirements for long tail personalized content.

I will also add more description in the draft regarding this.

Thanks, ramki

*******************************************************************************
----- Forwarded by BhumipKhasnabish197472/user/zte_ltd on 09/09/2012 11:40 PM -----
Ben Niven-Jenkins <[email-masked]<mailto:[email-masked]>>

09/08/2012 12:44 PM

To

ramki Krishnan <[email-masked]<mailto:[email-masked]>>

cc

"Francois Le Faucheur (flefauch)" <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>, Richard Woundy <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Subject

Re: [CDNi] Long Tail personalized content delivery over CDN Interconnections

Ramki,

On 8 Sep 2012, at 15:35, ramki Krishnan wrote:

> All,
>
> Thanks for the comments so far. A latest version of the draft is posted athttp://datatracker.ietf.org/doc/draft-krishnan-cdni-long-tail/. Kindly review and comment.

It is not clear to me what the draft is trying to articulate or the real problem it is trying to describe.

It starts by describing a problem case where long tail personalised content is not cacheable but then goes on to describe requirements to enable a dCDN to indicate to a uCDN which URLs the dCDN won't bother to cache.

I don't really see how the first leads to the second, i.e. how is the dCDN supposed to know a given URL is "long tail personalised" and therefore uncacheable?

Furthermore it is not clear to me why "long tail personalised" content is a special case. What about "short tail personalised" content?

I think you need to better describe the underlying problem/use case you are trying to solve before starting to define additional requirements to place on the CDNI specifications.

Ben

>
> thanks, ramki
>
> From: ramki Krishnan
> Sent: Wednesday, September 05, 2012 3:59 PM
> To: 'Francois Le Faucheur (flefauch)'
> Cc: [email-masked]'; [email-masked]';[email-masked]'
> Subject: FW: [CDNi] Long Tail personalized content delivery over CDN Interconnections
>
> Hi Francois,
>
> A gentle reminder … kindly review and comment at your earliest convenience.
>
> Thanks, ramki
>
> From: ramki Krishnan
> Sent: Wednesday, August 29, 2012 9:07 PM
> To: 'Francois Le Faucheur (flefauch)'
> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]';[email-masked]'
> Subject: RE: [CDNi] Long Tail personalized content delivery over CDN Interconnections
>
> Hi Francois,
>
> Please find updated draft attached. For convenience, I have described inline the Metadata interface requirements and Request routing interface changes.
>
> Metadata interface requirement
> The CDNI Metadata Distribution interface shall provide indication by the downstream CDN (dCDN) to the upstream CDN (uCDN) whether the content should be cached or not cached in the dCDN. This information should be on a per URL basis. The default behavior would be to cache the content in the dCDN
>
> Referring to the example in Fig. 2, Section 3 [I-D.ietf-cdni-framework]; it shows Operator A as the uCDN and Operator B as the dCDN, where the former has a relationship with a content provider and the latter being the best CDN to deliver content to the end-user. Referring to the HTTP example in Fig. 3, Section 3.2 [I-D.ietf-cdni-framework];
> Request routing interface changes
> Step 2: A Request Router for Operator A processes the HTTP request. The HTTP URL metadata is looked up in a metadata database. For long tail personalized content, the metadata database lookup result indicates that the content should not be cached by the dCDN. The Request Router for Operator A recognizes that the end-user is best served by the uCDN without any caching the in dCDN and returns a 302 redirect message with the URL of Operator A delivery node. The end-user proceeds to retrieve the data from Operator A delivery node.
>
> Thanks, ramki
>
>
> From: Francois Le Faucheur (flefauch) [mailto:[email-masked]]
> Sent: Friday, August 03, 2012 8:15 AM
> To: ramki Krishnan
> Cc: Francois Le Faucheur (flefauch); [email-masked]<mailto:[email-masked]>; Kevin J Ma; Ram Krishnan;[email-masked]
> Subject: Re: [CDNi] Long Tail personalized content delivery over CDN Interconnections
>
>
> On 3 Aug 2012, at 17:04, ramki Krishnan wrote:
>
>
> Hi Kevin,
>
> Thanks a lot for your comments. Please see response below
>
> Kevin:
> >>Wrt CDNI, what is it that draft-krishnan-cdni-long-tail-00 is proposing?
> >>The CDNI requirements (specifically META-14) already discuss distribution control policies, including preventing delegation.  Beyond the ability to >>prevent delegation, are you proposing that CDNs be required to implement analytics-based delegation policies?  That seems somewhat beyond our scope.
>
> Ramki:
> The CDNi req META-14 is about the selection of dCDN, but what long tail draft is proposing is the selection of uCDN
>
> the selection of uCDN by whom?
>
>
> based on the content attribute, i.e. whether the content is long tail personalized or not. The long tail draft also brings in the concept of no caching in the uCDN
>
> The intra-CDN decision of the uCDN to cache or not is generally outside the scope of CDNI. We are not disagreeing that the uCDN may elect to not cache some content (and in that case to not redirect to a dCDN), but this does not seem directly related to CDNI.
>
> and dCDN for certain types of content based on the content attribute, for e.g. long tail personalized content. The impacts of this on CDNi request routing is also explained.
>
> Can you summarize again very briefly the interaction you see between the desire to not cache some content and the CDNI interfaces? (when discussing Request Routing, please separate the impact you see on the Request Routing/Redirection interface vs Request Routing/Footprint & Cap Interface).
>
> Thanks
>
>
>
>
> Thanks, ramki
>
> From: Bhumip Khasnabish [mailto:[email-masked]]
> Sent: Tuesday, July 31, 2012 10:55 AM
> To: [email-masked]<mailto:[email-masked]>
> Cc: Ram Krishnan; ramki Krishnan; [email-masked]<mailto:[email-masked]>
> Subject: Fwd: Long Tail personalized content delivery over CDN Interconnections
>
>
> FYI.. looking for comments and suggestions on delivery of
> the most popular to long tail personalized content over CDNI.
>
> This document presents the issues and suggests solutions in delivering long tail
> personalized content in CDN Interconnection scenarios. Thanks a lot.
>
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> I-D Action: draft-krishnan-cdni-long-tail-00.txt
>
>                  • To: i-d-announce at ietf.org
>                  • Subject: I-D Action: draft-krishnan-cdni-long-tail-00.txt
>                  • From: internet-drafts at ietf.org
>                  • Date: Mon, 30 Jul 2012 16:49:30 -0700
>                  • Delivered-to: i-d-announce at ietfa.amsl.com
>                  • List-archive: <http://www.ietf.org/mail-archive/web/i-d-announce>
>                  • List-help: <mailto:[email-masked]?subject=help>
>                  • List-id: Internet Draft Announcements only <i-d-announce.ietf.org>
>                  • List-post: <mailto:[email-masked]>
>                  • List-subscribe: <https://www.ietf.org/mailman/listinfo/i-d-announce>, <mailto:[email-masked]?subject=subscribe>
>                  • List-unsubscribe: <https://www.ietf.org/mailman/options/i-d-announce>, <mailto:[email-masked]?subject=unsubscribe>
>                  • Reply-to: internet-drafts at ietf.org
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>         Title           : Long Tail personalized content delivery over CDN Interconnections
>         Author(s)       : Ram Krishnan
>                           Mian Li
>                           Bhumip Khasnabish
>         Filename        : draft-krishnan-cdni-long-tail-00.txt
>         Pages           : 7
>         Date            : 2012-07-30
>
> Abstract:
>    The content desire of users is evolving from most popular to long
>    tail personalized content. This document presents the issues and
>    suggests solutions in delivering long tail personalized content in
>    CDN Interconnection scenarios.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-krishnan-cdni-long-tail
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-krishnan-cdni-long-tail-00
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> _______________________________________________
> CDNi mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cdni
>
> _______________________________________________
> CDNi mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cdni

--------------------------------------------------------

ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 12 Sep 2012 07:37:45 +0100

Ramki,

On 11 Sep 2012, at 18:15, ramki Krishnan wrote:

> The following link gives you a good background on long tail personalized content;http://www.wired.com/wired/archive/12.10/tail.html 

I see. I find your use of the term "long tail personalized" confusing.

What you describe is what I know as "long tail" content (i.e. less popular/niche/etc).

Personalized to me implies the content itself is personalized for some subset of consumers of the content, e.g. it could be 'personalized' to a particular device or could be personalized to a particular consumer/end user.

I also wonder whether dealing with long tail content is an internal optimisation decision for a dCDN or an out of band discussion about what type of content the dCDN would like the uCDN to delegate delivery of to the dCDN. In other words how much do we really need a technical CDNI solution for that problem space?

Thanks
Ben

> Ben Niven-Jenkins <[email-masked]>
> 09/08/2012 12:44 PM
> 
> To
> ramki Krishnan <[email-masked]>
> cc
> "Francois Le Faucheur (flefauch)" <[email-masked]>,[email-masked], Richard Woundy <[email-masked]>, [email-masked],[email-masked]
> Subject
> > Cc: [email-masked]';[email-masked]';[email-masked]'
> > Cc: [email-masked];[email-masked]';[email-masked]'
> > Cc: Francois Le Faucheur (flefauch); [email-masked]; Kevin J Ma; Ram Krishnan;[email-masked]
> > To: [email-masked]
> > Cc: Ram Krishnan; ramki Krishnan; [email-masked]
> > [email-masked]
> > [email-masked]

---

From: ramki Krishnan <[email-masked]>
Date: Sat, 15 Sep 2012 17:30:41 -0700

All,

A latest version of the draft is posted. Looking forward to your comments.
http://datatracker.ietf.org/doc/draft-krishnan-cdni-long-tail/

thanks, ramki
From: [email-masked] [mailto:[email-masked]] On Behalf Of ramki Krishnan
Sent: Tuesday, September 11, 2012 10:15 AM
To: Ben Niven-Jenkins
Cc: [email-masked]; [email-masked]
Subject: Re: [CDNi] Long Tail personalized content delivery over CDN Interconnection

Hi Ben,

Thanks for the comments.

Thanks, ramki

----- Forwarded by BhumipKhasnabish197472/user/zte_ltd on 09/09/2012 11:40 PM -----

09/08/2012 12:44 PM

To

cc

Subject

Ramki,

Ben