Subject: [CDNi] Acronyms for the CDNI interfaces

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Thu, 8 Nov 2012 21:51:23 +0000

Folks,

As discussed during the Atlanta meeting, we need to agree on a set of acronyms to designate the CDNI interfaces consistently across documents (particularly in figures where the full name cannot be used).

A base proposal is:
	* "CCI" for the CDNI Control Interface
	* "CMI" for the CDNI Metadata distribution Interface
	* "CLI" for the CDNI Logging Interface
	* "CRI" for the CDNI request routing/Redirection Interface
	* "CFI" for the CDNI request routing/Footprint & capabilities advertisement Interface.

Let us know if you see issues with that, or if you want to offer a better proposal.

Cheers

Francois

PS: some of the acronyms above probably conflict with some acronyms you've already encountered somewhere else before, but those don't seem to be major conflict, and it'd be nice to stick to short acronyms.

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 8 Nov 2012 22:03:46 -0500

Hi Francois,

Thanks. This is a good start.

As you know, "CLI" is widely used for "Command Line Interface,"
(http://en.wikipedia.org/wiki/Command-line_interface)
so let us consider something different for "CDNI Logging Interface"...

Best.

Bhumip

On Thu, Nov 8, 2012 at 4:51 PM, Francois Le Faucheur (flefauch) <
[email-masked]> wrote:

> Folks,
>
> As discussed during the Atlanta meeting, we need to agree on a set of
> acronyms to designate the CDNI interfaces consistently across documents
> (particularly in figures where the full name cannot be used).
>
> A base proposal is:
> PS: some of the acronyms above probably conflict with some acronyms you've
> already encountered somewhere else before, but those don't seem to be major
> conflict, and it'd be nice to stick to short acronyms.
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
>

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Fri, 9 Nov 2012 13:36:56 +0000

On 9 Nov 2012, at 04:03, [email-masked]<mailto:[email-masked]> wrote:

Hi Francois,

As you know, "CLI" is widely used for "Command Line Interface,"
(http://en.wikipedia.org/wiki/Command-line_interface)
so let us consider something different for "CDNI Logging Interface"…

"CLoI" ?

Best.

Bhumip

On Thu, Nov 8, 2012 at 4:51 PM, Francois Le Faucheur (flefauch) <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

A base proposal is:

Cheers

Francois

PS: some of the acronyms above probably conflict with some acronyms you've already encountered somewhere else before, but those don't seem to be major conflict, and it'd be nice to stick to short acronyms.
_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni

---

From: Kevin J Ma <[email-masked]>
Date: Fri, 9 Nov 2012 08:58:30 -0500

The "C" is somewhat superfluous?  We could drop all the "C"s.
CI, MI, LI, RI, and FI?

And, at the risk of opening a rat hole, "FI" seems to imply
that footprint is more important than capabilities...  :)
"FCI"?

From: [email-masked] [mailto:[email-masked]] On Behalf Of Francois Le Faucheur (flefauch)
Sent: Friday, November 09, 2012 8:37 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [CDNi] Acronyms for the CDNI interfaces

Hi Francois,

"CLoI" ?

Best.

Bhumip

A base proposal is:

Cheers

Francois

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Fri, 9 Nov 2012 14:07:27 +0000

Works for me. So latest proposal on the table is:

* CI, MI, LI, RI, FCI

PS: and no, the "I" is not superfluous 8^)

On 9 Nov 2012, at 14:58, Kevin J Ma wrote:

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Francois Le Faucheur (flefauch)
Sent: Friday, November 09, 2012 8:37 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [CDNi] Acronyms for the CDNI interfaces

Hi Francois,

"CLoI" ?

Best.

Bhumip

A base proposal is:

Cheers

Francois

---

From: "Peterson, Larry" <[email-masked]>
Date: Mon, 12 Nov 2012 12:53:22 -0500

I'm good with these, but in working through the framework 
document, I note that we also make significant reference to 
the generic Request Routing Interface. While we could add
RRI to the set, and then fully qualify the two sub-interfaces
(i.e., RR/RI and RR/FCI), I propose instead to stick with RI 
and FCI, and just not use an acronym for the generic Request
Routing Interface. (For me, the main value of the acronyms
is in the figures, and we never need RRI.)

Larry

On Nov 9, 2012, at 9:07 AM, Francois Le Faucheur (flefauch) wrote:

>> On 9 Nov 2012, at 04:03, [email-masked] wrote:
>> 
>> 
>> Hi Francois,
>>  
>> On Thu, Nov 8, 2012 at 4:51 PM, Francois Le Faucheur (flefauch) <[email-masked]> wrote:
>> Folks,
>> 
> <ATT00001.c>

---

From: Kevin J Ma <[email-masked]>
Date: Mon, 12 Nov 2012 12:55:00 -0500

I agree with always specifically referencing RI or FCI directly.

> -----Original Message-----
> From: Peterson, Larry [mailto:[email-masked]]
> Sent: Monday, November 12, 2012 12:53 PM
> To: Francois Le Faucheur (flefauch)
> Cc: Kevin J Ma; [email-masked]
> >> PS: some of the acronyms above probably conflict with some acronyms
> you've already encountered somewhere else before, but those don't seem to
> be major conflict, and it'd be nice to stick to short acronyms.

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Mon, 12 Nov 2012 18:24:05 +0000

> is in the figures, and we never need RRI.)

First, I agree with not having an acronym for the Request Routing Interface.

Secondly, as the "CDNI request routing/Redirection Interface" and "CDNI request routing/Footprint & Capabilities advertisement Interface" are firming up, there is probably less and less rationale for even referring to the Request Routing Interface per say. At the beginning we were not sure whether the two components would be realized with one or two interfaces so we bundled the two functions under the term Request Routing Interface, but now that we are quite clear that they will be realized separately, we can probably always refer to RI and FCI specifically.

So, with respect to the Framework, I'd suggest:
	* explaining early in the document that the Request Routing Interface is a logical grouping of RI and FCI, because the two relate to enabling request routing
	* then, whenever possible, only use the terms "CDNI request routing/Redirection Interface" and "CDNI request routing/Footprint & Capabilities advertisement Interface". And when you want to refer to both, then just list them both (instead of using "Request Routing Interface") either using the full name or the acronym.

Makes sense?

Francois

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Wed, 21 Nov 2012 09:49:31 +0000

All,

So Just to close on that one.
I believe we have an agreement for the following:

      * "CI" for the CDNI Control Interface
      * "MI" for the CDNI Metadata distribution Interface
      * "LI" for the CDNI Logging Interface
      * "RI" for the CDNI request routing/Redirection Interface
      * "FCI" for the CDNI request routing/Footprint & Capabilities advertisement Interface
      * no acronym defined for the umbrella "Request Routing Interface"
      * avoid using the umbrella term of "Request Routing Interface" and instead use the specific terms of "CDNI request routing/Redirection Interface (RI)" and "CDNI request routing/Footprint & Capabilities advertisement Interface (FCI)"

To all CDNI I-Ds editors,
Please reflect the above agreement in all open Internet-Drafts.

Francois

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 21 Nov 2012 15:07:32 -0500

You may also consider the following .

      * "CDN-CI" for the CDNI Control Interface

      * "CDN-MI" for the CDNI Metadata distribution Interface
      * "CDN-LI" for the CDNI Logging Interface
      * "CDN-RI" for the CDNI request routing/Redirection Interface
      * "CDN-FCI" for the CDNI request routing/Footprint & Capabilities
advertisement Interface

Thanks for considering these Francois ..

Best.

Bhumip

On Wed, Nov 21, 2012 at 4:49 AM, Francois Le Faucheur (flefauch) <
[email-masked]> wrote:

>       * avoid using the umbrella term of "Request Routing Interface" and
> instead use the specific terms of "CDNI request routing/Redirection
> Interface (RI)" and "CDNI request routing/Footprint & Capabilities
> advertisement Interface (FCI)"
>
>
> > Secondly, as the "CDNI request routing/Redirection Interface" and "CDNI
> request routing/Footprint & Capabilities advertisement Interface" are
> firming up, there is probably less and less rationale for even referring to
> the Request Routing Interface per say. At the beginning we were not sure
> whether the two components would be realized with one or two interfaces so
> we bundled the two functions under the term Request Routing Interface, but
> now that we are quite clear that they will be realized separately, we can
> probably always refer to RI and FCI specifically.
> >
> >       * explaining early in the document that the Request Routing
> Interface is a logical grouping of RI and FCI, because the two relate to
> enabling request routing
> >       * then, whenever possible, only use the terms "CDNI request
> routing/Redirection Interface" and "CDNI request routing/Footprint &
> Capabilities advertisement Interface". And when you want to refer to both,
> then just list them both (instead of using "Request Routing Interface")
> either using the full name or the acronym.
> >
> > Makes sense?
> >
> > Francois
> >
> >>
> >> Larry
> >>
> >>

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Thu, 22 Nov 2012 07:55:39 +0000

Hi Bhumip,

In my opinion, prepending "CDN" to the proposed acronyms:
* is not useful since these acronyms will always be used in the context of CDNI (and mostly in figures)
* is confusing because it suggests these interfaces are generally applicable to "CDNs" when they are applicable to "CDN Interconnection" (i.e. if we were to prepend something it should probably be "CDNI" instead of "CDN")
* is going in the opposite direction to the earlier decision to remove the prepending "C" from all the acronyms (as they were proposed initially e.g. CCI etc)
* is making the acronyms overly long and hard to pronounce
So I think we should stick to the acronyms announced below.

As a matter of process, in the future I encourage you to try make suggestions early into a discussion, instead of after the chairs send a note aiming at closing a discussion that seem to have already run its course.

Thanks

Cheers

Francois

On 21 Nov 2012, at 21:07, [email-masked]<mailto:[email-masked]> wrote:

      * "CDN-MI" for the CDNI Metadata distribution Interface
      * "CDN-LI" for the CDNI Logging Interface
      * "CDN-RI" for the CDNI request routing/Redirection Interface
      * "CDN-FCI" for the CDNI request routing/Footprint & Capabilities advertisement Interface

Best.

Bhumip

On Wed, Nov 21, 2012 at 4:49 AM, Francois Le Faucheur (flefauch) <[email-masked]<mailto:[email-masked]>> wrote:
All,

Francois

On 12 Nov 2012, at 19:24, Francois Le Faucheur (flefauch) wrote:

>>>> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Francois Le Faucheur (flefauch)