Subject: [CDNi] Requesting Marcin Pilarski to share de-dup expt setup and results, ..Re: Draft IETF-85 minutes posted

From: "[email-masked]" <[email-masked]>
Date: Mon, 12 Nov 2012 13:53:56 -0500

Hi Francois ,

During the presentation of the following draft Marcin Pilarski suggested
that in his CDNI expt.
the problem of content duplication does not match at all what he is see in
his
environment
Content De-duplication for CDNi Optimization,
draft-jin-cdni-content-deduplication-optimization-03: Bhumip Khasnabish

Do you have access to Marcin's experiment. setup,
traffic/network/content profile,
and results? If yes, can you share those with us.
If not can you ask Marcin to share the setup info and results with us ASAP.

Many  thanks in advance.

Best.

Bhumip

==========================================================
>> Draft minutes for our two CDNI sessions of IETF-85 have been posted. You
can access them from the IETF-85 Meeting Material page or directly from:
>> http://www.ietf.org/proceedings/85/minutes/minutes-85-cdni.

- problem of de-duplication explained with 3 scenarios.
- survey up to 60% data stored is duplicated.
*Marcin Pilarski: what are the assumptions behind these numbers because
that does not match at all what I see in my environment
*Bhumip: will be explained in this draft or in separate draft
::::::
- Option 2 - decide it is a nice-to-have, but is not crucial for initial
versions of CDNI interfaces. We *continue the work on it inside the WG*,
but do not aim to support it in first version of the CDNI interfaces.
::::::::
- Option 2: ~20 people

==========================================================

On Mon, Nov 12, 2012 at 4:16 AM, Francois Le Faucheur (flefauch) <
[email-masked]> wrote:

> Hi everyone,
>
> The draft minutes have been updated with:
>         * the correction discussed below by Ray
>         * a correction on the Show-of-hand results for the long-tail I-D
> (that were swapped in earlier version) - thanks to Dave Melton for pointing
> that out.
>
> Any more comments/corrections?
>
> Francois
>
>
> On 9 Nov 2012, at 16:13, Brandenburg, R. (Ray) van wrote:
>
> > Hi Francois,
> >
> > One comment: the minutes note that the last presentation on Thursday was
> me presenting the HAS experiments draft, while it was actually Bhumip
> presenting the Intra-CDN providers draft (we diverged from the agenda).
> >
> > Ray
> >
> > On 9 nov. 2012, at 10:04, "Francois Le Faucheur (flefauch)" <
> [email-masked]> wrote:
> >
> >> Folks,
> >>
> >> Draft minutes for our two CDNI sessions of IETF-85 have been posted.
> You can access them from the IETF-85 Meeting Material page or directly from:
> >> http://www.ietf.org/proceedings/85/minutes/minutes-85-cdni.
> >>
> >> Thanks to Marcin for providing raw notes.
> >>
> >> We could not quite capture all statements of the discussion in some
> occurrences, and the audio recording won't be available for a little while,
> but the draft minutes aim at capturing the essential of the discussion.
> >>
> >> Corrections/comments welcome.
> >>
> >> Cheers
> >>
> >> Francois
> >> _______________________________________________
> >> CDNi mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/cdni
> > This e-mail and its contents are subject to the DISCLAIMER at
> http://www.tno.nl/emaildisclaimer
> >
>
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
>

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 13 Nov 2012 07:57:50 +0000

Hello Bhumip,
I suggest you communicate directly with Marcin.
Cheers
Francois

On 12 Nov 2012, at 19:53, [email-masked]<mailto:[email-masked]> wrote:

Hi Francois ,

During the presentation of the following draft Marcin Pilarski suggested that in his CDNI expt.
the problem of content duplication does not match at all what he is see in his
environment
Content De-duplication for CDNi Optimization,
draft-jin-cdni-content-deduplication-optimization-03: Bhumip Khasnabish

Do you have access to Marcin's experiment. setup, traffic/network/content profile,
and results? If yes, can you share those with us.
If not can you ask Marcin to share the setup info and results with us ASAP.

Many  thanks in advance.

Best.

Bhumip

>> Draft minutes for our two CDNI sessions of IETF-85 have been posted. You can access them from the IETF-85 Meeting Material page or directly from:

- problem of de-duplication explained with 3 scenarios.
- survey up to 60% data stored is duplicated.
*Marcin Pilarski: what are the assumptions behind these numbers because that does not match at all what I see in my environment
*Bhumip: will be explained in this draft or in separate draft
::::::
- Option 2 - decide it is a nice-to-have, but is not crucial for initial versions of CDNI interfaces. We continue the work on it inside the WG,  but do not aim to support it in first version of the CDNI interfaces.
::::::::
- Option 2: ~20 people

On Mon, Nov 12, 2012 at 4:16 AM, Francois Le Faucheur (flefauch) <[email-masked]<mailto:[email-masked]>> wrote:
Hi everyone,

The draft minutes have been updated with:
        * the correction discussed below by Ray
        * a correction on the Show-of-hand results for the long-tail I-D (that were swapped in earlier version) - thanks to Dave Melton for pointing that out.

Francois

On 9 Nov 2012, at 16:13, Brandenburg, R. (Ray) van wrote:

> Hi Francois,
>
> One comment: the minutes note that the last presentation on Thursday was me presenting the HAS experiments draft, while it was actually Bhumip presenting the Intra-CDN providers draft (we diverged from the agenda).
>
> Ray
>
> On 9 nov. 2012, at 10:04, "Francois Le Faucheur (flefauch)" <[email-masked]<mailto:[email-masked]>> wrote:
>
>> Folks,
>>
>> Draft minutes for our two CDNI sessions of IETF-85 have been posted. You can access them from the IETF-85 Meeting Material page or directly from:
>> We could not quite capture all statements of the discussion in some occurrences, and the audio recording won't be available for a little while, but the draft minutes aim at capturing the essential of the discussion.
>>
>> [email-masked]<mailto:[email-masked]>
> This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/emaildisclaimer
>

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 13 Nov 2012 10:01:46 -0500

Hello Francois,

PLS send us Marcin's email address, if you have it.

Not sure whether Marcin monitors the discussion in the CDNI WG.

If anyone knows Marcin's email address, pls forward this email ASAP.

Thanks

Best.

Bhumip

On Tue, Nov 13, 2012 at 2:57 AM, Francois Le Faucheur (flefauch) <
[email-masked]> wrote:

>  On 12 Nov 2012, at 19:53, [email-masked] wrote:
>
>  Hi Francois ,
>
>> > One comment: the minutes note that the last presentation on Thursday
>> was me presenting the HAS experiments draft, while it was actually Bhumip

-- 
Best.

Bhumip Khasnabish
[email-masked]
[email-masked]
[email-masked]
+1-781-752-8003 (mobile)
http://tinyurl.com/bhumip

                   __o
             _ `\ <, _
.......... ( • ) / ( • ) ......................

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 13 Nov 2012 10:20:30 -0500

Hello Marcin,

During the presentation of the following draft you suggested that in your
CDNI
experiment the problem of content duplication does not match at all what you
see in your environment.

> draft-jin-cdni-content-deduplication-optimization-03: Bhumip Khasnabish

Can you share details of your experiment. setup, traffic/network/content
profile,
and results?

We plan to update our drafts soon, and would appreciate quick feedback.

Many  thanks in advance.

Best.

Bhumip

- problem of de-duplication explained with 3 scenarios.
- survey up to 60% data stored is duplicated.
*Marcin Pilarski: what are the assumptions behind these numbers because
that does not match at all what I see in my environment
*Bhumip: will be explained in this draft or in separate draft
::::::
- Option 2 - decide it is a nice-to-have, but is not crucial for initial
versions of CDNI interfaces. We continue the work on it inside the WG,  but
do not aim to support it in first version of the CDNI interfaces.

::::::::
- Option 2: ~20 people

On Tue, Nov 13, 2012 at 10:06 AM, Pilarski Marcin - Korpo TP <
[email-masked]> wrote:

> Dear Bhumip,
>
> here is one of them,
>
> Best regards,
> Marcin Pilarski
>
> ---Sent from mobile device
>
> *Od*: [email-masked] [mailto:[email-masked]]
> *Wysłano*: Tuesday, November 13, 2012 04:01 PM
> *Do*: Francois Le Faucheur (flefauch) <[email-masked]>
> *DW*: [email-masked] <[email-masked]>; Ram Krishnan <[email-masked]>
> *Temat*: Re: [CDNi] Requesting Marcin Pilarski to share de-dup expt setup
> and results, ..Re: Draft IETF-85 minutes posted
>
> Hello Francois,
>

---

From: Pilarski Marcin - Korpo TP <[email-masked]>
Date: Tue, 13 Nov 2012 15:24:42 +0000

Dear Bhumip,

My comment and criticism was related to the yours setup that completely neglected DRM technology existence that is common is almost all Orange's setups. More over due to this fact the content is encrypted and packaged for each CP with their individual key so de-duplication is not an issue at all - because cannot be when different CP has different encryptions keys.

So what I would like to see is paragraph about co-existence of existing DRM technology and yours proposal before we do go any further.

I hope this will help,
Marcin

Od: [email-masked] [mailto:[email-masked]]
Wysłano: Tuesday, November 13, 2012 04:20 PM
Do: Pilarski Marcin - Korpo TP
DW: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Temat: Re: Odp.: Re: [CDNi] Requesting Marcin Pilarski to share de-dup expt setup and results, ..Re: Draft IETF-85 minutes posted

Hello Marcin,

During the presentation of the following draft you suggested that in your CDNI
experiment the problem of content duplication does not match at all what you
see in your environment.

> draft-jin-cdni-content-deduplication-optimization-03: Bhumip Khasnabish

Can you share details of your experiment. setup, traffic/network/content profile,
and results?

Many  thanks in advance.

Best.

Bhumip

::::::::
- Option 2: ~20 people

On Tue, Nov 13, 2012 at 10:06 AM, Pilarski Marcin - Korpo TP <[email-masked]<mailto:[email-masked]>> wrote:
Dear Bhumip,

here is one of them,

Best regards,
Marcin Pilarski

Od: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Wysłano: Tuesday, November 13, 2012 04:01 PM
Do: Francois Le Faucheur (flefauch) <[email-masked]<mailto:[email-masked]>>
DW: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Ram Krishnan <[email-masked]<mailto:[email-masked]>>
Temat: Re: [CDNi] Requesting Marcin Pilarski to share de-dup expt setup and results, ..Re: Draft IETF-85 minutes posted

Hello Francois,

Thanks

Best.

Bhumip

On Tue, Nov 13, 2012 at 2:57 AM, Francois Le Faucheur (flefauch) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Bhumip,
I suggest you communicate directly with Marcin.
Cheers
Francois

Hi Francois ,

Many  thanks in advance.

Best.

Bhumip

Francois

---

From: Pilarski Marcin - Korpo TP <[email-masked]>
Date: Tue, 13 Nov 2012 15:06:15 +0000

Dear Bhumip,

here is one of them,

Best regards,
Marcin Pilarski

Od: [email-masked] [mailto:[email-masked]]
Wysłano: Tuesday, November 13, 2012 04:01 PM
Do: Francois Le Faucheur (flefauch) <[email-masked]>
DW: [email-masked] <[email-masked]>; Ram Krishnan <[email-masked]>
Temat: Re: [CDNi] Requesting Marcin Pilarski to share de-dup expt setup and results, ..Re: Draft IETF-85 minutes posted

Hello Francois,

Thanks

Best.

Bhumip

Hi Francois ,

Many  thanks in advance.

Best.

Bhumip

Francois

--
Best.

Bhumip Khasnabish
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
+1-781-752-8003 (mobile)
http://tinyurl.com/bhumip

                   __o
             _ `\ <, _

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 16 Nov 2012 15:06:14 -0500

Hello Marcin,

Thanks for responding.

Are you saying that if you use DRM there is no duplication of contents even
in the
same provider environment.
You mention that you see very small (may be less than 5%) duplications.. is
that when you operate using DRM?
How many CDN operators are interconnected in your setup?
Is it possible to share the details of content distribution and operations
setup
in which your observation
 "*does not match at all"* what we cite  in the slides?

  ===============================================================
http://www.ietf.org/proceedings/85/minutes/minutes-85-cdni
- see slides
- problem of de-duplication explained with 3 scenarios.
- survey up to 60% data stored is duplicated.
*Marcin Pilarski: what are the assumptions behind these numbers because
that *does not match at all what I see in my environment
* .
====================================================================

By the way, there are also a few independent reports and studies which
confirms the
existence of duplicate content even in same operators environment,
and that it  is a non-trivial problem which need attention.

Let us continue the discussing so that we can improve the draft before
IETF86.

Thanks again.

Best.

Bhumip

On Tue, Nov 13, 2012 at 10:24 AM, Pilarski Marcin - Korpo TP <
[email-masked]> wrote:

> Dear Bhumip,
>
> My comment and criticism was related to the yours setup that completely
> neglected DRM technology existence that is common is almost all Orange's
> setups. More over due to this fact the content is encrypted and packaged
> for each CP with their individual key so de-duplication is not an issue at
> all - because cannot be when different CP has different encryptions keys.
>
> So what I would like to see is paragraph about co-existence of existing
> DRM technology and yours proposal before we do go any further.
>
> I hope this will help,
> Marcin
>
> *Wysłano*: Tuesday, November 13, 2012 04:20 PM
> *Do*: Pilarski Marcin - Korpo TP
> *DW*: [email-masked] <[email-masked]>; [email-masked] <
> [email-masked]>; [email-masked] <[email-masked]>;
> [email-masked] <[email-masked]>
> *Temat*: Re: Odp.: Re: [CDNi] Requesting Marcin Pilarski to share de-dup
> expt setup and results, ..Re: Draft IETF-85 minutes posted
>
> Hello Marcin,
>
>> *Temat*: Re: [CDNi] Requesting Marcin Pilarski to share de-dup expt
>> setup and results, ..Re: Draft IETF-85 minutes posted
>>
>> Hello Francois,
>>
>>>>         * a correction on the Show-of-hand results for the long-tail
>>>> I-D (that were swapped in earlier version) - thanks to Dave Melton for
>>>> pointing that out.
>>>>