Subject: Re: [CDNi] New draft submitted draft-famaey-cdni-has-experiments-00

From: Kevin J Ma <[email-masked]>
Date: Fri, 9 Nov 2012 17:57:15 -0500

Hi Jeroen,

  I read through the draft.  It seems that it essentially shows the
  upper bound on the encoded bitrate somewhere along the lines of:

    B * (SD - 4 * D + C) / SD

  where SD is the segment duration, in this case 2 seconds,
  4 * D is the two WAN RTTs required for the redirect, and
  C is the overhead of the access network latency plus the
  processing delay for the redirect messages?

  Certainly with HTTP adaptive protocols, it is the case that as
  the RTT approaches SD, the viable encoded bitrate goes to zero,
  even without redirects.  It is a primary reason for using SD = 10
  with HLS and presumably why the native SS client seems to just
  automatically use the redirect target for its subsequent requests.

  Pressumably the experiment is for a VoD scenario, i.e., all the
  segments are immediately available for download?  (Live delivery
  poses other issues...)  If the content provider selects a suitably
  large SD to try to protect against the worst case scenario, the
  impact to average encoded bitrate is probably less dramatic?

  While I agree that there is higher probability of the inter-CDN
  link having higher latency than the access network, there are
  plenty of bad access networks out there.  I was wondering if
  the selected values for "per-client bandwidth B" were designed
  to reflect any specific access network deployment scenarios?

  Selecting the "best" CDN to deliver the content (in this case
  lowest latency request router, though, it works for other cases,
  e.g., cheapest CDN) and sticking with it certainly has its
  advantages.  Is the intent of the draft just to support the
  concept of manifest rewrite, or are there specific redirctions
  or rewrite mechanisms that it would like to propose?

thanx.

--  Kevin J. Ma

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jeroen Famaey
Sent: Thursday, September 27, 2012 5:49 AM
To: [email-masked]
Subject: [CDNi] New draft submitted draft-famaey-cdni-has-experiments-00

Dear all,

We have submitted a new draft on the delivery of HTTP Adaptive Streaming (HAS) content over interconnected CDNs.  The document presents experimental results on the influence of multiple alternative CDN-I request routing approaches on the quality of delivered HAS content streams.  The approaches are based on the HAS chunk addressing methods proposed in draft-brandenburg-cdni-has-03.  We look forward to your comments and feedback.

http://tools.ietf.org/id/draft-famaey-cdni-has-experiments-00.txt

Kind regards,
Jeroen Famaey

--
Dr. Jeroen Famaey
Department of Information Technology
Internet Based Communication Networks and Services (IBCN)
Ghent University - IBBT
Gaston Crommenlaan 8 (Bus 201), B-9050 Gent, Belgium
T: +32 9 33 14938; T Secr: +32 (0)9 33 14900
F: +32 9 33 14899
E: [email-masked]<mailto:[email-masked]>
W: http://users.ugent.be/~jfamaey
W: http://www.ibcn.intec.UGent.be

---

From: Kevin J Ma <[email-masked]>
Date: Fri, 9 Nov 2012 18:03:05 -0500

there was a missing set of parens: B * (SD - (4 * D + C)) / SD

From: [email-masked] [mailto:[email-masked]] On Behalf Of Kevin J Ma
Sent: Friday, November 09, 2012 5:57 PM
To: Jeroen Famaey; [email-masked]
Subject: Re: [CDNi] New draft submitted draft-famaey-cdni-has-experiments-00

Hi Jeroen,

thanx.

--  Kevin J. Ma

Dear all,

Kind regards,
Jeroen Famaey

---

From: Jeroen Famaey <[email-masked]>
Date: Fri, 23 Nov 2012 14:26:56 +0100

Hello Kevin,

Thanks for the feedback.  We will definitely take this into account for the next version of the draft.  I've included my responses inline.

>     B * (SD - (4 * D + C)) / SD
>  
That is indeed the case for content that is located upstream, in the case of the Upstream policy.  If the content is located downstream, or one of the other redirection policies is used, this upper bound would be different.
>   automatically use the redirect target for its subsequent requests.
Using a higher SD indeed reduces the problems related to high RTT.  However, there are some downsides to increasing the SD as well.  For example, the bitrate adaptation algorithm will be able to react more slowly, reducing optimality and the ability to adapt to changing network conditions.  Also, automatically switching to the redirect target for subsequent requests might pose problems in CDN interconnection scenario's, where subsequent segments may be located on different servers, or even within different administrative domains.  As such, we believe it's also necessary to look into other techniques, including manifest rewriting (which was addressed in the draft).
>   impact to average encoded bitrate is probably less dramatic?
This is true, we will consider varying the SD and reporting results on that as well.
>   to reflect any specific access network deployment scenarios?
We currently have new results where we also looked at different conditions within the access network (varying latencies and varying client bandwidth).  We are planning to report these in future versions of the draft.
>   or rewrite mechanisms that it would like to propose?
Currently, our goal is to show the general advantages of more optimized redirection mechanisms (that reduce the number of necessary redirects), which can be achieved by some form of manifest rewriting.  We have not considered specific mechanisms as of yet.
> --  Kevin J. Ma

Kind regards,
Jeroen

--
Dr. Jeroen Famaey
Department of Information Technology
Internet Based Communication Networks and Services (IBCN)
Ghent University - iMinds
Gaston Crommenlaan 8 (Bus 201), B-9050 Gent, Belgium
T: +32 9 33 14938; T Secr: +32 (0)9 33 14900
F: +32 9 33 14899
E: [email-masked]
W: http://users.ugent.be/~jfamaey
W: http://www.ibcn.intec.UGent.be