Subject: Re: [CDNi] Tweaking text in draft-ietf-cdni-framework before it goes to WG Last Call

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 23 Apr 2013 16:07:59 +0000

Larry,
You OK incorporating the suggestions below in the next rev of the framework?
Thanks
Francois

PS: any progress re editing & incorporating the text from cdni-metadata provided by Ben on "rewrite"?

On 11 Apr 2013, at 15:42, Francois Le Faucheur <[email-masked]> wrote:

> Larry, Bruce,
> 
> Following up on the following point (from IETF-86 CDNI WG Minutes):
> "
> - francois (as himself): need to tweak "check with me" support i.e. to clarify this might require protocol extension or protocol changes to support
> - larry peterson (channeled via webex): ok with tweaking "check with me" text
> "
> 
> I believe the last 3 paragraphs of section "4.6 Metadata Interface" in cdni-framework-03 relate to that topic.
> 
> Regarding:
> "
>   Fine-grain control over how the downstream CDN delivers content on
>   behalf of the upstream CDN is also possible.  For example, by
>   including the X-Forwarded-For HTTP header with the conditional GET
>   request, the downstream CDN can report the end-user's IP address to
>   the upstream CDN, giving it an opportunity to control whether the
>   downstream CDN should serve the content to this particular end-user.
>   The upstream CDN would communicate its directive through its response
>   to the conditional GET.  The downstream CDN can cache information for
>   a period of time specified by the upstream CDN, thereby reducing
>   control overhead.
> "
> 
> 1) I recommend you also refer to the "Forwarded" header, which is the IETF standardised version of X-Forwarded-For and refer to draft-ietf-appsawg-http-forwarded-10, "Forwarded HTTP Extension" that , as far as I can tell, is in RFC Editor queue.
> 
> 2) to be crystal clear, we may want to replace:
> OLD:
> "
> The downstream CDN can cache information for
>   a period of time specified by the upstream CDN, thereby reducing
>   control overhead.
> "
> by
> NEW:
> "
> The downstream CDN can cache information for
>   a period of time specified by the upstream CDN, thereby reducing
>   control overhead, but then preventing per request control during the corresponding caching period.
> "
> 
> 
> 
> Regarding:
> "
>   All of these in-band techniques serve to illustrate that uCDNs have
>   the option of enforcing some of their access control policies
>   themselves (at the expense of increased inter-CDN signaling load),
>   rather than delegating enforcement to dCDNs using the Metadata
>   Interface.  As a consequence, the Metadata Interface should provide a
>   means for the uCDN to express its desire to retain enforcement for
>   itself.  For example, this might be done by including a "check with
>   me" flag in the metadata associated with certain content.
> "
> 
> 1) I suggest replacing "the Metadata Interface should provide" by "the Metadata Interface could provide". (just to avoid suggesting this is placing "requirements" on the solution.
> 2) I suggest adding a sentence along the lines of "The realisation of such in-band techniques over the various inter-CDN acquisition protocol (e.g. HTTP) requires further investigation and may require small extensions or semantics re-definition of the acquisition protocol."
> 
> How does that sound?
> 
> Francois

---

From: "Peterson, Larry" <[email-masked]>
Date: Tue, 23 Apr 2013 16:18:08 -0500

These changes are all fine. --Larry

On Apr 23, 2013, at 12:07 PM, Francois Le Faucheur (flefauch) wrote:

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni