Subject: [CDNi] SEC-4 in in draft-ietf-cdni-requirements

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Thu, 10 Oct 2013 14:08:03 +0000

Kent, Liu,

"
SEC-4  [MED] The CDNI solution should be able to ensure that the
          Downstream CDN cannot spoof a transaction log attempting to
          appear as if it corresponds to a request redirected by a given
          Upstream CDN when that request has not been redirected by this
          Upstream CDN.  This ensures non-repudiation by the Upstream
          CDN of transaction logs generated by the Downstream CDN for
          deliveries performed by the Downstream CDN on behalf of the
          Upstream CDN.
"
I think this requirement does not reflect correctly how non-repudiation could play in teh context of CDNI Logging. For example, since the logging information is sent by dCDN to uCDN, it only makes sense to talk about non-repudiation by dCDN, not by uCDN.

I suggest a rewording along the lines of: 

"
SEC-4  [MED] The CDNI solution should be able to ensure non-repudiation by the Downstream
          CDN of transaction logs generated by the Downstream CDN and communicated to an Upstream CDN. This reduces the incentives for the Downstream CDN to spoof a transaction log attempting to appear as if it corresponds to a request redirected by the Upstream CDN when that request has not been redirected by this Upstream CDN.
"

Cheers

Francois

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 14 Oct 2013 02:13:43 +0100

Francois, Colleagues,

>          CDN of transaction logs generated by the Downstream CDN and communicated to an Upstream CDN. This reduces the incentives for the Downstream CDN to spoof a transaction log attempting to app…

I don't see how the second sentence leads from the first. I.e. I don't see how a dCDN having the ability to ensure logs that it has generated are not modified reduces the dCDN's incentive to spoof (or not to spoof) log entries.

Maybe just drop the second sentence entirely?

Ben

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Mon, 14 Oct 2013 12:37:33 +0000

> I don't see how the second sentence leads from the first. I.e. I don't see how a dCDN having the ability to ensure logs that it has generated are not modified reduces the dCDN's incentive to spoof…

What non-repudiation brings is the fact that the dCDN can not dispute having sent a particular Log Record (and have it sent exactly as recieved by the uCDN).

So a dCDN that is caught sending a CDNI Logging file with invalid records (and the proof for that would have to be established via some other mechanism, such as for example contrasting it to CSP logs generated from end-devices) can not just say "oh, I never sent that file, you must have done something wrong yourself and generated/corrupted that logging record/file yourself". Basically, it brings traceability which generally helps keeping people honest. It is an open question as to whether such a non-repudiation mechanism brings sufficient value or not. Some argued "yes", which is why we have a requirement for it. But that is a separate question. 

Perhaps we should not say that "it reduces the incentive", but rather that it creates a disincentive to cheat. 

Perhaps this wording may help make things a little clearer:
"
SEC-4  [MED] The CDNI solution should be able to ensure non-repudiation by the Downstream CDN of transaction logs generated by the Downstream CDN and communicated to an Upstream CDN. This would ensure that the Downstream CDN can not repudiate transmitted Log records, and therefore act as a disincentive for the dCDN to spoof a transaction log (attempting to appear as if it corresponds to a request redirected by the Upstream CDN when that request has not been redirected by this Upstream CDN).
"

> Maybe just drop the second sentence entirely?

That woudl be an easy way out, but it is clearly far from trivial to articulate the rationale for including a requirement about non-repudiatin, I think we need to record teh rationale. Otherwise, the question will most likely come up come up at review time down the pipe.

Cheers

Francois

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Tue, 15 Oct 2013 19:14:15 +0000

Good discussion. So, do we have agreement to update the requirement with the following?

"SEC-4  [MED] The CDNI solution should be able to ensure non-repudiation by the Downstream CDN of transaction logs generated by the Downstream CDN and communicated to an Upstream CDN. This would ensure that the Downstream CDN cannot repudiate transmitted Log records, and therefore reduces the incentive for the dCDN to spoof a transaction log (attempting to appear as if it corresponds to a request redirected by the Upstream CDN when that request has not been redirected by this Upstream CDN)."

Kent

-----Original Message-----
From: Francois Le Faucheur (flefauch) 
Sent: Monday, October 14, 2013 5:38 AM
To: Ben Niven-Jenkins
Cc: Francois Le Faucheur (flefauch); Kent Leung (kleung); Yiu Lee; <[email-masked]>
Subject: Re: [CDNi] SEC-4 in in draft-ietf-cdni-requirements

Cheers

Francois

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Tue, 15 Oct 2013 19:17:52 +0000

Oops. This is the requirement text to confirm:

"
SEC-4  [MED] The CDNI solution should be able to ensure non-repudiation by the Downstream CDN of transaction logs generated by the Downstream CDN and communicated to an Upstream CDN. This would ensure that the Downstream CDN cannot repudiate transmitted Log records, and therefore act as a disincentive for the dCDN to spoof a transaction log (attempting to appear as if it corresponds to a request redirected by the Upstream CDN when that request has not been redirected by this Upstream CDN).
"

Kent

-----Original Message-----
From: Kent Leung (kleung) 
Sent: Tuesday, October 15, 2013 12:12 PM
To: Francois Le Faucheur (flefauch); Ben Niven-Jenkins
Cc: Yiu Lee; <[email-masked]>
Subject: RE: [CDNi] SEC-4 in in draft-ietf-cdni-requirements

Kent

-----Original Message-----
From: Francois Le Faucheur (flefauch) 
Sent: Monday, October 14, 2013 5:38 AM
To: Ben Niven-Jenkins
Cc: Francois Le Faucheur (flefauch); Kent Leung (kleung); Yiu Lee; <[email-masked]>
Subject: Re: [CDNi] SEC-4 in in draft-ietf-cdni-requirements

Cheers

Francois

---

From: <[email-masked]>
Date: Thu, 17 Oct 2013 10:06:29 +0200

I think it's a bit complicated, maybe replace the second phrase with something like:

This would ensure that the Downstream CDN cannot repudiate transmitted Log records, therefore discouraging the dCDN from spoofing a transaction log (attempting to appear as if it corresponds to a request redirected by the Upstream CDN when that request has not been redirected by this Upstream CDN). 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Kent Leung (kleung)
Envoyé : mardi 15 octobre 2013 21:18
À : Francois Le Faucheur (flefauch); Ben Niven-Jenkins
Cc : <[email-masked]>; Yiu Lee
Objet : Re: [CDNi] SEC-4 in in draft-ietf-cdni-requirements

"

Kent

-----Original Message-----
From: Kent Leung (kleung)
Sent: Tuesday, October 15, 2013 12:12 PM
To: Francois Le Faucheur (flefauch); Ben Niven-Jenkins
Cc: Yiu Lee; <[email-masked]>
Subject: RE: [CDNi] SEC-4 in in draft-ietf-cdni-requirements

Kent

-----Original Message-----
From: Francois Le Faucheur (flefauch)
Sent: Monday, October 14, 2013 5:38 AM
To: Ben Niven-Jenkins
Cc: Francois Le Faucheur (flefauch); Kent Leung (kleung); Yiu Lee; <[email-masked]>
Subject: Re: [CDNi] SEC-4 in in draft-ietf-cdni-requirements

Cheers

Francois

> Ben

_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Thu, 17 Oct 2013 09:51:28 +0000

> This would ensure that the Downstream CDN cannot repudiate transmitted Log records, therefore discouraging the dCDN from spoofing a transaction log (attempting to appear as if it corresponds to a r…

I also like this wording better.

Francois

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Mon, 21 Oct 2013 16:19:35 +0000

OK. Looks like there are no disagreements. I'll update the draft with the following:

SEC-4  [MED] The CDNI solution should be able to ensure non-repudiation by the Downstream CDN of transaction logs generated by the Downstream CDN and communicated to an Upstream CDN. This would ensure that the Downstream CDN cannot repudiate transmitted Log records, therefore discouraging the dCDN from spoofing a transaction log (attempting to appear as if it corresponds to a request redirected by the Upstream CDN when that request has not been redirected by this Upstream CDN).

Kent

-----Original Message-----
From: Francois Le Faucheur (flefauch) 
Sent: Thursday, October 17, 2013 2:51 AM
To: [email-masked]
Cc: Francois Le Faucheur (flefauch); Kent Leung (kleung); Ben Niven-Jenkins; <[email-masked]>; Yiu Lee
Subject: Re: [CDNi] SEC-4 in in draft-ietf-cdni-requirements

Francois

> De : [email-masked] [mailto:[email-masked]] De la part 
> de Kent Leung (kleung) Envoyé : mardi 15 octobre 2013 21:18 À : 
> Francois Le Faucheur (flefauch); Ben Niven-Jenkins Cc : 
> <[email-masked]>; Yiu Lee Objet : Re: [CDNi] SEC-4 in in 
> draft-ietf-cdni-requirements
> 
> ______________________________________________________________________
> ___________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.