Subject: [CDNi] I-D Action: draft-ietf-cdni-logging-08.txt

From: [email-masked]
Date: Fri, 18 Oct 2013 01:51:37 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Content Delivery Networks Interconnection Working Group of the IETF.

	Title           : CDNI Logging Interface
	Author(s)       : Francois Le Faucheur
                          Gilles Bertrand
                          Iuniana Oprescu
                          Roy Peterkofsky
	Filename        : draft-ietf-cdni-logging-08.txt
	Pages           : 46
	Date            : 2013-10-18

Abstract:
   This memo specifies the Logging interface between a downstream CDN
   (dCDN) and an upstream CDN (uCDN) that are interconnected as per the
   CDN Interconnection (CDNI) framework.  First, it describes a
   reference model for CDNI logging.  Then, it specifies the CDNI
   Logging File format and the actual protocol for exchange of CDNI
   Logging Files.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cdni-logging

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-cdni-logging-08

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-cdni-logging-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Fri, 18 Oct 2013 09:08:45 +0000

Folks,

(as a co-author)

The key changes from -07 to -08 are:
	* replaced the integrity-hash value in CDNI Logging File example with the correct value computed on the actual Logging file content
	* reflected discussion/agreement on the list about situation where the dCDN no longer wants to make old CDNI Logging file available
	* tweaked the example times in the CDNI Logging Feed example
	* changed "MUST" into "MAY" in "A client-side implementation of the CDNI Logging interface MAY pull, at its convenience, a CDNI Logging File". This is because it is up to a client to decide if/when they want t o pull logging files.
	* added a sub-section on DoS in Security Considerations, as a result of reviewing compliance against the Security related requirements of cdni-requirements.
	* corrected compliance to SEC-2 from "Full" to "partial" since no specific mechanisms are defined in spec against DOS
	* added editor's note clarifying that the Appendix reviewing compliance to cdni-requirements is expecte dto be removed before publication.
	* editos/typos
	* updated Ack section

>From the authors viewpoint, the document is now ready to move to WG Last Call and we plan to poll the WG in Vancouver about doing so.

Cheers

Francois & co-authors

On 18 Oct 2013, at 10:51, <[email-masked]>
 wrote:

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni