Subject: [CDNi] URI structure issue with draft-leung-cdni-uri-signing-03

From: "Kent Leung (kleung)" <[email-masked]>
Date: Fri, 8 Nov 2013 07:49:52 +0000

Just an update on this topic.

A few of us met with Mark Nottingham today to discuss the issue that he brought up in draft-nottingham-uri-get-off-my-lawn. In summary, Mark does not want "baked in" query string attributes or any portion in the URI. So, the proposed solution presented in the WG session should address that concern. Basically, CDNI metadata conveys how the query string is encoded to include the URI Signing information elements (URI signature, algorithm used, etc.) This information is used by the Downstream CDN to validate the Signed URI.

The next step is to revise the draft so the URI Signing method uses this approach. It should also incorporate the comments from Kevin. When that's ready, Mark agreed to review the draft and stamp it as "off his lawn" if the solution no longer is standardizing a structure in the URI. :)

Kent

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Fri, 8 Nov 2013 18:50:40 +0000

Putting Mark explicitely in the loop.
Francois

On 7 Nov 2013, at 23:49, Kent Leung (kleung) <[email-masked]<mailto:[email-masked]>> wrote:

A few of us met with Mark Nottingham today to discuss the issue that he brought up in draft-nottingham-uri-get-off-my-lawn. In summary, Mark does not want “baked in” query string attributes or any portion in the URI. So, the proposed solution presented in the WG session should address that concern. Basically, CDNI metadata conveys how the query string is encoded to include the URI Signing information elements (URI signature, algorithm used, etc.) This information is used by the Downstream CDN to validate the Signed URI.

The next step is to revise the draft so the URI Signing method uses this approach. It should also incorporate the comments from Kevin. When that’s ready, Mark agreed to review the draft and stamp it as “off his lawn” if the solution no longer is standardizing a structure in the URI. :)

Kent

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni