Subject: [CDNi] Dependencies & interactions between FCI and LI/MI/RI/CI

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Fri, 17 Oct 2014 15:56:00 +0000

Folks,

During the last IETF meeting we discussed dependencies and interactions between Fottprint & Capabilities advertisement and the other CDNI interfaces (Logging, Metadata, Redirection, Control): See excerpt from the Toronto CDNI minutes at the bottom of this message.

Two options for handling this were presented in Toronto and a tentative agreement for the second option was reached.

Since then, a bunch of the protagonists (Kevin, Jan, Jon, Daryl, Francois) continued discuss this and came up with a third Option which we feel is a better compromise. I have asked Kevin to summarise this third option and its merits for review and discussion on the list. If no objections are raised within a week of Kevin describing it, we’d like to adopt this as the approach going forward. Some of the LI/MI/RI/CI specs are on hold since they need to be aligned to the final agreed approach.

Please keep an eye for Kevin’s message and raise support or concern promptly.

Thanks

Francois
CDNI WG Chair

========================
FCI Semantics, draft-ietf-cdni-footprint-capabilities-semantics-03: Kevin Ma
-------------------------------------------------------------------------------
- Kevin presented the status update
- Problem presented regarding, “Binary options for Logging/Metadata capability
support is unlikely to be sufficient to describe optional modes.” (See slide 3 for details)
- Jan S: For things we know right now, binary is sufficient. But for future extensibility, we need to go beyond binary. Don’t know?
- Francois: Why not possible to avoid dependencies on FCI draft to publish Metadata and Logging drafts?
- Kevin: Avoid shadow registries that are for FCI and other CDNI interfaces (metadata, logging, uri signing)
- Jan S: Don’t need to decide now, WG needs to be aware of the issue and post comments on ML. Hard to decide right now w/o thinking more about it.
- Daryl: I would like to wrap this up ASAP and get Logging draft through
- Francois: Is there a way to reference the advertisement objects in other drafts from FCI registry?
- Kevin: This will block semantics draft, but not the FCI draft
- Spencer: If you go with binary, and stuck in the future, what would you do?
- Kevin/Jon: Rewrite the protocol, not non-backwards compatible
- Spencer: I don’t like that.
- Jan/Kevin/Jon: More debate …
- Francois: Can you update FCI semantics draft so other drafts can document their own FCI advertisement objects? Give guidance to other drafts.
- Matt C: My opinion that FCI is done before other drafts. I like option 2.
- Cary Fitzgerald: Seems that you need to do the parsing?
- Kevin: Duplicate registries are difficult to sync up
- Kent: Option #2 seems reasonable
- Ray: Likes option #2
- Jan S: Timeframe issue, can FCI semantics be done in time?
- Jon P: Need to steal stuff to write up FCI semantics
- Jon P.: Next version of FCI semantics draft can be done by mid-Sept
- Francois: Now the Logging draft needs to be updated to use the semantics for advertising of its objects. And there will still be a dependency for publication.
- Room rough consensus on #2 to have each draft document its own advertisement objects using the FCI semantics
- Chairs will identify a non-author reviewer for next rev of FCI semantics draft.

---

From: Kevin Ma J <[email-masked]>
Date: Fri, 17 Oct 2014 17:30:31 +0000

Hi all,

  The previous question was how to divide up the work of advertisement of capabilities
  (i.e., what logging fields do you support, what metadata/options do you support, etc.).
  Ideally, capability advertisement would be defined with interfaces themselves, however,
  the FCI specifications are not as mature as other (MI/LI/RI/CI) interfaces.  In an effort
  to allow progress of those interfaces, as we finish defining FCI, we propose the following:

  1. The MI/LI/RI/CI drafts remove any place holders for FCI discussion.
  2. The FCI semantics draft will define the template for FCI objects.
  3. The FCI semantics draft will define a registry for FCI objects.
  4. We will publish separate RFCs describing capability advertisement for MI/LI/RI/CI.
     The FCI objects defined in these RFCs will be registered in the FCI object registry
     created by the FCI semantics draft.

  We believe this provides the best trade-off between expediency and functionality.

thanx.

--  Kevin J. Ma

> -----Original Message-----
> From: Francois Le Faucheur (flefauch) [mailto:[email-masked]]
> Sent: Friday, October 17, 2014 11:56 AM
> To: [email-masked]
> Cc: Francois Le Faucheur (flefauch); Jon Peterson; Jan Seedorf; Kevin Ma J;
> Daryl Malas
> Subject: Dependencies & interactions between FCI and LI/MI/RI/CI
> 
> Folks,
> 
> During the last IETF meeting we discussed dependencies and interactions
> between Fottprint & Capabilities advertisement and the other CDNI interfaces
> (Logging, Metadata, Redirection, Control): See excerpt from the Toronto CDNI
> minutes at the bottom of this message.
> 
> Two options for handling this were presented in Toronto and a tentative
> agreement for the second option was reached.
> 
> Since then, a bunch of the protagonists (Kevin, Jan, Jon, Daryl, Francois)
> continued discuss this and came up with a third Option which we feel is a
> better compromise. I have asked Kevin to summarise this third option and its
> merits for review and discussion on the list. If no objections are raised
> within a week of Kevin describing it, we'd like to adopt this as the
> approach going forward. Some of the LI/MI/RI/CI specs are on hold since they
> need to be aligned to the final agreed approach.
> 
> Please keep an eye for Kevin's message and raise support or concern
> promptly.
> 
> Thanks
> 
> Francois
> CDNI WG Chair
> 
> 
> 
> ========================
> - Problem presented regarding, "Binary options for Logging/Metadata
> capability
> support is unlikely to be sufficient to describe optional modes." (See slide
> 3 for details)
> - Jan S: For things we know right now, binary is sufficient. But for future
> extensibility, we need to go beyond binary. Don't know?
> - Jan S: Don't need to decide now, WG needs to be aware of the issue and
> post comments on ML. Hard to decide right now w/o thinking more about it.
> - Spencer: I don't like that.
> - Jan/Kevin/Jon: More debate ...
> - Francois: Can you update FCI semantics draft so other drafts can document
> their own FCI advertisement objects? Give guidance to other drafts.
> - Francois: Now the Logging draft needs to be updated to use the semantics
> for advertising of its objects. And there will still be a dependency for
> publication.
> - Room rough consensus on #2 to have each draft document its own
> advertisement objects using the FCI semantics

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Mon, 20 Oct 2014 16:25:04 +0000

Hi all,

As mentioned before, if no objections are raised by 24 October, we’ll adopt the approach described below by Kevin.

Cheers

Francois

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 24 Oct 2014 13:28:06 +0100

Francois, Kevin,

The approach proposed seems pragmatic & sensible to me.

Ben

On 20 Oct 2014, at 17:25, Francois Le Faucheur (flefauch) <[email-masked]> wrote:

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Sat, 25 Oct 2014 13:54:46 +0000

Hi all,
Since no objections have been raised, the Working Group is adopting the approach described below by Kevin.

To all cdni document authors,
Please align all documents that are not yet aligned to this approach, if at all possible before the Honolulu cut-off date (i.e. Monday 27 October).

Thanks you

Francois & Daryl

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Thu, 30 Oct 2014 08:04:07 +0000

Hi all,

Sorry for the late response, I¹ve been on vacation. I¹m ok with the
proposal below. The only question I have concerns point 4. Did you guys
consider the option of writing a single RFC with the FCI parts of all four
main CDNI interfaces instead of having separate RFCs for each?

Thanks,

Ray

On 25/10/14 15:54, "Francois Le Faucheur (flefauch)" <[email-masked]>
wrote:

>Please align all documents that are not yet aligned to this approach, if
>at all possible before the Honolulu cut-off date (i.e. Monday 27 October).
>
>Thanks you
>
>Francois & Daryl
>
>
>> As mentioned before, if no objections are raised by 24 October, we¹ll
>>adopt the approach described below by Kevin.
>> 
>> Cheers
>> 
>> Francois
>> 
>>>>-----------------------------------------------------------------------
>>>>-----
>>>> ---
>>>> - Francois: Why not possible to avoid dependencies on FCI draft to
>>>>publish
>>>> Metadata and Logging drafts?
>>>> - Kevin: Avoid shadow registries that are for FCI and other CDNI
>>>>interfaces
>>>> (metadata, logging, uri signing)
>>>> - Francois: Is there a way to reference the advertisement objects in
>>>>other
>>>> drafts from FCI registry?
>>>> - Spencer: If you go with binary, and stuck in the future, what would
>>>>you
>>>> do?
>>>> - Chairs will identify a non-author reviewer for next rev of FCI
>>>>semantics
>>>> draft.
>> 

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Thu, 30 Oct 2014 08:40:07 +0000

Ray and all,

(As an individual)

See below:

> main CDNI interfaces instead of having separate RFCs for each?

That sounds like a very valid option.
When we’re at that point, we can decide between separate RFCs or a common one (there _may_ be a reason to go fro separate ones because of respective progress & timing of the different interfaces).

Cheers

Francois