Subject: Re: [CDNi] review comments to draft-ietf-cdni-metadata-08

From: Linda Dunbar <[email-masked]>
Date: Tue, 28 Oct 2014 22:22:34 +0000

Ben, Rob, Matt, and Kevin,

Is section 3 meant for "Information Model"?

I think there should be a section to describe the information model (or UML) for the CDNi Meta data before the actual data model.

Linda

From: Linda Dunbar
Sent: Tuesday, October 28, 2014 3:46 PM
To: [email-masked]'; [email-masked]
Subject: review comments to draft-ietf-cdni-metadata-08

Ben, Rob, Matt, and Kevin,

This draft is long and defined a lot of terms: Host Index, Host Match, host-meta-data, Path Match, path-meta-data, generic-metadata-objects, etc.
Is the intent of the draft to define the proper data structure for dCDN to request content from upstream CDN?

Is the following correct?

host-meta-data == "IP addresses"?
path-meta-data == URI?

The "PathMatch" is about matching the URI path, isn't it?
Is the "Host Match" about matching "Host Identity"?

For the example shown on Page 34:
If the incoming request has a Host header with "video.example.com"
then the downstream CDN would fetch the next metadata object from
"http://metadata.ucdn.example/host1234" expecting a MIME type of
"application/cdni.HostMetadata.v1+json":

A much simpler expression could be "if host = .., then fetch content from the URI".  It doesn't really need all the terminologies defined in earlier sections, does it?

Linda Dunbar

Huawei USA IP Technology Lab
5340 Legacy Drive,
Plano, TX 75024
Tel: +1 469-277 - 5840
Fax: +1 469 -277 - 5900

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 28 Oct 2014 23:10:13 +0000

Linda,

On 28 Oct 2014, at 22:22, Linda Dunbar <[email-masked]> wrote:

> Is section 3 meant for “Information Model”?
>  

Could you expand a bit on what improvement you think including an information model would add to the document?

I don't recall coming across something like that in other protocols specifications.

Thanks
Ben

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 30 Oct 2014 15:53:24 +0000

Ben, 

Your draft showed JSON model. The same information can be represented by other models, like XML or YANG. 

Therefore, I think it is better to have a section describing the information model, and have another section showing JSON data model. 

Linda 
-----Original Message-----
From: Ben Niven-Jenkins [mailto:[email-masked]] 
Sent: Tuesday, October 28, 2014 6:10 PM
To: Linda Dunbar
Cc: [email-masked]; [email-masked]
Subject: Re: [CDNi] review comments to draft-ietf-cdni-metadata-08

Linda,

Thanks
Ben