Subject: [CDNi] review comments to draft-ietf-cdni-metadata-08

From: Linda Dunbar <[email-masked]>
Date: Tue, 28 Oct 2014 20:46:10 +0000

Ben, Rob, Matt, and Kevin,

This draft is long and defined a lot of terms: Host Index, Host Match, host-meta-data, Path Match, path-meta-data, generic-metadata-objects, etc.
Is the intent of the draft to define the proper data structure for dCDN to request content from upstream CDN?

Is the following correct?

host-meta-data == "IP addresses"?
path-meta-data == URI?

The "PathMatch" is about matching the URI path, isn't it?
Is the "Host Match" about matching "Host Identity"?

For the example shown on Page 34:
If the incoming request has a Host header with "video.example.com"
then the downstream CDN would fetch the next metadata object from
"http://metadata.ucdn.example/host1234" expecting a MIME type of
"application/cdni.HostMetadata.v1+json":

A much simpler expression could be "if host = .., then fetch content from the URI".  It doesn't really need all the terminologies defined in earlier sections, does it?

Linda Dunbar

Huawei USA IP Technology Lab
5340 Legacy Drive,
Plano, TX 75024
Tel: +1 469-277 - 5840
Fax: +1 469 -277 - 5900

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 28 Oct 2014 23:29:14 +0000

Linda,

> Is the intent of the draft to define the proper data structure for dCDN to request content from upstream CDN?

No. The intent is to define data structures for describing how to deliver content, as well as policies for where is allowed to receive it, etc.

The details of how to obtain the content is only one part of describing how to deliver the content.
 
> host-meta-data == “IP addresses”?

host-meta-data isn't used in the document. I'm assuming you are asking what the value of the host-metadata property is?

It is a link to a URI that returns a HostMetadata object which is a JSON object describing the default CDNI Metadata objects for content served from that host.

> path-meta-data == URI?

path-metadata is a link to a URI that returns a PathMetadata object which is a JSON object describing the CDNI GenericMetadata objects for content served with the associated URI path (defined in a PathMatch object).

>  
> The “PathMatch” is about matching the URI path, isn’t it?

Yes.

> Is the “Host Match” about matching “Host Identity”?

I'm not sure what you mean by "host Identity". The HostMatch tells the dCDN which URIs provide the necessary metadata for which hostnames the CDN may receive request on.
 
> A much simpler expression could be “if host = .., then fetch content from the URI”.  It doesn’t really need all the terminologies defined in earlier sections, does it?

I don't understand your point? 

Ben

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 30 Oct 2014 21:05:03 +0000

Ben,

Thanks for the reply.

More suggestions inserted below:

-----Original Message-----
From: Ben Niven-Jenkins [mailto:[email-masked]]
Sent: Tuesday, October 28, 2014 6:29 PM
To: Linda Dunbar
Cc: [email-masked]; [email-masked]
Subject: Re: [CDNi] review comments to draft-ietf-cdni-metadata-08

Linda,

[Linda] It would make the document easier to read if you add this statement to the Introduction Section.

The current Abstract section says that the draft also describes the "Protocol for exchange Metadata". I would suggest Section 5 (Leverage existing protocol) to simply "Protocols for exchanging Metadata".  In the content, you can say why you need to leverage the existing protocols.

[Linda] Is there any significance to emphasize on the "Link to a URI" instead simple the "URI"?
Do you mean the value of "HostMetadata" is a link to a URI?

Thanks, Linda