Subject: Re: [CDNi] Working Group Last Call on draft-ietf-cdni-uri-signing (take 2)

From: Kevin Ma <[email-masked]>
Date: Wed, 7 Aug 2019 20:36:34 -0400

Hi Chris,

  I don't see any reason why we couldn't add a registry for the error codes.

Phil,

  Do you have any thoughts on Chris's comments?

thanx.

--  Kevin J. Ma

On Fri, Jul 26, 2019 at 2:23 PM Chris Lemmons <[email-masked]> wrote:

> So I was reviewing all the extension points. I noticed that although
> the s-uri-signing logging field is added to the IANA registry, the
> field itself is defined by a list of numbers that are themselves part
> of no registry. Since there's a one-to-one mapping between all failure
> types and a logging code, any extension claims cannot record an
> associated code. This will cause implementations to try to pick a
> "related" or "generic" logging code for validations that fail on
> account of a supported extension. (Unsupported extensions, of course,
> would record 409.) Is there a reasonable way to provide a registry for
> these codes?
>
> As an editorial note, the header provided in the example for cdni
> metadata is not valid: "jwt-header": "1234abcd". That 1234abcd should
> probably be a valid jwt header instead.
>
> On Wed, Jul 24, 2019 at 1:46 AM Kevin Ma <[email-masked]>
> wrote:
> >
> > Hi All,
> >
> >   Today will begin the two-week WGLC on:
> https://tools.ietf.org/html/draft-ietf-cdni-uri-signing-18
> >
> >   Please send any comments, questions, or concerns to the CDNI mailing
> list: [email-masked]
> >
> >  The WGLC will end on Wednesday August 7, 2019, at which time, assuming
> there are no objections, we will submit the draft to the IESG
> >
> > thanx!
> >
> > --  Kevin, Phil, and Francois
> > _______________________________________________
> > CDNi mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/cdni
>
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
>

---

From: Kevin Ma <[email-masked]>
Date: Wed, 7 Aug 2019 20:40:26 -0400

Hi All,

  The WGLC has now closed.  There were no major objections.  We will
address Chris's comments and move forward with submitting the draft.

thanx!

On Wed, Jul 24, 2019 at 1:46 AM Kevin Ma <[email-masked]> wrote:

>  The WGLC will end on Wednesday August 7, 2019, at which time, assuming there are no objections, we will submit the draft to the IESG
>
> thanx!
>