Subject: [CDNi] Common Access Token, for Awareness

From: Chris Lemmons <[email-masked]>
Date: Mon, 7 Mar 2022 09:12:15 -0700

The CTA WAVE project is working together to create a Common Access
Token and we've observed that the token there overlaps significantly
with the token defined in CDNI's URI Signing document. We thought that
the broad-strokes work might be of general interest and wondered if
this group would like to hear about the general direction and goals
for the token since they overlap heavily.

The current work on the CAT uses CWTs and will need to register
claims. Since many of the claims are nearly one-to-one identical with
URI Signing claims, if this group envisions a potential successor to
URI Signing that uses CWTs, there may be some value in making sure we
don't wind up with a duplicate or near-duplicate claims issue in the
CWT Claim Registry.

Is there interest in allocating a few minutes for me to share the
state of the work from the Common Access Token, for general awareness?

---

From: Christoph Neumann <[email-masked]>
Date: Mon, 14 Mar 2022 17:04:17 +0000

Hi Chris, all,

Thank you for your proposal to share the state of work for the Common Access Token. I think it would be really useful to have this presentation, especially if there is overlap with the CDNI's URI Signing document. I think it is important that these different initiatives align or at least go into the same direction.

Christoph

-----Original Message-----
From: CDNi <[email-masked]> On Behalf Of Chris Lemmons
Sent: lundi 7 mars 2022 17:12
To: <[email-masked]> <[email-masked]>
Subject: [CDNi] Common Access Token, for Awareness

The CTA WAVE project is working together to create a Common Access Token and we've observed that the token there overlaps significantly with the token defined in CDNI's URI Signing document. We thought that the broad-strokes work might be of general interest and wondered if this group would like to hear about the general direction and goals for the token since they overlap heavily.

The current work on the CAT uses CWTs and will need to register claims. Since many of the claims are nearly one-to-one identical with URI Signing claims, if this group envisions a potential successor to URI Signing that uses CWTs, there may be some value in making sure we don't wind up with a duplicate or near-duplicate claims issue in the CWT Claim Registry.

Is there interest in allocating a few minutes for me to share the state of the work from the Common Access Token, for general awareness?

_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

---

From: "Chaudhari, Pankaj" <[email-masked]>
Date: Mon, 14 Mar 2022 23:46:25 +0000

+1
Considering that the CAT (common access token) WG of CTA-WAVE is mostly settled on the use of CWT, it would be very beneficial that we have some alignment if not hear feedback from CDNi on the work done by CAT. 

- Pankaj

On 3/14/22, 10:04 AM, "CDNi on behalf of Christoph Neumann" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Chris, all,

    Christoph

    -----Original Message-----
    From: CDNi <[email-masked]> On Behalf Of Chris Lemmons
    Sent: lundi 7 mars 2022 17:12
    To: <[email-masked]> <[email-masked]>
    Subject: [CDNi] Common Access Token, for Awareness

    _______________________________________________
    CDNi mailing list
    [email-masked]
    https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fcdni&amp;data=04%7C01%7Cpc.chaudhari%40disneystreaming.com%7C9aa76938727848dd5dd708da05dcb864%7C65f03ca86d0a493e9e4ac85ac9526a03%7C0%7C0%7C637828742792791936%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=5A0WA%2BrLUHGdq94FtsoEWG2ZMW1tnL8kBXFl7Hx9apk%3D&amp;reserved=0

    _______________________________________________
    CDNi mailing list
    [email-masked]
    https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fcdni&amp;data=04%7C01%7Cpc.chaudhari%40disneystreaming.com%7C9aa76938727848dd5dd708da05dcb864%7C65f03ca86d0a493e9e4ac85ac9526a03%7C0%7C0%7C637828742792791936%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=5A0WA%2BrLUHGdq94FtsoEWG2ZMW1tnL8kBXFl7Hx9apk%3D&amp;reserved=0