Subject: [Cellar] DRAFT minutes of virtual interim meeting, 2018-08-28

From: Michael Richardson <[email-masked]>
Date: Wed, 19 Sep 2018 11:54:08 -0400

CELLAR -- Virtual Interim Meeting

DRAFT MINUTES FOR Virtual Interim Meeting:  August 28, 2018        20:00 UTC

INFO:
        https://datatracker.ietf.org/meeting/interim-2018-cellar-04/session/cellar

Attendees:
Michael Richardson
Moritz Bunkus
Jérôme Martinez
Martin Below
Steve Lhomme
Dave Rice (as call-in user)
Michael Niedermayer
<PLEASE SIGN YOUR NAME HERE>
Missing: Tim Terriberry

Agenda:

1. Note Well.    https://www.ietf.org/about/note-well/
2. Draft minutes from Last meeting  https://www.ietf.org/mail-archive/web/cellar/current/msg01652.html
Adopted as written.

3. Logistics for Meeting.
   2a) Etherpad for notes
       https://etherpad.tools.ietf.org/p/notes-cellar-virtual04?useMonospaceFont=true

   2b) Roll call

4. WG status update
   - milestones submitted.
   - EBML not in WG last call yet.
   - 

5. Progress on EBML comments and review.
   - when we can get EBML-05 posted?
   - 8 issues open, 4 are "feature requests" for a future revision, 4 are
      small issues with pull requests outstanding.
      https://github.com/Matroska-Org/ebml-specification/issues/183
      The Group thinks that First Come First Served should be fine for the EBML DocType Registry.
 Initial values of matroska, and webm.
 "rawcooked" will be added Jérôme Martinez.

      https://github.com/Matroska-Org/ebml-specification/issues/182
      closed with small change to document.

      https://github.com/Matroska-Org/ebml-specification/issues/176
    closed, with attachment not being recurring.

      https://github.com/Matroska-Org/ebml-specification/issues/175  LEFT OPEN
    unclear if this is an ebml issue, but this is an addition.
  
      https://github.com/Matroska-Org/ebml-specification/issues/164  LEFT OPEN
      desire for a rational number format, extension.  can be defined as an extension.

      https://github.com/Matroska-Org/ebml-specification/issues/157 closed
      #180 closed, nobody liked it.
 #181 https://github.com/Matroska-Org/ebml-specification/pull/181  <- consensus to go with this solution.

      https://github.com/Matroska-Org/ebml-specification/issues/156
      this should be a new document, JSON/XML/etc. translation of EBML.

      https://github.com/Matroska-Org/ebml-specification/issues/48  CLOSED in previous version.

6. EBML IANA Considerations, REDUX.

   - Link to IANA considerations thread -
      https://www.ietf.org/mail-archive/web/cellar/current/msg01601.html
   - EBML Header has TLV Element with Document Type. ElementID=xxx.
   - EBML Header Document Type needs a registry for Document Types: what is the amending
   - EBML header ElementIDs should have an update rule that says IETF Standards Action to update, (and version must be > 1).

(was discussed above)

ACTION:
    1) updated ebml document for week of August 27, with updated IANA considerations for all additions.
          (ElementName, and DocType Registry)
    2) ffv1 to be worked upon in September..
    3) work on Matroska document for September meeting.

7. Any other Business.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Wed, 19 Sep 2018 11:57:02 -0400

Last month we said:

and so I'm looking for agenda items relating to ffv1 and Matroska.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Michael Richardson <[email-masked]>
Date: Wed, 19 Sep 2018 11:58:43 -0400

Michael Richardson <[email-masked]> wrote:
    > 5. Progress on EBML comments and review.     - when we can get EBML-05
    > posted?

I think that we came to a number of useful conclusions at the last meeting,
and we need to get them into a new -05 document.

Do you think that we can get that posted this week?
If so, then we can get this document into WGLC.

    > ACTION:     1) updated ebml document for week of August 27, with
    > updated IANA considerations for all additions.            (ElementName,
    > and DocType Registry)

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 23 Sep 2018 08:24:02 +0200

-06 was alread published and -07 is pending. I'm checking the status
of the EBML extension if it needs to be merged in there or not. After
that there is no pending issue/PR for EBML v1.
Le mer. 19 sept. 2018 à 17:58, Michael Richardson
<[email-masked]> a écrit :
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman

---

From: Michael Richardson <[email-masked]>
Date: Sun, 23 Sep 2018 16:28:05 -0400

Steve Lhomme <[email-masked]> wrote:
    > -06 was alread published and -07 is pending. I'm checking the status of
    > the EBML extension if it needs to be merged in there or not. After that
    > there is no pending issue/PR for EBML v1.

That sounds like we can start a WGLC then.

---

From: Steve Lhomme <[email-masked]>
Date: Mon, 24 Sep 2018 09:58:23 +0200

I updated the Pull Request, addressing the issues pointed by Moritz:
https://github.com/Matroska-Org/ebml-specification/pull/181

IMO it both covers temporary extensions and regular/stable ones. 
Although it doesn't distinguish between them.

If we want something more thorough we may want to add the list of pathes 
in an extension. But we don't do that for the main DocType. On the other 
hand a parser knowing the main DocType is supposed to know the semantic, 
whearas the extension can come from anywhere.

Given the time we have I don't think it's good to add the pathes at this 
stage. If we do it should also be compatible/similar to the embedded 
Schema we'd like to do.

Once #181 is merged we can close 
https://github.com/Matroska-Org/ebml-specification/issues/157 and submit 
EBML-07 for a wider approval.