Subject: Re: [Cellar] Second AD review of draft-ietf-cellar-ebml-10

From: Steve Lhomme <[email-masked]>
Date: Sun, 3 Nov 2019 11:04:30 +0100

Hi,

Le ven. 25 oct. 2019 à 17:37, Alexey Melnikov <[email-masked]> a écrit :
>
> Hi Michael,
>
> On Thu, Oct 24, 2019, at 7:14 PM, Michael Richardson wrote:
> >
> > Alexey Melnikov <[email-masked]> wrote:
> >     >> A decision as to who is the legitimate documentator of the (existing)
> >     >> "webm" DocType would be up to the IESG.
> >
> >     > Is "webm" will be worked on in this WG?
> >
> > No, not unless Google shows up with it!
> > WebM shares a container format with Matroska (being EBML), but we are not
> > trying standard it.
>
> So the IANA policy for this entry would be IESG Approval or RFC Required. Why do you want IESG to be involved in the decision to remove "Reserved" for "webm"? I would rather have Expert Review here, so that IESG doesn't need to decide.

I'm not sure I understand the distinction between the two. The goal
here is to inform creators of an EBML format that "matroska" and
"webm" are known to be used elsewhere.

> If the WG has good reasons for IESG to be involved, that is fine. But I would like to understand the reason(s) first.
>
>
> Also, I just realized that the IANA registration policy for "ELLAR EBML DocType Registry" is not very clear. Does the WG want "IESG Approval" or "RFC Required" be applied to the whole registry or just to the 2 reserved values? The current text seems to be saying the latter.
>
> Best Regards,
> Alexey
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman

---

From: Michael Richardson <[email-masked]>
Date: Sun, 03 Nov 2019 12:33:42 -0500

>> >     > Is "webm" will be worked on in this WG?

    mcr> No, not unless Google shows up with it!
    mcr> WebM shares a container format with Matroska (being EBML), but we are not
    mcr> trying standard it.

    Alexey> So the IANA policy for this entry would be IESG Approval or RFC
    Alexey> Required. Why do you want IESG to be involved in the decision to
    Alexey> remove "Reserved" for "webm"? I would rather have Expert Review
    Alexey> here, so that IESG doesn't need to decide.

So, we went back and forth with IANA on this.
While the policy for names other than "webm" and "matroska" is First Come
First Served.  However, we have reserved the two names as already being in use.
"matroska" is within the CELLAR WG already (by IESG decree, when you
chartered the WG...)

We could use Expert Review. IANA suggested it be under the control of the
IESG to determine if some work arrived which properly represented "webm"

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Sun, 03 Nov 2019 12:51:53 -0500

> So, we went back and forth with IANA on this.

It's IANA ticket #1124191 and #1130813.
https://mailarchive.ietf.org/arch/msg/cellar/603pCXiKGp-8k8eo1xHN17pt5ik

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 4 Nov 2019 08:17:40 +0000

Hi Steve,

> On 3 Nov 2019, at 10:04, Steve Lhomme <[email-masked]> wrote:
> 
> Hi,
> 

The draft reserves 2 names, which is fine. The question is who is going to be authorized to change these reservations into proper registrations.

The difference between IESG Approval and Expert Review is who is going to decide to mark an IANA registration entry as properly registered. IESG is a collection of 15 people, whose membership partially changes every year. Current IESG knows almost nothing about EBML. An appointed Expert would have more context to make a decision. So I think it makes sense for an Expert to handle this, instead of overloading IESG.
(Maybe the following analogy would help: asking IESG is like asking a Board of Directors to make a technical direction. While IESG is ultimately responsible for the decision, it would prefer to delegate the decision to technical experts.)

Does this make sense?

Best Regards,
Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 4 Nov 2019 08:20:11 +0000

Hi Michael,

> On 3 Nov 2019, at 17:33, Michael Richardson <[email-masked]> wrote:
> 

Expert can always ask IESG if the expert is concerned about relationship between organizations. The most likely outcome is that IESG would say yes.

Best Regards,
Alexey

---

From: Michael Richardson <[email-masked]>
Date: Tue, 05 Nov 2019 17:12:07 -0500

> The draft reserves 2 names, which is fine. The question is who is going
    > to be authorized to change these reservations into proper
    > registrations.

I don't care what we write.
IANA said that the IESG was ultimately responsible, either by appointing an
Expert Reviewer, or by making the decision itself.

As "matroska" is within the CELLAR charter, and we will allocate that name to
the document, once the document is published (by Standards Action, which is a
superset of IESG Approval), then issue is **only** for "webm".

If a design team shows up and wants to say, "Here it the URL for a stable
WebM spec", then the IESG should have IANA update it's registry.
The question will be whether this is the right design team and the right URL,
will either be trivially obvious, or very difficult to determine.
I don't know if the IESG will find it any easier to appoint an Expert.

(Asking the CELLAR WG will be like asking the Bernie Sander's team about
whether it was right for Trump to go after Her Emails)

---

From: Steve Lhomme <[email-masked]>
Date: Mon, 11 Nov 2019 14:00:16 +0100

Hi,

> (Maybe the following analogy would help: asking IESG is like asking a Board of Directors to make a technical direction. While IESG is ultimately responsible for the decision, it would prefer to del…

Yes, thanks a lot for the clarification. It does sound like the simple
choice would be to have an Expert Review for new DocTypes. Assigning a
name doesn't seem too hard, but if it means making sure the format is
actually making proper use of EBML then an "expert" look is needed.

Also there's still the question whether we should define a general
purpose binary format or just a binary format for Matroska. (see
Robert Sparks review and the issue I opened
https://github.com/cellar-wg/ebml-specification/issues/304) We may not
even have a IANA registry at all in the end.