Subject: Re: [Cellar] Genart last call review of draft-ietf-cellar-ffv1-16

From: Jerome Martinez <[email-masked]>
Date: Sun, 9 Aug 2020 22:51:48 +0200

Hi Joel,

On 14/07/2020 06:17, Joel Halpern via Datatracker wrote:
> [...]
>
> Minor issues:
>      Section 3.4 (Context) introduces the notation Q_{#}[ subscript }.  As that
>      is the first reference to Q_{#}, it is rather confusing to the reader.  I
>      grant that the term is defined in the next section (3.5).  Couldn't they be
>      reversed?
>
>      Section 3.8.1.1 refers to C(i), C_{i}, and C_i.  Are these all the same
>      thing.
>
>      Section 3.8.1.2 refers to get-rac (which is treated as a function in the
>      pseudo-code) as being the process described in section 3.8.1.1.  The text
>      in 3.8.1.1 does not call out any of its computed values as an explicit
>      result or return.  While I would guess that the intention is to use the
>      byte stream (B()), the text does not actually say that.  If that is the
>      intention, could the last line of 3.8.1.1 be "get_rac() returns sequential
>      bytes from the Byte Stream (B()) as computed by the computation described
>      in section 3.8.1.1"?

Thank you for your review, I have addressed them in a pull request at 
https://github.com/FFmpeg/FFV1/pull/223

Jérôme

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 9 Aug 2020 17:19:48 -0400

Thank you.
Joel