Subject: [Cfrg] new draft on Random Data Encryption Mechanism (RDEM)

From: David McGrew <[email-masked]>
Date: Wed, 4 Jun 2008 10:25:37 -0700

Hi All,

here is a new Internet Draft that's in scope for CFRG.

best,

David

--

Begin forwarded message:

> From: [email-masked]
> Date: June 4, 2008 12:45:01 PM EDT
> To: [email-masked]
> Subject: I-D ACTION:draft-rdem-mukul-jaitly-00.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: Random Data Encryption Mechanism (RDEM)
> 	Author(s)	: M. Jaitly
> 	Filename	: draft-rdem-mukul-jaitly-00.txt
> 	Pages		: 10
> 	Date		: 2008-6-1
> 	
> This document describe an data encryption specification which is
>   based on random bytes selection of data and random key generation.
>   This encryption process accepts variable input and the key size is
>   dependent on the input data. This encryption process does not
>   depend upon any 128 or 256 fixed block encryption. The mechanism
>   for encryption is simpler to implement, but gives key complexity
>   of more than 256 bit encryption.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-rdem-mukul-jaitly-00.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
Cfrg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cfrg

---

From: Greg Rose <[email-masked]>
Date: Wed, 04 Jun 2008 11:04:35 -0700

> here is a new Internet Draft that's in scope for CFRG.

Have you looked at this before sending it? I hope it's a joke, but am 
afraid it may not be. So I offer three reasons not to waste time on it.

1. it specifies how to encrypt random data with a random key. What good 
is that?

2. The algorithm is entirely linear and cryptographically useless. (The 
only operations are fixed rotations and XORs.)

3. I don't think CFRG should be evaluating new encryption algorithms. 
Protocols, implementations and specifications, sure, but not entirely 
new algorithms; they should be published and peer-reviewed before ever 
getting to the IETF.

Greg.

---

From: David McGrew <[email-masked]>
Date: Wed, 4 Jun 2008 11:21:55 -0700

Hi Greg,

one of the functions that CFRG performs for the IETF is providing  
independent expert review of drafts - thanks for chiming in.  I agree  
that algorithms are best reviewed elsewhere, but when that process is  
not followed and a draft is submitted to IETF, our comments are  
probably even more valuable.

I certainly think that ciphers that can't survive chosen plaintext  
attacks are inappropriate for use.  Maybe I should have sent my  
comments with the draft, but as RG co-chair I wanted to avoid the  
perception of bias.

David