Subject: [Cfrg] CMAC based KEYMAT

From: Robert Moskowitz <[email-masked]>
Date: Tue, 16 Mar 2010 08:03:11 -0400

I am looking for information on using CMAC for the KEYMAT function.

The arguement in IEEE 802.15 is the desire to minimize code requirements 
and avoid needing a HASH function (the MACsec in 802.15 where done well 
is AES-CCM).

In the Medwin 802.15.6 (Medical Body Area Networks, MBAN) this is 
proposed in:

https://mentor.ieee.org/802.15/dcn/09/15-09-0327-02-0006-medwin-mac-and-security-proposal-documentation.doc

Annex A.

Please point me to any other uses of CMAC for the KEYMAT function or 
information on why this is problematic.

---

From: "Blumenthal, Uri - 0662 - MITLL" <[email-masked]>
Date: Wed, 17 Mar 2010 20:25:10 -0400

I for one see NO problem using CMAC for KEYMAT.

On 3/16/10  08:03 , "Robert Moskowitz" <[email-masked]> wrote:

> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

-- 
Regards,
Uri         [email-masked]
<Disclaimer>

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 18 Mar 2010 08:33:11 -0400

Lily Chen of NIST pointed me to her publication: 800-108 where she 
provides a CMAC-based KDF.

On 03/16/2010 08:03 AM, Robert Moskowitz wrote:
> The arguement in IEEE 802.15 is the desire to minimize code 
> requirements and avoid needing a HASH function (the MACsec in 802.15 
> where done well is AES-CCM).
>