Subject: [Cfrg] Strengths For Public Keys

From: Robert Moskowitz <[email-masked]>
Date: Thu, 08 Apr 2010 09:46:29 -0400

Is there more current information than RFC 3766?

Also clear content on relation of Eliptic Curve compared to RSA key sizes?

Hopefully referencable material for Internet Drafts, and in one place....

---

From: Alfonso De Gregorio <[email-masked]>
Date: Thu, 8 Apr 2010 16:03:52 +0200

> Hopefully referencable material for Internet Drafts, and in one place....

Hi Robert,

On Keylength.com you can find a number of references on guidelines to
selecting keysizes and lifetimes.
Relevant guidelines published after RFC 3766 are:

- Recommendation for Key Management, Special Publication 800-57 Part
1, NIST, 03/2007;
- Mécanismes cryptographiques - Règles et recommandations "standards",
Rev. 1.10, FNISA , 12/2006.
- Algorithms for Qualified Electronic Signatures, BNetzA, BSI, 01/2009
updated with this draft, BSI, 08/2009

Cheers,

alfonso

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 8 Apr 2010 07:44:40 -0700

>Is there more current information than RFC 3766?

In a word: no. The predictions we made there have stuck pretty well.

>Also clear content on relation of Eliptic Curve compared to RSA key sizes?

Sure. All literature I have see says that effective strength of an elliptic curve key is half its length for popular curves such as P256 and P384. You can thus compare it to the RSA key size.

NIST SP 800-57 Part 1 has some tables about this, but they are a bit confusing. Also, the status of that document is not clear, given the existence of draft SP 800-131.

--Paul Hoffman, Director
--VPN Consortium

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 08 Apr 2010 11:47:33 -0400

> Sure. All literature I have see says that effective strength of an elliptic curve key is half its length for popular curves such as P256 and P384. You can thus compare it to the RSA key size.

 From draft-mcgrew-fundamental-ecc-02.txt, I found that p-256 == 
sym-128, referencing RFC 4753.

In 4753, I find in sec 4 I find:

The groups proposed in this document correspond to the symmetric key
sizes 128 bits, 192 bits, and 256 bits.

With no attributions. I ASSuME, given the source, I can reference this 
without further attributions...