Subject: [Cfrg] PKCS-5 alternative

From: Robert Moskowitz <[email-masked]>
Date: Mon, 17 May 2010 16:16:55 -0400

I am looking for an alternative to PKCS-5 that does not use an 
underlying hash function.  CMAC allowed.  I suspect there is something 
'commonly' used, but right now I am NOT finding it.

More of my efforts to slim down crypto primatives.

Thank you.

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 17 May 2010 16:31:56 -0400

On 05/17/2010 04:23 PM, :
> On May 17, 2010, at 1:16 PM, Robert Moskowitz wrote:
>
>    
>> I am looking for an alternative to PKCS-5 that does not use an underlying hash function.  CMAC allowed.  I suspect there is something 'commonly' used, but right now I am NOT finding it.
>>
> What part of PKCS5?
> The password derivation parts?

Password based challenge response stuff.  I believe that is PBES2.