Subject: Re: [Cfrg] Call for Review on draft-kanno-secsh-camellia-00

From: Satoru Kanno <[email-masked]>
Date: Fri, 07 May 2010 19:29:31 +0900

(2010/04/26 19:23), Simon Josefsson wrote:
> Satoru Kanno<[email-masked]>  writes:
>
>> Dear List,
>>
>> We have submitted draft of Camellia for secure shell as an individual
>> draft, because we found the Camellia patch for OpenSSH.
>>
>> Camellia draft:
>>   http://www.ietf.org/id/draft-kanno-secsh-camellia-00.txt
>> Camellia patch:
>>   https://bugzilla.mindrot.org/show_bug.cgi?id=1340
>>
>> Comments about our document would be welcome.
>

Dear Simon,

First of all, I'm sorry for the delayed reply.
And, thanks for your comments.

> Thanks for writing the document.  My comments:
>
> 1) As you know, Camellia is patented by your organization, and you need
> to file a patent disclosure to the IETF.  The earlier disclosures
> related to Camellia are not relevant: they don't permit use for Secure
> Shell.

Now, we are preparing Camellia IPR for Secure Shell. The IPR style is 
similar to Kerberos.

> 2) It is not possible to implement your document without also reading
> RFC 5646, thus I believe that document has to be a normative reference.
> Alternatively, you could duplicate the necessary text.
>

OK. I will move the document for GCM mode from informative reference to 
normative reference. I will revise your comment to the next draft.

By the way, I'd like to confirm your pointed RFC, I think that RFC 5646 
is typo. Is RFC 5647 right?

  -- RFC5646: Tags for Identifying Languages
  -- RFC5647: AES Galois Counter Mode for the Secure Shell Transport
              Layer Protocol

Best regards,
Satoru

> /Simon

-- 
Satoru Kanno

Security Business Unit
Mobile and Security Solution Business Group
NTT Software Corporation

e-mail: [email-masked]

---

From: Simon Josefsson <[email-masked]>
Date: Fri, 07 May 2010 12:58:31 +0200

> Now, we are preparing Camellia IPR for Secure Shell. The IPR style is

Thanks!

> OK. I will move the document for GCM mode from informative reference
> to normative reference. I will revise your comment to the next draft.
>
> By the way, I'd like to confirm your pointed RFC, I think that RFC
> 5646 is typo. Is RFC 5647 right?
>

Yes, I meant RFC5647.  Must have been muscle memory typing there.

/Simon

---

From: Satoru Kanno <[email-masked]>
Date: Tue, 18 May 2010 20:33:07 +0900

Folks,

I uploaded the revised draft.

URL:
  http://www.ietf.org/id/draft-kanno-secsh-camellia-01.txt

Change from -00:
  - Simon comments
    + Move to Normative reference on RFC 5647 [Finished]
    + Camellia IPR for Secure Shell [ongoing]

All other comments and suggestions are welcomed.

Regards,
Satoru

-- 
Satoru Kanno

Security Business Unit