Subject: [Cfrg] Influences [was RE: [TLS] draft-sheffer-tls-bcp: DH recommendations]

From: Dan Brown <[email-masked]>
Date: Tue, 24 Sep 2013 17:11:56 +0000

> -----Original Message-----
> From: Peter Gutmann
> Sent: Tuesday, September 24, 2013 12:46 AM
> To: [email-masked]
> 
> ... you've got potentially NSA-influenced values
> like P256 that the NSA has been awfully keen to get everyone to use,
> and that even without NSA skullduggery make a nice single target for
> attack.  So that's an entirely different problem.
> 

1. You seem to be saying there that P256 has security problems (unless it does not), which is something that AFAIK no other cryptographer has ever noticed.  Perhaps you could clarify the weakness for the list, and then consider publishing a conference paper on it.  It sounds like an amazing breakthrough in the cryptanalysis of P256.  [Just borrowed your own phrasing about HMAC on another TLS thread, Peter, thanks.]

2. What is the consensus on possible influences on SHA1 and SHA2, compared to P256 and other NIST curves?  These hashes do not have magic constants, but small changes in hash algorithm can cause large weaknesses (as in SHA0, SHA1 and various SHA3 candidates).  On one hand, P256 etc depend on SHA1; on the other, only a negligible fraction of curves have been compromised.  I do not have a good sense about what to say for hash functions.  Can one say that only a negligible fraction of some natural class of hash functions to which MD5, SHA0, SHA1, and SHA2 belong, has been broken?
---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: David Jacobson <[email-masked]>
Date: Tue, 24 Sep 2013 21:08:01 -0700

On 9/24/13 10:11 AM, Dan Brown wrote:
> On one hand, P256 etc depend on SHA1; ...
How does P256 depend on SHA1?

    --David Jacobson