Subject: [Cfrg] Acceptance call for draft-mcgrew-hash-sigs-02.txt

From: Alexey Melnikov <[email-masked]>
Date: Sun, 14 Sep 2014 22:05:51 +0100

Dear RG participants,
CFRG chairs received a request to accept draft-mcgrew-hash-sigs-02.txt 
("Hash-Based Signatures") as a RG document:
  http://datatracker.ietf.org/doc/draft-mcgrew-hash-sigs/

The document was presented in Toronto and chairs would like to know if 
there is enough interest to complete this document in CFRG.

The acceptance call starts today and will last for slightly over 2 
weeks: please send your comments and statement of support (or not) for 
this work till the end of September 28th.

Thank you,
Alexey, on behalf of CFRG Chairs.

---

From: Johannes Merkle <[email-masked]>
Date: Wed, 24 Sep 2014 14:06:19 +0200

Alexey Melnikov wrote on 14.09.2014 23:05:
> CFRG chairs received a request to accept draft-mcgrew-hash-sigs-02.txt ("Hash-Based Signatures") as a RG document:
> The document was presented in Toronto and chairs would like to know if there is enough interest to complete this
> document in CFRG.
> 

I support adoption by CFRG.
-- 
Johannes

---

From: Ira McDonald <[email-masked]>
Date: Wed, 24 Sep 2014 08:08:43 -0400

Hi,

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Sun, Sep 14, 2014 at 5:05 PM, Alexey Melnikov <[email-masked]>
wrote:

> weeks: please send your comments and statement of support (or not) for this
> work till the end of September 28th.
>
>  Thank you,
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg
>
>

---

From: David Jacobson <[email-masked]>
Date: Thu, 25 Sep 2014 07:50:23 -0700

> Alexey, on behalf of CFRG Chairs.
In the draft there are these definitions

If r is a non-negative real number, then we define the following
    functions:

       ceil(r) : returns the smallest integer larger than r

       floor(r) : returns the largest integer smaller than r

       lg(r) : returns the base-2 logarithm of r

The definition of floor is incorrect. "smaller than" should be replaced 
with "equal to or smaller than", or perhaps "not larger than".

--David Jacobson

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Thu, 25 Sep 2014 11:51:53 -0400

> with "equal to or smaller than", or perhaps "not larger than".

By the same token, the definition of ceil(r) is also incorrect.

in commonly-accepted terms:

 ceil(4.0) = 4

but according to the definition stated, it should be 5.

it should be:

ceil(r) : returns the smallest integer greater than or equal to r

floor(r) : returns the largest integer less than or equal to r

	--dkg

---

From: Johannes Merkle <[email-masked]>
Date: Thu, 25 Sep 2014 18:00:28 +0200

Good catches.

But since this is an acceptance call: what's your position w.r.t adoption by CFRG?

Johannes

Daniel Kahn Gillmor wrote on 25.09.2014 17:51:
>> If r is a non-negative real number, then we define the following functions:
>> 
>> The definition of floor is incorrect. "smaller than" should be replaced with "equal to or smaller than", or
>> perhaps "not larger than".
> 
> 
> _______________________________________________ Cfrg mailing list [email-masked]