Subject: Re: [Cfrg] Preserving Implementation Optimizations

From: "Salz, Rich" <[email-masked]>
Date: Mon, 1 Sep 2014 12:19:33 -0400

> First, the use of the same curve for digital signature and key agreement is
> highly desirable.  This provides obvious modularity.

Can you explain what you mean by the term "modularity"  Tnx.

	/r$, expert in only admitting what I don't know

--  
Principal Security Engineer
Akamai Technologies, Cambridge MA
IM: [email-masked] Twitter: RichSalz

---

From: Russ Housley <[email-masked]>
Date: Tue, 2 Sep 2014 02:27:55 -0400

Rich:

> Can you explain what you mean by the term "modularity"?

In structuring an implementation, I see different interfaces for signing and key agreement.  The software and hardware that implement these interfaces will have several modules, with a wide multiply at the more primitive end of things.  In my view, the more modules that are in common between signing and key agreement the better.

Russ