Subject: Re: [Cfrg] [IANA #807002] Conflict Review requested for draft-irtf-cfrg-chacha20-poly1305

From: Yoav Nir <[email-masked]>
Date: Tue, 17 Feb 2015 00:28:22 +0200

Hi.

RFC 5116 makes no statement about what characters are allowed for names in this registry. The only requirement is for names to begin with “AEAD_”. Additionally, these names are not used in any protocol, so the risk of having parsers making assumptions is very low.

The reason this name contains a hyphen is to distinguish parameters and modes of operation that are separated by underscored (such as AEAD_AES_128_GCM, where 128 is the key length and GCM is the mode of operation), from combinations of algorithms that we separated by a hyphen. That same algorithms might have been named AEAD_AES_128-GHASH instead. Since there is no mode of operation associated with Poly1305, we instead used the hyphen notation. 

I don’t believe this makes much of a difference either way, so if others believe it should be replaced with an underscore, that’s fine with me.

Yoav

> On Feb 17, 2015, at 12:15 AM, Pearl Liang via RT <[email-masked]> wrote:
> 
> (BEGIN IANA COMMENTS)
> 
> IESG/Authors:
> 
> IANA has reviewed draft-irtf-cfrg-chacha20-poly1305 version -09.  Authors should review the comments and/or questions below.  Please report any inaccuracies and respond to any questions as soon as possible.
> 
> We received the following comments/questions from the IANA's reviewer:
> 
> IANA understands that, upon approval of this document, there is a single action which need completion.
> 
> In the AEAD Algorithms subregistry of the Authenticated Encryption with Associated Data (AEAD) Parameters registry located at:
> 
> https://www.iana.org/assignments/aead-parameters/
> 
> a single, new AEAD Algorithm will be registered as follows:
> 
> Numeric ID: [ TBD-at-Registration ]
> Name: AEAD_CHACHA20-POLY1305
> Reference: [ RFC-to-be ]
> 
> Note: The DE, David McGrew, has reviewed this draft version -03 in November 2014.
> This version does not make any change to the requested IANA action from version -03.
> 
> Question: The new registration name is "AEAD_CHACHA20-POLY1305" that contains
> a hyphen.  Is it (hyphen) allowed in the registry AEAD Algorithms?  All names in 
> that registry are using underscores.    We just double check with you as you know 
> the specification better.
> 
> IANA understands that this is the only action required to be completed upon approval of this document.
> 
> Note:  The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is only to confirm what actions will be performed.  
> 
> Thanks,
> 
> Pearl Liang
> ICANN
> 
> (END IANA COMMENTS)
> 
> 
> On Tue Feb 03 10:00:54 2015, [email-masked] wrote:
>> Lars Eggert has requested a conflict review for:
>>    draft-irtf-cfrg-chacha20-poly1305
>>    ChaCha20 and Poly1305 for IETF protocols
>> 
>> The conflict review is being tracked at
>> <http://datatracker.ietf.org/doc/conflict-review-irtf-cfrg-chacha20-
>> poly1305/>
> 
>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 17 Feb 2015 00:28:22 +0200

Hi.

Yoav

---

From: Stefan Bühler <[email-masked]>
Date: Tue, 17 Feb 2015 07:52:16 +0100

Hi,

On Tue, 17 Feb 2015 00:28:22 +0200
Yoav Nir <[email-masked]> wrote:

> Hi.
> 
> RFC 5116 makes no statement about what characters are allowed for
> names in this registry. The only requirement is for names to begin
> with “AEAD_”. Additionally, these names are not used in any protocol,
> so the risk of having parsers making assumptions is very low.
> 
> The reason this name contains a hyphen is to distinguish parameters
> and modes of operation that are separated by underscored (such as
> AEAD_AES_128_GCM, where 128 is the key length and GCM is the mode of
> operation), from combinations of algorithms that we separated by a
> hyphen. That same algorithms might have been named AEAD_AES_128-GHASH
> instead. Since there is no mode of operation associated with
> Poly1305, we instead used the hyphen notation. 
> 
> I don’t believe this makes much of a difference either way, so if
> others believe it should be replaced with an underscore, that’s fine
> with me.

I think many implementations will try to use the name as identifier,
and most languages won't allow hyphens as part of that - so I'd replace
it with an underscore to have consistent names.

Stefan

---

From: Stefan Bühler <[email-masked]>
Date: Tue, 17 Feb 2015 07:52:16 +0100

Hi,

Stefan

---

From: Yoav Nir <[email-masked]>
Date: Tue, 17 Feb 2015 11:39:50 +0200

> it with an underscore to have consistent names.

I’m fine with that as well.

---

From: Yoav Nir <[email-masked]>
Date: Tue, 17 Feb 2015 11:39:50 +0200

---

From: Yoav Nir <[email-masked]>
Date: Fri, 20 Feb 2015 23:53:30 +0200

Fixed in version -10.

> On Feb 17, 2015, at 6:21 PM, Pearl Liang via RT <[email-masked]> wrote:
> 
> Thank you Stefan for pointing that out.
> 
> Yoav, please update the next version of the draft to the new requested name to 
> 'AEAD_CHACHA20_POLY1305' with underscores.  Regarding what characters
> are allowed in RFC5116, you may check with David McGrew.
> 
> I leave it as IANA Okay for the draft.
> 
> Thanks,
> ~pl
> 
> On Tue Feb 17 09:40:17 2015, [email-masked] wrote:

---

From: Yoav Nir <[email-masked]>
Date: Fri, 20 Feb 2015 23:53:30 +0200

Fixed in version -10.