Subject: Re: [Cfrg] Elliptic Curves - poll on security levels (ends on February 17th)

From: "Annie Yousar" <[email-masked]>
Date: Wed, 11 Feb 2015 20:46:27 +0100 (CET)

Am 10.02.2015 um 11:52 schrieb Alexey Melnikov:
> CFRG chairs are starting a poll, containing 2 initial questions:
>
> Q1: Should CFRG recommend a curve at the 192-bit security level?
Yes. It corresponds to 384 bit curves.

> Q2: Should CFRG recommend a curve at the 256-bit security level?
Yes. It corresponds to 512 bit curves.

---

From: Michael Scott <[email-masked]>
Date: Sat, 14 Feb 2015 12:26:37 +0000

>Q1: Should CFRG recommend a curve at the 192-bit security level?

No

>Q2: Should CFRG recommend a curve at the 256-bit security level?

No

(only point would be to match AES-192 and AES-256, which are only useful if
some-one comes up with a quantum computer, in which elliptic curves of any
size are toast!)

Michael Scott