Subject: [Cfrg] Conclusions: poll about curve around 256bit work factor

From: Alexey Melnikov <[email-masked]>
Date: Mon, 23 Feb 2015 20:58:54 +0000

From responses and discussions on the mailing list it is clear that there is rough consensus against using curve 512-C. However, part of the responders said that they prefer 521 (the original Q3 asked), while other responded to extended list suggested by Phillip.

Based on answers chairs declare CFRG consensus against the curve 512 being in the CFRG recommendation at the 256 WF level. Other curves (521, 448, etc) still remain as contenders for the CFRG recommendation.

Chairs will return to the question of a specific curve recommendation above 128 level at a later date.

---

From: Kurt Roeckx <[email-masked]>
Date: Mon, 23 Feb 2015 22:22:53 +0100

> Based on answers chairs declare CFRG consensus against the curve 512 being in the CFRG recommendation at the 256 WF level. Other curves (521, 448, etc) still remain as contenders for the CFRG recom…

Could you next time please ask what you want really want to ask?
You've asked about speed vs bandwidth, which clearly is not the
only thing people are concerned about.  There might be a consensus
to prefer 521 over 512, but it's not what you asked.

Maybe it could help that you propose the question first so that we
give feedback on that?

Kurt

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 23 Feb 2015 13:36:47 -0800

> Chairs will return to the question of a specific curve recommendation above 128 level at a later date.

And what will the chairs now do at a sooner date? That is, what is next for the RG to help move this forwards?

--Paul Hoffman

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 23 Feb 2015 21:39:28 +0000

> And what will the chairs now do at a sooner date? That is, what is next for the RG to help move this forwards?
Patience :-). Another poll is coming.

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 23 Feb 2015 22:19:39 +0000

Hi,

> to prefer 521 over 512, but it's not what you asked.
Ok, maybe the question was not well thought, but that was the main 
factor raised earlier to decide between 521 and 512.
> Maybe it could help that you propose the question first so that we give feedback on that?
Will do, although some of the followup questions are a bit more obvious.

---

From: Simon Josefsson <[email-masked]>
Date: Tue, 24 Feb 2015 13:39:08 +0100

Kurt Roeckx <[email-masked]> writes:

>> From responses and discussions on the mailing list it is clear that
>> there is rough consensus against using curve 512-C. However, part of
>> the responders said that they prefer 521 (the original Q3 asked),
>> while other responded to extended list suggested by Phillip.
>> 
>> Based on answers chairs declare CFRG consensus against the curve 512
>> being in the CFRG recommendation at the 256 WF level. Other curves
>> (521, 448, etc) still remain as contenders for the CFRG
>> recommendation.
>

+1

The question that was asked was:

 "Is bandwidth cost of going to p521 worth the speed win over primes
  closer to 512 bits?"

and now my (and others') answer to that questions is used to make a
consensus call on the following statement:

  "against the curve 512 being in the CFRG recommendation at the 256 WF
  level"

My opinion on the first question cannot be extrapolated to cover the
second statement.

/Simon

---

From: Jon Callas <[email-masked]>
Date: Tue, 24 Feb 2015 12:05:36 -0800

> Maybe it could help that you propose the question first so that we

Hear, hear.

It has been very difficult to tell what the question actually was, with lots of things tacitly rolled into a single question.

	Jon

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 24 Feb 2015 22:52:46 +0000

Hi,

> It has been very difficult to tell what the question actually was, with lots of things tacitly rolled into a single question.
Ok, chairs will strive to ask clearer questions.

We will also redo the poll, by asking a better question. I hope the 
outcome of it is going to be just confirmation of information already 
received, but in order to be more fair and transparent, it is worth to 
redo the poll.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 24 Feb 2015 23:15:30 +0000

> received, but in order to be more fair and transparent, it is worth to

Thanks!
S.

---

From: Tony Arcieri <[email-masked]>
Date: Tue, 24 Feb 2015 15:24:10 -0800

On Tue, Feb 24, 2015 at 2:52 PM, Alexey Melnikov <[email-masked]>
wrote:

> received, but in order to be more fair and transparent, it is worth to redo
> the poll.

Sounds good, thank you!

-- 
Tony Arcieri