Subject: Re: [Cfrg] Elliptic Curves - poll on security levels (ends on February 17th)

From: Dan Brown <[email-masked]>
Date: Tue, 10 Feb 2015 12:35:55 +0000

Yes + yes.

clarification: curve _providing at least_ security level x. eg 521 for 512.

main reason: margin of error

Best regards, 

-- Dan
  Original Message  
From: Alexey Melnikov
Sent: Tuesday, February 10, 2015 5:52 AM
To: [email-masked]
Subject: [Cfrg] Elliptic Curves - poll on security levels (ends on February	17th)

CFRG chairs are starting a poll, containing 2 initial questions:

Q1: Should CFRG recommend a curve at the 192-bit security level?

Q2: Should CFRG recommend a curve at the 256-bit security level?

Answering Yes/No to each of these would suffice.

Once this first set of issues is resolved, we will move to choices of prime
at the selected security level(s), if any. After that we will be
discussing implementation specifics and coordinate systems for
Diffie-Hellman. We will then make decisions on signature schemes.
Please don't discuss any of these future topics at this time.

_______________________________________________
Cfrg mailing list
[email-masked]
http://www.irtf.org/mailman/listinfo/cfrg

---

From: Dan Brown <[email-masked]>
Date: Wed, 11 Feb 2015 16:19:35 +0000

I revise my vote due to the chairs' clarifications:

Short term: {192=no,256=no} so that IRTF can recommend Curve25519 within an
IETF timeframe.
Long term: {192=yes,256=yes} so that IRTF can recommend curves that try to
minimize risks of ECC.  

Also, I think the chairs have clarified well enough that they were asking
the short term question, so my vote becomes (no,no).

Regarding what's 192, I note NIST/SEC2 recommended a 409-bit binary for 192,
so 414 is not too far off that precedent.

Regarding using non-EC DH groups instead of larger EC groups, that seems to
introduce some rather new risks, albeit perhaps with efficiency gains,
without solving the risk due to Shor's algorithm.  So, I disagree: I think
yet more security can be squeezed out of ECC.

> -----Original Message-----
> From: Dan Brown
> Sent: Tuesday, February 10, 2015 7:36 AM
> Yes + yes.
>