Subject: Re: [Cfrg] Crystalline Cipher

From: "Paterson, Kenny" <[email-masked]>
Date: Thu, 21 May 2015 21:30:13 +0000

Mark,

Permit me to be frank. My co-chair Alexey would probably put things much
more politely than me, but he is a natural diplomat and I am not.

The "official position" that you seek clarification on is as follows. We
don't want discussions about junk home-brew crypto clogging up our mailing
list. 

The replies from Tony, Mike and William that were posted in response to
your initial messages, and your subsequent replies to them, demonstrate
clearly to me that your algorithm is fully deserving of that epithet.

You were in fact lucky that they paid any attention at all to your
proposal, and they've already given you many hundreds if not thousands of
dollars worth of free consultancy between them.

Concerning CFRG's remit: our job is take the fastest, most secure, most
heavily peer-reviewed research in cryptography and make use of it to make
the Internet stronger.

It is *not* our job to help enthusiasts - no matter how enthusiastic and
willing they are to learn - develop their pet algorithms.

To end on a more positive note, I would recommend that you try writing
your scheme up in a scientific manner and obtaining some peer review for
it from the scientific community. A venue such as the IACR FSE workshop
(http://www.iacr.org/meetings/fse/) would be a good target if I understand
the nature of your proposal correctly.

Regards,

Kenny

On 21/05/2015 17:56, "Mark McCarron" <[email-masked]> wrote:

>Kenny,
>
>Posting an official position of the chairs on-list would probably be more
>appropriate.  I think a full and clear explantion of why the CFRG is not
>living living up to its stated remit is important.  Further, I would like
>to gain an insight as to your personal
> opinion in regards to some of the fud that has been posted to this group
>in regards to what is, or is not, a break in a cipher.
>
>I'm not claiming that anyone is suppressing anything, as we both know it
>doesn't take a genius to make an unbreakable cipher.  It does, however,
>take some skill to develop one that is practical.  But 'practical' means
>different things to different people and
> I would like to understand why the list has become dedicated to the
>likes of AES and Eliptic curve cryptography.  Coincidently, the same
>techniques and ciphers being pushed by the NSA.  Many people, including
>myself, don't trust these techniques and feel that
> there is a certain dollar amount in hardware before weaknesses emerge.
>
>Regards,
>
>Mark McCarron
>
>--- original message ---
>From: "Paterson, Kenny" <[email-masked]>
>Date: 21.05.2015 17:03:03
>To: Mike Hamburg <[email-masked]>
>Subject: Re: [Cfrg] Crystalline Cipher
>
>Please do desist. 
> 
>Mark: I can expand on the reasons why offline if you wish.
> 
>Regards,
> 
>Kenny (for the chairs)
>
>Sent from my iPhone
>
>On 21 May 2015, at 15:55, Mike Hamburg <[email-masked]> wrote:
>
>I agree that this was a waste of time.  I'm not learning anything from
>this discussion, and apparently neither are you.  I don't think anyone
>else on this list is learning anything either.  So maybe it's best to
>just end things here.
>
>-- Mike
>
>On 05/20/2015 11:51 PM, Mark McCarron wrote:
>
>Mike,
>
>I see a lot of talking and not a lot of doing.  If you think this can be
>used to recover the plaintext, then I am sure you can provide a worked
>example.  But I can tell you now that you are wasting your time.
>
>Regards,
>
>Mark McCarron
>--- Ursprüngliche Nachricht ---
>Von: Mike Hamburg 
><[email-masked]> <mailto:[email-masked]>
>Datum: 21.05.2015 08:43:33
>An: Mark McCarron 
><[email-masked]> <mailto:[email-masked]>, Tony
>Arcieri 
><[email-masked]> <mailto:[email-masked]>
>Betreff: Re: [Cfrg] Crystalline Cipher
>
>But you see Mark, he did break it.
>
>This is why I wrote to you (off-list) about why cryptographers don't like
>this sort of interaction, and why I tried to brush you off originally.
>We'll spend some effort and break your code, but you won't agree that
>it's broken and nobody will be happy.  It's
> just a waste of time all around.
>
>We cryptographers want to build things on our ciphers, not just use them
>to send compressed files around.  To do that with confidence, the ciphers
>must be a firm foundation, not something that itself needs to be
>protected by compression or whatever your next
> excuse will be.  If you need to protect the cipher in this way, it is
>already broken.
>
>-- Mike
>
>On 5/20/2015 11:36 PM, Mark McCarron wrote:
>Hi Tony,
>
>I have examined this issue in depth.  The repeated pattern that you
>pointed out does not lead to a break in the cipher.  That image is drawn
>from a file filled with 0x00 which is a junk test in the context of
>Crystalline.  Due to the way in which Crystalline
> encrypts, such patterns are unobservable in files that contain data.
>Further, that pattern is the result of using a limited set of colours to
>represent the entire range of values.  When you examine the byte stream,
>it is chaotic and the salt/key/plaintext
> are mathematically unrecoverable.  Basically, what you are seeing is a
>bias introduced by long runs of the same initial value.  It is easily
>resolved through the use of compression as can be seen in this image:
>
>http://i.imgur.com/3DLWNTc.jpg
>
>So, its a bit of a red herring in any practical sense.  Try to use it to
>break the cipher, it doesn't work.
>
>Regards,
>
>Mark McCarron
>
>--- Ursprüngliche Nachricht ---
>Von: Tony Arcieri 
><[email-masked]> <mailto:[email-masked]>
>Datum: 21.05.2015 02:34:45
>An: Mark McCarron 
><[email-masked]> <mailto:[email-masked]>
>Betreff: Re: [Cfrg] Crystalline Cipher
>
>On Wed, May 20, 2015 at 3:59 PM, Mark McCarron
><[email-masked]> wrote:
>
>I'm somewhat disappointed in your reply, as I presumed that someone with
>a stated interest in ciphers would be eager to investigate anything new
>to pop up that didn't have obvious holes in it.
>
> 
>Hi Mark,
> 
>I did investigate your scheme, and I'm afraid to say it's obviously
>broken. It appears to be an implementation of a Knuth Shuffle with a few
>added bells and whistles.
>
> 
>This image, which I believe you produced, shows repeated patterns in the
>ciphertext:
> 
>https://i.imgur.com/MWmMc0J.png
> 
>Likewise, there are severe failures on Chi Squared tests:
> 
>http://www.freecx.co.uk/cryptanalysis/Crystalline/
> 
>Specifically:
> 
>http://www.freecx.co.uk/cryptanalysis/Crystalline/bias-result_(1)_10MB.txt
> 
><http://www.freecx.co.uk/cryptanalysis/Crystalline/bias-result_%281%29_10M
>B.txt>
>Overall Chi Squared value is 7474.808 (threshold 18.4753)
>Overall likely non-uniform (>99%)
>http://www.freecx.co.uk/cryptanalysis/Crystalline/bias-result_(2)_10MB.txt
> 
><http://www.freecx.co.uk/cryptanalysis/Crystalline/bias-result_%282%29_10M
>B.txt>
>Overall Chi Squared value is 13485.34 (threshold 30.5779)
>Overall likely non-uniform (>99%)
>http://www.freecx.co.uk/cryptanalysis/Crystalline/bias-result_(4)_10MB.txt
> 
><http://www.freecx.co.uk/cryptanalysis/Crystalline/bias-result_%284%29_10M
>B.txt>
>Overall Chi Squared value is 20607.94 (threshold 52.1914)
>Overall likely non-uniform (>99%)
>http://www.freecx.co.uk/cryptanalysis/Crystalline/bias-result_(8)_10MB.txt
> 
><http://www.freecx.co.uk/cryptanalysis/Crystalline/bias-result_%288%29_10M
>B.txt>
>Overall Chi Squared value is 45699.52 (threshold 91.81917)
>Overall likely non-uniform (>99%)
>I think the biggest problem though is all of this has already been
>pointed out to you repeatedly in other forums and you completely refuse
>to acknowledge that your cipher fails to meet the absolute most minimum
>criteria for a secure cipher.
> 
>If your cipher were secure, this image would not contain obvious
>repeating patterns:
> 
>https://i.imgur.com/MWmMc0J.png
> 
>If your cipher were secure, it would pass all randomness tests.
> 
>There are many more requirements for a secure cipher, but your cipher
>fails to meet the baseline requirements.
> 
>-- 
>Tony Arcieri
>
>
>
>
>
>---
>Free, fast and secure email: https://www.eclipso.eu
>
>
>
>
>---
>Free, fast and secure email: https://www.eclipso.eu
>
>_______________________________________________
>Cfrg mailing list
>[email-masked]://www.irtf.org/mailman/listinfo/cfrg
>
>
>
>
>_______________________________________________
>Cfrg mailing list
>[email-masked]
>http://www.irtf.org/mailman/listinfo/cfrg
>
>
>
>
>
>---
>Free, fast and secure email: https://www.eclipso.eu

---

From: "Mark McCarron" <[email-masked]>
Date: Fri, 22 May 2015 00:52:08 +0200

Kenny,

But you will clog up the mailing list with NSA-backed crypto schemes that embed multiple copies of the data in higher dimensions where your cheap computing resources can't see it?  Or didn't you spot this?  Perhaps something is wrong with your receiver.

As I said earlier, some people just don't understand the principles of cryptography. 

I will end this conversation here and finish Beta 3 of Crystalline.  If you feel like posting that break of this really bad cipher, just reopen the thread.

It has certainly been an experience.

Regards,

Mark McCarron