Subject: [Cfrg] No new curves for SPAKE?

From: Paul Lambert <[email-masked]>
Date: Mon, 4 May 2015 20:48:52 -0700

I was wondering …. why does the SPAKE draft (https://tools.ietf.org/html/draft-irtf-cfrg-spake2-01) not use ( https://tools.ietf.org/html/draft-irtf-cfrg-curves-02 )?

The point format is also not compatible with the new CFRG curve and uses a SEC1 compressed point.

Paul

---

From: Watson Ladd <[email-masked]>
Date: Mon, 4 May 2015 22:42:53 -0700

On Mon, May 4, 2015 at 8:48 PM, Paul Lambert <[email-masked]> wrote:
>
> I was wondering …. why does the SPAKE draft
> (https://tools.ietf.org/html/draft-irtf-cfrg-spake2-01) not use (
> https://tools.ietf.org/html/draft-irtf-cfrg-curves-02 )?

As of now, there is no point format specified that permits addition.
When such a point is specified, I will add the curves to the draft.
> The point format is also not compatible with the new CFRG curve and uses a

The draft assumes that every group has a unique point format, and uses
that format. It does not specify a new format.

>
> Paul
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg
>

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.

---

From: Paul Lambert <[email-masked]>
Date: Mon, 4 May 2015 23:25:21 -0700

On 5/4/15, 10:42 PM, "Watson Ladd" <[email-masked]> wrote:

>> I was wondering Š. why does the SPAKE draft

Yes, that¹s half my point in asking Š
Also, there is no Œsafe¹ point addition algorithm documented in the
 ¹curves¹ specification.

>>
>> The point format is also not compatible with the new CFRG curve and
>>uses a
>> SEC1 compressed point.
>

Yes, it¹s not new, just different.

Paul